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Welcome to DEVONthink, a powerful

assistant in your quest to organize many

kinds of information. From recipes to

your dissertation, hobbies to health, for

work or home, DEVONthink can help you

gather, organize, and connect your data.

This manual will help get you familiarized

with DEVONthink's concepts, interface, and

options. We begin with simple overviews,

move into descriptions of the essential

elements, then conclude with the deepest

details in the appendix.

This manual is meant as a handy reference,

not as a series of mandates on how you must

use it. DEVONthink can be used very simply

or in very complex ways and each person

brings their own personal approach to using

it. With the flexibility and capabilities built-

in, the possibilities are seemingly limitless.

To that end, it's impossible for this guide to

be exhaustive. But we strive to provide a

guidebook of the core concepts, philosophy,

and the controls of this application.

Conventions: To reduce redundancy and

assist in connecting sections in this manual,

we make use of links throughout the content.

These links will help direct you from concept

to concept, introduction to description, from

general to specifics. As you read, you should

notice certain typographical conventions.

Interface Links: Underlined in blue with

a bolder font, these are links to sections

in the manual describing specific parts

of the interface you'd interact with, e.g.,

the menu command DEVONthink > About

DEVONthink.

Interface Elements: Presented emboldened

in blue, these are also parts of the

interface. But as there are often several

references to the same elements in a

section, for example, the Global Inbox,

generally the first instance uses an

interface link while subsequent mentions

display as an interface element.

Document Links: Underlined in blue with

a lighter weight font, these are links to

parts of the documentation covering

more conceptual things. For example,

automation is not something you click on in

the interface. It is a broad concept but has

a chapter dedicated to it.

User Input and Paths: To set apart user

input or choices, they are presented in a

monospaced medium purple font. You will

see this for script commands (get chat

response for message), examples of

search syntax (kind:any text:taxes),

smart actions chosen (Scan Text),
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Markdown syntax (![](img/turtle.jpg)),

etc. We also use this convention for file

paths, e.g., the default directory for your

databases is ~/Databases.

Pro+ Features: There are some features only

available in the Pro and Server editions of

DEVONthink. As seen here, the text for these

features will appear in blue or display a blue

sidebar to the left of the section.

Style: Lastly, to aid in readability we try to

use less formal language for some interface

items. For example, we will use a shorted

form like "the Tags inspector" versus "the

Tools > Inspectors > AI > Tags inspector",

when possible. However, for certain items

like multi-tabbed settings, we will typically

include the parent setting's name, e.g., "

the General > Appearance settings" as the

specific setting isn't immediately visible when

opening DEVONthink's settings.

We hope our efforts in providing solid

information and our mindfulness in trying to

avoid information and link overload makes

this an approachable, and possibly even

enjoyable, resource for you.

Warmest Regards, The DEVONtechnologies

Team

Now let's get into it…

FIRST AND LAST STEPS

INSTALLING

If you haven't already installed DEVONthink,

here are the easy steps to accomplish that:

Download an installer from our Download

page.

If your browser isn't set to open safe

downloaded files, double-click the ZIP file

to decompress it. You will see a disk image

file.

Double-click the disk image to open it.

Drag and drop the application from the

disk image to the Applications folder

shortcut.

After the application has copied, press ⌘E

to eject the disk image.

Note: DEVONthink should be installed

in the /Applications directory to

properly work with macOS Services and

DEVONagent. Also, while a logout/login or

a restart isn't required, it is recommended.

MACOS PRIVACY OPTIONS

With continued changes in Apple's security

policies, you are now required to explicitly

grant permissions for many actions your

applications perform. Regarding DEVONthink,

here are options you always should allow in

macOS' System Settings > Privacy & Security,

noting these allowances already had been

granted for years preceding Apple's changes:

Full Disk Access: Provides access to

the filesystem, including your Desktop,

Documents, Downloads, mounted volumes,

items in your user Library, as well as Safari

bookmarks and history.

Automation: Several features in

DEVONthink interact with other

applications, including the Finder. Press

Allow when prompted "DEVONthink want

to control application X"
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Local Network: Starting with macOS

Sequoia, you need to give DEVONthink

access to devices on your local network,

e.g., a multifunction scanner/printer. This is

also required for syncing to devices on your

network, e.g., via Bonjour or local WebDAV

services.

Contacts: Provides access to your

Contacts, used when importing contacts or

handling emails.

Some of the features of the Sorter require

specific permissions. Enable DEVONthink for

these settings:

Accessibility: To use the Copy Selection

function.

Screen & System Audio Recording: To use

the Screen Capture function.

Camera: To use the Video Note function.

Microphone: To use the Audio Note

function.

LICENSING

Now that you've got DEVONthink installed

and given it permissions, you want to activate

your license on this Mac. A purchase or

upgrade comes with two seats so you can

install on two Macs, say a desktop and a

laptop. Do this on each Mac for which you

want to use a seat….

Step 1: Log into your DEVONtechnologies

customer account online.

Step 2: Click the edition you purchased in

the "Your Licenses" section.

Step 3: At the top of the page, click

the "Activate" button. Okay opening

DEVONthink, if prompted by your browser.

Step 4: In DEVONthink's License dialog,

which should be populated with your

information, press the Register button and

you should be ready to go!

UPDATING

Updates to DEVONthink are done per the

schedule set in Settings > General > General

> Check for Updates. If you'd like to check

manually, choose DEVONthink > Check For

Updates.

Note: When checking for updates no

information is uploaded from your

computer to the DEVONtechnologies

server. DEVONthink only downloads a file

containing a list of the current versions to

compare with your installed version.

If you need to manually update the software,

follow the previous installation instructions,

but allow the Finder to overwrite the

old version. Your database(s) will not be

affected. To avoid any potential problems, do

not use a third-party uninstaller utility. Just

replace the current version, as directed.

UNINSTALLING

If for some reason you need to fully uninstall

DEVONthink from your Mac, trash the

following files and folders (~ stands for your

account's home folder):

The DEVONthink application

~/Library/Application Support/

DEVONthink

~/Library/Application Scripts/

com.devon-technologies.think

~/Library/Preferences/com.devon-

technologies.think.*

All DEVONthink-specific scripts in ~/

Library/Scripts
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All DEVONthink-specific workflows in ~/

Library/Workflows/

All DEVONthink-specific scripts in ~/

Library/PDF Services/

Excluding Safari, uninstall the DEVONthink

browser extension, following the

uninstallation process for the particular

browser.

Bookmarklets from your web browser

The alias to the Global Inbox folder in the

Finder's sidebar

Keychain entries containing devoncloudy

in the name

Note: In troubleshooting situations, please

do not uninstall the software without

talking to our support team beforehand.

Most issues can be resolved without

uninstalling the software.
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DEVONTHINK SIMPLIFIED

DEVONthink is a very flexible application,

appealing to a broad range of people and

accommodating many different working

styles. Since people use it in such diverse

ways, it often leads people to believe there

is a "steep learning curve" associated with

it. The truth of the matter is DEVONthink is

a powerful application built on simple, and

often familiar components and concepts.

Here we'll cover the basics.

INTERFACE

DEVONthink has two main window types: a

main window (seen immediately when the

software opens), and document windows.

These windows are used in already familiar

ways, supporting drag and drop, sorting on

different attributes, full screen views, etc.

Whatever you're doing in DEVONthink, you

will be using one or both types of windows.

Similar to the Finder, DEVONthink supports

different ways of viewing your items, e.g.,

in lists or as icons, navigating and viewing

details about your documents, etc. Unlike

the Finder, you can also import new content

in a variety of ways, annotate documents,

process documents from email to invoices,

run (and create) automations, and much

more, all within one application. As we

move through this manual, we'll cover more

specifics about the interface, e.g, types of

windows and what the inspectors are for.

DEVONthink also has a powerful suite of

tools found in its menus. Many of these

are also found in the context menus when

Control-clicking items. And to fine-tune your

experience, it also has extensive settings.
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DATABASES

Beyond the interface, DEVONthink has only a

few core working components: databases and

items. Items are comprised of two essential

components: groups and documents.

Note: Throughout the documentation, we

use item to represent both groups and

documents. Things that only apply to one

or the other will use the appropriate term.

We also distinguish between groups in

DEVONthink and "folders" in the Finder.

This importance of this distinction

becomes more evident in the In & Out

chapter.

Displayed as  and shown only in the

Navigate sidebar, databases are the

fundamental unit in DEVONthink, filled with

items. No matter if your content is grouped,

ungrouped, or a mix, it is all housed inside

your database. You add, remove, organize, and

search for files within DEVONthink, just as

you've done in the Finder forever. Simple.

When you create a database, it is made

as a self-contained package in the Finder.

(Package files are technically folders that are

handled like single files by the Finder.) This

makes your database a simple, portable unit

that can be backed up or transferred as a

singular file.

DEVONthink databases are not merely a

series of files and folders in the Finder, but

are isolated from each other and function

a bit more like disks. When you plug in an

external drive, it appears in the Finder's

sidebar isolated from other disks, but still

capable of moving and organizing data on it.

In a similar fashion, open databases appear

in DEVONthink's sidebar and behave in much

the same way.

Global Inbox: Displayed as , when you

launch DEVONthink, you will immediately

see a database called Inbox. This is a

special database and a core component of

the software. As an essential part of the

software, you can't delete or close it, as it

provides an always open database for quickly

storing unfiled or transient data.

Imagine you are reading about fission

reactions and someone sends a link about

a vacation place in Bali. You jump to the

website and quickly clip a webarchive

of the page. But instead of putting it in

your research database, you add it to the

Global Inbox and get back to work. You can

go back later and read or sort things to

other databases. If you are familiar with

productivity strategies like Getting Things

Done, you'll recognize the concept.

The Global Inbox is also special as it is the

only database you can add a shortcut to

in the Finder's sidebar. This allows you to

save a file into the Global Inbox from other

applications, even adding items to it while

DEVONthink isn't running.

All databases also have an Inbox group with

the same purpose as the Global Inbox. It just

allows you to save unfiled data to a more

specific database, as needed.

GROUPS

One of the two basic items are groups. No

different than the folders and groups found

in many other applications, they merely
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serve as ways to keep certain bits of data

together. But within the DEVONthink groups

are a few variations. They are all simple to

recognize and understand, but they bear

being introduced individually.

Ordinary Groups: Displayed as  , these are

analogous to folders in the Finder. Except

for underlying technology, groups operate in

the same fashion. Groups are the simplest

way to segregate data. Creating, adding

and removing contents, and deleting are all

essentially the same. DEVONthink allows you

to create deeply nested hierarchies or simple

shallow groups, whatever you need to keep

things organized in a way that makes sense to

you.

New empty groups can be made with the

Data > New > Group command. Groups

of selected items can be easily made and

unmade via the Group Items and Ungroup

Items commands in the Data menu. These

commands are also in the context menu.

Groups are also the target of DEVONthink's

classify function. The AI compares

document contents and locations and offers

suggestions for where items may best be

filed. As documents are filed, manually or

taking the AI's suggestions, it becomes more

and more adept at helping you file more

efficiently.

Group Tags: Displayed as  , these are

created and operate like ordinary groups, with

one extra function: the name of a group tag is

applied as a tag to its contents (sometimes

referred to as "children"). By unchecking

Exclude Groups from Tagging, any group you

create will function this way. For individual

groups, you have the option of choosing

Exclude from Tagging from the context menu

or Generic Info inspector.

As you add items to a group tag, they are

automatically tagged with the parent folders'

name. Similarly, removing items from a group

tag will remove the parent tags. If you create

sub-groups, these will also be created as

group tags. This can be useful if you're using

a group for staging purposes, e.g., a groups

for unassigned, in progress, and done items.

Moving files between these groups would

change the tag to its current parent group.

Smart Groups: Displayed as , smart groups

should be familiar to anyone using saved

searches in the Finder. Similar to them, smart

groups don't actually contain anything. They

merely show you items matching the criteria

you specify. Sometimes broadly used in

situations where deeply nested groups are

not used, you can create as many as you'd like

no matter your approach.

These special groups allow you to create

virtual groups based on any number of

matching criteria. These can be simple, e.g.,

"all PDF files in a database", or complex, like

"all unread documents with a specific color

label added in the last week but excluding

HTML files". If you like to use a looser filing

method, using smart groups allows you

to file your items with less concern about

where they're located in the database.

With smart groups you can also have items

appear in more than one smart group without

replicating or duplicating files explicitly. For

example, a smart group could show items

DEVONthink 4.3.2 Documentation, page 11



tagged with "taxes". You could then create

another smart group with items tagged with

"taxes","business", and "2018".

Local smart groups, i.e., ones applied to

a specific database, can be created and

edited via the Data > New > Smart Group

command. You can also find this command

in the context menu when Control-clicking

in the item list. Smart groups can also be

created when doing an Advanced search.

When you create a new database,

DEVONthink automatically adds a few

of predefined smart groups for your

convenience:

All Images: Shows all images.

All PDF Documents: Shows all PDF

documents.

Duplicates: Lists all duplicates.

Note: Smart groups filtering on dates or

unread status are shown with special icons.

Smart Rules: Displayed as  and found only

in the Navigate sidebar, smart rules are a

type of smart group with an extra function:

they not only match items by the criteria you

specify, they can also act on them. These

actions can even trigger when certain events

happen. For example, you could have a smart

rule matching PDFs in the Global Inbox and

have newly added PDFs be added to the

Reading List.

DOCUMENTS

The second basic item in DEVONthink are

documents. No different than the Finder,

documents are any files you add or create in

your databases. Perhaps you are importing

spreadsheets for work, or PDFs for your

thesis. Maybe some photos from your

vacation you want to link to in a Markdown

document you're working on. They're all just

documents.

DEVONthink supports adding many kinds

of files to your databases, but note the

type of file determines its usefulness in the

database. For example, images can easily

be added but searching for them is limited

to searching by attributes like file type or

filename. Remember DEVONthink excels at

text-based operations, so files like rich text

or PDFs are very well supported. We go more

in-depth about the native and third-party file

formats in the Documents chapter.

While not types of document per se, there

are two variations on documents available to

you: duplicates and replicants.

Duplicates: Displayed with  to the right of

a document's name or the name optionally

shown in blue type, there are two ways to

get a duplicate in your database. Firstly, just

as you'd expect in the Finder, select a file

and press ⌘D: a duplicate is made. Secondly,

if DEVONthink examines the contents and

determines it has another file with the same

content, it will mark them as duplicates.

Making changes to the content of one will

usually remove its duplicate status. But if

documents have sufficiently similar content,

they will be marked as duplicates of each

other. For example, if you have pay stubs in

a database and the only changing content

is the date, the content is essentially "the

same". The more text in the document that's

the same, the more likely it will be detected

as a duplicate. Five words in a document with

100 words is a large proportion of the text.
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Five words out of 10,000 words is a much

smaller proportion and likely to be considered

a duplicate. If you want only exact duplicates

to be marked, enable the Files > General >

Stricter recognition of duplicates setting.

Replicants: Displayed with  to the right of

a document's name or the name optionally

shown in red type, replicants are conceptually

similar to aliases in the Finder. Replicants

are one file showing up in more than one

location, called instances. However, they

consume no more space than a single file.

Since they are clones, changes made to any

instance of a document apply to all instances.

This makes them useful when you want to

file a document in more than one location,

but don't want to have to update each

document individually. It can also be useful

if you have larger files you want filed in more

than one group. A 10 MB PDF, replicated in

ten different groups, would only use 10 MB of

space in the database.

It's even possible to have a document that

is both replicated and a duplicate. This will

display this icon to the right of the name: 

It's important that you understand how

replicants work before you begin making

changes to documents. Any changes to a

replicant are carried over to all replicants; as

you might imagine, this means that you can

to do some very powerful (and potentially

negative) things with your database's

contents via replicants. Duplicates, on the

other hand, allow you to change the files

without modifying the original document

or group. Duplicates are less powerful than

replicants, but no less important in the grand

scheme of database organization.

Note: Replicants cannot be created in the

same location as the originating file, nor

can they be made across databases.

THE DETAILS

We hope this has given you some insight

into the basics of DEVONthink. DEVONthink

is deep and powerful, but understanding

these basic concepts and seeing parts you

are already familiar with will hopefully dispel

some of the "fear" that it's complicated and

hard to learn.

That being said, we also have more in-depth

information for you. From simple overviews

of menu commands to details in the appendix

can be found in the remainder of this guide.

BUILDING YOUR DATABASE

Now that we've discussed the philosophy and

core elements of DEVONthink, let's discuss

actually making one.

CHOOSING THE TYPE OF DATABASE

As you've read, a database is the core

element you work with in DEVONthink

— the place where you store, organize,

find, and access your documents. But not

every database has the same purpose or

requires the same level of privacy and control.

So DEVONthink offers several types of

databases from which to choose.

Database (unencrypted): The most

commonly used type, an unencrypted

database is used for any purpose, from

personal to professional. Easily created and

able to grow as large as needed (and your
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internal disk space allows), these are the core

type used by many people. The file extension

in the Finder is .dtBase2.

Encrypted Databases: If you have databases

containing sensitive or private information

you want to lock away when not in use,

create an encrypted database. This is

specialized AES-256 encrypted disk image

with a file extension of .dtSparse when

closed. The mounted disk will not appear

in the Finder's sidebar or on your desktop

when it's open. To further enhance security,

quitting DEVONthink or closing the database

unmounts the disk, again locking its contents

away. This means you are always required

to enter the password to access it. To help

visually identify it, an encrypted database will

display a  key property icon to the right of

the database's name in the Navigate sidebar.

Revision-Proof Database: If you have

mandatory requirements to store documents

that can't be edited, e.g., for tax or legal

reasons, an revision-proof database fulfills

this goal. Revision-proof databases are

archival and intended to be compliant with

legal or financial standards. They are not

working databases, but ones in which you

store and "lock away" important documents.

As such, they are inherently very limited in

what you can do with them.

You can create groups or smart groups and

you can import documents to the database.

For long-term storage compliance, you can

convert PDFs to PDF/A before you add them

to your database. Once you add a document

to the database, it is read-only and cannot

be edited. The limitations also prohibits

using actions like services or adding files via

automation to add files. OCR and imprinting

documents is also prohibited. If you open

a document in an external application and

attempt to edit it, you will be warned it's

locked. If you make a change, it will not

persist. Your only option is to duplicate and

save a new version outside the database.

Every item added to the database is stored in

an uneditable internal log with the metadata

like the name, content hash, and filesystem

dates. If you rename a document, the original

name is still preserved. Dates cannot be

changed. And even if you delete a document,

the deletion is also recorded. All these

interactions can be audited for selected

documents or you can export an audit report

for the whole database.

An revision-proof database can be synced like

any other database. However, it can only be

imported to another Mac as an revision-proof

database.

As preserving the security and integrity of

the documents is paramount, there are also

filesystem safeguards in place. For example,

the Path in the Generic inspector does not

display the document's file path, nor can

you reveal the file in the Finder or copy its

path. If you attempt to rename the database

file in the Finder, it cannot be opened. And

any attempt to modify the internals of an

open revision-proof database will result in

irreparable damage to it.

These databases are clearly not for casual use

and should be utilized when your situation

requires it.
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Note: revision-proof databases are

completely incompatible with DEVONthink

3.x.

Technically similar to encrypted databases

and mounted in a protected disk image, the

file extension when closed is .dtArchive.

In the Navigate sidebar, each revision-proof

database has a  icon to the right of its

name.

When you create an encrypted or revision-

proof database, you need to provide a few

extra pieces of information:

Encryption key: Enter an encryption key

that locks the database when it's closed.

Bear in mind, you must remember or

take not of this key. It is not stored in

any accessible location. And it cannot be

changed. So if you forget it, your data will

be forever locked out of your hands.

Size: Since these databases are contained

in secure disk images, you must specify the

anticipated maximum size, in megabytes or

gigabytes, it will grow to. We recommend

you determine a maximum size and add

20 to 30 percent to it. This allows for

unanticipated future growth.

Spotlight Indexing: For all types of databases,

you have the option to let Spotlight index

its contents. However, the Spotlight index is

stored locally and isn't encrypted so Spotlight

is typically disabled for encrypted databases.

Otherwise, someone potentially could see

a document exists via a Spotlight search.

However, they wouldn't be able to open and

access the database without the proper

key. Spotlight indexing can be enabled and

disabled per-database in the Database

Properties.

DATABASE LOCATION

Ideally, databases are stored in the

Databases folder in your home directory, as

that folder is: quickly accessible, not synced

via iCloud, and generally part of a standard

backup. Alternatively, you can store it on a

connected external hard drive, if your internal

drive space is low. You can put the database

on an NAS but we only recommend this

if you're on a hardwired gigabit Ethernet

connection or better. That being said, you

cannot create or store a database in a cloud-

synced folder, e.g., iCloud Drive or Dropbox.

This is not data-safe so the behavior is

explicitly disallowed. If you try to open a

database in one of these locations, you will

be prompted to let DEVONthink move the

database, or reveal it so you can manually

relocate it.

You may think it is a clever idea to store

your databases on an SD card; a portable

database on hyper-portable media. However,

this is not a good idea as this type of media

are not robust or made for long-term storage.

(Consider how quickly pro photographers

offload their SD cards to other drives.) We

would caution you about thumb drives as

well.

Once you've determined what type of

database you need, select File > New

Database and select the type. Give your

database an easily recognizable name, set any

type-specific options as mentioned above,

then choose where you want to save it.
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ADDING YOUR FILES

Adding items to a database is often a simple

matter of dragging and dropping files into

your database. And we've covered many other

options in the important In and Out chapter.

But the question is: What should I put in it,

everything or…?

While you may be tempted to dump every

file on your hard drive into DEVONthink and

sort it out later, you're best off being more

selective in what you add (especially in the

beginning). Consider this: On your Mac are

hundreds of thousands of files, including in

your User Library. Many of those files are

never seen or accessed by you. Putting your

entire user account in a database only adds

an incredible amount of useless data. And

weeding these unwanted files out after-the-

fact is both time-consuming and frustrating.

DEVONthink is not a Finder nor a Spotlight

replacement and having a database filled

with 90% useless documents is no practical

benefit to you. Also remember, DEVONthink

has to index the metadata and contents of

any compatible files. Indexing unnecessary

files bloats the index of a database and

leads to imprecise search results and false

positives.

However, if you are working in your

Documents folder, that would be more useful

to add. Or if you are working on separate

topics in that folder, perhaps storing your

dissertation files in one folder and bookmarks

and PDFs about kayaking in another, you

could add each folder individually, or even to

its own database.

One way to effectively create separate

databases is to use a topical database

approach. Create multiple databases, with

each holding only related information: a bird

watching database full of birding articles and

newsletters; a quantum physics research

database with research briefs and email. This

method can improve the effectiveness of

DEVONthink's internal artificial intelligence

(AI) with each database as it works best

within a database that contains contextual

relationships among many documents.

Clogging your new database with everything

from A (apple pie recipes) to Z (zebra

population statistics) will only hamper the

AI's ability to work effectively.

Having topical databases can help down the

road as well. You may be collaborating on a

database, syncing between machines in a

group. Imagine having just one database: You

decide to share your painstakingly researched

academic articles with colleagues, only to

find that you've mistakenly also shared

personal financial records and chats. It's not

hard to imagine how that has the potential

to be both dangerous and embarrassing.

Having multiple, topical databases will allow

you to keep your data separate and private.

This approach can also be beneficial from a

performance standpoint, which we'll see next.

Database Size: When it comes to database

size, there are many variables that can limit

the size or performance. Obviously, you need

available disk space to grow the database.

And you should always keep at least double

the space free in case you require virtual

memory or maintenance. But the file size

of a database is not the critical factor; it's

the number of words and amount of RAM
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available to DEVONthink. The reason is this:

When you open a DEVONthink database,

the index is loaded into memory. This makes

search and classification lightning-fast! But

the more words in your database, the larger

the index. The larger the index, the more

RAM is required to avoid using the hard drive

as virtual memory. Look at the number of

unique and total words for a database in the

Database Properties window and use these

soft-limits as a guideline:

Total Words: 400 million total words

Unique Words: 4 million unique words

Total Items: 250,000 items

As your growing databases use RAM,

processor time, etc., smaller, more focused

databases are often a more effective

approach than using singular, monolithic

databases. Separate databases generally

perform better, sync faster, and in the rare

case of a catastrophe, can help avoid data

loss since you're not keeping "all your eggs in

one basket". Another benefit of this approach

is the ability to conserve some machine

resources. With a single, large database all

the information is always using resources,

even files unrelated to what you're working

on at the moment. With separate databases,

you can close and open specific databases as

the need dictates.

You should also have as much RAM as

possible. In fact, this should be a deciding

factor when purchasing a Mac: the more

RAM, the better. Choosing a machine with

8GB RAM may be functional but can also

be less performant as your databases

grow. With more powerful machines having

much more RAM, the stated figures can be

exceeded. However, staying within these

limits helps keep things running smoothly.

ORGANIZING

Database organization depends on the

parties involved. For collaborative work, you'll

want to organize it in a manner that's agreed

upon by all parties using it. This is especially

important since our sync technology is a

mirroring sync, meaning changes to one

copy of the database gets synced to the

other copies. If one person decides to

reorganize things, it affects everyone. For

personal work, just set up your database in

a manner that makes sense to you. There is

no right or wrong way to organize it. This is

something you've likely already been doing in

the Finder, making folders and filing things

in them. Apply the same personal choices to

DEVONthink.

You will likely see various organizational

methods proclaimed as "this most effective".

DEVONthink isn't built to accommodate any

of them. Its flexibility just allows people to

adapt these methods in their databases. Feel

free to explore these options if you'd like, but

the best method is the one that makes sense

and is efficient and effective for YOU.

CASE STUDY: BILL'S DATABASE FARM

Bill DeVille, formerly DEVONtechnologies'

Evangelist, worked in a number of scientific

areas. Bill's main database covered

environmental science and technology

topics, with related interests in science

and technology exchanges with developing

nations. The database even contained some
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projects dealing with graduate education

in environmental sciences and engineering.

There's a broad topical relationship among

these subjects and the database covers

disciplines ranging from chemistry, toxicology,

statistics, risk assessment, and engineering

to economics, legal, regulatory, and policy

issues. These disciplines fit together and

combinations of these topics are necessary in

many real-world cases.

As you can imagine from the above

description, Bill's main database was quite

large, containing about 20,000 documents

and over 20,000,000 total words. Because

of the relationships knitting together all

these scientific, technical, legal, and policy

issues, the artificial intelligence features

of DEVONthink worked very well for Bill in

researching the database and contextualizing

the information.

In addition to his main database, Bill had

seven additional databases (so, eight total).

For example, he had one database for Apple

Newton literature he has accumulated over

the years. It was almost as big as his main

database, but the topical coverage has no

practical relationship to the main database,

so Bill kept the Apple Newton literature in its

own domain. If he were to keep this unrelated

information in his main research database,

the result would be a larger, slower database,

with poorer performance by the artificial

intelligence.

Occasionally, Bill added topical materials to

it that are not related to its main purpose.

However, when those "unrelated" topics grew

large enough in volume, he spun them off into

to a new database in order to preserve AI

accuracy and relevance.

If you'd like to follow Bill's method, start by

creating a database with some collections

of files that interest you, but don't be afraid

to create other databases that contain

"different" material as your interests, and

main your database, grow. And if you need

to search across databases, simply open all

of them at the same time. DEVONthink can

easily search them simultaneously.

Remember that creating databases isn't an

immutable commitment. Create and destroy

them as you see fit. Start with one way of

organization, see how it works for you, and

decide later to re-organize, if needed. You can

keep multiple databases open simultaneously,

easily moving documents from one database

to the other at any time. As you work with

your databases, new ideas may spark new

approaches which can easily be tried and

adopted or discarded. Remember this:

The best organization method for your

databases is the one that makes sense to and

is effective for YOU..

TAGGING

Tagging is a common method of creating

context relationships between documents.

For example, you can apply a "hobby" tag

to a woodworking article and a sewing

machine PDF manual. You would then

find both documents when searching for

the "hobby" tag. Used in the Finder and

many other applications, DEVONthink also

supports tagging in your databases (including
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optionally preserving Finder tags on imported

and indexed items). Tags are either ordinary

tags or group tags, each discussed below.

ORDINARY TAGS

Similar to tagging methods used in other

applications, ordinary tags are added to

items by you. Each database has its own Tags

group and is accessed in the item list or the

Tags section of the Navigate sidebar. The

item count of a tag shows how many items

it has been applied to. If there are unread

items in a tag, the tag's name will appear in

bold type. If there is a mixture of read and

unread items, the count in the item list will be

displayed as "unread items/total items".

Creating tags: When you add a new tag to

an item, a tag group is automatically created

in the Tags group for the database you're

working in. However, you can also create

tags to be used later. Create them in the

database's Tags using the Data > New > Tag

command or the New > Tag command in the

context menu or New toolbar button.

Applying tags: When you apply a tag to an

item, a reference to that item is created in

the appropriate tag group. You will have an

item reference in each tag you apply to it. So

if you add three tags to a document, you will

see a reference to the document in each of

the three tags.

Ordinary tags are most commonly manually

applied by these methods:

Type tags into the Tag bar under a

document's view/edit pane.

Type tags into the Tags section of the

Info inspector or the Info popover for a

document.

Add tags via the commands in the Data >

Tags submenu.

Add tags via the AI > Tags inspector by

double-clicking suggested tags, related

tags in the Tags graph, or manually entering

them.

Drag items in your database to the desired

tag in the Tags section. Be aware dragging

an item to a tag in another database will

move it to the receiving database.

You can tag multiple selected items via the

Info inspector, Info popover, or the Tag bar.

Note: While importing directly into a tag,

e.g., via drag and drop, is supported, it is

not generally recommended. If you do this,

an item reference is made in the tag but

the original item will be located in the Inbox

of the receiving database. Importing then

tagging is suggested.

Modifying and Merging Tags: You can rename

an existing tag in the Tags of a database

as simply as renaming any other item. The

change will instantly apply to all the items

using that tag. If you have similar tags but

would like to consolidate them into one, e.g.,

having tags of apple and Apple, select them

in the Tags group, then choose Tools > Merge
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n Tags. The tags and their item references

will be merged into one tag, preserving the

topmost tag's name. Again this change is

applied immediately.

A tag can be dragged and dropped into

another tag to create parent/child tags. But

please read and understand the Nested Tags

subsection below before proceeding.

Deleting Tags and Tag Groups: Deleting

individual tags from items is done via the

same methods you apply them, e.g., in the

Generic Info inspector. Deleting tag groups

is done in the Tags group of the database.

Simply select the unwanted tag and choose

Data > Move to Trash. This immediately

removes the tag from all them items it was

applied to. And only the item references are

moved to the Trash, not the original items in

the database.

Applying, modifying, or removing tags can

also be done by more automated means, e.g.,

scripting, smart rules, and batch processing.

see the Automation chapter for more

information.

FINDER TAGS

Finder Tags: DEVONthink supports reading

and writing macOS' Finder tags. If tags are

present on an imported or indexed files, they

will be preserved in the database. When

tagging imported files, tags are not written to

the filesystem. Instead the tags are recorded

in the Spotlight metadata when the Create

Spotlight Index option is enabled in Database

Properties popover. This allows searching

for tags in Spotlight using the tags:myTag

syntax. If you export or drag and drop files

to the Finder, macOS tags will be written

to the exported file. When tagging indexed

files, the tags are immediately written in the

filesystem and searchable, just as they would

be if you tagged them directly in the Finder.

You can change whether Finder tags should

be imported or exported in the Files > Tags

settings. Bear in mind these options are

global.

TAGGING SOURCES

Beyond the tag exchange with the Finder,

tags can come from several other sources.

The following options in DEVONthink's Files

> Tags or RSS settings control other tagging

mechanisms. Tags from these options can

also be manually applied via the Data > Tags

submenu and the context menu in the item

list.

RSS: In the RSS settings, the Convert

categories and hashtags to tags option

converts categories detected in the feed

articles or hashtags in the contents into tags.

In conjunction with the previously mentioned

Finder tags or Spotlight data, this can lead to

a large number of macOS tags being added

automatically in the Finder.

Hashtags: Popularized in social media,

hashtags are a type of tag prefixed by a #.

If enabled in the Tags settings, DEVONthink

can detect hashtags in the contents of

text-based files and convert them to tags

for the file automatically. Removing the

hashtags from the content will remove the

tags from the file. Hashtags do not support

spaces in them and they should be listed on

a separate line. They will not be detected

within existing paragraphs. Of special note,

hashtags supports creating nested tags
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as noted here. The first tag just needs to

be prefixed with the # to be detected as a

hashtag..

Keywords: When enabled in the Tags

preferences, DEVONthink will convert the

keywords of PDFs and rich text documents

into tags.

Properties: Also found in the Tags

preferences, DEVONthink will attempt to

convert certain properties to tags, e.g., the

names and email addresses of the sender and

recipients of emails.

Geolocation: Enable Convert location to

tags in the Import preferences to convert

the applied geolocation of a file into tags.

The Geolocation can be viewed in the Info

inspector.

Assign existing tags: DEVONthink attempts

to classify the document based on existing

tags. If it can't, it examines the contents and

title to find words matching tags and applies

those it finds.

Add Vision suggestions to images: This

option uses Apple's Vision framework to

recognize items in images add subject matter

tags to the document. These tend to be more

generic identifiers.

Add Chat suggestions to documents: Uses

your chosen Chat provider to examine the

document and add tags. Optionally, you can

have it only apply tags that already exist.

These are often more specific, e.g., snow

leopard versus feline.

NESTED TAGS

Sometimes referred to as "hierarchical tags",

nested tags are a series of related ordinary

tags, combined under a parent tag. When

you add a child tag, the item automatically

inherits the parent tags. In the example

shown below, adding a tag of "Casper" to an

item would automatically add the "Wyoming"

and "US" tags.

A special mechanism in DEVONthink allows

you to create nested tags automatically:

enter the tags separated by a forward

slash. For example, type a tag of software/

productivity to create a parent tag of

software with a child tag of productivity.

Use this option in the places where tags are

entered, e.g., the Tags bar, Tags field of the

Info inspector and Info popover, and the Tags

column in the item list.

Note: If you are having trouble deleting a

tag from an item, check to see if you are

adding a nested tag.

Caution: Tags for a database can have the

same name. This may seem illogical, but it's

something more commonly seen that you

may expect. For example, say you have a

travel database with points of interest like

restaurants tagged in different locations. You

may find yourself with a tag structure like

this…

Example:

US

  Wyoming

    Casper

      Restaurant

  Minnesota

    St. Paul
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      Restaurant

If you added a tag Restaurant to an item,

what tag would it go to? It actually would go

to the most recently entered instance of the

Restaurant tag.

So how is this resolved? Tags are meant to

be unique, so eliminating redundant tags is

first priority. Restaurants aren't specific to a

geographic location. Create the Restaurant

tag as a top level tag. If you had a need

for hierarchy with the tag, perhaps for tax

purposes, you could move it into a parent

Tag of Entertainment. Then you would get

both tags when you added Restaurant. But

again, if you anticipate wanting to use the tag

without the parent tag, you should make it a

top level tag.

Also, you shouldn't view the tags as a group

structure in and of itself. Nested tags are just

meant to group tags specifically related to

each other, so they can be applied en masse.

Note: Tagging methods and philosophy is

full of strong opinions. Many people feel

tagging should always be flat; only top

level tags and no hierarchies. DEVONthink

accommodates both approaches. However,

if you want to used nested tags, we hope

you carefully consider the caution we've

presented and use a hybrid method to

avoid unexpected behavior.

GROUP TAGS

Previously discussed in the Groups section

earlier in this chapter, group tags allow

you to dynamically assign tags based on

their location. As you add files to a group,

they have tags of the parent group's name

assigned to them. Similarly, if you move

the items to a new group, the tags are

removed and new ones applied relative to

the new location. Whether used statically

or dynamically, group tags can be used

creatively. They also work in conjunction

with ordinary tags, so you can employ both

methods in one database.

Example:

Imagine you have a work database with

groups for different stages of a project:

Unreviewed, Assigned, In Progress, On

Hold, and Done. At the beginning of

the process, you'd put the item in the

Unreviewed group and it would be tagged

as such. After reviewing, you could move

the file into the Assigned group and

the previous tag would be removed and

replaced with Assigned. As the project

moves through the staging groups, the tag

would change.

And of course you can use ordinary

tags, e.g., Reviewed or a client identifier,

on these items. Those tags would be

preserved no matter where you move them

in the databases.

Groups tags are applied by DEVONthink

automatically. But you can also do some

automatic filing by entering existing group

tags manually. If you enter the name of an

existing group that is not excluded from

tagging into the Tag bar or an Info panel or

popover, the item will be replicated to the

appropriate group. You can also drag an item

to a group tag in the Tag Cloud at the bottom

of the Navigate sidebar.
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Considerations: When you enable using group

tags for a database, it starts as an all-or-

nothing situation. All groups in the database

function as group tags.

If you want to use group tags for most groups

in a database, you can Control-click specific

groups and choose Exclude from Tagging. You

can also choose this option in the Exclude

from… section of the Info inspector or Info

popup for a specific group. However, note

you must change this setting on all individual

groups you'd like to exclude.

If you only want a limited number of tags, it

would be advisable to exclude groups from

tagging for the database and use ordinary

tags instead.

AUTOCOMPLETION

When you are typing tags, an autocompletion

list will appear. In the Global Inbox, tags

from any open databases are shown as

potential tags. In other databases, the items

displayed are only from the tags of the

current database.

While group tags aren't added to the Tags

group for a database, they are displayed in

autocompletion suggestions.

Tags and Aliases: DEVONthink also honors

aliases added to groups. You can add

"alternative names" to a group using Info

popup or inspector and later use these

alternative names as a tag. Continuing the

previous example, you could add an alias of

IP to the In Progress group. Now, type

IP as a tag and it will be replicated to the

In Progress group. When you view the

file, you will see the proper group tag was

automatically added.

SEARCH AND GATHER

Finally, tags have two main functions:

segregating data and searching for data. You

use tags to gather items together in certain

contexts. You also use tags to search for

those items.

Searching for items by their tags is easily

done in a few ways:

Search field: The search field at the top of

every main window allows you to search for

tags by using the advanced options for a

search. You can also search for tags using

a simple tags: prefix. Multiple tags can be

specified, separated by semicolons. You

can also use tags!: to exclude tags.

Tag cloud: The Tags Cloud allows you to

filter the current list of files by clicking on

available tags. As you click, only related

tags are shown so you can fine-tune the

items displayed in the item list.

Tags inspector: The Tags inspector  not

only shows tags on the current document

but also existing tags that may apply.

Additionally, select a tag and the Tags

graph will show other related tags.

Gathering similarly tagged items is powerfully

achieved with Smart Groups. Smart groups

allow you to use the smart group editor

controls to set criteria to be matched.

Included and excluded tags can be added as

criteria. Files matching the parameters of the

smart group are shown, regardless of their
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location in the database. This way you can

leave your files where they are and create

virtual folders for specific purposes.

AI EXPLAINED

Artificial Intelligence (AI) has been the stuff

of science fiction writers and tech evangelists

for decades. Slowly and quietly, technology

evolved as hardware improved and knowledge

was gained. But in November of 2022, a

company called OpenAI released a Large

Language Model (LLM) called ChatGPT.

Within a month, it was one of the most

talked about technologies in the world,

sparking everything from excitement to

fear to puzzlement, becoming synonymous

with the term "AI". Since then, we have

seen a technological arms race to make it

better, faster, more powerful and, well… more

intelligent. Where this all leads, no one truly

knows, but just as fire can be destructive

it can also provide warmth and utility when

handled properly. And while many companies

rushed to be "first to market" with some kind

of integration, our commitment to privacy

and the safety of your data dictated our

direction and investigations. After countless

hours of development and testing, to the

drawing board and back, we have created

controlled ways for AI to be accessible, useful,

and safe in your databases. We appreciate

the patience and understanding from all of

you as we journeyed down this path.

DEVONTHINK'S AI

To clarify, an AI model is the technology used

by services like ChatGPT, etc. In contrast,

DEVONthink's AI predates these LLMs by 20

years and was built by us using an entirely

different set of methods, methods that

are still as powerful and functional today

as they've always been. For example, the

See Also inspector, the Tags and Graph

inspectors, as well as commands in the Data

menu are still controlled by our internal

AI. The remainder of this section is about

external AI services, like ChatGPT.

AI BASICS

If you're new to AI, perhaps having heard

people talking on forums, the news, etc., but

you don't know much about it, here's a very

simplified intro.

How does chat work?: At a very simplified

level, your chat questions are broken down

into bits and pieces, called "tokens", which

are processed by AI. It examines a token then

looks into its huge database of parameters

trying to identify it and the most likely token

that would follow it. It puts the best match

in place then moves on to the next token.

This process is repeated over and over again,

mathematically constructing the tokens into

words, then sentences returned to you as a

response.

Parts of a query: There are three parts to

making an AI query. Two are mandatory; the

third, optional but useful.

AI model: The chat engine you're asking

questions of. Obviously, you need to send

the question somewhere. The default

model you choose will handle those

inquiries, though you can also choose

others if you have access to them.

Prompt: This is your question or command.

These can be simple, e.g., "Tell me about

sea turtles." or "For the selected document,
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suggest three possible filenames."

However, the more specific the prompts,

the more specific the responses. You

can include directives about how the

response should be delivered, what level

of explanation, etc. It's even possible to

request certain types of formatting like

asking for content returned in a Markdown

table instead of a list.

Role: An optional but sometimes useful

component, a role can define a persona to

help direct the responses. This could be

for yourself like, "I am in an undergraduate

calculus class…" or for the AI engine such

as "You are presenting an introductory

workshop on woodworking…" The chat

responses will be tailored to be appropriate

for the role and setting. The role can be

added as a part of your prompt. If you

have a specific role you want to use with

automation and templates, you can add a

default role in the AI > Chat settings.

Example:  You are a biologist providing

research data for government reporting.

Provide a Markdown list of the last

ten years of counted leatherback sea

turtle eggs compared to hatchlings.

Include columns for the number and

percentage of increase or decrease. Include

a prologue section to the document with

an assessment of last years numbers.

Include an epilogue with a forecast for this

year's anticipated numbers.

We have also included some relevant terms in

the Glossary > AI section of the Appendix.

Choosing an LLM: Remember that using AI

is entirely optional. However, since you're

reading this you are at least curious about it.

So the first step is choosing an LLM. If you

look at the AI > Chat settings, you will see

where you set a default Chat model. These

are the currently supported options, with no

specific advocacy for any:

ChatGPT: OpenAI's breakthrough LLM,

ChatGPT is a fast and powerful general

purpose model but can also handle more

technical inquiries.

Claude: Created by Anthropic, Claude

is a privacy-focused LLM that provides

excellent conversational responses to a

variety of requests. It also can handle more

technical inquiries. It does tend to provide

more commentary, so you may want to add

No chatter. to your prompt if you need to

curb the excess.

Gemini: Google's Gemini LLM is a fast, no-

nonsense responder, often just producing

results with little excess commentary. This

can be especially useful in information

gathering and document construction.

Mistral: Mistral is from a French AI

company traditionally focused on open-

sourcing many of its models. Their models

are broadly useful, from document analysis

or code snippets to more general inquiries.

Perplexity: Beginning as a search-based

AI engine similar to Google from the US,

Perplexity offers self-branching searches

with its Deep Research to gather and

assess before responding. It also offers

reasoning models. Deep Research is only

intended for use with the Chat assistant.

Apple Intelligence: Available on macOS

Tahoe, Apple's Foundation model

is supported but very limited in its

capabilities. With a tiny context window

and no support for advanced functions like
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vision or tool calls, it's mostly suitable for

simple tasks like tagging or summarizing.

Note that Apple Intelligence needs to

be enabled in System Settings > Apple

Intelligence & Siri before you can use it in

DEVONthink.

Local LLMs: LMStudio and Ollama are

two bespoke AI applications that allow

running an LLM downloaded on your Mac

or accessible on a network.. DEVONthink

also supports using other AI application,

provided they use an OpenAI compatible

endpoint. These applications tout privacy

and offline use and can sometimes produce

excellent results. However, performance

and responses are often limited by your

hardware and the size of the model you can

run.

OpenRouter: Similar to how WebDAV syncs

provide other sync options, OpenRouter

provides access to some AI models that

aren't officially added. Currently accessible

models are from: Amazon, Anthropic,

Google, Meta, Microsoft, Mistral, OpenAI,

Perplexity, xAI, Baidu, Deepseek, Moonshot

AI, and Qwen. But note we aren't providing

access to beta, preview, experimental,

outdated, or distilled models. The available

capabilities depend on the models.Also, if

you already have an API key for a specific

supported provider, e.g., ChatGPT, we

recommend using it instead of accessing it

via OpenRouter.

For a list of the supported models, please

refer to the AI Models section of the

Appendix.

THOUGHTS ON CHOOSING AND USING AI

As we've mentioned, adding AI capabilities

was no trivial thing to investigate, discuss,

and implement. And while we have come to

terms with the areas of concern we could

control, on a personal (or professional) level,

there are still topics that you must consider

and decide on for yourself.

Privacy: We are firm believers in data-

privacy and we do whatever we can to

keep things in your control. However, when

dealing with a commercial AI service, your

questions and potentially documents go to

servers controlled by that service. We don't

advocate being paranoid about using such a

service, but it's good to know about and feel

comfortable with whom you are sharing some

of your data. However, you may wish to opt-

out of having your AI "conversations" being

used to further train their AI.

DEVONthink doesn't allow AI to have

uncontrolled access to your data and

databases but takes several steps to

safeguard your privacy. By default, using the

Chat assistant or any AI assisted automation

only uses selected documents. When the

database search option is enabled in the

settings, only the selected items, items

matched by smart rules, or the group

selected in the Navigate sidebar, i.e., the

current location, are accessible to AI, further

limiting its reach.

DEVONthink also never sends your original

document to an AI engine, taking these steps

to keep things private:
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Image files are scaled, recompressed, and

sent without the original metadata.

For PDF documents without a text layer,

a certain number of page thumbnails are

sent, dependent on the AI model you're

using.

Text-based documents only send raw text

with no metadata.

In case of audio and video files, any

available transcription or still images

from video would be sent when chatting

about them. Also, when using a remote

transcription model like OpenAI's

Whisper, the audio track is extracted

and recompressed before it's sent for

recognition.

To improve results and enhance privacy,

links in content, including email addresses,

are anonymized. This can also reduce token

usage.

When using commercial AI models

supporting tool calls, data is only sent on

demand, never in advance.

Lastly, DEVONthink doesn't come with AI

access enabled and running. It's up to you

to set up and choose the options you want

to use. So using external AI is completely

optional, not a requirement, and not using it

may be exactly the level of privacy you want.

Expenses: "There's no such thing as a free

lunch." This applies to using a commercial

LLM as well. While they typically offer a

free account of some kind, it's very limited

and made for familiarizing yourself with the

process and responses. Once you determine

this is something you want to use more

often, get out your credit card. You will be

purchasing tokens, again "bits of words",

either in bulk or running up a tab as they're

used. While they're typically relatively

inexpensive per-token, heavier use of AI

will deplete your reserves or increase your

bill faster. As a courtesy, we've included

property icons in the AI settings denoting

if a particular chat model is known to be

expensive.

Another thing to be aware of is the difference

between using a chat agent, e.g., talking to

ChatGPT, and using their API. An API is how

third-party applications programmatically

access services and data provided by a

company. To use commercial AI services, you

will need to create an API key for the service

and enter it in the Chat > API Key settings.

Check with your AI provider how to generate

a key and any involved costs.

Here are some general recommendations

that may help curb costs:

For everyday tasks and automation, use

the cheapest model, e.g., Claude Haiku.

DEVONthink automatically chooses the

cheaper models for certain tasks, e.g.,

chatting with the Help viewer.

In the Usage dropdown are three options

for broadly adjusting the number of tokens

being used. This obviously affects your AI

costs. While you can experiment with the

settings, Auto strikes a good balance and

is one less thing to think about. You can

always temporarily change this for certain

situations. Chatting about a document will

use more tokens the longer the document.

In this case, you could try setting the Usage

to Cheapest.

Choose more expensive models if the

lower-tiered model fails to produce a useful

answer or you need the features of a higher
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model, like "thinking". The Chat assistant

or AI-based smart actions, like the Chat -

Query action, let you temporarily switch

models.

When generating images, use very specific

image prompts to avoid endlessly iterating

through pictures that aren't what you're

envisioning. While it can be fun to see

what it comes up with, image generation is

usually a more costly use of AI.

Quality of results: As we discussed previously,

these chat engines are doing incredible

computational gymnastics to produce

responses but don't have any actual

knowledge to draw from. It has no way to

verify its answers in the way a human can.

Earlier on they were known for "hallucinating",

i.e., returning responses that were complete

sentences but made no sense or had little

to no relevance to the question asked.

Things have certainly improved, and likely

will continue to, but it is still possible to have

incomplete or inaccurate responses. So while

you may get a reasonable response, be aware

the result isn't guaranteed to be accurate.

Especially on questions of consequence, you

should be checking the responses.

The limitations of local AI: No one wants to

share their data. No want wants to pay for AI.

We certainly understand those things. While

there is an ever-growing list of "Run the AI of

your choice on your Mac now!!" applications,

let's take a realistic look at running your own

AI:

Performance: AI requires a lot of

computing resources to run well. Similar to

how DEVONthink loads a database's index

into memory for lightning-fast searches,

classification, etc., an AI engine loads its

model into memory. The larger the model,

measured in the number of parameters, the

more memory is required to effectively run

it. However, many Macs have very limited

RAM. Even a "good MacBook" with 16GB

RAM, would only be able to run a small

model of 6-8 billion parameters, given

other apps and the operating system are

also using machine resources. Those are

very small models. Running larger models

may be possible but they will be slower to

the point of being inefficient.

Quality of responses: With the

aforementioned limitations imposed by

machine resources, you may feel a small

model is just fine for you. While it may

actually run, the responses you receive

are almost certainly going to be from less

accurate to hallucinating. Consider the

disparity in knowledge between a child

and an adult. Ask both, "Why is the sky

blue?". A child would have a small number

of "parameters" to drawn from to answer

the question. But the adult, especially one

with more specialized knowledge, would

have a vastly larger set of parameters to

respond from.

Context window: The context window

is like the short term memory of AI, and

it is a finite resource. The smaller the

context window, the sooner AI will lose

track of the "thread of the conversation".

For commercial LLMs, this is large enough

for ad-hoc inquiries but the size can be

a limiting factor when trying to process

longer documents, e.g., a scientific PDF. For

locally run AI, the context window is much

smaller. And using larger context windows

locally consumes more resources.
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However, if you're inclined and curious — and

your hardware can support it — using local AI

is certainly something you can explore.

WHAT CAN'T BE DONE WITH AI

While there are many things that can be

done, there are still limits imposed by

privacy concerns or technical considerations.

For example, AI has access to the current

location in a main window, not all your

databases. It also isn't going to operate

like an automaton, creating databases,

constructing its group structures,

downloading and filling those groups, then

examining and issuing reports on it all. It

is an "assistant" in your labors, not your

replacement.

Another critical thing to be aware of, AI is

not going to "process and connect" years

of your documents and information in your

database. The way AI is hyped by many makes

this sound feasible, but it actually is not.

Will you be able to process documents in a

useful way? Of course, but on a much more

limited scale. So while we understand the

hope, actually accomplishing this would be

time and cost-prohibitive for most people

and require sharing all those documents with

third-parties.

We believe it's important to approach AI in

DEVONthink with a good understanding of

the possibilities and limitations (and yes,

some things may change as technologies

evolve). That all being said, we believe you'll

find many uses for the extended abilities of

AI in DEVONthink. In the next section, you'll

find an overview of where AI is integrated,

some practical use cases, and an important

tip on how to use AI more effectively.

AI IN PRACTICE

In the previous section, we introduced AI

concepts and considerations as related to

DEVONthink. Here we'll cover: where AI is

integrated, some ideas for practical uses, an

explanation of one of the important settings,

controlling AI's access, and a few tips on

getting better responses.

ASSISTANTS

Though it is possible to have a chat with AI,

DEVONthink isn't merely a front-end to an AI

provider. It has been integrated into several

aspects of the application, providing new or

improved functions, complementing our own

internal AI. For non-automated functions, you

interact with AI via several assistants and a

specialized server.

Chat Assistant: Many of your interactions

will happen in the Chat inspector or

Chat popover. Whether you're asking an

impromptu question or chatting about the

selected document, the assistant is made

just for these things, all shown in a familiar

message-style interface. And if you want to

keep a record of the "conversation", you can

easily save it as a reference for later. If you

become a frequent AI user, you'll likely chat

via the assistant often.

The Chat inspector inspector and the Chat

popover have the same functionality but

operate independently. When they open, they

use the same default AI engine. However,
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each can use a different model and each

conversation is isolated. So you could have

a discussion in the inspector and issue

commands in the popover, without losing

continuity in either discussion.

Note the Chat inspector belongs to a window.

So if you have an active chat in a main

window and open a separate document

window, it will not retain the previous

chat. Also, the Chat popover is persistent,

retaining its contents across relaunches of

the application.

Search Assistant: When doing a toolbar

search, press the AI button to open the

Search assistant. This lets search with

more natural language, e.g., "Show me PDF

documents with more than 10 annotations."

The AI processes and shows the raw search

syntax, kind:pdf md_annotationcount>10.

Help Assistant: Instead of reading through

DEVONthink's built-in help, you can open

the Help assistant and ask questions. The AI

model is given access to the documentation

and may be able to provide answers and links

to related parts of the documentation.

Script Assistant: If you want to create

DEVONthink scripts but don't know how, AI

can assist in drafting a script for you. Choose

Data > New > Script to open the Script Editor

window, choose a model, explain what you

want, and let the AI code something for you.

MCP Server: An MCP server is an internal

AI server allowing you to connect to and

work with your databases while outside

our application, but still in a controlled

and safe manner. There are a wide variety

of commands available encompassing

many practical features, like: creating

and modifying documents and getting

information about them, document format

conversions, searching databases, classifying

and filing documents, transcribing speech-

to-text or text recognition, performing

online searches, file imports and exports,

etc. Used in conjunction with MCP-capable

applications, e.g., Claude Desktop, this

expands the ways you can work with your

data.

Once the server is set up, you will be able

to ask questions and and give instructions

like, "Get this document's DOI. Then find

the document online and download it to my

Bibliography database with full CrossRef

metadata."

One distinction to make between the Chat

assistant and the MCP server is: prompt

versus skills. In a chat you usually discuss

things in a more impromptu manner. With

MCP, you can create a range of connected

commands and consolidate them into a skill

to accomplish repetitive tasks. You define a

generic set of MCP actions for AI to follow

when the situation requires it. So instead

of telling AI to file a particular email, give it

examples and parameters to process and file

future emails. Or create a system you run

daily that examines and builds a report of

things recently finished, due soon, or overdue.

When run in conjunction with other MCP

servers, you can create and run some very

complex workflows.

And all DEVONthink's MCP interactions are

done with your privacy and data-safety in

mind. For a deeper dive on the topic, see the

Appendix > MCP Server section.
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CAPABILITIES

The possible uses of AI are extensive and

as you work with it, you're likely to stumble

onto new ways of using it. But here are a few

common, broad functions.

Document Processing: Summarize the

document you're reading, or transform

selected text via two buttons in the

Navigation Bar. Or use AI to change metadata

like label, ratings, etc. Or have it examine the

contents for tagging, renaming, etc.

Media and Image Processing: Process and

transcribe audio and video files and examine

images with machine learning. You can

generate a transcript from audio or video

files in your databases. Let AI determine the

subject, transcribe text on signs, menus, etc.

In both cases, the text is stored in one of a

few ways. With one setting this can even

happen automatically when adding the files

to your database.

Document/Image Generation: Create

documents with AI, both text-based and

images. DEVONthink provides some AI

templates made for creating text documents.

Or use Data > New > Generate Image

command to open the Generate Image

window where you can describe an image and

have AI create it for you. Additionally, some

chat inquires can create new documents. You

can read more about this in the AI and Your

Documents section.

Database Searching: You can ask AI to look

for documents as you talk with the Chat

assistant, the Search assistant, or the MCP

server. For example, you could ask for it to

find your espresso machine manual or a

receipt for your telescope purchase.

Automation: Using chat queries and

responses in smart actions like Chat –

Query and the chat-based placeholder

Query Response, present new automation

possibilities for everyone. Additionally, there

are new AI-driven commands available in

AppleScript and JavaScript.

PRACTICAL USES

The preceding section presents a more

general view how you interact and broad uses.

Let's look at a few example use cases and

methods:

AI Renaming Files: It's not uncommon to get

a document with a less than useful name.

Select it and tell the Chat assistant to Add

the filename to the finder comments

of this document then rename it with

a reasonable name. This lets you preserve

the original name, if needed, but also gives

you something easier to find at-a-glance or in

searches. Alternatively, you could tell it to Add

only the filename as an alias on this

document….

Another option is to use batch processing to

rename selected files based on their content.

These could be any type of file. Select a few

documents and choose Rename to Chat

Suggestion in the Tools > Batch Process

submenu. Your default AI engine will attempt

to examine each document and rename

it. Note you can choose another engine by

clicking the  button.
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AI Tagging Assistance: While it's possible

to automatically tag documents on import,

you may want to handle tagging on a case-

by-case basis. Select a document and ask

Chat, What tags would you recommend

for this document?. If you like some

of the suggestions but don't want to add

specific ones, you could tell it to add them,

e.g., Add three broad and two specific

tags from that list. Or if this was in

a recipe database, you could tell it to Add

the ingredients as tags. And don't

miss the AI commands Data > Tags > Add

Chat Suggestions to Documents, Add

Vision Suggestions to Images or the same

commands in the Tags smart action.

AI Documents from Web Content: If you have

a bookmark selected in DEVONthink and

want to gather specific information from

it, you can ask Chat to create a document

for you. For example, if you were reading

about how to build a birdhouse, you could use

Add the instructions on how to build

a birdhouse on the selected page.

You could also try a less specific prompt,

like Capture the instructions on the

selected page. The default format will be

Markdown but you can request plain text,

Markdown, or HTML documents from Chat.

However, it is possible for the AI to respond

with a format it decides.

Here's another example: Imagine you're

shopping for a car and looking at a bookmark

in DEVONthink. You get some results you

like but just want to extract some specific

information separately. Tell Chat to Capture

the two cheapest cars newer than

2014 with less than 100,000 miles

from this page. With some AI engines,

you may get the document and also some

commentary about them as well.

AI Searches: With AI, you can do "semantic

searches", essentially looking for things

related by concept instead of specific

terms. As an example, ask Chat to look for

documents that talk about vehicles

and watch it generate its own query,

e.g, searching for car* OR boat*

or plane*…. Logically, you can be more

specific, as needed. In a database of PDFs

from car manufacturers, you can ask for

documents about Italian vehicles

without mentioning a brand, and it will return

documents about or that mention Italian

vehicles.

One thing you may be surprised by is how

natural a chat can be. Say you're gathering

information for a local animal shelter and

want to locate some of your documents

on different breeds. You ask Chat, What

documents discuss Manx cats?. You then

ask, What about collies?. Then you ask

very naturally, ferrets?, without repeating

the full question, and get results. Using an

AI with a large context window, the previous

discussion is considered when replying to

subsequent questions.

AI SEARCH SCOPE

The data stored for AI models is usually quite

extensive, especially for commercial services.

This means some questions can be answered

directly from its own dataset. However,

no service will have all the information

needed for every reply and the training

data stops at a certain point in the past.
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Due to these conditions, providing answers

requires accessing data outside its own

boundaries. This not only may provide more

current information but can also reduce

hallucinations.

Inside DEVONthink, AI has the ability to

initiate a toolbar search. This is nothing more

than an automated way of entering search

terms. On its own it won't necessarily create

an optimal search, e.g., using search prefixes,

but it may produce some useful results.

Beyond the toolbar search, the options in

the AI > Chat > Search settings come into

play. These control where AI can search

for information when creating a response

for you. Note these aren't options it must

use; they are ones it could use. If the LLM

can't answer from its own data, it will try

any of the options you've enabled. The

options are: arXiv, general Web searching,

Wikipedia, PubMed, or Database. The last

option controls whether AI can examine the

contents of documents in your database. If

disabled, AI may use DEVONthink's toolbar

search to display items but it can't access the

contents of documents directly. If enabled,

the AI can examine documents' contents

in a toolbar search, in selected groups or

documents in the item list, or selected

locations in the Navigate sidebar. Next we'll

cover how to use this "safely".

CONTROLLING AI'S ACCESS

Your databases likely contain private

documents and information, things you may

not want accessible to AI. When you're using

the Chat assistant to search your databases

with the Database search option enabled,

it's important to understand how AI's access

works. It's a simple and controllable concept

that helps you limit its reach.

Selection: The AI firstly sees a selection as

everything it has access to. This includes a

selected document, even if it's not currently

displayed in the view/edit pane. When you

search, it will report it's "Searching the

database", however it is only searching the

selected item. If you have a group selected, AI

will search the documents in that group and

its subgroups. So selecting a document or a

group gives you very strict control. And yes, if

you select multiple groups, they will be all be

used as the limits of AI's reach.

Location: On the next level, is the current

location. If you're in a group with four

unselected documents, AI considers the

group and its documents as "the database".

Whatever you ask it to search for will only

involve those four documents. But not every

group has only ungrouped documents. In this

case, AI will search documents within the

groups and subgroups of the location. If we

follow the logic, this means as we ascend

through parent groups, we are extending

the range of groups AI can search while still

confining it to the current location. And

if we select the database in the Navigate

sidebar, we are giving it access to all the

documents in the root of the database. So if

you're not quite sure what specific group you

may need to search, you can go up as far as

you're comfortable and the subgroups will be

searched.

Extended Locations: To open up some other

possibilities, select a local smart group in

your database. AI also sees this as "the
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database" to be searched. If you want an even

wider range, you can select a global smart

group. And for more impromptu uses, AI will

treat your database search results as the

only place it can search. So you can use these

dynamic items as ad-hoc locations, searching

documents no matter where they are.

Additional Control: Now that we've seen

how much access we can give, there may still

be places we want AI to ignore. AI honors

the same setting as our internal search

engine, Exclude from Search, but also the

explicit Exclude from Chat & MCP. Select

a document or group and open the Generic

inspector or the Info popover, and enable the

exclusion. If this is a group, it will hide all its

contents as well, so think about what you're

excluding. You can even exclude an entire

database from AI in the Database Properties.

GET TO KNOW YOUR AI

As AI engines aren't all the same, what you

ask about and how you phrase things can

vary. Also, their capabilities depend highly on

the selection and the settings. So how do you

know what is possible and how to talk to your

AI engine? Open the Chat inspector or Chat

popover and ask questions like these:

Create a table of your capabilities: This

produces a list of what the AI can do within

DEVONthink. You may be surprised at

what it is capable of. This one is the most

important to get a real understanding of

what's possible.

Create a table of the properties you can

get and set: If the AI can access or modify

the properties of an item, it's good to know

which ones.

How can I effectively ask you to search

for something?: It's important to know

the terms and phrasing an AI model

understands. Asked this way, it usually

provides examples as well.

How can I effectively tell you to create an

item?: Following suit, you can determine

how best to have AI create items, if it

reported it can.

How can I effectively tell you to update

an item: If the AI reports it can update

existing documents, it's good to know this

phrasing too.

These questions can be especially useful

if you're trying to decide which engine to

use. Ask your questions, choose a different

model or engine, and ask it the same ones.

For future reference, you can save the chat or

even tell the assistant to put its responses in

a new document.

Another handy tip if you're testing, or even

just curious about, how models respond to

the same prompt. In the Chat assistant,

choose a model and use it as your normally

would. Then choose a different model or AI

engine in the selector popup and click the

 button. The newly selected engine will

respond to the last prompt you gave to the

previous model. This can be useful when

you're testing responses from specific models

or AI settings.

TIPS AND CONSIDERATIONS

Finally, here are a few tips to help you

potentially get better results from AI…

Focusing with metadata: Tags, Finder

comments and other metadata may play a

factor in AI's searching. A PDF about canoes
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may not contain the word "hobby" but if you

add it as a tag, it's more likely AI will find it.

Adding it to Finder comments may improve

the chances of being found. However, as

noted in the next tip, precision is helpful. If

you ask about documents regarding hobbies,

the AI will likely look only for that plural term,

not assuming you want it to consider hobby

as well.

Phrasing and clear and specific prompts:

Your phrasing can affect the method of

searching. For example, if you say, Find

documents about hiking, a toolbar search

may be initiated. But if you instead say, What

documents mention hiking?, the AI may

examine the contents of available documents

to find matches. If you are having problems

getting an expected response, try rephrasing

your prompt.

Providing clearer and more specific

instructions is going to produce better

responses. Consider the prompt about

a selected document: Translate this

document to Spanish. This will almost

certainly result in the document's content

changing, just as requested. But if you want

to preserve the text, ask What is the

Spanish translation of this document?

This should return the translated text. But

now what to do with it? You could save the

chat or be even more specific in your prompt:

Translate the text of the selected

document to Spanish and save it as

a Markdown document. Include the

original text in italics at the end

of the new document. Preserve the

document's original filename in the

Finder comments.

We hope these last two sections gave

you a clearer understanding of the

complementary, but powerful, role of external

AI in DEVONthink. You'll find other passages

threaded throughout other chapters, e.g.,

AI and Your Documents or the AI Assisted

Automation section. As it is a feature of the

higher editions, keep your eyes open for blue

sidebars or sections of blue text as you read.

A WORD ABOUT BACKUPS

As the old adage goes, "Expect the

unexpected." and being prepared for an

emergency provides peace of mind when

the unexpected eventually happens. Despite

Macs being well-crafted, they are still

machines which can (and do) fail. Your

hard drive will fail (it's not a matter if, but

when). Any sudden flux in power could

corrupt the files on your hard drive. Beyond

electromechanical issues, your laptop

could be dropped, lost, or stolen. And a

catastrophe, like a house fire or flood, could

claim your computer and data as a victim.

How important is your data? For many

users, the value of the data is much greater

than the value of the computer that hosts

it. If your data is critical to your business,

education, life, etc., back it up.

INTERNAL BACKUPS

DEVONthink does not do file backups. That

is the job of backup applications, as we

discuss next. However, for your databases,

it keeps an internal backup of each one's

internal metadata. This is a rolling weekly

backup, maintaining two internal backups
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inside the database package. These are only

used for troubleshooting in very specific

circumstances.

FILE BACKUPS

When it comes to backups, there are a few

critical things to consider:

Do not put your databases in the cloud:

This may seem like an obvious thing to do,

but you should never put your DEVONthink

databases in any cloud-synced location,

e.g., iCloud Drive, or you could irreparably

damage them.

Sync is not a backup: As noted in our FAQ,

sync is not a backup, neither advertised

nor advocated as such. While database

restoration may be possible with sync data,

it is not meant to be relied upon or used

in lieu of proper primary backups. Backups

should be application-agnostic; sync is not.

And backups preserve previous versions to

restore; sync does not. So you can't recover

files from the past.

Snapshot-style backups: When considering

backup applications or online backup

services, you should not use a feature that

claims continual or "real-time" backups.

Instead, you want to use a snapshot-style

backup that backs up the machine on a

schedule, at a particular point in time.

Backup Options: Concerning how and where

to create your backups, there are several

options to consider. Generally, we do suggest

having a local backup as your primary as

it's the quickest and easiest to access,

unaffected by network conditions or online

services.

Local: Backing up your files is simply done

and often only requires connecting a hard

drive. Apple's Time Machine or similar

application like Carbon Copy Cloner and an

external drive makes backups as simple as

connecting an external hard drive, giving

Time Machine permission to use it, then

letting it do its thing. And with the low

cost of portable external drives, it's even

feasible to take a multi-terabyte drive,

small enough to fit in your shirt pocket, for

backups when you're out and about.

Time Machine Snapshots: Other than being

free, already installed, and very simple to

use, another benefit of using Time Machine

is local snapshots. If you have backed

up your Mac with it just one time, Time

Machine will create local snapshots of the

internal drive even if your backup drive isn't

connected. This happens once per hour,

keeping each snapshot for 24 hours. While

it may not allow you to recover something

from a month ago, it can certainly help you

restore something within the last hour or

day. So regardless if you ultimately end

up using another backup application, we

strongly recommend doing a full backup

with Time Machine, especially when you're

first setting up a new machine.

Backup Archive: Specific in DEVONthink,

another available backup option is creating

an optimized and compressed copy of the

whole database that you can then save on

a server or other media. Use File > Export

> Database Archive or Scripts > Export >

Daily Backup Archive to create a ZIP file

of the database. The former option allows

you to choose a folder to save to; the latter

uses a Backup folder in your home folder.
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Local Networked Volumes: It may be

possible to do a backup on a file server

(NAS) on a network. This may be done

via a backup application supporting

backups to remote volumes or possibly

backup software provided by the NAS

manufacturer. In either case, you should

again ensure it's using a scheduled

snapshot, not continuous backups. Also,

some routers allow you to connect an

external hard drive. This too may be

used for backups. Bear in mind, backup

performance to a networked volume of

any kind will be better when your Mac is

connected via Ethernet.

Online: Backing up your data to the cloud

is also possible, either as an alternative

or a secondary backup. Arq Backup is well

known to work well with DEVONthink's

databases. Check the support pages for a

service to see if it uses scheduled backups.

Offsite: Considering the potential for

unforeseen events, like fires, earthquakes,

tornadoes, etc., having an off-site backup

is widely considered an important part of

a full backup strategy. A full backup can

be performed periodically and stored at

a secure, off-site location such as a bank

safe. You can also put database archive ZIP

files of your database in your cloud account

to provide another online backup.

Redundant Backups: There is a common

method of backing up files, known simply as

the "3-2-1 backup". This means: 3 copies of

a file, on 2 separate types of media, with 1

backup offsite. Of the three copies, one is

the working copy, in DEVONthink, this is the

database you're working on. The other two

copies are backups. Of the two media types,

one is typically an external hard drive. The

second could be another external hard drive,

an online backup, or even specialized media

like a tape drive used in corporate situations.

And ideally, you should have at least one

offsite backup as previously mentioned.

While using this method isn't a requirement,

it may be something you want to consider.

Test Your Backups: Lastly, and something

many people don't consider: you should

periodically test your backups. Anything

in life can fail at some point, so yes it is

possible to have a bad backup. Generally,

it's not something to be overly concerned

about. However, every 4 to 6 months, you

could restore a database to a separate

location and open it. DEVONthink verifies

a database when opening it and reports if

there is anything wrong. If all is well, delete it

and repeat with other databases, if desired.

If there is an issue, close and delete the

restored copy. Then do a File > Verify &

Repair Database on the current database in

DEVONthink to ensure it's healthy, fix things

up if it's not, then initiate a manual backup.

You may want to add a calendar event or

even in the Comment in the database's

Database Properties, noting the date of the

verified backup.

TUTORIALS, TIPS, AND MORE

In addition to the documentation you're

now reading, there are specific tutorials in

the Support Assistant. There you'll also find

extra scripts, smart rules, and templates that

extend DEVONthink's functionality.
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For a great resource of tips, promotions, and

release announcements, check out the Extras

sidebar or our company blog.

And if you feel like talking to other people

using any of our applications, you'll find

discussion, camaraderie, and almost two

decades worth of information on our Forums.

Take time to learn how to work with the

software — and to decide how you want the

software to work. You'll be rewarded with a

powerful assistant for all your information

organization needs.

DEVONthink 4.3.2 Documentation, page 38

https://www.devontechnologies.com/redirect/blog
https://www.devontechnologies.com/redirect/community


TASKS

IN THIS CHAPTER

Writing 39

Capture Data From the Web 40

Going Paperless 41

Handling Emails 42

Document Relationships 43

Leveraging AI 43

Browse and Bookmark 44

Read News Feeds 46

Index Files on Your Hard Drive 47

Working With Media Files 48

Sync and Share 49

The number of possible uses for DEVONthink

is nearly endless. In this chapter we present

a brief view of the core activities, and some

use cases, for daily life and work.

WRITING

If you need to take notes or write longer

documents, you can do both in DEVONthink

while working directly in your databases.

If you need to write a quick note, open the

Take Note view of the Sorter, type it up, and

quickly add it to your selected location. You

can compose in plain or rich text, Markdown,

or formatted note formats. You can open this

view with Data > Take Note or the command

in the Dock menu. Add a hotkey in the Sorter

settings so you can open the Sorter, type

your note, and tap the ↩ Return key for very

efficient note-taking. And all these notes can

be further edited directly in DEVONthink.

If you need to write some longer form

documents, you can easily create a document

via the Data > New menu in one of several

formats including plain or rich text,

Markdown, etc. These options are also

available in the New toolbar button and the

context menu in the item list. No matter your

need, you can likely find a format that suits it.

If you're researching a topic with a PDF

reference, you can create a document called

an annotation file. This is a separate but
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linked document where you can write as

many notes as you need. Insert selected

text as quotes, add links to certain pages,

and even add an AI summary right in the

document. If you're taking notes on a video,

you can add timestamps in the annotation

file and take notes on it. And when the video

is paused, you can add a screen capture of

the current frame into the document.

Using DEVONthink's powerful templates

feature, you can quickly create a new copy

of often-used documents. One example is

our Phone Note template. When you answer

a phone call, use it to record the essence

of your conversation, and fill in the details

about who called. You'll notice it's already

timestamped for you too so you have an

accurate record.

Possible uses:

Write down ideas before they're forgotten

Take quick phone messages

Keep project notes, meeting minutes,

journal, and more

Continue to read here:

Create new documents

Use annotation files for note-taking about

certain documents

Revise notes and documents using the

built-in rich text editor

CAPTURE DATA FROM THE
WEB

Increasingly, information is provided not on

paper but directly through web sites, blogs,

online news sites, social media, and user

forums. Clipping is just another tool you can

use to build your "library".

DEVONthink has several mechanisms for

clipping web contents. A browser extension,

including a Safari-native one, bookmarklets,

useful when using a browser with limited

extension support, the macOS Share

menu, and services. Capturing content in

several formats, e.g., bookmarks, Markdown,

formatted notes, rich text, etc. is fast

and efficient. And for a more future-proof

capture, or sometimes for problematic

paywalled sites, you can also capture to

PDF. And these formats are editable right

in DEVONthink. So not only can you capture

data, you can edit and annotate those

captured documents too.
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Possible uses:

Capture important news, research, hobby

and pastime information

Collect related links and documents in a

fully searchable database

Continue to read here:

Clip web pages directly from your browser

Capture selected content using services

Capture data with bookmarklets or

browser extensions

"Print" any web page or document as PDF

to your database

GOING PAPERLESS

DEVONthink is the "paperless office" solution

for the Mac, a central hub for all your paper

and electronic documents.

In addition to the steady inflow of emails,

we still have and receive many printed

documents. While it's a good idea to keep

more recent hardcopies, we can't keep

everything forever. Using the integrated

scanner support you can scan documents,

make them searchable through OCR (optical

character recognition), and file them all

directly in DEVONthink. You can scan

single documents, including double-sided

ones, multi-page documents, and scan

multiple small documents like receipts.

There is even a job queue where you can add

information about several documents you

need to produce, and have it run in a more

unattended fashion.

In addition to the internal scanning, you can

send scans into DEVONthink from third-party

scanning applications, e.g., ScanSnap Home.

And if you have a collection of scans you need

searchable in your database, you can add

them via the Import > Images (with OCR)

command that will add a steady stream of

searchable documents into your database.

Lastly, with a little setup between the Finder

and our application, it is possible to use

smart rules to add scans to a Finder folder

and have DEVONthink detect, import, and

OCR them automatically!

Possible uses:

Store your important documents, both

personal and professional

Archive invoices, offers, purchases, or

software licenses

Keep accurate records for legal and

financial purposes

Continue to read here:

Scan paper documents

Using smart rules for OCR on-the-fly

Create a compliant revision-proof database

for critical information
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HANDLING EMAILS

DEVONthink lets you archive emails or send

documents via email directly from your

databases.

Get your emails into DEVONthink from

Apple Mail, Microsoft Outlook, or any email

applications using standard Unix mailboxes,

e.g., Thunderbird. You can even set a hotkey

to archive messages and mailboxes while in

Apple Mail and Outlook. With its hierarchical

groups structure, classification feature,

and powerful search engine, DEVONthink

is perfectly suited for adding, sorting,

and finding emails in your databases. And

attachments can be imported automatically

or on demand.

You can also use the Send by Email command

in the Data or context menu to create a draft

email with a selected document attached,

provided you're using a compatible email

applications. And of course, you can drag and

drop from your database into an email you're

composing.

Possible uses:

Archive invoices, offers, purchases, or

software licenses

Gather personal emails for posterity

Keep project-related emails and other

documents together

Continue to read here:

Import emails or archive mailboxes

Email documents or reply to archived

emails
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DOCUMENT RELATIONSHIPS

With its built-in artificial intelligence (AI)

functions, DEVONthink can be used to

analyze the documents in your databases

as show you information and suggestions

about them. There are more AI-driven

functions than shown here but here are a few

highlights…

DEVONthink has long had its own internal

AI, the brain of the application, working in

the background, indexing and analyzing the

content and locations of your documents.

Every time you add documents, make

changes to them, reorganize them, it updates

its internal knowledge. This knowledge is

used to offer a few things: suggestions where

an item could be filed, what group it best

belongs in, and what documents seem to be

related to it. These recommendations can be

viewed in the See Also inspector. So as you

work with your database, the AI takes note

and adjusts with those changes, essentially

training itself based on what YOU do.

In the Tags inspector, the AI displays the

tags on a document. But using its internal

knowledge of your tagging practices, it also

makes suggestions about other tags that you

may want to add to the document. Adding

and removing tags is as simple as two clicks.

In addition, a network graph of a selected tag

illustrates the relationship between a tag and

others in your database.

Lastly, the Graph inspector also shows

connections between documents. But in

this view you can see how a document is

linked to by other documents via item links

or WikiLinks. Or examine what documents

mention each other. While this information is

also found in other specific places, this graph

can be helpful in visualizing the relationships

in one consolidated view.

Possible uses:

Analyze the complexity and focus of a

specific document collection

Helps make tagging decisions and apply

those tags

View the interlocking relationships

between documents, their tags, and links

Continue to read here:

Get an insight into the tagging possibilities

for a document

Get recommendations on where to file your

documents

Examine the word distributions of your

documents

LEVERAGING AI

As a complement to DEVONthink's built-in AI,

you can use an external AI engine to process,

and in some cases, create documents in your

database.
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You can leverage many of the capabilities of

third-party AI services with your documents

and databases in a few ways. Your boss sent

you a few PDFs but you don't have time to

read it now. The Summarize Documents via

Chat command can produce a document

with summaries of them for you to read the

key points. If you need to add an image to a

document you're working on, describe it and

save the image when you see one you like.

Or imagine writing an email to a government

representative proposing an idea, but you

aren't sure it sounds "professional". Use Edit

> Transformations > Transform text via chat

to get a suggested rewrite. You can also

ask questions of a chat engine, requesting

specific output, e.g., "Create a Markdown

list of the 15 best vacation spots in the

continental US for a family with kids. Provide

a single paragraph summary as to why each

is included and add links to the Chamber of

Commerce of each place, where available."

and you should shortly have a document in

your database.

AI also plays a part in other aspects of

DEVONthink. Select the toolbar search

field, tap the ↩ Return key, and press the AI

button. Briefly describe what you're looking

for and AI will show you the DEVONthink-

specific search syntax or launch the search

for you. For automation enthusiasts, there

are new AppleScript commands as well

as placeholders and smart actions that

integrate with AI. Now you can utilize AI

in your automations to produce more

customized results.

Do bear in mind, the capabilities are relative

to the AI engine you're using, as well as any

associated costs of using a commercial AI

service.

Possible uses:

Get overviews and essential concepts of

documents

Get creative with AI generated images and

story outlines

Ask impromptu questions, further refine

via chatting, and save the conversation or

results

Continue to read here:

Analyze and create documents with AI

Get recommendations on rewriting your

text

Create a smart rule using AI to affect the

results

BROWSE AND BOOKMARK

In additions to being a knowledge and

information database, DEVONthink has built-

in web browsing capabilities. This allows you

to browse and capture online information

directly in a database.
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Whenever you select a bookmark,

DEVONthink loads the online content in

the view/edit. You can navigate between

pages and sites, just as you do in your

browser. However, unlike your browser, you

can immediately clip and capture to your

database. From the Tools > Capture menu

or the  button, choose the format of your

choice and the document will appear in the

current group. You can also use DEVONthink's

Clip to DEVONthink just as if you were in an

external browser. You can also select, then

drag and drop content from the loaded page

directly into your groups, the Sorter, etc.

In the Scripts > Tabs menu, you will find

the Open Google script. This opens a new

window or tab with Google loaded and ready

to search. Where you go from there is up to

you.

Since this is an actual browser view, another

powerful option is accessing online cloud

accounts. For example, you could log into

your Dropbox account and manage things

without leaving the application. That includes

adding files to it. Grab a file in the Finder,

then drag and drop it into the loaded page in

DEVONthink. And to extend that idea even

further, leave the browser open, switch to

another DEVONthink window, then grab a

document and drag and drop it between

DEVONthink windows to upload it!

With its integrated, document-based web

browser, DEVONthink can also be used as a

bookmark manager. Organize your bookmarks

wherever they're needed, from a collection

of them to grouping them with other

documents. You can even import bookmarks

from some of the popular browsers.
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Possible uses:

Build a library of bookmarks right inside

DEVONthink

Visit frequently visited web sites, including

paywalled sites, in a convenient interface

Capture and clip content from web sites

and store it in DEVONthink

Access your cloud services, like iCloud or

Dropbox

Continue to read here:

Create a new bookmark

Capture data from the Web

Integrate news feeds with your data

READ NEWS FEEDS

Keep up with your RSS news directly in your

database.

DEVONthink comes with built-in support for

news feeds, which makes it a reliable basic

news reader. Add your favorite RSS feeds

to your database. News comes in as HTML,

typically linked to an original article. Jump

to the linked article with a single command:

Complete News. Clip the linked page to

another format or select content and use

our services to make a new document from

it. You can also set a global feed format or a

format for each feed, to gather information

e.g., as PDFs.

Possible uses:

Read your daily news in a convenient

interface

Integrate "live" newsfeeds with your other

documents

Grab interesting information from linked

pages and store it in DEVONthink

Continue to read here:

Add a news feed

Choose a specific per-feed format

Create new documents with selected

content
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INDEX FILES ON YOUR HARD DRIVE

DEVONthink's databases are designed

as portable, self-contained collections of

documents and information, encapsulated

in a single "file". However, some use cases

require external access to some documents.

But DEVONthink can accommodate that too.

If you have an existing folder structure

that must be accessible by others but you

still want to leverage DEVONthink's power

with them, you may be able to index them.

Indexing creates links to files outside the

database and treats them as if they've been

imported (copied). The database doesn't

contain copies of the files, only links to

them, so it will be smaller than an imported

database. You retain the ability to search for

and edit compatible files. Files can be opened

in their external applications, modified, and

saved as you normally would. Since you're

acting on the actual files in the filesystem,

the database is "updated" automatically. And

yes, it's possible to have a hybrid database

containing both imported and indexed

documents.

Indexing is often used with cloud-synced

folders, e.g., Dropbox but can be used

with any accessible location. Bear in mind,

performance can be affected if indexing

networked volumes. Another option is to

index media files, including on removable

media. If you have a thumb drive of family

photos, you can index those pictures

and view them in DEVONthink while the

drive is mounted. Or if you have assets on

unmounted media, you could search for files

on it and determine where they're located.

In the case of text-based documents, this

includes content-base searches. And though

it's not a replacement for Apple Music or a
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bespoke music player, you could index your

Music library or a folder of audio files and play

them when you wish.

IMPORTANT: While indexing seems like the

best of both worlds, using it needs to be

approached thoughtfully as you are dealing

with the actual files in the filesystem. Please

read and understand the In & Out > Importing

& Indexing section before committing to it.

Possible uses:

Keep the folder structures you've created

in the Finder, while allowing access to

DEVONthink

Create a front-end for your document

collection

Integrate indexed items with imported and

items you've created in DEVONthink

Continue to read here:

Import or index files

Search your database

Launch the original file of an indexed item

WORKING WITH MEDIA FILES

While DEVONthink excels at handling

text-based documents, it can also contain

multimedia files such as images, audio, and

video.

While not designed to replace Photos

or Music, DEVONthink can be used as a

repository for media files, whether for

nostalgia, business, research, or any other

project-related purpose. View and add

images to documents, like rich text or
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Markdown documents. For a more visually

appealing view of images, you can use set the

item list to View > as Icons.

You can play audio and video with Apple's

familiar controls. Combine the audio-visual

files with an annotation files and you can take

notes as it plays back, including the ability to

add timestamps for easy, future navigation in

the playback. And yes, you can also just play a

song in the background, if you'd like!

Two of the most powerful media features in

DEVONthink are the integration of AI speech-

to-text transcription and image analysis.

Your audio or video files can be converted,

automatically or on-demand, into a transcript

of the text. So you can convert and read your

sermons, lectures, speeches, sound bites, etc.

With your images, you can ask your AI engine

to tell you about an image, whether asking for

a description of it, wondering what a foreign

sign says, or requesting a story idea based on

it.

Possible uses:

Create a dedicated database of images

Create media rich documents

Include project-related images, audio, and

video in your databases

Play your music from within your work

environment

Continue to read here:

Transcribe your audio-visual files

Use your images, audio, and video

SYNC AND SHARE

Having multiple Apple devices is so common,

it feels more unusual when someone has

less than two. If you're running DEVONthink

on more than one Mac, it's likely you want

to access the same documents on both.

DEVONthink helps keep a local copy of

your database on multiple Apple devices

in sync with each other. Changes made on

one machine propagate to the others. The

sync doesn't require using a cloud service,

though that may be an option, but can usually

be handled locally and privately. It also can

include encrypting the sync data as it's sent

and stored, adding one more layer of privacy.

In a business, academic, or even a group

collaborative setting, you can share a

DEVONthink database. With the built-in

DEVONthink 4.3.2 Documentation, page 49



web server, provide controlled, per-database

access, even in a cross-platform environment.

Ideal on a local network, with some technical

know-how, you can even share over the

Internet.

Possible uses:

Use your database in a multi-device

situation, having the same documents and

metadata on each

Use our mobile application, DEVONthink To

Go, as a companion to DEVONthink

Give other users access or collaborate on a

database on other platforms

Continue to read here:

Keep the database on your devices in sync

Use DEVONthink's web server to share your

database
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As DEVONthink is an information and

document management application, it

supports importing many different file types.

In this chapter we cover commonly used

interface elements, how AI works with your

documents, and specific details about the

kinds of documents you can work with in your

databases.

GENERAL

DEVONthink is made for documents. It's

powerful internal AI, reads, indexes, analyzes,

and stores information about each document

added to your databases. But it not only

provides solid storage and organizational

features, it also lets you create certain

types of documents directly in a database.

While not intending to replace bespoke

applications, like Pages, etc., for many

people, in many situations, the convenience

of integrated document creation makes

DEVONthink a central hub for their work and

lives.

Let's take a quick look at the parts of the

interface you'll commonly use when viewing

or editing your documents.

VIEW/EDIT PANE

The view/edit pane is where you can see or

edit the current document (with compatible

files). Whether you're journaling, annotating,

planning, or even just reading, this pane is

where you'll likely spend a lot of time.

NAVIGATION BAR

At the top of the view/edit pane,

DEVONthink is the Navigation bar with

information about the selected document.

Which tools are available depends on the

type of the document you are viewing. The

options below are shown in the Navigation

bar for most file types. Specific options are

shown in the separate sections throughout

this chapter:

Navigates back to the last visited

document after following a link.

Navigates back to the next visited

document after going back.

Reloads the displayed page in a web view.

Only visible for, e.g., bookmarks.

Shows an action menu with options for

opening the shown page in Safari, copy its

address, or capture the page in a variety of

formats.

Shows if the document is locked or

editable.
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Scrolls to the previous highlight, e.g., a

search term occurrence.

Scrolls to the next highlight, e.g., a search

term occurrence.

Scrolls to the next page of the displayed

document.

Scrolls to the previous page of the

displayed document.

Switches to Text Alternative mode. Useful

for selecting text in uneditable formats,

e.g., Word documents.

Switches to Best Alternative mode. For

Markdown documents, this is the rendered

HTML view.

Word Count: Shows the number of

paragraphs, words, and characters of the

displayed text.

URL: Shows the URL associated with the

displayed item, if one is present. If a PDF

annotation is selected the URL field shows

the associated URL if available. Click to

launch the URL in its default application.

Hold the ⌥ Option or the ⌘ Command

key to open the URL in a new tab. Holding

⇧⌥ or ⇧⌘ opens the URL in a new tab and

selects it.

Page Count: Shows the number of pages

as well as the page number of the currently

displayed page. Click the page number in

PDF or PostScript documents and enter a

page number to jump directly to that page.

EDITING BAR

For some formats, e.g., rich text or sheets,

there is another bar available: the Editing

bar. If you click this icon , the editing bar

will appear in place of the Navigation bar.

This offers quick access to some editing tools

related to the file type you're working on. See

the appropriate file type section for more

info.

TAG BAR

The Tag bar appears under the view/edit

pane and shows all the tags associated with

the document. Just click into the bar and

start typing. Any potentially matching tags

will be suggested. The suggestions come

from the current database unless you're in

the Global Inbox where suggestions come

from all open databases. When you type the

name of a tag, DEVONthink offers automatic

completion. Choose an existing tag with the

mouse or the arrow keys and press ↩ Return

or  Enter to accept it. Press ⎋ Escape

to ignore the suggestion. Press ⇥ Tab to

enter another tag. You can remove a tag by

selecting it and pressing the ⌫ Backspace or

⌦ Delete key to remove it. You can toggle the

Tag bar on or off via the Tags toolbar button.

If you have multiple items selected, tags will

only appear in the Tag bar if all items have all

the same tags. However, it's still possible to

add tags to all the selected items.

CONTEXT MENU ITEMS

If you Control-click in many types of

documents in DEVONthink, you are presented

with a context menu showing many options.

The options displayed depend on what you're

clicking; e.g., selected text, and whether

you're in the editing or preview mode. As

many of these commands are the same for

most formats, we have provided a list in the
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appendix. Format-specific context menu

commands are listed in their respective

sections in this chapter.

TOOLBAR

In addition to creating documents via the

Data > New or Data > New from Template

submenus, you can also quickly make new

ones via the New  button.

VERSIONING

As we compose our documents, things

happen. We click on the ⌦ Delete key

accidentally and wipe out several paragraphs.

Or we may stop and wonder if an earlier edit

sounded better or made more sense. Enter

the Versions inspector, where you can jump

back to a document's previous states without

having to manually create a separate file on

your own.

Versions are enabled on a per-database basis

in the Database Properties. As you make

edits to a document in DEVONthink then

save it, a version is preserved. If you need

to view or restore a previous state, you'll

find them in Versions inspector. Selecting

a previous version temporarily changes the

contents in the view/edit pane. Restore it,

choose another version, or click an empty

area in the inspector to revert to the current

state. You can also find these commands, and

options to remove one or all versions in the

context menu.

Make sure to open the Files > General

settings to set the parameters for your

versioning. Versions do consume space in

your database so you'll want to make wise

choices in the allowable number of versions

per document, the maximum size each

version can be, and the how long they're

kept in the database. This is something you

should be especially aware of when using

an encrypted database. If you check out

the Database Properties for your database,

the number of versions isn't included in the

various document counts. However, they

are listed with their combined space in the

database Totals.

Note: Versioning only applies to edits made

in DEVONthink, not those made in external

applications. Documents are automatically

saved every five minutes after the last

modification, when deactivating the

window, or when quitting DEVONthink.

And if it has been less than two minutes

between saves, a new version will not be

produced.

While every file format has its own strengths

(and weaknesses), you can likely find a type

suitable for your purposes. Each of the native

types, and how DEVONthink handles other

file types, are described in the subsequent

sections in this chapter.

AI AND YOUR DOCUMENTS

DEVONthink is focused on document and

information management. AI is all about

document analysis and generation. These

facts make for an excellent cooperative

relationship between the two. While AI is

implemented in several other aspects of

DEVONthink, let's take a quick look at how it

works with your documents, including some

practical examples.
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DOCUMENT ANALYSIS

Broadly speaking, if you have a document in

your database, you can use AI to analyze it.

This could be content in a PDF document or

a selection of rich text files. Say you have an

invoice and a tools-compatible AI engine, you

can ask questions about the contents. For

example, you can ask how many widgets were

purchased. You can then ask for a breakdown

of the cost per widget, their percentage

of the total cost, or any other questions

for which you need answers. If this was an

anticipated order, you could ask for it to

provide the cost for different quantities. As

you progressively ask questions, the AI will

take previous parts of your conversation into

consideration when it answers.

Examining an invoice or receipt focuses very

narrowly on its contents, typically requiring

no outside information. But when generating

responses about other documents, the AI

engine may need to refer to other sources. To

give you more control over where AI is getting

its answer, you'll need to set permissions for

what AI can access in the AI > Chat settings.

For example, if you want it to use online

searches, set it here.

Imagine you have a PDF about the Hubble

Space Telescope and ask chat, In this

document, what happened in 1995?.

The response may include links within the

document or it some extra commentary

with interesting information. You could then

follow up with a question like, Using other

resources, how does Hubble compare

to the James Web Telescope?. This

"gives permission" to the AI to consult other

sources, like Wikipedia or online searches,

for its response. Utilizing both the document

and online resources can prove to be a

very powerful combination in research and

learning about documents in your database.

"Translating" jargon or high-level language

is another useful function. For example,

say you have a PDF from PubMed but much

of it is beyond your understanding. Select

some text, open the Chat inspector and

ask for an explanation in layperson's terms.

And while it may not be wise to use this to

make important decisions, e.g., medical or

legal ones, it could help you understand the

essence of the text.

Note: The responses vary per AI engine,

e.g., ChatGPT versus Claude, but can

also vary per-model. Temporarily change

to a different engine in the dropdown

next to the query field if you'd like to try

for a different response. Note the more
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expensive models sometimes produce

more in-depth and thorough responses,

but the Chat assistant always opens to

the default model you've chosen in the AI >

Chat settings.

SUMMARIZE AND TRANSFORM

Summarize: Summarizing is an excellent

way to quickly get the essence, the core

concepts, of a document. Using the Edit >

Summarize via Chat command or clicking

the  button in the Navigation bar opens

the Summarize popover. This provides a

simple analysis of a selected document,

which you can save directly into a Markdown

or rich text document. You can also query

multiple selected documents when using

the Summarize Documents via Chat

command, with the key points broken down

by document. Additionally, you can use

the summarize content of AppleScript

command in your automations.

Transform: Logically, if you can edit the

contents of a document in DEVONthink,

you can also transform the text. Use this

to rewrite content in a different style or

tone. Select some text in a document then

open the Transform popover via Edit >

Transformations > Transform text via chat or

press the  button in the Navigation Bar. If

you like the recommendation, you can replace

the selected text with the click of a button.

TEXT DOCUMENTS

There are many options for creating text-

based documents with AI. From the Chat

popover, you can ask a question and tell it to

save the results as a Markdown document.

Some AI engines, e.g., Claude, will often

produce an appropriate document type on

its own. For example, asking for a list of 25

European songbirds, including their common

and scientific names, and notes about their

migration patterns will likely result in a

Markdown document. But you could also tell

it to create a sheet, if that better suits your

purpose.

You may also find use in one of our AI-

directed templates. With the Research

Overview template, provide a topic for AI to

research and you'll get the response delivered

in a document. Or select an image and use

the Story Assistant — Markdown to generate

a story outline based on the contents of the

image.

Built with powerful automation features,

DEVONthink can create documents with

smart actions and AppleScript commands.

Using your documents or queries as a starting

point, you can use AI replies to create

documents with more personalized and fine-

tuned control.

IMAGES AND MEDIA FILES

Images have always been supported in

DEVONthink but in more of a supportive role,

e.g., as an illustration in rich text, etc. Within

DEVONthink, AI has opened new possibilities

for them.
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Image Generation: Open the Generate Image

panel. Fill in a description of the image you

want, including as many details as you have.

Choose the generative image engine you have

access to and let the AI create an image for

you. Or perhaps you have a document with an

outline or a synopsis of a story. Select it and

choose the Short Story — Illustration from

the Data > New from Template > AI menu.

AI will "read" your document and create an

image based on it. And if you're a scripter,

there is an AppleScript command to create

images with AI with more control in using

the output, e.g., linking it to a Markdown

document.

Analysis and Recognition: The Edit >

Summarize via chat can analyze and provide

a description of an image's contents, e.g.,

as bullet points or a paragraph. You may

even be able to get information about the

subject of an image. For example, use the

Chat > Geolocate Image script on an image
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of the Eiffel Tower. Obviously this would work

best with well-known or often photographed

landmarks.

Images also can be converted to text via

AI transcription. Using the Recognition >

Transcribe Text & Notes command in the

Data or context menu, AI can examine an

image and extract the text much in the way

OCR does, but utilizing either Apple's Vision

framework or a vision-capable AI model. With

an appropriate prompt and capable model,

you can use this for a variety of purposes,

including translating between languages.

Speech to Text: Another powerful AI

recognition function in DEVONthink is

speech-to-text capabilities used with audio

and video files. Long ago, this technology

was a niche (and expensive) process that

progressed to providing conversion of short

bits of audio directly on your Mac. Now, the

technology is capable of fully transcribing

long audio and video content, providing a

written transcript for you to use as you need.

And with Apple's Speech framework, this can

even happen on your Mac.

After having set your desired options in

the AI > Transcription settings, select an

audio or video file and choose Recognition >

Transcribe Speech command from the Data

or context menu. This will process the audio

and convert it into text. Logically, the longer

the document, the more time is required to

transcribe it.

When transcribing images and media, it may

appear nothing has happened. However, you

need to look at where the transcribed text is

being saved. In the AI > Transcription settings,

you will find these options:

Searchable Text: This functions similar

to Apple's Live Text feature in that it

recognizes the text but doesn't modify the

actual file. The transcribed text is stored

in the database's index and associated

with the file, allowing for toolbar searches

and See Also and classification, just like

OCR'd documents. And even though there

is no embedded text layer,  in-document

searches are still possible.

Comment: The extracted text is stored

in the document's Finder Comments.

While this can't be used for in-document

searches, you can still use the comment:

search prefix for toolbar searches. Using

the Finder comment also lets you access

the extracted text in a more visually

intuitive manner. Bear in mind, the

Finder allows a very limited number of

characters in a Finder Comment. However,

DEVONthink supports storing much more

text internally.

Annotation: Storing the recognized text in

an external annotation file may be a useful

way to examine the text isolated from

the original image. The annotation file can

be edited and used in whatever way you

need to, but it remains associated with the

original image.

Transcribed text may also contain

timestamps, if you're transcribing to

Finder comments or an annotation file.

Timestamps can be toggled on or off via the

Add timestamps to transcriptions setting.

When transcribing to an annotation file,

you can use them to jump to certain points

in the playback. Be aware timestamps are
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inserted after short pauses in the audio, not

periodically, so they may not always appear in

a place you would put them.

Note: The recognized text may not be

100% accurate, especially when using local

Apple Speech but it may also be more than

sufficient for your needs. However, you

may not want to send video to Apple's or

OpenAI's servers for processing.

TAGGING

Lastly, if you often use tags on your

documents, AI can provide assistance

with it. With the Add Chat suggestions to

documents option in the Files > Tags settings,

AI can examine files and tag them as they're

added to your database. To keep your tags

from getting out of control, you can require

AI to only use already existing tags. You can

also use Apple's Vision framework for tagging

images, if you aren't using a vision-capable AI

engine.

CONTROLLED RECOGNITION

As mentioned above, the option to recognize

text in images may be very useful. However,

the option in the Files > Import settings is

a global setting, meaning it will attempt to

recognize text in every image you add. Not

only may that not be necessary, it could incur

a cost if you're using a commercial AI engine.

However, we can exert a more control with a

simple smart rule.

1: Select your desired database or location in

the Navigate sidebar then click the  button

at the bottom of the pane and choose New

Smart Rule.

2: Enter a name and ensure the Search in

dropdown is targeting the correct location.

3: Set criteria Kind is Image and enter

another filtering criteria, e.g., Tag is not

AI Processed. This latter criterion can help

avoid reprocessing documents.

4: Click the  button to add an On Import

event trigger. This is optional but adds some

unattended automation to the database.

5: Choose the Recognize action and

Transcribe Text & Notes. Following our

example, add the Add Tags action and enter

AI Processed as the Tag. Then press OK to

close it.

6: Now drag and drop an image into

the database. It should be transcribed

automatically per the option you chose in the

AI > Transcription settings.

Lastly, drag and drop an image into another

database and you'll see it doesn't trigger the

smart rule. You could also add other filtering

criteria, e.g., Name begins with screen to

only process screen captures you've taken.

Now you have much more control over when

transcription happens, saving computer

resources and potentially some money.

PS: This same logic can also be applied if you

want to use AI-assisted tagging on import.
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SPEECH-TO-TEXT

On Location: Imagine you're in school

listening to a lecture, in a house of worship,

attending a seminar, etc. You wish you could

record and read what's being said later. Here's

a way you could accomplish that assisted

by AI. The first two steps are only for setup.

Once they're set, you can leave them alone

and just start at step 3.

1: Open the AI > Transcription settings.

Choose the transcription engine and how

you want to store the transcribed text. We'll

choose Annotation to create a separate

annotation file.

2: Optionally, open the Files > Import settings

and enable Transcribe Audio Files. We'll

enable it for this example.

If you don't enable the option to transcribe

on import, you can process the saved

audio file later via the Data > Recognition >

Transcribe Speech command or the context

menu.

3: Open the Sorter's Voice Note view and

start recording.

4: When finished, stop the recording. Choose

the destination, modify any metadata, e.g.,

the name or tags, and press ⌘S or the Add

button to save the audio to your database.

The transcription engine should automatically

start processing the audio.

5: Navigate to the destination and check

the results, if finished. Note the length of

the audio determines how long it takes to

process, so be patient.
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On Demand: If you have a pre-recorded

audio file, you can process it even more

simply. Assuming steps 1 and 2 are set as

needed, drag and drop the audio file into your

database. It will be processed in the same

way.

Note: Recording may not be allowed, or it

may even be illegal, in certain locations.

We hope this provided a bit of insight,

direction, and perhaps inspiration, into

how AI can be effectively used with your

documents.

DOCUMENT LINKING

Documents in DEVONthink are independent

items but often have contextual relationships

with other documents in your databases.

Efficiently creating and using these links is

key in many peoples' use cases. DEVONthink

supports three types of links.

LINK TYPES

Relative and Absolute Links: Almost

exclusively used in Markdown documents,

these are links similar to what is seen

in the source code of web pages; e.g., /

stylesheets/styles.css. It is possible

to manually add these links to an HTML

document, but that is certainly less

commonly done in DEVONthink. In regards to

Markdown, you can read more about linking in

the Markdown section of this chapter.

WikiLinks: WikiLinks are a way to create

interconnected documents in your databases.

When enabled, DEVONthink attempts to

detect other documents matching the

words you've typed in plain text, rich text,

or Markdown documents. This creates

an active hyperlink to the detected item,

allowing you to quickly jump to it by clicking

the link in the document. WikiLinks can be

used in plain text, rich text, and Markdown

documents. Use them to link to existing

items or create documents on-the-fly. For

existing items, these links are automatically

detected depending on the method chosen

in the WikiLinks settings. If a matching

document isn't found, a new document will

be created with the text as the filename and

containing text as defined in the template in

the settings. If you enable Update name of

WikiLinks in square brackets automatically

in the settings, the link text in a document

will update if you change the name of a

WikiLinked item.

Square bracket WikiLinks support using

a description as an alternate name in

Markdown. The description comes after

a pipe | character, e.g., [[fw4.pdf|

W4 Tax Form]] displays as "W4 Tax

Form" but links to the "fw4.pdf" file. They

also support section anchors following

a hash symbol #, e.g., [[Choosing a

Mac.html#workrequirements]] jumps to

a "Work Requirements" section in the linked

document.

Note WikiLinks are not item links, which are

discussed next.

Item Links: Many applications today have a

URL scheme — a special URL that provides

some extra functionality for that application.

In DEVONthink, every item has a unique URL

called an item link, pointing only to that item.

When used with in-application documents

or in external applications that support URL
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schemes, the item link will open the linked

document in our software. In some cases, the

link may even contain certain parameters to

do things like open a video to a specific time.

Item links are either incoming and outgoing

links. The two types of links function as sides

of one operation. If you create an item link

to an image, the file will have an outgoing

link detected. The image you have linked to

will have an incoming link detected since the

file has a link pointing to it. Documents with

these links will have a special property icon

displayed to the right of the filename in the

item list. You can display a sortable Incoming

Item Links and Outgoing Item Links column

in the headers of the item list in List view.

There also are incoming and outgoing item

link criteria usable in toolbar searches, smart

groups, smart rules, and AppleScript.

Similar to the behavior of WikiLinks, the

link text in a document can be updated

automatically when you rename a linked

document. Enable the Update name of item

links automatically in the WikiLinks settings.

If this is disabled, you can use the Tools > Item

Links > Update Name of Item Links command

to manually update a document. To switch

from WikiLinks to item links in a document,

use the Tools > Item Links > Convert WikiLinks

to Item Links command.

Note: Item links also have some utility in

automation, discussed in the Automation >

Item Links section of this help.

CREATING LINKS

Making links to other documents should

be easy to do. However, working within the

constraints of certain file formats sometimes

requires different methods to create them.

Listed below are the most common ways to

add links between documents.

Crosslinks: Item links added in documents

are also known as crosslinks. You can very

quickly insert them into plain/rich text

or Markdown documents by typing >>

followed by the beginning letters of an

item's name. Note this will only match

items in the current database, whereas the

Insert Link popover can link to documents

in any open database.

Make Link: In rich text files, you can select

words and choose Format > Make Link to

create an active hyperlink of the selected

words. Clicking on the hyperlink will

generate a new WikiLinked document.

Add Link: For text in rich text and

formatted notes, you can select words and

choose Format > Add Link. You can then

add a URL, including an item link, to create

an active hyperlink of the selected words.

Insert Link: Edit > Insert > Item Link opens

the Insert Item Link popover, allowing you

to add an item link to a document.

Drag and Drop: You can Option-Command-

drag and drop a file into a compatible

document to insert an item link. This is an

efficient way to insert links into rich text or

Markdown documents.

Copy and Paste: Select an item in the

item list and choose Copy Item Link. This

captures the item's unique link to the

clipboard so you can paste it into another

document or even another application.

Some other types of links can be captured,

e.g., page links. Item linking methods
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specific to certain file formats are covered

in their respective sections of this chapter.

Source Links: A very powerful method

involves selected text in a document.

Select some text and choose Edit > Copy

with Source Link. This captures the text

and a link to it. this can be pasted into

other documents, potentially including

documents in other applications. The

opposite command is similarly powerful:

Paste with Source Link. If text is on

the clipboard and has a reference to its

origin, use this command to paste into a

document in DEVONthink. You should get

the selected text and a reference to the

original document, if available.

VIEWING LINKS

If you want to view the links in a document,

open the Document > Links inspector.

Outgoing links show item links from the

current document to other documents or

other URLs, e.g., to web pages. If you're

viewing the source of a Markdown document,

WikiLinks are not listed as outgoing links. If

you want to see what documents are linking

to the current document, those are listed in

the Incoming Links section at the bottom of

the pane. This section does include WikiLinks

pointing to the active document.

Another inspector, the Graph inspector, can

also show links between documents, including

both WikiLinks and item links.

PLAIN AND RICH TEXTS

PLAIN TEXT

Plain text files may seem too simple to be

truly useful. No styling. No images. Nothing

but text. But the reality is these simple files

are underlying a lot of your daily experience.

From the HTML code instructing your

browser how to display a web site, to the

code DEVONthink is written in, plain text is

very powerful. DEVONthink supports plain

text files as a native, editable format.

Plain text files can be created via Data >

New > Plain Text. While they don't support

formatting, they are often an ideal format

for rapidly recording thoughts with less

distraction. They are cross-platform,

including on mobile, and can be opened in

dozens (if not hundreds) of applications.

Another benefit of plain text is it can be

easily processed in automations.

There are a large number of plain text file

formats in the world. DEVONthink recognizes

many of them and they should be editable

just like standard .txt files. However, if
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you have a format that is not recognized,

you can add the extension to be recognized

as a plain text format. See the Hidden

Preferences section of the Appendix on how

to accomplish that.

RICH TEXT

Word processing applications brought

us text with flair. Need some bold and

italic text? How about adding a photo to

the page? And color? These applications

were providing it all. But their formats are

proprietary so if you don't have the creator

application, you can't open the file or you'll

have to convert it first. The rich text format

provides a useful text format that supports

formatted text. These files are generally

cross-platform compatible and editable in

many applications. DEVONthink uses the

same text engine found in Apple TextEdit, so

it's an easy transition if you're already familiar

with it.

Rich text files can be created via Data > New

> Rich Text. You can attach other documents

to rich text documents simply by dragging

them into the text. Technically the rich

text document becomes an .rtfd package

and the dragged file is saved as part of the

package. Using the context menu, you can

show an attachment's content in a Quick

Look preview. Also, if you double-click an

attachment, it will open in the system default

application.

Outlining: If you need to may lists in your

rich text documents, there is a built-in "mini

outliner" is a built into the text engine. On

any blank line in a rich text document, type

⌥⇥ Option-Tab to create a bullet point

(macOS shows dashes instead of bullets).

Type something then press ↩ Return to create

the next line item, and so on. Additional ⌥⇥

will increase the indentation; ⇧⇥ will outdent

the line. Press ↩ multiple times to exit the

list. Lists use a hyphen by default but you can

change this via the Format > List dialog on a

selected level of the list.

Annotating: Part of the popularity of rich text

is the speed of composition but also being

able to format with highlights, underlines,

etc.

Sections: Another powerful feature of rich

text is the ability to create sections and

subsections. Especially useful in long-form

documents, set a solitary line in bold and it

will be detected as a section. A single line

underlined acts as a subsection. But note

these lines must be standalones and not

mixed styles.

INTERFACE

Editing Bar: The navigation bar for rich text

files includes the Editing Bar. Click this 

icon and the editing bar will appear in place

of the navigation bar. The tools available here

consist of:

Edit the formatting of a list.

Edit parameters of a table.

 Increase the size of the font.

 Decrease the size of the font.

 Set characters to be subscript.

 Set characters to be superscript.

Adjust the line spacing of selected text.

 Set bold on the text.

 Set italic on the text.

 Set underlines on the text.

 Set strikethrough on the text.
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Highlight selected text. This uses the

currently selected highlight color.

Add or edit a link applied to the selected

text.

Convert selected text into an active link.

This can be used to dynamically create Wiki

documents.

Show or hide the ruler. Place tab stops with

the mouse, then remove them by dragging

them off the ruler. Drag new tab stops (left

aligned, centered, right aligned, or decimal

aligned) from the repository at the right

side to their desired positions on the ruler.

Use the mouse to adjust the left and right

margins and indent.

Show the Fonts panel.

Show the Color Picker.

Format Bar: In addition to formatting options

in the Format menu and the simple controls

in the editing bar, DEVONthink provides

another toolbar just for rich text editing.

Select Format > Show Format Bar to display

a set of rich text controls under the toolbar

in main or document windows. Similar to

TextEdit, it provides the following options:

Styles: Select a predefined text style from

the pop-up menu. To define your own

styles, choose Other to open the standard

macOS style editor. In the style editor,

navigate back and forth through the styles

of your document or the stored favorite

styles. (Use the radio buttons to switch

between document and favorite styles.)

Click Select to select all occurrences

of text with the displayed style in the

document, click Apply to apply the style

to selected text, or click Done to leave

the style editor. To add a style from your

document to the favorites, click Add

To Favorites; to remove a favorite, click

Remove From Favorites.

Font Controls: Displaying three dropdown

menus for, choosing the font face, font

weight, and font size.

Colors: Two buttons are available for

setting the text and background color.

Basic Styling: Allows you to choose bold,

italic, or underlines.

Alignment: Align the current paragraph

(the one with the insertion caret inside)

left, centered, justified, or right by clicking

the according alignment buttons in the

ruler.

Spacing: Choose the desired spacing for

the current paragraph from the Spacing

pop-up menu. Choose Other to enter

values other than the ones shown.

Lists: Make the current paragraph a list

(indented and with a bullet or numbered)

by choosing the desired list style from the

Lists pop-up menu. Choose Other to define

your own list style.

Context Menu: In addition to the context

menu items available with text selections,

rich text files also feature these specific

commands:

Insert > ...: Inserts special characters or

items into the document.

Quick Look Attachment: Opens a Quick

Look panel for the selected attachment in

a rich text file.

Split Document: Splits the document

at the current insertion position. A new

document is created for the text after

the cursor position and removed from the

current document. This can be used in rich

text and plain text, including Markdown

content in edit mode.
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Inspectors: The usual inspectors work with

both plain and rich text files, but there are a

few inspectors that work with rich text:

Properties: The Info > Properties inspector

can display metadata on rich text files, like

Keywords, the Author, or Organization.

Table of Contents: If you read above about

creating sections and subsections, the

Table of Contents inspector is where you

can view and navigate these sections.

Annotations: Rich text supports

highlighting, underlining, strikethrough,

etc. You can view and access these in the

Document > Annotations inspector.

ITEM LINKING

In addition to the document's standard item

link, plain and rich text files support this

alternative item link:

Paragraph Link: Link to the paragraph of

the selected text.

Alternate item links are available in the

context menu in the view/edit pane or when

holding the Shift key while viewing the Edit

menu.

MARKDOWN DOCUMENTS

Markdown is a simple formatting language

invented by John Gruber and has only gained

in popularity. It allows you to write in plain

text, using some easily learned control

characters, to produce nicely rendered HTML

output. Created via Data > New > Markdown

text or added from external sources, with

some styling and ingenuity, you can create

many kinds of documents.

EDITING

While there are many Markdown applications

available, DEVONthink's editor is full-featured

enough for many peoples' needs. Here are

some modern functions to make your writing

more pleasant and efficient.

As you're writing you can switch easily

between three views, all chosen in the View >

Document Display submenu. Source displays

a plain text view for editing. Preview shows

the rendered view of the page. And Side-by-

Side displays the source and preview in two
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connected panes. If there is a view you prefer,

you can set it as the default in the  Files >

Markdown > Markdown Display dropdown.

Syntax Highlighting: When editing the source

of the Markdown, DEVONthink's hybrid

source rendering will display many types

of formatting or elements as you type. For

example, typing **important** will display

the plain text in bold; `{"name":"Audrey

Hepburn"}` will display as a code block,

etc. If you'd prefer to never see formatting

in the source code, you can disable Syntax

Highlighting in the Files > Markdown settings.

WYSIWYG Editing: Another feature of syntax

highlighting is WYSIWYG images & links.

This renders links as active hyperlinks and

image links as the linked image. An example

of this is shown in the image at the top of

this section. You can enable this globally

in the Files > Markdown settings or toggle

Format > WYSIWYG Editing on a document-

by-document basis. Note this feature requires

syntax highlighting to be enabled in the

application settings.

In WYSIWYG mode, you can edit the

attributes of a rendered image. Control-click

it and choose Edit Image. Modify or remove

the caption, change the image by modifying

the URL, or add an optional parameter, e.g.,

width=250px. For a rendered non-image link,

Control-click it and choose Edit Link or select

the text and use Format > Edit Link. This

change does not affect the link's text.

Typewriter-like Scrolling: A feature used

by some other writing applications is

typewriter-like scrolling. This keeps the

current line you're editing in the middle of the

page.

Linking Documents: To create links in your

Markdown documents, you can use linking

methods described in the Document Linking

section, e.g., WikiLinks, cross-links, etc. But

there are also special behaviors when you

drag and drop or copy and paste documents

in your database into Markdown:

Adding an image automatically inserts

a valid Markdown link, e.g., ![piglet]

(piglet.png), depending on your

application settings or the location of the

image.

Copy a document in your database.

Pasting it into your document yields a valid

Markdown link with an item link.

Drop MP3, MP4, or PDF documents to

insert a playable multimedia link via a

special transclusion link, discussed below..

Organizing Your Linked Images: If you

are including images in your Markdown

documents, keeping them organized can

require creating groups to contain them.

There is a function in the settings to help

make this easier and more automatic. In the

Files > Markdown settings, enable Import

images to group. Below that is a text field

with Assets as the name. Now images you

drag and drop or copy and paste images into

the document will be automatically filed in

an Assets subgroup in the same group as

your documents, all properly linked. (For

many years, this has been a tried-and-true

filing method for web content.) If you clip

documents as Markdown, downloaded images

will also be filed in this group. You can change

the name in the settings, as needed. And if

you want to create the group in a different
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location, you can read about the link syntax in

the Appendix > Markdown Explored > Linking

section.

File Transclusion: A special feature of

DEVONthink Markdown is file transclusion.

This creates a special link to display the

contents of one file inside the contents

of a Markdown document. This supports

displaying the contents of: plain text, rich

text, HTML, formatted notes, sheet, or

more commonly, other Markdown files. For

example, imagine you wrote several chapters

of a book in individual Markdown files. Using

transclusion you can view and arrange them

as if they're one document, all without

needing to merge or copy and paste content

between files.

To use transclusion, just enter the desired

document's name or item link between

double braces, e.g., {{Chapter 1}}.

Transclusion supports filenames with and

without extensions, relative and absolute

links, as well as item links. It also supports the

Obsidian syntax, e.g., ![[Chapter 2.md]].

Markdown Extensions: To support some

features in Markdown that aren't built in,

DEVONthink supports a handful of known

and widely used extensions. The first option

below requires no user interaction. The

following three can be enabled in the Files >

Markdown settings: Mathjax for rendering

equations and formulae, Mermaid for creating

diagrams, and Lea Verou's Prism for syntax

highlighting code.

If you're interested in composing in

Markdown, including the supported

extensions, the Appendix > Markdown

Explored section will help you get started.

While not exhaustive it covers a wide range

of elements supported in DEVONthink

Markdown.

INTERFACE

Navigation Bar: When working with

Markdown documents, you can switch

between Preview and Source modes. There

also is a special icon  present in the

navigation bar. This switches to Side-by-Side

mode, allowing you to edit and preview the

current document in two side-by-side panes.

Editing Bar: The Editing bar is only available

when editing the source. It has a subset

of the tools used in rich text editing, e.g.,

Highlight, Bold, etc.

Inspectors: These inspectors provide

navigation or a view into the resources in

Markdown documents:

Table of Contents: You can view and

navigate your Markdown sections in the

Table of Contents inspector.

Annotations: Markdown highlighting,

underlining, strikethrough, etc. are shown in

the Document > Annotations inspector.

Links: Excluding WikiLinks, many types of

outgoing links are shown in the Document

> Links inspector, including item links, web

URLs, other URL schemes like mailto:, etc.

Attachments: Images added to the

Markdown document are listed in the

Document > Attachments inspector.

Context Menu: Markdown documents

support the same context menu items

available with text selections in the
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document source. But there are a few special

commands available both in the source and

preview:

Copy/Reveal/Edit…: Copies or reveals a

linked document or opens it for editing.

Set as Thumbnail: Use a Control-clicked

image as the document's thumbnail.

ITEM LINKING

In addition to the document's standard item

link, Markdown documents support this

alternative item link:

Section Link: Links to the section, e.g., an

h1 header, of the selected text.

Alternate item links are available in the

context menu in the view/edit pane or when

holding the Shift key while viewing the Edit

menu.

PDFS

PDFs are a very common format, from

academia and online bill payments to

equipment manuals. Fortunately, they

are first-class citizens that can be viewed

and annotated within DEVONthink. The

annotation tools should be familiar and

include options like arrows, text, and link

annotations. While DEVONthink may not

have some options found in specialized PDF

applications, it is still a very capable PDF tool.

Beyond importing and indexing, PDF files can

also be created by capturing web content,

directly in DEVONthink or via our browser

extension, Clip to DEVONthink. You can also

print a paginated PDF with the Save PDF

to DEVONthink in the PDF dropdown of the

print dialogs of most macOS applications.

PDFs often come directly from text

sources, like word processing or page layout

applications. The content of these files

should be indexed and searchable when

added to your database. But there are also

times when a PDF only contains pages of

images, e.g., PDFs made from scans of old

books. In a process similar to Apple's Live

Text, DEVONthink will detect and index the

text transparently, allowing you to search

for these documents. However, you will not

be able to use the Search inspector and see

occurrences of search terms in the found

documents as there is no actual text layer

present.

OCR: Even if PDF text is detected internally,

we strongly recommend you use OCR to

create properly searchable documents. OCR

adds a text layer to the document, allowing

search hits to be shown in the Search

inspector. That text layer is a permanent

part of the document, so it is preserved

when using it outside of our application, or
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even across platforms. For scanned PDFs

without a text layer, you can do OCR directly

in DEVONthink when needed.

Viewing PDFs: When you view a PDF it will

display as single or two side-by-side pages.

Choose the desired option in the View >

PDF Display options. When the document

opens, the pages are viewed as the entire

page or magnified to the width of the view/

edit pane. You can choose how the document

is displayed in the View > Zoom submenu. If

you'd like to always view PDFs with a specific

Zoom option, you can set a default in the

Files > Multimedia > PDF Display preferences.

Enable Automatically resize then choose

a single or double page option. The Zoom

option used is controlled as shown below:

Continuous: Zoom to Width

Non-Continuous: Zoom to Fit

INTERFACE

Navigation Bar: Not only containing the

typical properties like word count, with PDFs

the Navigation bar shows the the current

page folio along side the total number of

pages in the document. Clicking on this

navigation bar item opens a Go to page

function so you can quickly jump to a specific

page. In addition, there are buttons to move

to the first, previous, next, or last page. Also,

you will see an  icon if the document is

encrypted. Also, if the document is read-only

and cannot be edited, for whatever reason,

you will see this  icon.

Editing Bar: The navigation bar for PDF files

includes the Editing Bar, providing access to

editing and annotation tools. Click this 

and the editing bar will replace the navigation

bar. You can also access them in the Tools >

Annotate menu. The available tools are:

Select text for copy or highlighting.

Select annotations on the page. Double-

click an annotation to edit its properties.

Press the ⌦ Delete key to remove the

annotation.

Move or scroll the current page.

Underline selected text in the document.

Strike through selected text in the

document.

Apply or remove highlighting on selected

text. The highlight color will be the color

selected in Format > Highlight Color.

Alternately, click and hold to select another

color.

Add a link to a selected area. Click and

drag over an area to establish a hotspot

for the link to be active. For the Link

Type, choose Link within PDF, navigate

to another page and click Set to create a

link between pages within the same PDF.

Alternatively, choose URL and enter a URL

to an external item. This can be a web site

address, or drag files from the Finder or

your DEVONthink databases into this field.

Add a rectangle annotation.

Add an oval annotation.

Add a line annotation.

Add a note annotation.

Add a text annotation. Drag to create

a text box. To change the font, choose

Format > Font > Show Fonts.. Note only one

font can apply to each text annotation.

Rotate the current page left (counter-

clockwise).

Rotate the current page right (clockwise).
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Add a new blank page before the current

page.

Delete the current page.

Reverse the page order of the document.

When using certain annotation tools, e.g.,

Note or Link annotations, the Annotations

panel will open. You can set type-specific

properties in this panel. The settings here will

be retained for subsequent uses of each type

of annotation.

Context Menu: In addition to many common

context menu items, there are also a few

PDF-specific commands:

Add to Reading List/Favorites: Add the

current page to the Reading List sidebar

or the Favorites section of the Navigate

sidebar.

Add to Table of Contents: Adds the

current page as a bookmark to the Table of

Contents. This command is also available in

the Document > Thumbnails inspector.

Automatically Resize: When checked, the

zoom factor adjusts to the width of the

view/edit pane or document window.

Delete Annotation: Deletes the selected

annotations.

Single Page/Two Page (Continuous):

Displays the PDF as single or double

pages. Use the Continuous option to allow

quick scrolling through the pages as one

continuous document.

Previous/Next Page: Jumps to the previous

or next page.

Rotate Left/Right: Rotates the current

page 90 degrees in the selected direction.

Insert Blank Page: Insert a new blank page

before the current page.

Delete Page: Delete the current page.

Reverse Page Order: Reverses the order of

the pages in the entire document.

Inspectors: There are a few inspector panes

with information specifically pertaining to

PDF documents: Info > Properties, Content

inspectors, and Document > Annotations.

Properties: The Properties inspector

displays PDF metadata from some third-

party applications, e.g., Adobe Acrobat.

It will display things like a title, copyright,

author, and keywords, if available.

Content: The Table of Contents inspector

displays a PDF's table of contents, if one

exists. You can navigate through the

document with the section markers in it.

The Thumbnails inspector displays page

thumbnails of the PDF currently displayed

in the view/edit pane. You can navigate

the document via the thumbnails. You can

also drag to rearrange the pages or even

drag them out of the inspector to export

them. Alternately, drag other PDFs into

the inspector to merge one document

into another. Commands for deleting or

inserting blank pages are found in the Tools

> PDF submenu. And the Split Document

command becomes available in the Tools

and context menus when you've selected a

page thumbnail.

Document: If you are annotating your PDFs,

the Document > Annotations inspector

is where you can see and manage the

document's annotations. Edits made with

the annotation tools mentioned above will

appear here. You can also selectively delete

annotations in this inspector. While not

specific to just PDFs, the Document > Links
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inspector displays links detected in the

content.

ITEM LINKING

In addition to the document's standard

item link, PDF documents support these

alternative item links:

Page Link: Links to the current page.

Selection Link: Links to selected text.

Annotation Link: Links to a selected

annotation.

Alternate item links are available in the

context menu in the view/edit pane or the

Thumbnails inspector. The alternate links are

also accessible when holding the ⇧ Shift key

while viewing the Edit menu.

HTML-BASED FORMATS

HTML-based files in DEVONthink include

bookmarks, web archives, formatted notes,

and RSS articles. These are formats that

are viewable in web browsers and are also

mobile-native, so they will work nicely in

DEVONthink To Go too!

BOOKMARKS

Bookmarks are exactly the same as the

ones found in your web browser. With

DEVONthink's ability to act as a browser,

bookmarks can be a valuable part of your

experience. When using File > Import >

Bookmarks,  you can bring your bookmarks

into DEVONthink easily. Though this depends

on the capability of the individual browser,

you may be able to drag links directly into

your database. You can also capture them

with DEVONthink's Sorter.

In addition to importing bookmark files, they

can be created via Data > New > Bookmark.

Just provide a URL and title. If you don't enter

a title, DEVONthink will attempt to detect

and use the page title.

Note: If you import your bookmarks from

a browser, this is a copy operation not

a sync, i.e., if you modify bookmarks in

your browser, this will have no effect on

DEVONthink's contents. However, you

can do another import to add the new

bookmarks to your database without

duplicating the previous ones.

FORMATTED NOTES AND HTML

Formatted Notes: Formatted notes are

a simple web-based note format, like a

mobile rich text format. These files can be

viewed with most web browsers. Similar

to their text-based counterparts, they

support adding images and formatting text,

though the range of formatting options is

smaller than that of rich text. You can find all

available formatting commands in the Edit

and Format menus. Newly created formatted

notes use the font set in Editing > Format >
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Rich Text & Note Font. Captured or imported

formatted notes, e.g., from Evernote, use the

font set in Settings > Web > Standard Font

Images are embedded directly into the HTML

code so that formatted notes are completely

self-contained. However, the resulting file size

can grow large very quickly. Resizing images

before adding them is encouraged. The HTML

code is also cleaned from unnecessary tags

and an identifying meta tag is inserted that

lets DEVONthink distinguish formatted notes

from normal HTML pages. Form tags, e.g., for

checkboxes and input fields are not removed

and the status of checkboxes and form fields

is retained.

Bear in mind, the underlying markup

in formatted notes can't be edited in

DEVONthink. However, you can open the files

in a compatible external editor, if you'd like.

HTML Files: HTML files are similar to

formatted notes, however they do not

preserve the state of certain elements,

e.g., checkboxes and form fields. You also

cannot add images by dragging them into the

live editing view. However, you can edit the

underlying HTML code using the Source and

Side-by-Side modes found in the navigation

bar. HTML files can be created via Data > New

> HTML page or clipped.

Formatted notes can be created via Data >

New > Formatted note. When using the Notes

from Evernote or Folders & Attachments

from Notes options in the File > Import menu,

the imported notes are formatted notes.

WEB ARCHIVES

Web archives are a special HTML file format

intended to create offline archives of

individual web pages. The downloaded data

preserves the look and feel of the page very

closely. It is often a more useful capture

option when a PDF would generate a very

long page since web archives always view at

the size determined by the browsing area.

They function in a similar fashion as

formatted notes, so you can actually edit the

captured contents and save your changes.

This can be very handy for highlighting

passages or removing unwanted elements,

e.g., ads, in a captured web page. Also, since

they are HTML files the underlying markup

can be edited using the Source and Side-by-

Side modes found in the navigation bar.

Note: Web archives can be very useful with

web pages using statically linked content.

However, some popular and monetized

sites get their contents dynamically from

other sources, so the actual data is not

in the underlying HTML. These pages may

have missing content due to this, require

an internet connection to display content,

and run JavaScript. If you encounter this,

capturing to PDF may be a better archiving

option.

You can't natively create web archives files

in DEVONthink. They are the result of web

clipping, either in DEVONthink or using our

browser extension.
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RSS

RSS feeds are special "web pages" that don't

show as pages but as a stream of news

articles. DEVONthink allows you to keep that

news flowing directly into your databases.

Supporting RSS, RDF, Atom, and JSON feeds,

DEVONthink functions as a basic newsreader.

RSS feeds are treated as a special type

of group. Feed articles are downloaded

to the feed and saved in a format you

specify in DEVONthink's Settings > RSS

> Feed Format. The default is Automatic

and saves summary files as HTML. When

using an option other than Automatic as the

feed format, DEVONthink must download

the linked content and convert it to the

appropriate format. The styling of the HTML

articles is controlled by an internal CSS

stylesheet specified in Settings > RSS > Feed

Style Sheet. Other formats will get their

styling from the source they're downloaded

from.

Add a new RSS feed via Data > New > Feed.

Just provide a URL and an optional title.

If you don't enter a title, DEVONthink will

attempt to detect and use the feed's title.

INTERFACE

Editing Bar: Like rich text files, editing

HTML-based files (excluding bookmarks)

includes the Editing Bar. Click this  icon

and the editing bar will appear in place of

the navigation bar. The tools available here

consist of:

 Increase the size of the font.

 Decrease the size of the font.

 Set characters to be subscript.

 Set characters to be superscript.

 Set bold on the text.

 Set italic on the text.

 Set an underline on the text.

 Set strikethrough on the text.

Highlight selected text. This uses the

currently selected highlight color.

Add or edit a link applied to the selected

text.

Show the Fonts panel.

Show the Color Picker.

Context Menu: In addition to the context

menu commands available with text

selections in a document, HTML based files

often include these items:

Capture …: Captures the Control-clicked

frame, image, link to the inbox of the

current database.

Capture Page: Captures the current page

in the selected format to the inbox of the

current database.

Copy … Address: Copies the frame URL of

a Control-clicked frame, image, page, or

video to the clipboard.

Insert > ...: Inserts checkboxes into the

document.

Open … in New Tab: Opens a Control-

clicked image, page, or video in a new

DEVONthink tab.

Open Image in PhotoStickies: Opens the

image in PhotoStickies.

Open Page in Browser: Opens the current

page in your default web browser.

Open Page in DEVONagent: Opens the

current page in DEVONagent Pro.

Reload: Reloads the page from the Internet.
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Update Bookmark: Updates the URL of this

document to the current one, e.g., after

navigating to a sub-page.

Update Captured Archive: Updates the

contents of a web archive file with the live

version on the Internet.

Add Page to Downloads: Adds the page

address to the Download Manager.

Download Video: Downloads the video

using the Download Manager.

Inspectors: Beyond the standard inspectors,

a few others have specific utility with these

formats:

Links: The Document > Links inspector is

a great place to check out (and interact

with) links in the documents.

Annotations: If you are annotating

any of these formats, the Document >

Annotations inspector lets you see, select,

and even delete annotations.

Properties: For clipped content, certain

attributes may be shown in the Info >

Properties inspector, e.g., keywords or the

page's description.

ITEM LINKING

Web-based formats support two specialized

link types.

Selection Link: Link to the paragraph

of the selected text on a document,

e.g., formatted note. This displays as

highlighted text when the link is used.

Note this is a cosmetic effect and not an

annotation.

Copy Link With Highlight: Available in

the context menu for selected text when

viewing bookmarks in DEVONthink, the

passage is shown highlighted on the web

page when the link is used.

SHEETS

Sheets are a specialized format used to store

and display tabular data. For example, a sheet

could contain a table of peoples' name, title,

and department, your software titles and

licenses, or the bibliographic information

about research papers you're working with.

Sheets are made up of records, defined by

parameters you specify, and displayed as a

form or columns.

Sheets are created via Data > New > Sheet. If

you import tab or comma-delimited files, e.g.,

CSV or TSV files, they will be imported and

displayed as sheets. With these imported

documents, you may need to define column

headings, which you can modify at any time.

When you create a sheet or edit the columns

via the Column Editor, you will specify the

column name and their type. An explanation

of these data types can be found in the Data

section of the appendix.
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Sheets can be displayed as a table or a form

via the View > Document Display menu or

using the  and  buttons in the navigation

bar. The table view is similar to standard

spreadsheet views. Form view is similar to

the record view e.g., in FileMaker. You can

set the default view for sheets in the Files >

Sheets settings.

Editing sheets works a bit differently than

other formats. In Table view, click a cell to

edit its content. To move to the next column,

press the ⇥ Tab key. To finish editing and

begin a new record, tap the ↩ Return key. This

can make editing sheets a very quick process.

In Form view, tabs and returns work more

like other text-based formats. Add new and

remove selected rows using the Add Record

and Remove Record commands in the Tools >

Sheets > Add Record menu.

When working with a sheet, columns with

links are handled differently. For cells

containing a URL, hold the ⇧⌘ keys and click

the link to open it in an external application

while switching to it. For cells using an item

link, the same keys open the linked document

in a new tab or document window, depending

on the General > Interface settings.

INTERFACE

Navigation Bar: Above the view/edit pane,

the Navigation bar displays the current

record and the total number of records in the

sheet. Clicking on this information opens a

Go to record function so you can quickly jump

to a specific record in the sheet. In addition,

there are options to go to the first, previous,

next, or last records.

Editing Bar: To make working with sheets

even more efficient, DEVONthink includes the

Editing bar with some basic tools:

Add a new record to the sheet.

Duplicate the current or selected records.

Delete a new record from the sheet.

Add a new column to the sheet.

Displays the Column Editor to allow editing

and managing the columns.

Delete a column from the sheet.

In Form view, there is one more option

enabled in the Editing bar: Delete Selected

Column allows you to delete a column. Just

click on the column header you want to delete

then this option is enabled.

Context Menu: There are a few sheet-specific

context menu items available when you're

Control-clicking in a sheet.

New Record: Creates a new record in the

sheet.

Duplicate Record: Duplicates a selected

record in the sheet.

New Column: Creates a new column in the

sheet.

Edit Columns: Displays the Column Editor

to allow editing and managing the columns.

Delete Records/Columns: Deletes the

selected record(s) or selected column(s).
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Copy Item Link: Copies the unique link to

the document.

Add To: Add the document to the Favorites

or Reading List.

In Table View, there are also Cut, Copy, and

Paste commands. Pasting always adds as the

last record in the sheet.

ITEM LINKING

Sheets currently support no alternate item

links.

Note: Despite any visual or behavior

similarities with Microsoft Excel, sheets

are not spreadsheets and therefore do not

provide functions and formulae.

IMAGES, AUDIO, AND VIDEO

While DEVONthink's strengths lie in text-

based content, you certainly can add images,

audio, and video files to your databases. You

can even add new media documents via the

Sorter's Audio Note, Video Note, and Screen

Capture features.

DEVONthink uses macOS core technologies

to display images and videos, and also play

audio. Interacting with images uses the same

controls you are used to, like pinch to zoom

in and out, two-finger tap to zoom to width,

and even two-finger rotation in 90 degree

increments. Audio and video files display the

familiar macOS playback controls.

INTERFACE

Navigation bar: The Navigation Bar has no

special controls options for images. But for

audio and video files, it displays the playback

time. If you click the time it shows a Go to

time function so you can quickly jump to

another time in the playback.

Editing Bar: When viewing an image, the

Editing Bar offers some editing tools:

Markup Tools: Add marks to your image

with the Rectangle, Circle, Line, and Text

tools.

Rotation: Rotate left or right 90 degrees or

a full 180.

Flip: Flip the image on its horizontal or

vertical axis.

To the left are Select and Move tools so you

can select and modify the image annotations

or scroll the image. But be aware, these

annotations will be flattened into the image

when you save or deselect the image. They

can't be removed at a latter time.

Edit pane for images: In addition to the

Editing Bar's tools, double-clicking opens an

edit panel with three tabs. The Adjust tab

allows you to do some basic image editing,

like adjust exposure, saturation, adding a

sepia tone, etc. The Effects tab provides
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some simple pre-defined image effects. The

Details tab displays metadata about the

image, including EXIF metadata and a map of

the geolocated origin of the file.

Context Menu: There are a few media-

specific context menu items available,

excluding common ones related to magnifying

the image. In addition to the standard

controls, e.g., volume, playback position, etc.,

some of the same context menu options are

found in the action menu for these files.

Rotate Left/Right: Rotate the image left

and right.

Flip Horizontal/Vertical: Flip the image on

the chosen axis.

Edit: Opens the Edit panel for images.

Copy Image: Copies the image or current

video frame to the clipboard. When this

command is used with an image, a .tiff

file is created on the clipboard. These files

can be quite sizable but are also lossless.

Set As Thumbnail: Use the current frame

as the thumbnail of the video while

playback is paused.

ITEM LINKING

In addition to the document's standard

item link, audio and video files support this

alternative item link:

Frame Link: Link to the current time of

paused media.

Alternate item links may be available in the

context menu in the view/edit pane or via

the Action menu (gear icon) while the media

is paused. The alternative command is also

accessible while holding the ⇧ Shift key while

viewing the Edit menu.

Note: We sometimes get inquiries

about including entire photo libraries in

DEVONthink, e.g., from Photos, Lightroom,

etc. While it's certainly possible to

include images in your databases, please

understand DEVONthink is not a digital

asset management application. If you

want to include some images on a per

project basis, perhaps for journaling or

genealogy, etc., that works fine. If you are

trying to have an image archive, searchable

by media-specific metadata, you'll be

better off using an application built for this

specific purpose.

OFFICE DOCUMENTS, EMAIL,
AND OTHERS

DEVONthink is the central hub for many

environments, from home to office, and you

are likely using several other applications

along side it. As often mentioned,

DEVONthink supports importing many file

types; some editable, some not. If a format

is text-based, like XML files, they may be

directly editable. But even if a file is not

editable, it may be searchable. This section

is obviously not exhaustive in what kind of

files can be added to DEVONthink, but if

you have a format we haven't discussed, the

easiest thing to do is just try importing it.

Any failures will be reported in Window > Log.

EPUB

A popular format used for digital books

(including our manual), EPUB files (.epub)

can be added to your databases. While they

can't be edited in DEVONthink, their contents

are fully indexed and searchable, making

them a viable resource in your databases.
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Navigate an .epub file in the Content > Table

of Contents inspector or choose the View >

Document Display > Text Alternative view.

When searching an EPUB file, the view/edit

pane will switch automatically to the View >

Document Display > Text Alternative view to

display the search hits.

OFFICE DOCUMENTS

Word processing, spreadsheet, and

presentation applications are common in

many situations. When using the proprietary

formats from these applications, like

Microsoft Word documents (.doc, .docx),

these formats aren't directly editable in

DEVONthink. However, it does support

importing and indexing these particular

document types:

Apple Pages (.pages), Numbers

(.numbers), and Keynote (.key) from

Apple's iWork suite

Word (.doc(x)), Excel (.xls(x)) and

PowerPoint (.ppt(x)) from Microsoft's

Microsoft Office suite.

Files from supporting applications, like the

OpenOffice or  LibreOffice suites.

Files from the popular macOS Mellel word

processor.

These formats can only be imported, however

it is possible to add template files of these

formats. For example, you may have a

boilerplate Pages document you often use.

This could be added as a template to quickly

add to your database, then opened and

edited in Pages. See the appendix for a bit

more information.

EMAIL

Imported email messages (.eml) have

their contents indexed. This makes them

searchable and a valuable asset, whether

you're archiving email for personal or

professional reasons. If the email contains

indexable attachments, e.g., a rich text file or

PDF document with a text layer, the content

will be indexed and treated as part of the

content of the email document. You can

confirm this in the Concordance inspector.

Note attachments like images, audio/video

files, and PDF documents without a text

layer will not be indexed nor processed, e.g.,

transcribed, as part of the import process.

But they can be processed separately, as we'll

see next.

Dealing with attachments: Attachments

are included as part of the email; they

are embedded and add to the file size.

Separating the attachments allows them to

be used independently, but be aware they will

also consume twice the space – in the email

and as a separate document. However, when

separated they can then be made searchable

or transcribed as needed. If you want to

import them separately, do this:

Drag and drop in DEVONthink: Select an

email with attachments, then drag and

drop an attachment to the item list while

using the View > Document Display > Text

Alternative view.

Drag and drop from an email client: If you're

not importing the email but only want the

attachment, select it in the email, then

drag and drop it to your database, the

Sorter, DEVONthink's Dock icon, etc. This

will work for Apple Mail and Outlook and
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will likely be allowed in several other email

clients.

Import attachments automatically: Enable

the Files > Emails > Import attachments

setting and the attachments will be

imported along side their containing

emails. Note this will not group the email

and its attachments. Be cautious with

this as the global setting means ALL

attachments will be imported from all

emails being imported.

Import on demand: If you want to control

what attachments you want to import

from specific emails, select an email

and choose the Tools > Import Email

Attachments command.

Mail Scripts: In Apple Mail and Legacy

Outlook, select an email with an

attachment. Then in the global Scripts

menu at the top of your screen, choose Add

attachments to DEVONthink to import

only the attachments or Add message(s)

& attachments to DEVONthink. The

latter command will group the email and its

attachments together.

For more information on email importing see

the In & Out > Handling Emails section.

OTHER FORMATS

You may be reading through this section and

thinking, "Well, there are many more kinds

of files than you've listed here. What about

those?!" That is indeed true and the fact is

you can likely put any kind of file into your

database. But there are a few things to think

about.

The first thing is whether there's a real

benefit to putting certain files into

DEVONthink. For example, it is possible to

put .zip files in a database but they serve

no functional purpose in they aren't indexed

or searchable. It may make sense if it's just

for archival purposes, but it would make less

sense in an active database. The same would

apply to build files, log files, temp files, etc.

The second thing to consider is whether you

have two per-format components on your

Mac: a QuickLook plugin and a Spotlight

importer. These components come from

third-parties, typically the developer of the

format or an application that can edit it.

The QuickLook plugin generates a preview of

a file and DEVONthink can use this to display

the file. If there isn't a plugin loaded on your

Mac, you will see a generic file icon.

If there is a Spotlight importer available

for the file format you're adding to your

database, DEVONthink may be able to

use it to gather some information about

the document. The kind and amount of

information is dependent on how the

importer was developed.

Two ways to improve the chances of getting

at least a preview are: run native macOS

applications and make sure the compatible

application is installed on the Mac and has

been launched at least once. That way a

QuickLook plugin or Spotlight importer, if

available, should be registered for specific

formats on the machine.
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TEXT AND BEST ALTERNATIVE

For some document formats, e.g., email

messages or Word documents, DEVONthink

only allows you to select and copy text in

the Text Alternative view. If DEVONthink is

able to interpret and convert the document

format, you can use the  and  buttons

in the navigation bar to switch between a

view that allows you to select, copy, and drag

text or the Quick Look view showing a more

"accurate" view of a file.

Also note you will have text-related context

menu commands available when you can

make text selections in the Text Alternative

view of a file.

INTERFACE

Context Menu: Context menu items aren't

available in Quick Look views, e.g., Control-

clicking in a PowerPoint file. Also, when using

the Text Alternative mode for these files,

some but not all context items related to text

selections are available. See also p. 301ff

ITEM LINKING

No alternate item links are available for non-

native formats.

LINKED FILES

On occasion we get an inquiry about

importing files with linked assets, like Adobe

Illustrator or InDesign files. While it's certainly

possible to import these, the links will be

broken if you try to import a folder structure

containing the links. Groups in DEVONthink

do not exist in the file system, so the groups

that are created when you import a folder

structure from the Finder don't exist as

real folders in the database. The files inside

the folders are imported into the internal

structure of the database, so their paths are

not pointing to the groups in the database.

If you want to include these kinds of files in

your databases, you could keep the linked

files external and only import the documents.

You could also index the complete folder

structure containing your files into the

database, leaving them where they are in the

Finder. Since the paths aren't changing, the

links would be preserved when you open the

documents.
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DEVONthink is not an island. It integrates

with the rest of your Mac and iOS devices

in a variety of ways to make it easy for you

to add data to DEVONthink. There are even

some options that allow you to share your

data with friends and colleagues. The first

part of this chapter will discuss the various

ways to get documents into your databases.

This is followed by a section on the exporting

options, with the remainder of the chapter

discussing sync, in philosophy and practice.

IMPORTING & INDEXING

When it comes to getting data into your

databases, there are two fundamental

methods to consider: importing and indexing.

IMPORT

Importing copies files into the internal

structure of the database. This creates a

portable, self-contained database that can

be moved as a single file. This is the default

behavior of DEVONthink.

When you drag-and-drop files or choose File

> Import > Files and Folders, files are copied.

This does leave the originals in the Finder,

which you can choose to keep or delete. But

note there is no connection between the

files any longer. Editing the file in the Finder

after importing has no effect on the file in

the database, as the database has a copy of

it. If you want to access and edit the files, do

so from inside DEVONthink.

If you hold the ⌘ Command key when you

drag into DEVONthink, the file will be moved,

not copied, into the database. If you are using

File > Import > Files and Folders, you can

click the Options button and enable Move

Originals to Trash.

INDEX

Creates links to files outside the database.

This allows more direct access to the files in

the Finder by other applications or people.

A common example is people using a cloud

service like Dropbox and indexing folders

in the local Dropbox folders. DEVONthink

indexes the content and metadata for use

with classification and other content-related

functions, just as it does with imported
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items. Do note while indexing doesn't copy

the contents of the files, the full text of text-

based documents is stored. This can still take

up a considerable amount of space.

Finder files and folders can be indexed using

File > Index. You can also hold ⌥⌘ while

dragging and dropping into your database.

When you do, you will see a curved arrow

on the cursor while dragging, indicating the

items will be indexed. Indexed items will have

a small square Finder icon to the right of the

item's name.

INDEXING AND THE FILESYSTEM

Indexing is not the default option for getting

files into your databases. This is not only

because importing creates a singular,

portable database, but also due to some

technical things that must be considered

when indexing. Here are a few behaviors you

should know and understand before indexing.

With indexing, the integration with the

filesystem is very tight. When you rename a

file in DEVONthink, the file's name changes

in the Finder. If you rename in the Finder, the

change should be automatically reflected in

the database. DEVONthink tries to keep the

group in the database and the folder in the

Finder in the same state. Also, if you move

a non-indexed file into an indexed group or

create a new file in an indexed group, the file

will be moved to the external indexed folder, a

process we call "deconsolidation".

When indexing items into DEVONthink, you

can index a file, a folder, or a parent folder

containing subfolders. In the image shown,

the "DEVONtech" folder is the parent folder

and could be indexed with all its contents

included. You could also index an individual

folder, e.g., the "Data" folder, which would be

treated as a parent folder for its contents. Or

you could index individual files. Each of these

options has specific behaviors you should be

aware of, covered below.

Updating indexed files: In general use,

DEVONthink can usually detect filesystem

changes of indexed folders and will update

the indexed group in the database. However,

there are two things to be aware of regarding

automatic updating of indexed files.

Files synced by other applications: If

you are indexing files in a folder synced

by another application, e.g., iCloud or

Dropbox, you may need to use the File

> Update Indexed Items command to

manually update the indexed group.

DEVONthink does this to avoid causing

a discrepancy in the data for the other
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application. Also, a particular process

may not generate a filesystem event

for DEVONthink to detect a change has

occurred.

Individually indexed files: While it's

certainly feasible to index individual files,

be aware these files won't always be

updated automatically. If you have an

indexed file selected in DEVONthink and

make external changes, the file will not

show the changes in the view/edit pane

automatically when you return to your

database. In this case, use File > Update

Indexed Items or reselect the document.

You should then see the updates.

Note: In the Appendix > Hidden

Preferences, you will find some

settings specific to indexing:

DisableAutomaticUpdatingOfItems,

DisableFileSystemEvents, and

DisableFileCoordination. If you'd like to

control whether DEVONthink automatically

moves indexed files into a database

(consolidation) and moves items to the

external Finder folder (deconsolidation),

see the Files > General > Indexed Items

settings.

Moving Indexed Items: DEVONthink stores

individually indexed items by its absolute

path in the filesystem. If you move an

individually indexed file or folder, it will

disappear when the database updates or be

reported as missing. This is because the item

no longer exists in the indexed location, so

the absolute path points to nothing. If you

move a file or subfolder inside an indexed

parent group, the change should be reflected

in the database or the Finder. The parent

folder still exists in the same location and

DEVONthink can adjust for the changed

relative paths within it.

While it's generally best to index fairly

static locations, i.e., ones that you won't

be relocating or renaming, sometimes

it becomes necessary to do some

housekeeping. Perhaps you are running low on

space on the internal drive and need to move

an indexed folder to a connected external

drive. Open the Tools > Inspectors > Generic

Info inspector, you can click the down arrow

next to the Path title, choose Select, and

select the parent folder in its new location.

DEVONthink should update the stored paths

to point to the Finder folder and its contents

in the new location.

Deleting Indexed Items: When deleting

indexed items, you will see one of two

warnings when you empty the database's

trash, depending on how you've indexed

the item. With individually indexed files or
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an indexed parent folder, you will see the

warning above prompting you to choose

whether to delete the item from the file

system or just the reference in the database.

In this instance, DEVONthink is prompting

you to make sure you aware of the potential

removal of a top level indexed item.

If you delete a subgroup or file in an indexed

group and empty the database's trash, you

will be shown a warning there are indexed

items detected in the trash. You can choose

to Remove Imported Items which will not

delete indexed files. Choose Remove All

Items to remove both indexed and imported

files when emptying the trash. Indexed files

will be moved to the system trash from

their location in the Finder. In this situation,

DEVONthink is modifying the content of the

indexed parent to ensure both the Finder and

database's contents match.

Duplicating Indexed Items: When you

duplicate an indexed item, the behavior

depends on if you're duplicating within a

database or between databases. if you

duplicate the item in the same database,

a copy will be created in the Finder in

anticipation of potential changes. If you

duplicate the item into another database, no

copy will be created in the Finder. However,

changes made to the item - in either

database - will affect both databases as the

indexed item is pointing at the same item in

the Finder.

Note: While you cannot replicate files

between databases, the duplication of an

indexed file across databases can provide

you with a similar behavior. However,

the files will not be marked as duplicates

since duplicates are not detected across

databases.

Replicating Indexed Files: Replicating indexed

files within a database, individually or within

parent folders, has no effect on the files in

the Finder. Replicating only adds a record

of another instance of the file. However, if

you delete a replicant of an indexed file and

empty the database's trash, this will have

no effect on the files in the Finder. They will

remain intact.

Indexing Cloud-synced Folders: One of

the common uses of indexing is to keep

a local folder in a cloud-synced location,

e.g., Dropbox, and have access to the files

within DEVONthink. While this is certainly

supported, be aware that changes made

to the local folder, especially when the

cloud service syncs, they may not always be

detected by DEVONthink. In that instance,
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you can manually update the indexed group

by selecting and hoisting it via the disclosure

triangle or choosing the File > Update Indexed

Items command. Also, you should only index

local data, e.g., on the local hard drive or

connected drives. DEVONthink doesn't

support indexing data that resides only in the

cloud.

Lastly, if you are indexing content and want

to sync the databases between devices,

please review the Indexing and Sync section.

Due to the flexibility of DEVONthink, it's

possible to have a database containing both

imported and indexed files.

Note: While DEVONthink can handle large

amounts of data, it is inadvisable to import

or index uncurated data, like entire hard

drives or your Home directory. You should

be judicious in what you put into your

databases.

DRAG & DROP

The Mac has always been an environment

with rich drag-and-drop support.

DEVONthink is a well-behaved citizen in this

regard. In fact, on a Mac your first instinct

should be trying a drag and drop. Here are are

few useful scenarios to consider:

IN

The easiest way to add data to DEVONthink,

other than creating the documents directly

inside the application, is to drag files or

selected data, e.g., text, images, etc., into a

DEVONthink window.

Drag files from the Finder into a database.

Holding certain command keys will allow

you to copy, move, or index them. See also

p. 81ff

Drag files from the Finder to DEVONthink's

dock icon. Files will be sent to

DEVONthink's default destination.

With applications supporting drag-and-

drop, you can drag data between them

and DEVONthink. For example, you can

drag messages from Apple Mail into your

database or DEVONthink's dock icon.

Inside DEVONthink, you may be able to

drag content from a file into the database.

If you have an email message with an

attachment imported into your database,

you can drag the attachment out as a

separate file.

With some file types it's possible to select

text and drag it out to create a new file.

DEVONthink will attempt to create the

most appropriate file type.

Note: With the last two options, you may

be able to drag-and-drop content between

files.

OUT

DEVONthink isn't just a receiver; it also allows

drag-and-drop of its files too.

For email applications lacking good

automation support, drag a document onto

its dock icon or into a draft email to attach

it.

Drag documents or groups to the Finder as

a quick export option. When you do this,
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DEVONthink may export Finder tags on

those documents, if enabled.

If you need to upload a document to a

website, drag the document directly from

your database just as you would in the

Finder. If you need to upload a group of

files, you'd need to drag the group to the

Finder first, likely compress it, then upload

to the site.

INSIDE

And obviously DEVONthink allows

dragging database items inside itself for

reorganization.

Dragging: Moves items, by default.

Option-Dragging: Duplicates items to the

dropped location.

Option-Command-Dragging: Replicates

items to the dropped location. Note you

cannot replicate a file to the same location

as the dragged file.

SORTER

The Sorter is a multi-purpose utility built into

DEVONthink providing options for adding

files and creating various types of notes.

When enabled in Settings > Sorter, it is found

in the menubar at the top of your screen —

displayed as DEVONthink or the  nautilus

icon — or docked to the side of your window.

Details about the views and controls of the

Sorter are covered in the Sorter section of

the Windows chapter.

Note: Due to the tight connections

between the Sorter and DEVONthink, our

application must be running in order to use

the Sorter's functions.

Navigation: The first view of the Sorter is

the Navigation  view. If you are in another

application and want to quickly add a

document to your database, this is the view

you will use. When it opens you will see

databases and groups you can drag and drop

to. If you have a group you frequently use, add

it to the Favorites section of the Navigate

sidebar and it will also appear in the Sorter.

If you have a particular group in mind, you

can use the search field to quickly locate it.

Start typing part of the name and matches

will appear as you type but bear in mind

this doesn't support wildcards, like *tech*.

While DEVONthink is running, it will retain the

search. Beyond adding files, you can double-

click a group or database to open it in its own

window. Alternately, you can choose to Open

or Reveal the group in a new window via the

context menu.

COMMON NOTE CONTROLS

In the note-taking views, you'll find a set of

controls in every pane: Name, Info containing

property metadata like ratings, label, etc.,

and Tags. There are also familiar buttons you'll

see: Add and the Reset button to clear the
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pane and start afresh. You can press ⌘S to

add a document or the ⎋ Escape key to reset

the pane.

One item to note is the Location dropdown,

i.e., choosing where to save the document.

If you want to create a new group, it's the

first option in the dropdown. If you want

to change the database, choose it first,

then open the dropdown again and choose

New Group. And the last used location is

remembered, so you can quickly create notes

in the same location.

NOTE CREATION

Take Note: If you ever just needed to jot

down a thought, you likely have gone in

search of some utility to help with that. And

while there are some apps built just for that

purpose, they don't directly integrate with

DEVONthink.

You can quickly open the Sorter and switch

to this view or use a hotkey you specified

as mentioned above. A quick tap of the

hotkey and you can compose a note in plain

or rich text, formatted note, or Markdown.

It supports formatting for the specific

types, e.g., bold, italic, Markdown headings,

etc. If you're not finished with your note,

the content is saved for later, even across

application relaunches. Set tags, ratings,

labels, etc., as needed. When you're finished,

save it directly into your database.

The Take Note view also responds to the Copy

Selection hotkey, allowing you to clip selected

text.

Voice Note: If typing isn't an option, the

Sorter can also record audio. Open the  view,

press the record button, and make your note.

After you stop recording, you can play it back

then add it or reset the pane and record

again. When done, add your metadata, if

needed, and add it to your database.

Video Note: Using your Mac's built-in camera

or webcam, you record video notes in the

Sorter. Open to the Video Notes view and the

camera turns on, showing you a live preview.

Click the record button and create a video to

be saved directly into your database.

When you're done recording, you can play

back the video before saving it. Scrub

through the video with the slider to move

quickly to certain parts. You can trim the

video by pressing the scissor icon then

dragging the end points then press the Trim

key. You can re-trim the file until you save it.

When you're satisfied with the result, enter

any metadata, if it's needed, and add it in

your chosen location.

Screen Capture: Similar to note taking, many

people have a screen capture app, even if it's

just the built-in commands from Apple. As a

convenience, DEVONthink has this function

built-in for quick and simple captures directly

into your database. Open the view and click

your option: Screen, Window, or Selection.

While using the windowed or selection

modes, you can still switch applications via

macOS' ⌃⇥ or Mission Control spaces, if the

need arises. After the clip, you can change

the name and metadata and add the image,

or reset the pane and do another screen

capture.
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On a side note, there is a small suite of

markup tools for images so you can add some

emphasis to the screen captures after the

fact.

Web Clip: The Web Clip is for clipping

content from browser, acting as the

interface to our Clip To DEVONthink browser

extension. In these scenarios, the Web Clip

view opens, pre-populated with the page title

and URL.

You are using your favorite compatible-

browser and want to capture the current

page. Click the our extension button or

use the Clip to DEVONthink hotkey you

defined.

You are reading in a document, an email,

or even a message, that has a link in it.

Control-click the link and choose Copy Link.

Open the Web Clip view and choose URL

on the clipboard.

Perhaps less commonly used, but if you

know the URL you want to clip, you can

choose Enter manually and type it in

yourself.

And just as you've read about the other

views, reset the pane or add the document to

your database.

GOING PAPERLESS IN
DEVONTHINK

Scanning is an integral part of many

workflows, at home, on the road, or in the

office. DEVONthink has built-in scanning

controls to interface directly with your

databases. Combined with the internal OCR,

it makes for a much more efficient workflow.

If you are using a Ricoh (Fujitsu) ScanSnap

scanner, see the next section.

TECHNICAL CONSIDERATIONS

If you have a scanner or are shopping for one,

you should check the details of the specific

product. It should firstly be compatible

with the version of macOS you're running.

This is especially true if you're buying a

used or older scanner. Secondly, and more

importantly, make sure it supports Apple's

Image Capture Architecture. Search for the

scanner's downloadable drivers and look for

ICA drivers not TWAIN. The ICA driver should

work with Apple's Image Capture application

and also DEVONthink.

Note: Hold a sheet of paper in your hand.

Technically, it is one leaf with two sides: a

front and a back. So if you have a single leaf

with printing on both sides, you have two

pages to scan, not one. This distinction is

important to understand when scanning

double-sided or multi-leaved documents.

All of DEVONthink's internal scanning

functions are done in the View > Import

sidebar. Here we will look at simple step-

by-step instructions for the types of scans

you may need to do. So start by opening the

Image Capture section.
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SINGLE PAGE SCANS

Single page single-sided documents are

very common, e.g., receipts or invoices.

Fortunately, they're also very quickly and

easily scanned.

1. Select the scanner: Choose your scanner

listed in Devices. DEVONthink will connect

with the scanner. If Flatbed is chosen, an

overview of the scanning area will be shown.

If no document is on the flatbed, add one

and press the Overview button to refresh the

preview.

2. Set the scanning options: There are a small

number of options to choose, many of which

will remain as defaults, e.g., the resolution.

These are described in the Windows >

Sidebar: Image Capture section. However,

for a quick reference, here are a few you may

change per-document:

Name: Enter a specific name for the

resulting document. Otherwise a

timestamp will be used.

To: Choose a location in a database under

the DEVONthink option where the final

document should be saved, e.g., in the

Global Inbox.

Tags: Add any per-document tags, if

needed, e.g., receipt.

OCR: Choose whether to use OCR to

create a searchable document.

3. Load and scan: Put your document on

the flatbed or in the document feeder. The

press the Start button in DEVONthink's

scan window. You should now have your

finished document in your chosen location.

If you aren't entering a specific name and are

scanning to the same location, put in a new

document and continue scanning.

Ganged Scans: A variation on single-page

scans is ganged scanning: scanning multiple

smaller documents on a flatbed scanner.

Imagine you have five receipts from a

business night out. Lay them out on the

scanner fairly squarely and not overlapping.

Enable the Use Custom Size option. Click

and drag the handles of the purple overlay

to encompass one receipt. Click away from

the overlay when it's sized correctly. Now

click and drag over the next receipt to add an

overlay for it. Continue adding overlays for

each individual item on the scanner. When

ready, press the Scan button and each will be

scanned to individual documents, saved to

the destination you chose.
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DEFERRED SCANNING

In some scenarios, you may need to scan

multiple documents without immediately

producing a final PDF. This may be rapid-fire

scanning receipts to be collated later. Or you

may have a partial set of documents scanned

but await the arrival of more to add to a final

document. To do this, follow the same steps

as multi-page scanning.

Binders: A binder in DEVONthink is similar

to its real-world counterpart: a temporary

holding place for documents. You can choose

a binder or create a new one in your scan

settings. In the Imports section, select a

binder to see the current scans it holds.

Within a binder, there are some specific tools

for working with the documents:

Double-click a page to edit it. For PDF

pages, you can rotate to correct the

orientation. For image pages: double-click

the loaded image to adjust the color, drag a

marquee and press the Crop tool to remove

unwanted border areas.

Drag and drop to manually reorder the

pages.

Click the Organize button at the bottom to

reverse/shuffle the pages or to merge two

binders into one.

Click the  button to set metadata like

the Author and Subject, as well as set the

Destination to save to.

When you have all your scans in the binder,

organized as needed, press the Save button

to process it into the finished document.

Imports: Scans in the Imports section are

ungrouped and can be modified individually.

Or select and gather them into an existing

binder via drag and drop or into a new binder

via the context menu. When you're ready, you

can press the Save button to process a loose

scan or a binder into a finished document.

MULTI-PAGE SCANS

Many documents are double-sided or have

multiple pages that need to be collated into

a single document. This requires scanning

into a binder you'll save when you're finished

scanning pages belonging in one finished

document. These steps begin in the same

way as single-page scans.

1. Select the scanner: Choose your scanner

listed in Devices. DEVONthink will connect

with the scanner. If using a flatbed scanner,
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choose Flatbed and remember you'll have to

manually turn over the page to scan the back.

If using a document feeder, check Duplex if

needed.

2. Set the scanning options: There are a small

number of options to choose, many of which

will remain as defaults, e.g., the resolution.

These are described in the Windows >

Sidebar: Image Capture section. However,

for a quick reference, here are a few you may

change per-document:

Name: Enter a specific name for the

resulting document. Otherwise a

timestamp will be used.

Tags: Add any per-document tags, if

needed, e.g., receipt.

OCR: Choose whether to use OCR to

create a searchable document.

3. Select or create a binder: In the To

dropdown, choose Create New Binder or

choose an existing one.

4. Choose the destination: Set where the

final multi-page PDF should be saved.

5. Load and scan: Put your document on

the flatbed or in the document feeder. The

press the Start button in DEVONthink's

scan window. After the page is scanned,

you will see a report section appear in the

scanner window. This displays the name, the

number of scanned pages, the estimated size

of the finished document, and the chosen

destination. Continue scanning the remaining

pages. When done, press the Save button to

process and save the final PDF.

After a binder is processed, the pages

are sent to the scanner's Trash. It's

recommended to periodically empty this

trash with a quick Control-click then Empty

Trash.

QUEUED SCANS

The scanning queue is where you can set up

scan jobs to expedite scanning a group of

separate documents. Each document, e.g.,

a twenty page insurance benefits package,

is a separate job that will produce a single

document. This is used more effectively with

scanners having a document feeder.

1. Select the Queue: Instead of selecting the

scanner in the Devices, select Queue.

2. Select the scanner: In the dropdown at the

bottom of the window, choose your scanner.

3. Select the input type: Choose whether

to use the Flatbed or Document Feeder, if

available.

4. Set the scanning options: Click the 

button and set the Mode, Resolution, Size,

and Duplex if the pages are double-sided.

5. Add a scan job: Click the  button to add

an entry for your first document. Fill out the

parameters for the job.
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Title: If you want the document specifically

named, enter the Title. Otherwise, a

timestamp will be used as a default name.

Destination: Choose the location in which

to save the finished document, e.g., the

Inbox of a specific database.

Type: Choose the type. For multi-page

documents, you must use PDF.

Separator: Choose how DEVONthink's

scanner can differentiate one document

from the next. If you choose Blank Page,

insert a blank sheet of paper at the end of

each document in your stack, including one

as the very last page. Otherwise, choose

Page Count and fill out the next parameter.

Pages: If you chose Page Count, enter

the number of scanned pages in the

document. See the note above regarding

the difference between leaves and pages.

OCR: Choose whether to use OCR to

produce a searchable document. This is

enabled by default.

Tags: Optionally, enter any per-document

tags, e.g., health insurance,2025, etc.

6. Load and scan: Now prepare your

documents, remembering to insert blank

pages between each if you chose the Blank

Page separator. Put them in your scanner

then press the Start button in DEVONthink's

scanning window. Each job will be scanned

one after the other until all are finished. Note

the queue may pause if there are jobs to

process but nothing in the document feeder.

Add more documents to it and press Start

again.

Finished jobs will show in the queue. Press

the dropdown next to the minus button and

remove sent (processed) jobs or all of them.

GOING PAPERLESS (OTHER
OPTIONS)

If you don't have an ICA-compatible scanner,

you likely can still get your scans into

DEVONthink. And if you already have a

collection of images you want to put in your

databases, there are options to process

those images as well.

SCANSNAP SCANNERS

A veteran in the scanning industry and

considered solid and reliable, ScanSnap

scanners are a good choice. They can't be

directly controlled by us but with a proper

scanning profile in the ScanSnap software,

DEVONthink can receive and process those

scans. Here's how to properly set up a profile

in the ScanSnap Home (SSH) software:

1. Install the software: Download the SSH

application from the link above and install it.

2. Set up a scanning profile: In the SSH

application, create a scan profile following

these proven steps:

Select ScanSnap Home > Scan Settings.

Select Profile > Add new profile and select

the ScanSnap Home profile.

Change the profile name to Scan to

DEVONthink. In the Managing options, set

the Type to Mac (Scan to file). Leave the

Save to field as-is.

You need to establish a connection

between SSH and DEVONthink. Click

the dropdown menu for Application >

Send to and choose Add or Remove. Press

Add. Click , locate DEVONthink, and add

it as a destination. Enter a name, e.g.,
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DEVONthink. Leave the other options as-is

and press . Then select DEVONthink

Now that these parameters are all set up,

press the Add button to save the profile.

3. Load and Scan: Choose your new profile

to scan to. Put a document into the scanner

and scan it normally. The files will be

sent to DEVONthink, either to the Global

Inbox or a location you choose, depending

on what you've set in Settings > Files >

Import > Destination. Just make sure this

is the chosen profile to send scans to your

database.

ScanSnap Home also has OCR built-in. If

you prefer to use it, click the File format >

Option button in your scanning profile and

enable Convert to Searchable PDF. Then

set DEVONthink's OCR > Convert Incoming

Scans settings to No action. Otherwise, use

DEVONthink's OCR. You should not enable

OCR in both applications.

USING AN UNSUPPORTED SCANNER

If you have a scanner with only a TWAIN

driver, you may still be able to use it with

DEVONthink. Open the settings of the

scanner's application's and look for a Open

With or Send To option that allows you to

open or send the finished scan to another

application. Set DEVONthink as the receiving

application. If you're not running the Pro

or Server editions of DEVONthink and the

scanning application has OCR capabilities,

enable it and set DEVONthink's OCR >

Convert Incoming Scans settings to No

action.

Load a document into the device and scan it

as you normally would. The document should

be sent to DEVONthink.

If the scanning application isn't OCR-capable,

DEVONthink knows the identifiers of many

scan applications and will convert the

incoming scan to a searchable PDF if possible.

If DEVONthink does not recognize your scan

application, please create a Zip archive of

the application and send it to us so that we

can add its identifier to a future release of

DEVONthink.

Note: In the settings for the scanning

application you're using, it is best to leave

the default location for the output path,

often ~/Pictures. Do not set the path to

DEVONthink's Global Inbox, as this can lead

to errors when DEVONthink tries to import

a scan that is not completed yet.

IMPORTING WITH OCR

If you already have an archive of scanned

documents without OCR, you can import

them while applying OCR.

To import an document while applying OCR,

choose File > Import > Image with OCR. Click

the Options button to choose the output

format and whether to send the original to

the system trash after importing. The image

will be processed with DEVONthink's OCR

engine and be imported to the database

in the chosen format. If you have enabled

Searchable PDF: Set metadata after text

recognition in the OCR settings, DEVONthink

will show a metadata entry window when the

OCR process is completed (before the file is

actually imported to the database).
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The date of the created document is set to

the date of the original file. Thus, for archival

purposes, the searchable document is

identical to the original one. The modification

date is set to the current date and time to

reflect the addition of the searchable text

layer. If you're importing a PDF, any keywords

in the original file are retained and used as

tags.

AI ASSISTED TRANSCRIPTION

AI provides a power function for processing

incoming images: Image Recognition. Using

Apple's built-in Vision framework or a vision-

capable AI engine, images can be examined

and converted into text. That text can

be stored in the database's index, as an

annotation file, or a Finder Comment on the

document. While not a replacement for OCR,

the recognized text is immediately for various

purposes.

Transcribing images can be done manually

via the Recognize > Transcribe Text & Notes

command in the Data and context menus. If

you'd like to have this happen on every image

you import, enable Transcribe Text & Notes in

images in the Files > Import settings.

If you'd like to exert more control over

transcribing images, don't enable the setting

and instead implement a smart rule targeting

a specific database or group and using the On

Import event trigger.

HANDLING EMAIL

Email is an important item in many

situations, both professional and personal.

Imported email messages are saved in their

original, uneditable file format (.eml) and

are displayed using QuickLook or as an text

alternative view. Some metadata, e.g., the

"read" and "flagged" status of email messages

will be preserved, when possible. Take some

time to review the Files > Emails settings as

well as a breakdown of the interface in the

Sidebar: Email section of this document.

To address the need to store and search for

emails, and to work around limitations of

some email clients, DEVONthink supports

several methods of importing emails. Let's

look at the options…

IMPORT TO DEVONTHINK

Importing emails from Apple Mail or

Microsoft Outlook can be done directly in

DEVONthink.
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1. Open the Import sidebar: Open the View >

Import sidebar.

2. Select the email application: Open the

appropriate email client, Apple Mail or

Microsoft Outlook in the Emails section on

the left.

3. Choose a mailbox: Select the desired

mailbox. DEVONthink will communicate with

the email application and begin building a list

of available emails in the mailbox. Building

this list takes more time with larger numbers

of unimported emails.

4. Choose where to import: Choose or verify

the target database in the Destination

dropdown.

5. Archive the mailbox or import emails:

Press the Archive button to archive the entire

mailbox or select some emails and press the

Import button. Repeat with other emails or

mailboxes, as needed.

When you need to import emails while in

DEVONthink, return to this sidebar and

import or archive again. Also, don't forget the

suite of controls on the right hand side are

available to filter down to specific emails, e.g.,

from a particular person.

Import or Archive: When it comes to

archiving email, the question arises: "Do I use

import or archive?" Here's the simple way to

understand it:

Import Email: While Import can be used on

a mailbox, it is generally used on selected,

individual emails. This is especially useful

when using a filtered view, e.g., filtering

by a date range or recipient. You'd select

those files and use the Import option.

Imported emails are stored in the location

selected in the Destination dropdown.

Archive Mailbox: As the name implies, this

command can only be used on selected

mailboxes. The mailbox will be imported

into a special Emails group at the root of

the database. DEVONthink will attempt

to preserve the mailbox structure shown

in the email application. This is very useful

for archiving a mailbox and keeping it

up to date. Since previously imported

emails are excluded from the mailbox view,

subsequent visits to the Import sidebar

will only show newly received emails. Using

the Archive Mailbox option will import only

those new emails into the existing Emails

group in the database.

Import Via Hotkey: If you find yourself more

actively working in Apple Mail or Outlook, you

can archive a mailbox or selected emails with

a hotkey. Set your desired key combinations

in DEVONthink's Files > Emails settings. For

longtime users of DEVONthink, you can set

the familiar hotkeys previously used with our

mail plugin: ⌥⌘M for messages; ⌥⇧⌘M for

mailboxes. Go to the email client, select a

few emails, then press your hotkeys. They will

be imported based on your preferred import

destination set inFiles > Import > Destination.

Note: Due to changes made by Microsoft,

the Legacy interface is required for these

commands to work. If you switch from the

New Outlook to Legacy, please make sure

to click the  button to let them know it's

important for them to continue supporting

inter-application communication on Macs.
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OTHER OPTIONS

Here are some alternate ways for you to get

emails into DEVONthink. But bear in mind,

the possibilities depend on the what your

email application supports, e.g., scripting.

Drag and drop: Drag to the Finder then into

DEVONthink, into the Sorter, into the Global

Inbox, or directly into a database.

Importing UNIX Mailboxes: UNIX mailboxes

(.mbox files) exported from some email

applications, e.g., Thunderbird, can be

imported into your database. There is no

mailbox structure in these exported files so

multiple mailboxes have to be exported and

imported separately. They can be imported

into DEVONthink in one of two ways:

File > Import: Use File > Import > UNIX

Mailboxes, then select the .mbox file in

the Open dialog and press Open. This will

import the messages into a group in the

current location.

Drag and Drop: Drag and drop the .mbox

file onto DEVONthink's dock icon to import

the messages into your database.

Mail Scripts: In scriptable email applications,

e.g., Apple Mail, you can run application

scripts from the global Scripts menu. There

are a few provided for Apple Mail and Outlook

but you are free to add your own if you have

another email application that supports

scripting.

Mail Rule Scripts: Apple Mail rules support

running AppleScripts in their mail rules. We

have provided a few for you to use or modify.

COPIES AND CONVERSATIONS

Importing copies of emails: Briefly discussed

in the Appendix, a UUID is a value given to

each item in DEVONthink. It is unique to

each item and more than one item can't have

the same UUID. When email messages are

imported, they are given such an identifier

based on metadata from the actual email.

This means you can't import the same

message into a database more than once,

as that would result in more than one file

having the same UUID. When you try, the Log

window will show an error about "n emails

already imported".

All that being said, it's not unusual to store

an email in the more than one mailbox. But

an import of your mailboxes may appear to

be missing some emails as the copies won't

import separately. To allow for this, enable

Previously imported will become replicants

in the Files > Emails settings and the copies

will be imported into the same database as

replicants.

Conversation threading: Depending on the

settings in Files > Emails > Conversations,

DEVONthink can attempt to import complete

conversations and optionally group them.

But be aware, email threading is not an exact

process. A lack of standards and decades

of legacy emails can inhibit the ability to

fully detect a conversation. DEVONthink will

attempt to thread the conversations, but

cannot guarantee all related emails will be

detected.
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REPLYING AND SENDING

To reply to an archived email message in

DEVONthink, select it and choose Data >

Send Reply or Control-click it and choose the

command from the context menu. A draft

message will be composed in your default

email application.

If you need to email a document to someone,

select it, then choose Send by Email or

Control-click it and choose the command

from the context menu. This should create a

draft email in your default email application

with the document attached. Alternatively,

many macOS applications support dropping

files on their dock icon. For an email app, this

usually creates a draft with the dropped file

attached.

Note: The inter-application communication

capabilities of the email client you are using

determine how well these two commands

work. If the commands aren't producing

the expected results, check with the

developer about what kind of interactions

they allow between applications.

You can read a bit more about emails in

DEVONthink in the Documents > Office

Documents, Email, and Others > Email

section. And if you're having issues archiving

emails, please see the Troubleshooting >

Email Import Issues section for assistance.

EXTENSIONS AND
BOOKMARKLETS

DEVONthink provides a macOS sharing

extension, a web browser extension, as well

as bookmarklets, for conveniently clipping

information from other applications into your

DEVONthink database.

BROWSER EXTENSIONS

Browser extensions add functionality to your

favorite web browser. DEVONthink's Clip to

DEVONthink extension usually appears as a

 nautilus icon in the web browser's toolbar.

When clicked, the Clip to DEVONthink will

identify data about the current page in the

browser and open the Web Clip section of

the Sorter so you can quickly store references

to web pages in your databases

Installing: Clip to DEVONthink is a native

Safari extension but due to security changes

made by Apple, you may need to enable it in

Safari's Settings > Extensions. The extensions

for Firefox and Chrome can be installed

from our Extras download page. You can also

access these pages via the DEVONthink >

Install Add-Ons panel. Note there is no direct

support for other browsers though some

allow you to install Chrome extensions. This

may allow you to install our extension in those

browsers as well.

Another thing to consider is the security

settings of browsers. When you clip content,

you may see messages about allowing

our extension to work on site A, then on

site B, then site C, etc. You may also see

multiple prompts asking to allow using our

URL scheme. Those are messages from the

browser, not our extension. These things can
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change over time, usually becoming more and

more restrictive. Check with their developers

about supporting URL schemes.

BOOKMARKLETS

Similar in function to a browser extension,

but much simpler, bookmarklets are special

bookmarks that execute a line of JavaScript

to capture the current page or selection in

the browser. To use one of the bookmarklets,

load the page you wish to archive or clip

text from in your web browser. When the

page is fully shown, select the bookmarklet

in your bookmarks bar. Instead of loading

another page as normal bookmarks do, the

bookmarklet adds the selected text or the

whole page as text, bookmark, HTML code,

web archive, or PDF to DEVONthink's default

destination.

Installing: Bookmarklets can be installed

from our Extras download page. Typically,

the bookmarklet can just be dragged and

dropped to the browser's bookmarks toolbar.

However, you may need to Control-click

the bookmarklet and copy the code to

add it manually, if the browser requires it.

We have provided separate bookmarklets,

one for each type, currently supporting

capturing: bookmark, web archive, HTML,

PDF (paginated or single page), plain text, or

the selection as plain text.

Note: Due to increased security in macOS,

Apple Safari will prompt you to allow

launching DEVONthink when using the

browser extension or bookmarklets. Other

browsers allow you to make a persistent

choice about this behavior.

PDF SERVICES

Another way to get files into DEVONthink is

using PDF services. Installing DEVONthink's

service adds a Save PDF to DEVONthink

option to the PDF button of the print dialog

in any Mac application. This allows you

to print a paginated PDF directly to your

database.

To install the PDF service, select DEVONthink

> Install Add-ons and check PDF Services in

the dialog window. Then click Install and the

option should now be available.

Printing to your database: To "print" (save) a

document to DEVONthink as a PDF, open it

in its creator application (this could even be

DEVONthink itself). Then, do the following:

Select File > Print.

In the appearing print dialog window, click

the PDF button at the lower left corner

and select Save PDF to DEVONthink from

the menu. A PDF will be printed and sent

to DEVONthink. Depending on your choice

for the Files > Import > Destination setting,

files import into the Global Inbox or lets

you choose the destination group.

OTHER SOURCES

Beyond manually adding or creating

documents, there are a variety of other

contributors available in DEVONthink.

THE SHARE MENU

The macOS Share menu lets applications

"share" data with other applications, Airdrop,

etc. When you access the Share menu in

a compatible application, you should see
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an option, Add to DEVONthink that allows

you to send data from the application to

DEVONthink.

Installing: Depending on what version of

macOS you're running, you may need to

manually enable our sharing extension. Open

System Settings > Extensions > Sharing

and enable DEVONthink. It should now be

available in any sharing-enabled application's

Share menu.

Note: The data being sent is controlled by

the sending application, not DEVONthink.

If there are issues with the data received

in your database, please contact the

developer of the application to report your

findings.

THIRD-PARTY APPLICATIONS

Another source of new documents comes

from special considerations for some third-

party applications.

Apple Notes: You can import your Apple

Notes via the Files > Import > Folders

& Attachments from Notes  command.

Imported as editable formatted notes,

DEVONthink will also attempt to preserve

folder structures in Notes. Be aware this

is not a sync with Notes and subsequent

imports will generate duplicates.

Evernote: From Evernote, you can import

exported .enex files. This can be done

via the File > Import > Files and Folders

command or by dropping the file on

DEVONthink's dock icon. The notes are

imported as editable formatted notes.

This also is not a sync with Evernote

and subsequent imports will generate

duplicates.

Bookends: A very popular bibliographic

application is Bookends. Using the File

> Import > References from Bookends

command, you can import Bookends

references as rich text documents with

a back link to the original item. If you run

this command again, existing rich text

documents will be updated instead of

reimported as duplicates.

Tinderbox: Copy notes in Tinderbox and

choose Data > New > With Clipboard to

create plain or rich text copies of the notes

in DEVONthink including backlinks and

tags.

AI

Chat: When using AI, you can also generate

documents. For example, chatting with

certain AI engines like Claude, often

automatically return responses as Markdown

documents. These documents can easily be

identified by the (AI) suffix at the end of

their names. In fact, you can create a smart

group with the criterion Name ends with

(AI) to show all AI-generated documents.

Transcription: If you are using a speech-

to-text AI engine to transcribe audio or

video files, you can generate annotation

files from the output. This often includes

some timestamps from specific points in the

playback.

Images: If you have access to a generative

image AI engine, creating an image can be

done via the Data > New > Generate Image

panel. It's also possible to request an image

during an AI chat and to copy or capture the

image via the context menu.
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TEMPLATES

Another way to create new documents is

via Templates. Accessed in the Data > New

from Template submenus, these are special

files and smart templates that generate

new documents on demand. These can be

simple documents, like a phone note or more

complicated documents, like a journaling

document. Some of them are even AI-

powered.

We also periodically publish additional

templates via the Support Assistant.

AUTOMATION

DEVONthink is well known for it powerful

automation features including the ability to

create documents via scripting. We also make

additional scripts available via the Support

Assistant.

Application Scripts: Application scripts

are those that run via the global Script

menu while in another application. For

example, while in Safari, you could run a

script to generate bookmarks of all the tabs

in the frontmost window. Our offerings are

discussed in the Application Scripts section.

Our Mail rule scripts are another example of

application scripts.

Your scripts: If you are inclined to

automation, or even just learning, you can

write scripts to create documents. See the

AppleScript section for more information on

getting started with scripting.

URL Commands: As discussed in the URL

Commands section, DEVONthink has a

URL scheme that can be used to create

certain kinds of documents. While they're

less powerful and less commonly used, they

are yet another tool available to making new

documents via automation.

Bookmarklets: And just to make note of it,

the bookmarklets discussed earlier in this

chapter are also a type of automation that

generates new documents for you.

DEVONTHINK SERVICES

The DEVONthink > Services menu gives

you access to special commands provided

either by other applications, such as TextEdit

or Safari, or by services extensions such

as DEVONtechnologies' WordService or

CalcService. Also, DEVONthink publishes its

own services in the Services menu.

DEVONthink installs several services for

copying or summarizing selected text,

capturing a web page, or searching for

documents in your databases.

Add to DEVONthink: Adds selected files,

bookmarks, or images to your database.

This service is also available in the Finder's

context menu.

Add to Reading List: Adds a bookmark to a

URL selected in text to the Reading List.

Take Plain/Rich Note/Markdown Note:

Adds selected text to the global inbox

as a plain text, rich text, or Markdown

document from any application that

support services. Taking a rich text or

Markdown note also copies images and

clickable links. If the source document is a

web page or a news feed, DEVONthink tries

to capture the address of the page or feed

as well. This only works with applications

that support this feature, such as Safari,
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DEVONagent Pro, and other Mac-native

web browsers.

Append Plain/Rich Note/Markdown Note:

Adds selected text as plain text, rich text,

or Markdown to the last note taken using

the DEVONthink Services menu items.

Lookup: Opens the search pane in

DEVONthink with the selected text copied

as search term.

Summarize: Creates a new note in

DEVONthink's inbox with a summary of the

selected text using AI.

If you want to assign hotkeys to services,

go to System Settings > Keyboard >

Keyboard Shortcuts > Services. Do note that

application hotkeys can override hotkeys set

here. Try to make sure to specify unused key

combinations in your shortcuts. Also, due to

the way macOS loads menus, you may need

to show the DEVONthink > Services menu

once before the hotkey will become active.

WEB SHARING

DEVONthink allows you to give others on

the local network access to your databases

using a standard web browser on any

operating system (including Windows and

Linux). Perhaps you're running DEVONthink

in a corporate situation and want to

give workers controlled access to some

databases you have. In an educational

setting, classroom resources could be

available to students. Academic or creative

collaborators contribute to a common

database, even if they're not all Mac users.

The embedded web server in the Server

edition provides an interactive web interface

that allows your users to interact with the

shared databases. Here are the steps to

getting started using this powerful feature.

SETTING IT UP

DEVONthink's web server runs on macOS

inside our application. It is not a separate

process. This means you need to install and

run it on a Mac that is on and awake when

people need access to it. Many times this is

a dedicated Mac mini. Regarding databases,

it only makes available databases you have

open, though you can control who has access

to them. Fortunately, getting things up and

running is typically a fairly simple thing.

1. Open your databases: Whatever databases

you need to make available, open them. Don't

imagine you need to open and close certain

ones for certain people. That is managed in

the settings.

2. Set up the server: The Server > General

settings are not complicated, though

administered networks, e.g., corporate/

academic networks, may require IT's
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involvement. However, this is typically a one-

time setup, unless changes are required in the

future.

Two things to consider are setting a specific

Bonjour Name and Bonjour Port. The name

just makes things more easily identifiable to

the end user, though it's not critical if you're

sharing an IP-based URL. We do recommend

specifying a port number. This makes for a

consistent point of access for your users. If

you don't specify one, a random unused port

will be used every time the server launches.

Certificates: Another thing to think about

is the TLS certificate, assuring the server

is legitimate to your end users . Where you

obtain one is up to you but you need to

obtain a file you can import via the Load P12/

PFX file button.

Self-signed: While we don't advocate one

way or the other, there is the possibility of

creating a certificate directly in DEVONthink.

Click the Create self-signed certificate

button then select DEVONthink Server in

the certificate dropdown.

Self-signed certificates will often show

warnings in a browser that a certificate is

unknown or invalid. But you can manually set

the trust level to avoid the warning:

1: Open /Applications/Utilities/

Keychain Access.

2: Click login in the sidebar, then My

Certificates.

3: Search for devonthink to locate our

certificate.

4: Double-click it, open the Trust section,

and set When using this certificate to

Always Trust. Close it, okaying the change

when prompted.

5: With the certificate selected, choose

File > Export Items and save a .p12 file

you could share with an end-user. Note

the .p12 file is typically used on Macs

(non-Windows machines) and the format

exported from Keychain Access.

3. Add users: First decide who needs access

and how granular that access is. For example,

it could be sufficient to have a department

account, e.g., Shipping with a single login

and password. Or you could set up individual

logins, say for the head of Human Resources.

Secondly, you decide what permissions

on what databases these users have. For

example, a student may have read-only

access to a classroom database while the

teacher has all permissions. Additionally, if

no permissions are granted to an individual

for a certain database, it won't be visible in

the web interface. Also, be aware no one will

have permissions to write to, i.e., modify file

contents, in an revision-proof database.

4. Start the server: Once all the users and

their permissions are established, press the

Start button. You can also select the Tools >

Start Server command or choose the Start

Server command in DEVONthink's dock icon.

If the server is running, these will display Stop

instead.

At the bottom of the Settings window you

will see two URLs: one is IP-based, the other

uses the Bonjour name. We don't dictate

which to use and both give the same access.
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5. Invite the users: You will need to share

the URL to any user who needs access. How

you disseminate that is up to you and the

channels of communication you feel are

appropriate. You can click and open the URL

in a browser, Control-click it in the Settings

window and either copy or share it, or you can

drag and drop it into other applications. Also,

you may need to provide a certificate to them

as well.

We recommend the end-user adds the URL as

bookmark in their browser so they can quickly

access it in the future, as needed. This is also

why setting a specific port is a good idea.

Now the users should be able to login with

their provided credentials and use the

databases they have been granted access

to. And during normal operation, the only

steps you as the administrator may need to

do occasionally is stopping and starting the

server to add, remove, or modify users.

Note: We believe in data privacy and

hope you do too. Browsers may present

options to save login credentials. Some

may even save the credentials by default.

We are cautious of the first and not a fan

of the second. If the user is on a shared

computer, consider what access other

users could have if using these options to

save credentials.

COMMON QUESTIONS

How many licenses am I going to need?: This

may be surprising but the answer is: one.

The only license you need is for the Mac

running the Server edition. You don't need to

purchase per-user licenses.

How many people can connect?: The built-

in web server is not designed to become

a user-facing portal on the Internet for

thousands of daily users. It is ideally used on

a local network with the possibility of remote

connections (see below). There is no stated

maximum number of concurrent users.

Is there feature parity with the desktop

app?: The answer is no as it's technologically

infeasible. The web interface is limited by

web technologies in a browser and a browser

is also no match for the heavy-lifting our

desktop app does daily. That being said, it

is very functional for many groups of people

across the world.

USING THE WEB INTERFACE

The interactive web interface imitates the

look-and-feel of DEVONthink in many ways,

but in a condensed form. Contrary to a static

web site, it only loads once; clicking buttons

or links does not reload the whole page but

dynamically updates it. While a simpler

interface than our desktop application, it

provides useful access in many situations.

You can also find descriptions of the controls

in the Web Sharing section of the Windows

chapter.
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Similar to the DEVONthink, the web interface

is divided into panes: sidebar, item list,

and view/edit pane, etc. However, some

operations, e.g., deleting or organizing items,

are logically dependent on the per-user

permissions.

Sidebar: The sidebar is where you can

navigate the databases' inboxes, groups,

tags, and trashes in the sidebar. You can drag

items from the item list to reorganize things.

Control-clicking an item here gives you the

option to make a new group or RSS feed,

delete or rename a group, or empty the Trash.

Item List: Selecting items in the sidebar will

display the contents in the item list. The list

can be sorted by clicking the column headers.

While they can't be reordered, you can enable

or disable them in the context menu of the

headers. If you move your cursor between the

section headers, a separator will appear. Click

and drag it to resize the columns.

Double-click groups to display their contents

in the item list. For quick navigation, press

the < arrow to go back to previously visited

locations. Click to select items or hold the

⌘ Command key to select multiple items. This

applies to contiguous and non-contiguous

selections. Selected items can be dragged

and dropped, e.g., into groups in the item

list or in the sidebar. You can also access

commands in the context menu when you

Control-click in the item list. This is a quick

way to add a new file.

View/Edit pane: Displayed below the item

list, this pane will display the contents of

compatible files. Due to the limitations of

browser technologies, some file types can't

be displayed. Clicking and dragging the

divider bar allows you to resize the pane. A

select number of file types, e.g., plain text,

formatted notes, and Markdown files can be

viewed and edited in this pane.

Search: Searching the viewable databases

can be done in the search field. Enter search

terms, including using search prefixes to

focus the searches. For example, you can do a

search for text:housing tags:government.

You can filter where you're searching by

selecting a different scope in the location

dropdown, e.g., All Databases or a specific

database to search in.

Toolbar: In addition to the search field,

the toolbar has a few other options. The

new document menu lets you create a new

native document or upload one from the

Finder. Quickly move a selected item to the

database's Trash with its own button. The

Action menu lets you do a few things: copy

the item link or URL of a selected item, open

the Generic info inspector with Get Info,

download the document to your device, or

move it to the Trash. The User menu allows

you to switch between English and German

language, from light to dark mode, and also

provides a Log Out option. Lastly, click the

Info button to open the inspectors.

Info Inspectors: The Generic inspector on

the right displays basic metadata about

the selected item, with certain attributes

being editable, e.g, Tags or Label. The Data

inspector lets you view and edit custom

metadata applied to the selected document.

See Also: The next view is the See Also

inspector, displaying potentially related files

in the current database you are viewing.

Clicking on a match displays it in the view/
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edit pane. Note the original document is

always the top match, so you can return to

the original document by clicking it at the top

of the inspector.

ACCESSING YOUR DATA OVER THE

INTERNET

Web sharing is best used on a local area

network (LAN). But there may be situations

where you want to share the database to

users that aren't on your network. While we

can't provide specific support due to the

differences in equipment and environments,

we have provided a simple guide that may

prove useful.

To access your database from outside

your network, you need to make your Mac

"visible" to the outside world. In general,

your computer is connected to the Internet

through a router. Routers create an intranet

that your Mac is connected to and "route"

traffic between the internet and your

personal intranet. Now, you need to create

a route from the outside leading to the Mac

sharing your database. This offers a port on

the outside that is directly connected to the

port on which DEVONthink is publishing.

If everything goes well, you will be able to

access your database using an address like:

http://xxx.xxx.xxx.xxx:port, where

xxx.xxx.xxx.xxx is your current public IP

address. (Note: This is your router's address

on the internet, not your Mac's.) Next, port

is the outside port number leading to your

published database.

Port forwarding done manually: The following

is only a rough outline of the steps needed

to configure port forwarding manually. The

precise way to do it varies from router to

router. You will need to consult the manual for

your router in order to determine exactly how

to set things up. To configure port forwarding,

follow these steps:

Step 1: Begin by determining your Mac's

public IP address. This can be done

by visiting a web site like https://

www.whatismyip.com from your machine.

Step 2: Determine the port on which

DEVONthink published on your Mac. You

set the port in Settings > Server. To publish

on the internet, enter a port number

here and do not let DEVONthink set it

automatically as the port number may

then change every time you open the

application.

Step 3: Determine your Mac's private

IP address. The IP address is usually of

the form 10.x.y.z, 192.168.y.z or

172.16.y.z. You can find your Mac's

private IP address by going to the Network

preferences panel in System Preferences

and looking it up under TCP/IP for the

interface you are using (usually Built-In

Ethernet or Wi-Fi).

Step 4: Decide on a public port for

DEVONthink. The port should be in the

range 1025-65500. We suggest that you

use port 8080, which is traditionally a

default port for private web servers.

Step 5: Configure port forwarding on

your router. The steps to do this vary

from router to router, but all of them

require you to provide these details: Public

port, private destination IP, and private

destination port. You found the private

destination port in step 2, and the private

destination IP in step 3, and you selected
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the public port in step 4. If you are in doubt

about how you configure your router to

do port forwarding, you need to consult

the manual that came with your router.

It is usually done through a web-based

interface or custom-built administration

application.

Step 6: Save the configuration changes

on your router, and restart the router if

required. At this point, you are ready to

connect to your DEVONthink from the

outside.

Step 7: From the remote computer, open

a web browser and enter the address as

follows: http://xxx.xxx.xxx.xxx:port,

where xxx.xxx.xxx.xxx is the public IP

address you found in step 1, and port the

public port you selected in step 4. Press

↩ Return and you should get presented

with your database's web interface.

Setting up port forwarding can be tricky, but

the difficult part is mainly in determining

how to configure your particular router. If you

are in doubt, search online for your router's

name and combine it with a search for "port

forwarding" or "port mapping."

EXPORTS

The first part of this chapter focused on

getting your documents into your databases.

Here are some of the export options for

getting your documents (and groups) out.

DRAG & DROP

The simplest, and most macOS-native

way, to export items is via drag and drop.

This is something you do in the Finder

all the time and there's no need to vary

your behavior with the documents in your

databases. Groups export as Finder folders

and include their contents. When dragging

out documents, there is no conversion of the

dropped file just as there is no conversion

when importing them. The only change to the

file is the inclusion of Finder tags or custom

metadata.

One of the common misunderstandings

about using your documents with third-party

applications is that they are "locked away"

in your database. This causes people to try

and get into the internals of the database to

use them. You should not do this and there is

absolutely no need to. With few exceptions,

you can drag and drop a document from

your database into another application. This

includes dropping into a Save panel, e.g.,

when uploading to a website using a Choose

File button.

Remember, the receiving application controls

whether they accept dropped data and how

it is handled. If you do run into an issue, you

can try dragging and dropping to the Finder

first, but this should be a rare exception.

EXPORT COMMANDS

In the Files > Export submenu, there are a

variety of commands for exporting data. A

range of options are available, including some

commands to export an aggregate file from

a selection of documents. For example, if

you have multiple rich text files selected, you

can export to a single document from this

menu. This is in contrast to using the Data >

Convert command, which produces one PDF

per document.
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Beyond drag and drop, you can use the File

> Export > Files and Folders command on a

selection of items in your database. When

you use this command, it's a good idea to

export to a newly created folder to keep the

exported items separate from unrelated files.

You may see a DEVONthink export produces

a support file, a DEVONtech_Storage file,

used for future reimporting. If you're not

reimporting, these files can be removed.

If you are serious about backups (and we

hope you are!), the Export > Database

Archive command creates an optimized

and compressed ZIP archive of a selected

database, perfect for a secondary backup.

The ZIP can be safely archived to an external

disk or even a cloud service. Note this is a

full backup, so it takes longer to backup and

requires more disk space as your database

grows.

AUTOMATION

For those that like to script, there is a

specific export record command. Just

provide a record, including a selection,

and specify where to export with the to

parameter. If used with a group, the group

and its contents will be exported to the

specified location. This command also

produces the storage file mentioned above,

but you can disable exporting this file with a

without DEVONtech_Storage parameter.

Now finally, let's discuss syncing…

SYNC EXPLAINED

In this section, we will clarify what sync is

(and isn't) and how to make an informed

choice about the method you choose. In the

subsequent pages we will discuss technical

considerations and the basic setup of each

type. But let us clarify: this section isn't long

because sync is complicated. It's long due to

the variety of options available.

SYNC SIMPLIFIED

Sync is an incredibly simple and logical

concept. You have a database on Mac A. You

want that database on Mac B. On Mac A,

you upload the database to a sync location

accessible to both machines. On Mac B, you

access the same sync location and import

the database. Now both Macs have a local

copy of a database. When anything changes

on either Mac, they are transmitted to

each other via the sync location. The only

variation is if Mac B already has a copy of

the database, it will be able to merge with

the sync data in the sync location. That's it:

simple.

And every sync is conceptually the same,

following the same essential pattern shown

here:

Enable a location (with or without an

encryption key) on Mac A.

Upload a database to the sync location.

Enable the same location in DEVONthink

on Mac B, making sure to use the same

encryption key, if specified.

Import the database or merge with the

existing sync data.
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So you're essentially only using steps 2 and

4 when you want to sync new or unsynced

databases, something that likely won't

happen often. In fact, the only practical

difference is, a Bonjour sync transmits

directly between the devices so you wouldn't

use step 2.

INDEXING AND SYNC

Often people index content from the local

repository of a cloud service like Dropbox.

The question then arises: "If I have my data

on Dropbox' servers and I sync to Dropbox

via DEVONthink, aren't I just using twice

the space?" The answer is practically, yes.

In the Show Info for a sync location in the

Sync settings there is an option Synchronize

contents of indexed items. Unchecking this

will sync only the metadata for the files,

not the contents. However, you should only

disable this option if:

You are syncing another Mac, linked to

your Dropbox account, and having the

local Dropbox folder in the same relative

location. The default location is ~/Dropbox.

If the locations are different, the files will

appear as missing on the second Mac.

You are not syncing with our mobile

application, DEVONthink To Go. Note it

does not support indexed items. Also,

if you are using the Download Files: On

demand option in DEVONthink To Go, you

could never download the contents since

the contents are not present in the sync

location.

For the most flexibility, it is advisable to

ensure you have enough storage space for

syncing.

CHOOSING A SYNC METHOD

Choosing a sync method requires assessing

your needs while being aware of technical

considerations. Regarding syncing, the first

question you need to ask yourself is, "Do I

need a remote sync option?". Consider these

questions…

Do you need to sync between machines —

especially desktop Macs that aren't easily

relocated, unlike laptops — in different

geographic locations?

Do you have a colleague, assistant,

significant other, etc. that needs frequent

updates to synced data?

Are you using a shallow sync, i.e., Download

Files: On demand in DEVONthink To Go?

If the answer is no to these questions, a local

sync on your network is suggested.

For the optimal experience, you should use

a remote sync option when you need to.

Just having a Dropbox, iCloud, etc. account

does not make it an optimal solution for

all situations. This doesn’t mean you can’t

successfully use a remote solution. It just

means there are some stumbling blocks

that can occur when using them, blocks

caused by the conditions mentioned below

that can inhibit proper syncing. If you do

need a remote sync option or just want to

pursue that avenue for syncing, you need to

understand and accept the potential pitfalls

involved:

Network conditions - local and remote

Remote server reachability and response

times

DEVONthink 4.3.2 Documentation, page 108



Maximum concurrent connection

limitations imposed by the service

Bandwidth throttling measures employed

by cloud services

That all being said, here are the sync methods

available in DEVONthink:

Bonjour: Bonjour is a direct connection sync

between two Macs that are on the same

local network. It is fast, private, and generally

reliable with no intermediary sync location.

It requires devices to be on and our app

running

It only works on LANs permitting

Bonjour or non-standard port traffic and

does not work over VPN. Firewalls and

networking apps must allow exceptions for

DEVONthink's traffic.

Local Sync Store: A local sync store syncs to

a specialized folder residing on a commonly

accessible location, like a drive on your

network. It can also be stored on a connected

external drive or thumb drive. It is generally

very fast and very private.

It can be located on an external drive or a

shared resource, like an NAS. And it doesn't

require other Macs to be up and running.

Only for Mac-to-Mac syncing. It also

requires access to the volume or machine

where the sync store is located.

Dropbox: A Dropbox sync transmits and

stores sync data directly on Dropbox' servers.

Generally reliable and doesn't unnecessarily

use local disk space and bandwidth when

set up properly.

As a remote location, you could experience

slow/unresponsive servers, limited

maximum connections, and bandwidth

throttling.Questions of privacy can be

offset by using an encryption key.

iCloud: There are actually two iCloud syncs: a

iCloud (Legacy) sync and a CloudKit (iCloud)

sync. Both transmit and store sync data on

Apple's servers.

Easy to setup. CloudKit (iCloud) syncs

directly to Apple's servers.

Like any remote service, the same pitfalls

apply. Some people experience stalls or

temporary outages, but this is not true for

everyone.

WebDAV: A WebDAV sync transmits and

stores sync data on a WebDAV server,

whether locally, e.g., on an NAS or via a

commercial cloud provider.

Offers potentially more sync opportunities.

When hosted locally, provides a fast,

generally reliable, and private sync. This is

especially true on Ethernet.

The reliability of a local setup may vary and

may require more technical expertise to set

up and administer. If accessing WebDAV

remotely, the same remote pitfalls have to

be considered.

Note: If you intend to sync with

DEVONthink To Go on an Apple-mobile

device, a local sync store cannot be used.

COMMON QUESTIONS

There are many questions we get over and

over, so here are some important things to

understand as well as clarifying some of the

terminology.
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What is a sync store? : A sync store is a

special folder on a server or service (the

'sync location') that DEVONthink uses to

store sync data for your syncing databases.

Give it a name made only of alphanumeric

characters. A concatenated name, e.g.,

Research_01 can be used. Note this folder is

only for use by our sync engine.

What is a 'copy of the database'? : One

detail to understand about syncing: Only

true copies of a database will sync together.

Two databases having the same name but

created independently are not the same

database. These databases will never sync

together. This is also why you shouldn't

create a database on the receiving machine,

hoping to "fill it up" with data from the source

database.

If you copy the database (.dtBase2 file)

between machines, that is clearly a true copy

of the database. Also, importing a database

via sync logically yields a true copy of the

database. True copies are databases that

have the same internal identifier (UUID).

What is an encryption key? : Regarding

the privacy of your synced data, all sync

methods allow you to specify an optional

(but recommended) encryption key for a sync

location. The key is an alphanumeric string

of your choice and length. This key is used

to "scramble" or "descramble" the sync data

using AES-256 encryption and the data is

stored in an encrypted state. All databases

synced to a location using an encryption key

will sync encrypted data. Bear in mind, if you

specify a key when syncing, you must use the

same encryption key when setting up the

same sync location on other devices running

DEVONthink or DEVONthink To Go.

If you get a message in the Log window or

popover about an invalid encryption key,

please check out the Sync troubleshooting

section.

Note: Bonjour syncs don't allow you to

explicitly specify a key, but the sync data is

encrypted by default.

What are the Local and Remote sections

for? : As noted above, a database must

be local to the machine so it must either

be open in DEVONthink or imported from

the sync location. For a non-Bonjour sync

location, Local section of the Databases

list displays all local open databases. For a

Bonjour location, the Local section displays

databases that are open both on the local

machine and the Bonjour server machine. In

both cases, the Remote section displays any

databases that aren't open locally or those

that have never been imported to the local

machine. Remember this: You cannot sync

to a remote database. It must be imported

locally, then you work with and sync the local

copy.

Can I use more than one sync method at

the same time? : Indeed this is supported

behavior. For example, you may want to set

up a Bonjour or a local sync store for syncing

on your local network and a remote sync

option for syncing when you're out and about.

However, if you want to sync via two cloud-

synced services, e.g., Dropbox and iCloud,

you should not sync the same databases

via two different methods. Doing so could

cause conditions where one cloud-service's
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sync data would be out of date, causing

conflicts with syncing. Each sync location is

updated independently so changes may not

be received in one location before it syncs.

Additionally, unnecessary duplicates might

be caused, especially if the Conflicts setting

in Sync preferences is set to Duplicate

documents. Lastly, syncing a database to

multiple remote locations may waste space

and bandwidth in some cases.

Should I use one sync store per database? :

This is either a personal choice or a

requirement of your specific situation. A sync

location can be used with one, several, or

all databases. Multiple sync stores can be

employed for different sync situations and/or

different devices, e.g., to synchronize specific

databases via one sync store for personal use

and sync others via a second sync store for

business purposes. In situations where you

need to sync certain databases to certain

individuals, you can use one sync store for

each subset of databases.

And while this shouldn't be the first

consideration, if you'd like to use one sync

store per database or for a subset of them, it

may lessen the time troubleshooting a sync

issue with a particular database.

How quickly will it sync? : DEVONthink's

sync does not run constantly. To balance

performance and reduce unnecessary

network noise, it syncs on an interval. While

the interval can vary by sync method, a good

standard to consider is: sync will initiate

up to 45 seconds after a change is saved

in a database and every 4.5 minutes of idle

time when set to Automatic. You can set a

different interval, noting a longer interval,

e.g., Hourly, can help lessen the resource load.

Another consideration with a remote sync

is the quality of the network and server

responses. If your network is slow or poor

quality or the remote servers are slow, not

responding quickly, or bandwidth is being

throttled, the speed of the sync will be

affected. Syncs on your local network, e.g.,

Bonjour, are much less likely to be affected.

Sync is my backup: If you've spent any time

on our forums, you will have heard this before.

Sync is neither advertised nor advocated as a

backup method. A proper backup:

is application-agnostic, meaning the

files in the backup are accessible in the

filesystem or by other applications. Our

sync data is only usable in DEVONthink and

DEVONthink To Go.

ideally stores files in their native state so

you can easily restore individual items as

needed. Our sync data is not storing your

files. You can't go into a sync location and

find a PDF of your 2020 taxes, nor can

anyone. And when including encryption

on your sync location, there is nothing

recognizable to anyone.

provides access to the past state of files.

Our sync engine continuously updates the

sync data, not preserving any previous

states.

Sync fulfills none of those criteria. For a

discussion on proper backups, see A Word

About Backups in the opening chapter of the

help.
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I'll just put my databases in (name your cloud

service): This is not data-safe and never

has been. The mechanisms used by cloud

services are not compatible with package

files, like our databases. Due to the number

of broken databases we've seen over the

years, DEVONthink will neither sync nor open

databases stored in these locations. We

suggest keeping them in a folder in your home

folder, like ~/Databases.

I want to access my databases from one

location: To clarify, you can't store your

databases in the cloud. They must be stored

locally, whether that's on the internal hard

drive or a connected external drive. As NAS is

possible but you should do this only if you're

on gigabit Ethernet or better.

I want to find my files in the sync location:

Your databases do not "live in the cloud". And

sync does not merely copy your databases

and files into any sync location. It transmits

raw, chunked, and optionally encrypted

DEVONthink-specific data, only useful to

DEVONthink and DEVONthink To Go. You

cannot go into a sync location and retrieve a

specific file, and neither could anyone else,

friend or foe.

SYNC: BONJOUR

Bonjour (also called a direct connection) is

technology you are almost certainly already

acquainted with. If you have a wireless printer

or scanner and notice how your Macs and

mobile devices can see those devices by

name with no setup by you, they are using

Bonjour. Bonjour is a way for devices, or

services like DEVONthink's sync, to broadcast

its presence on a network without requiring

technical know-how by the user.

A Bonjour sync is a direct connection

between devices. One device acts as a server,

the other a client to that server. There is no

intermediary location where data is stored.

This is much faster than uploading all data to

some server on the internet and downloading

it again on another device. It is also much

more private since your data remains in your

control at all times.

TECHNICAL CONSIDERATIONS

A Bonjour sync is simple but these things

need to be considered first:
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The devices must be on the same local

network, noting it will not work over VPN.

You must be on your own network or one

that allows Bonjour traffic or non-standard

ports. Public, corporate, and academic

networks sometimes disallows these.

If you're running a firewall or network

monitoring software like Little Snitch, you

must add exceptions for DEVONthink's

traffic.

The devices, one acting as the Bonjour

server, the other as the Bonjour client,

must be on and running DEVONthink

or DEVONthink To Go, with the sync

databases open.

There must be only one device acting as

the Bonjour server for a set of databases. If

you enable it on one Mac, you should not be

enabling it on another device, neither Mac

or mobile.

Our applications must have local network

access, mandated by Apple. On macOS

Sequoia, you must enable DEVONthink

in System Settings > Privacy & Security

> Local Network. On iOS/iPadOS, enable

DEVONthink in Settings > Privacy &

Security > Local Network.

SETUP

In a typical Bonjour setup, the most active

Mac is the Bonjour server. For the smoothest

process, this is also where you will make new

databases, when needed. Here is how to set

up the server and a client Mac.

Setting up the server Mac:

Step 1: Open DEVONthink's Sync settings

and click the Bonjour Options button.

Step 2: Check Enable Incoming

Connections.

Step 3: If you have a known port to assign,

enter it in the Port field. Otherwise, leave it

empty and an unused one will be assigned

at launch.

Step 4: Enter a mandatory Password, used

to authenticate client devices.

Step 5: Leave DEVONthink running and

awake.

Setting up a client Mac:

Step 1: Open DEVONthink's Sync settings.

In the Locations list, you should see the

server Mac available as a sync location.

Step 2: Enable the checkbox next to the

server Mac and enter the Bonjour password

you specified. If entered incorrectly, you

will be prompted to enter it again. If

entered correctly, the sync location will

become active.

Step 3: Select the sync location. In the

Databases list on the right, you will see

databases that are open on both devices,

e.g., ones you copied over manually. In the

Remote section, you will see databases

that either aren't open or haven't been

imported.

Step 4: If you have a matching Local

database, check the checkbox to merge

with the server Mac's copy. Repeat with

others as needed.

Step 5: If you need to import a remote

database, Control-click it in the Remote

section and choose the appropriate import

DEVONthink 4.3.2 Documentation, page 113



option, ideally saving to the ~/Databases

directory. Repeat this step as needed.

You are now syncing a local copy of the

database between the two Macs, with

changes made on either propagating to the

other.

SYNC: LOCAL SYNC STORE

A local sync store is a specialized folder

containing sync data on your local machine or

connected drives and servers. This is a very

fast, reliable sync, and very private method

for Mac-to-Mac syncing. You can use one sync

store to sync multiple databases or create

more than one, e.g., one for a particular group

of databases.

TECHNICAL CONSIDERATIONS

There are very few technical limitations to

local sync stores. To be used with multiple

Macs, they are ideally located on a file server

or networked volume. It's even possible to

create a sync store on an external drive

that gets ejected and connected to other

Macs, back and forth. For example, if you

have a computer at home and the office or

a vacation home, this would be an incredibly

private way to shuttle databases changes

between locations.

Note: Local sync stores cannot be used

with DEVONthink To Go.

SETUP

Setting up and using a local sync store is a

simple thing to accomplish. It is created on

one Mac then accessed and added on others.

On the first Mac…

Setup a new Local Sync Store:

Step 1: Open Settings > Sync and enable

the Local Sync Store option. If you already

have one created, click the + button and

choose Add Local Sync Store.

Step 2: In the sheet that appears, navigate

to the location you want to save the sync

store. Enter the Sync Store Name, an

optional encryption key, if desired, and set

any options you need. Then press Add.

Step 3: When the location is created,

select it and enable the databases you

want to sync in the Databases list on the

right.

On a second Mac, you have to access the

location of the sync store. You will not be

creating a new one; you will be adding an

existing one.

Setup an existing Local Sync Store:

Step 1: Locate the local sync store

(.dtCloud) file in the Finder.

Step 2: Double-click the sync store or drag

and drop it into the Locations pane in the

Sync preferences.
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Step 3: If an encryption key was used when

the sync store was created, select the it

in the Locations list and press the Info

button. Enter the appropriate encryption

key in both fields, then click away to

dismiss the popup.

Step 4: Select the sync location. In the

Databases list on the right, you will see

databases that are open on both devices,

e.g., ones you copied over manually. In the

Remote section, you will see databases

that either aren't open or haven't been

imported.

Step 5: Enable any Local databases you

want to sync. If you need to import a

remote database, Control-click it in

the Remote section and choose the

appropriate import option, ideally saving

to the ~/Databases directory. Repeat this

step as needed.

SYNC: ICLOUD

As most Apple devices are already logged into

your Apple ID, iCloud is the simplest method

to set up.

TECHNICAL CONSIDERATIONS

There are two iCloud sync methods available

in DEVONthink. Both technically behave a bit

differently in terms of how the sync data is

handled, but the both use the same setup

steps.

iCloud (Legacy): With Legacy syncing, initially

the sync is done locally. After sync is finished,

iCloud uploads to Apple's servers, then to

devices using your Apple ID. This means

databases may not be immediately available

to sync on the other devices. The initial

sync requires patience, as DEVONthink has

no control over the speed and reliability of

iCloud's process.

CloudKit (iCloud): Connecting to the same

active iCloud account, the CloudKit option

offers a single-stage sync interacting directly

with Apple's servers. This can appear to

be a bit slower than the legacy option, but

once the sync is finished the files are already

uploaded without having to wait for iCloud

to sync on its own. This also conserves space

as no sync data is temporarily stored on the

local machine's hard drive.

Note, while the iCloud methods have worked

well for many people, there have also been

many reports of issues. This is not only

specific to our applications but other

applications as well.

SETUP

Setting up the iCloud sync is the simplest

method of all, as you merely enable it and

the databases you want to sync. However,

whatever option you choose you must use

the same method on the other devices,
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e.g., you can't set up a Legacy sync on

one machine and expect it to sync with a

CloudKit sync location on another. On the

first Mac…

Setup a new iCloud sync:

Step 1: Open the Sync settings and enable

either the iCloud (Legacy) or CloudKit

(iCloud) option.

Step 2: Enter an optional encryption key

and choose the options you want to use.

Then click outside the popup to dismiss it.

Step 3: Select the sync location and enable

the databases you want to sync in the

Databases list on the right. If you already

synced from another machine, double-click

a database in the Remote section, saving it

to a safe location, e.g., ~/Databases.

On a second Mac, the setup is essentially the

same but you must make sure to choose the

same sync method.

Setup an existing iCloud sync:

Step 1: Open the Sync settings and enable

the iCloud sync option you initially used,

either iCloud (Legacy) or CloudKit (iCloud).

Step 2: In the sync info popup, if you used

an encryption key when you first set up the

location, enter it in both fields. Otherwise,

leave them empty. Then click outside the

popup to dismiss it.

Step 3: Select the sync location. In the

Databases list on the right, you will see

databases that are open on both devices,

e.g., ones you copied over manually. In the

Remote section, you will see databases

that either aren't open or haven't been

imported.

Step 4: Enable any Local databases you

want to sync. If you need to import a

remote database, Control-click it in

the Remote section and choose the

appropriate import option, ideally saving

to the ~/Databases directory. Repeat this

step as needed.

SYNC: DROPBOX

Dropbox was the first supported cloud

service and over time, has been a reliable

performer for many of our customers. While

there are a few technical details you need to

be aware of, it's easy enough to set up and

sync.
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TECHNICAL CONSIDERATIONS

Authentication: Since the Dropbox sync

connects and syncs directly with the Dropbox

servers, you are required to authenticate the

connection. When you first enable a Dropbox

sync location in DEVONthink your default

web browser will open asking if DEVONthink

can access the DEVONthink Packet Sync

folder. This will need to be done on other

devices the first time you set up a Dropbox

sync location. Once the authentication

is allowed, you subsequently can add and

remove other Dropbox sync locations in

DEVONthink.

API Restrictions: There are a few things

Dropbox' API doesn't allow DEVONthink to

do:

You can't sync between Dropbox accounts,

e.g., between yours and a colleague's

account.

You can't connect DEVONthink to more

than one Dropbox account at a time.

You can't share the contents of the Apps

folder in your Dropbox account, where

DEVONthink stores your sync data.

Exclude Local Sync Data: Also, DEVONthink

works directly with Dropbox' servers. It does

not sync to the local Dropbox folders on your

Mac. In fact, you don't even need the Dropbox

application installed to sync DEVONthink

with it.

In order to not waste bandwidth and disk

space, you need to explicitly change a setting

in the Dropbox application's settings.

Step 1: Click the Dropbox icon in the

menubar at the top of your screen,

then click the account icon and choose

Preferences.

Step 2: Select the Sync tab and click the

Choose folders to sync button.

Step 3: Select the Apps folder, and uncheck

the DEVONthink Packet Sync folder.

Step 4: Click the Update button and okay

the removal of the local data.

SETUP

Setting up and using a Dropbox sync is simple

but requires specifying or choosing a sync

store in the setup. On the first Mac…

Setup a new Dropbox sync:

Step 1: Open Settings > Sync and enable

the Dropbox option. As noted above, you

will be required to authenticate access the

first time you set up a Dropbox sync.

Step 2: In the sync setup sheet, enter the

Sync Store Name, an optional encryption
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key, and set any options you need. Then

press OK.

Step 3: When the location is created,

select it and enable the databases you

want to sync in the Databases list on the

right.

On a second Mac, the setup is almost the

same and you will need to authenticate

access to Dropbox once. Make sure you are

logged into the same Dropbox account.

Remember: you will be adding an existing

sync location, not creating a new one.

Setup an existing Dropbox sync:

Step 1: Open Settings > Sync and enable

the Dropbox option.

Step 2: In the sync setup sheet, click the

Sync Store Name dropdown and choose

the existing sync store. If you used an

encryption key when you set it up, enter it

in both fields, otherwise leave them empty.

Set any options you need then press OK.

Step 3: Select the sync location. In the

Databases list on the right, you will see

databases that are open on both devices,

e.g., ones you copied over manually. In the

Remote section, you will see databases

that either aren't open or haven't been

imported.

Step 4: Enable any Local databases you

want to sync. If you need to import a

remote database, Control-click it in

the Remote section and choose the

appropriate import option, ideally saving

to the ~/Databases directory. Repeat this

step as needed.

SYNC: WEBDAV

We often get requests about supporting

other cloud services, e.g., OneDrive. However,

it's no trivial task to add and support

more and more services. To open up sync

opportunities, DEVONthink supports

WebDAV, a well-known file transfer

technology used by many companies,

universities, and individuals across the globe.

Cloud services: If you want to explore the

options, you can find lists of WebDAV

providers online. One we specifically support

is a European cloud service, CloudMe.

Rolling your own: It is also possible to

run a WebDAV server on your own. Some

NAS drives, e.g., Synology, have WebDAV

capabilities and you can run a WebDAV server

by repurposing an older Mac. Even some

more full-featured packages like OwnCloud

or NextCloud can be set up for WebDAV

services. However, these options can provide

more technical challenges in setup and

administration beyond the scope of our

support. Check the manufacturer or service's

support pages for information on setting up a

WebDAV server.
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For some, setting up a WebDAV server may

be too daunting a task but it's possible

to run one directly on your Mac. While we

don't develop or offer support for it, this

application lets you set up a simple WebDAV

server on a Mac: WebDAVNav Server.

Choose a folder for your sync store, set up

credentials, set up security with a certificate,

then start the server. This would be ideal on

an always-on Mac mini, but could be used on

any Mac.

One technical note: When using this

application, you do not need to include the

folder path in the URL of the sync setup.

TECHNICAL CONSIDERATIONS

Remember WebDAV is a server, so

connecting to it is just like connecting to a

website using its web address, its URL. And

similar to websites that require you to log in

with user credentials.

URL: In order to connect to a WebDAV server,

you need to its URL. The appropriate URL is

something you need to get from the cloud

service or manufacturer's documentation. For

a commercial service, the URL likely is simple.

If you're running your own server, it may be

more extended.

Port: When using WebDAV with an NAS,

you will likely need to enter a Port number.

This is typically brand-specific, e.g.,

Synology uses 5006, but can be modified by

you, if needed.

Path: You generally cannot write directly to

the root of the server, but instead need to

use a shared folder. It is best if there are no

spaces or punctuation other than hyphens

or underscores. A name like Home_Sync

or uniSyncData would work well. Most

importantly, the folder name is case-

sensitive, so devonsync is not DEVONsync.

So your URL could look similar to: https://

devoncrew.local:5006/DEVONsync.

Credentials: In order to log into the server,

you will need to enter your Username and

Password.

Remote Access: If you're running your own

WebDAV server, accessing and syncing to

it on your local network is trivial. However,

access it from outside you're network will

require instruction beyond the scope of our

help. Check the documentation for the device

to see how to set it up.

SETUP

Setting up and using a WebDAV sync requires

entering the address of the server, your login

credentials, and specifying or choosing a sync

store. On the first Mac…

Setup a new WebDAV sync:

Step 1: Open Settings > Sync and enable

the WebDAV option.

Step 2: In the sync setup sheet, enter the

URL, Username, Password, and a Sync

Store Name. Add an optional encryption

key and set any options you need. Then

press OK.

Step 3: When the location is created,

select it and enable the databases you

want to sync in the Databases list on the

right.
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On a second Mac, the setup is almost the

same but you'll be choosing an existing sync

store. Remember: you will be adding an

existing sync location, not creating a new

one.

Setup an existing WebDAV sync:

Step 1: Open Settings > Sync and enable

the WebDAV option.

Step 2: In the sync setup sheet, enter the

same URL, your Username and Password.

Click the Sync Store Name dropdown and

choose the existing sync store. If you used

an encryption key when you set it up, enter

it in both fields, otherwise leave them

empty. Set any options you need then

press OK.

Step 3: Select the sync location. In the

Databases list on the right, you will see

databases that are open on both devices,

e.g., ones you copied over manually. In the

Remote section, you will see databases

that either aren't open or haven't been

imported.

Step 4: Enable any Local databases you

want to sync. If you need to import a

remote database, Control-click it in

the Remote section and choose the

appropriate import option, ideally saving

to the ~/Databases directory. Repeat this

step as needed.
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DEVONthink uses a number of windows to

present information. These windows are

used for displaying and manipulating groups

and documents, finding information, editing

metadata, analyzing text, and changing the

properties of your database. This chapter is

focused on the different types of windows

and descriptions of their components. For

more practical uses, please check out the In &

Out chapter.
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MAIN WINDOW

The main window is split into simple sections,

some of which will be familiar from other

applications. In fact, as we introduce the

components of the window you'll see

DEVONthink has many familiar elements in

it. We start off with the fundamental panes

you'll use.

ITEM LIST

When you open a Finder window, you are

presented with a list of files in a certain

location. The view may be icons or a list, etc.

but you are still just viewing the contents of a

folder, hard drive, etc.

DEVONthink is no different in this respect.

When you open a main window, you will see a

list of groups and documents in the current

location. Clicking on or opening other groups

shows their contents. Smart groups, just like

the Finder's smart folders, also display their

contents in an item list. The item list also

supports familiar operations like drag-and-

drop between groups, copy and paste, group

and ungroup, context menu items when you

Control-click, etc., just as you've done in the

Finder.

Views: Again, taking a cue from the Finder,

the item list allows you to display your

documents in some familiar views:

Icon: For the more visually inclined, we

have the  Icon view. This displays the

thumbnails of the documents with just

their name. If you enable View > Show

Details, it will display some additional

metadata about the documents. This

is normally used in a Standard view or

with the View/Edit pane hidden. You can

change the size of the thumbnails with
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the slider in the information bar below

the toolbar. However this will affect the

amount of metadata shown as well if the

details are shown. Double-clicking groups

behaves just as double-clicking a Finder

folder, displaying the contents in the

current or a new window, depending on the

Double-click opens groups in a new window

checkbox in General > Interface settings.

List: Behaving much like Finder's List view,

the  List view shows a list view of the

items with metadata columns. Sort them

by clicking the column headers, switching

between ascending and descending each

time you click. Drag the columns left and

right to reorder them to your liking. Add

and remove columns by Control-clicking

and choosing headers or toggling them in

the View > List Columns submenu.

Columns: The  Columns view functions

in the same way as the Finder, displaying

sibling items in columns. For example,

selecting a group shows its contents in

the next column. If you use View > Show

Details, a column appears to display

metadata and the document's thumbnail.

You can resize the width of columns by

dragging the separator line between them.

Double-clicking the separator expands the

column to the width of the widest title

and holding the ⌥ Option key expands all

columns. To make this easier you can set

macOS' System Settings > Appearance

> Show scroll bars to Always. This view

typically works best with a preview in

Standard layout as the item list's width in

Widescreen usually only shows the current

column.

All these views can be easily changed in the

View > View options, as well as the trio of

icons  on the right-hand side of the

Information bar.

Sort: In addition to sorting the item list by

clicking column headers or using the View

> Sort menu, you can also choose a sort

method in the Sort dropdown menu in the

information bar. The default is sorting by

Name. If you feel there are too many options

available, choose Customize Metadata in the

View > List Columns > Customize Metadata,

the context menu, and this button. A panel

opens listing all the available properties.

Toggle the options you want to be able to

choose as a sort method.

VISUAL CUES

DEVONthink provides some visual cues

applied to items in the item list. These are

also described in the Iconology section of the

Appendix.
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Duplicates and Replicants:

Duplicates: Display their name emboldened

in blue or with the  icon, depending on

your setting in Settings > General > Mark

duplicates and replicants in color.

Replicants: Display their name in red italics

or the  icon, again depending on the

preference setting.

Files with Attributes:

Finder Comment: Displays a small speech

bubble property icon.

Reminder: Displays a small bell property

icon.

Attachment: Displays a paperclip property

icon. Generally seen on email and RTFD

files.

Indexed: Displays a small Finder property

icon.

Labeled: Displays a chosen color on or

near the filename depending on the Label

option chosen in Settings > General >

Appearance.

Files with Links:

Annotation File: Displays an asterisk

property icon as well as an outgoing link

icon.

Incoming Link: Displays a property icon of a

lined square with an arrow pointing inward

from the right.

Outgoing Link: Displays a property icon

of a lined square with an arrow pointing

outward to the right.

Incoming and Outgoing Links: Displays both

the incoming and outgoing link property

icons.

Marked files are ones with item attributes

found in the Data > Mark menu. In List and

Columns views, the property icons will not be

shown unless the Flag option in View > List

Columns is enabled.

Marked Files:

Flagged: Displays a flag property icon.

Locked: Displays a lock property icon.

Unread: Displays a dot property icon and

the name in bold. Groups containing unread

items will also display their names in bold.

Enabled in the View > List Columns menu, the

Flag column shows the state of an item: 

flagged or unflagged, or the  unread status

of items. Clicking in the flag column toggles

the flagged state. If an item is unread, a circle

will appear in this column. If you have a group

containing a mix of flagged and unflagged

items, a dash will appear in this column,

showing an indeterminate state.
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As illustrated above, DEVONthink displays

special property icons to the right of item

names for attributes like Finder Comments,

reminders, etc. A key of the property icons is

in the Iconology section of the appendix.

Context menu: The available context menu

commands depend on the current selection

in the item list. As there are many commands,

they are described separately in the Context

Menu > Item List section of the Appendix.

Note: To maintain visual consistency

and make some functions more broadly

accessible, item lists are used throughout

DEVONthink's interface, so you'll see them

in some other places, e.g., the AI > See Also

inspector.

VIEW/EDIT PANE

When You launch DEVONthink you will see

an empty pane at the bottom of the window

reading Nothing Selected. This is the View/

Edit pane, a core element in the interface you

will likely use very often. This pane is where

you can view documents and edit compatible

formats, e.g., rich text. You can also view the

documents in a selected group if you have

Behavior: Preview group content enabled in

the General > Interface settings. You can can

toggle the pane's position or visibility in the

View > Preview menu or via a toolbar button.

The menu options are:

Layouts:

Widescreen: The View/Edit pane is

displayed to the right of the item list, an

option common in many Mac applications.

Standard: The View/Edit pane is displayed

under the item list. This is a bit more

traditional but very useful on smaller

screens, e.g., MacBooks.

None: Hides the View/Edit pane. Note you

can still select any file and press the space

bar to preview it in a Quick Look pane, as

needed.

As noted above, DEVONthink allows

displaying and editing, and even creating,

some file types. Please refer to the

Documents chapter for more information on

this and other components related to the

View/Edit pane.

TOOLBAR

At the top of most Mac applications you

encounter, including the Finder, you will see

the toolbar. For people who prefer working

with tracking devices, e.g., mice, trackpads,

etc., the toolbar allows you to have quick

access to some functions without having

to go through the menus. DEVONthink also

provides a toolbar in main and document

windows.

The toolbar comes pre-installed with a handy

default set of buttons, including the search

field (see below). It can be customized via

Tools > Customize Toolbar command or

in the context menu of the toolbar. Add,

remove, and reorder these items to suit your

particular needs. On a side note that also

applies to Finder windows, if you want to

quickly reorganize items on the toolbar, hold

the ⌘ Command key and drag the item to its

desired location, or off the toolbar to remove

it.

If you're looking for a little more space for

your toolbar, or even a little less, you can

choose to display the toolbar as Icon and
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Text, Icons Only, or Text Only. If you choose

Icon Only, the current selection's database

and name will not appear. And if you want to

go fully minimal, View > Hide Toolbar hides

the it completely.

You will find a list of the available toolbar

items is available in the Toolbar section of the

appendix.

SIDEBARS

Seen in scores of applications for many

years, a sidebar is a top level organizational

structure, typically found on the left side

of an application window. The Finder or

Apple Mail sidebars are perfect examples

of this. Looking at them, you should

see the immediate similarities with

DEVONthink. However, unlike most other

apps, DEVONthink has multiple sidebars,

each with their own special functions covered

a bit later in this chapter.

INSPECTORS

In some applications, extra information about

files is shown in a pane on the right side of a

window. DEVONthink has several inspectors

providing a wide range of information and

commands, separated into related views. For

example, data about the name, tags, type,

etc. of a selected file are available in the

Generic Info inspector. The various inspectors

are gathered into one pane displayed on the

right side of main and document windows

alike, especially helpful on smaller screens.

The inspectors are individually discussed in

the Inspectors chapter.
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SEARCH PANE

Storing information is a useful thing, but

it's more useful when you can find things

too. DEVONthink offers a strong search

function for finding items in your databases,

all integrated into a main window.

In the toolbar is a search field for entering

your search terms. Type in a word and the

search pane appears showing any matched

items — and yes, it's another item list

supporting the different views and sort

methods discussed above. If the View/Edit

pane is open, it will display selected result.

For contents-based searches, the search

terms will be highlighted in the preview,

whenever possible.

Search options: In the search field, you will

notice a  magnifying glass icon. Click this

icon to see where to search, list the ten most

recent search queries, one choose among the

following options:

Live while typing: Enable this option to

search while typing or disable it to search

only when you press ↩ Return.

Partial matches while typing: This option

assumes an asterisk wildcard at the end

of the last search term. That term is only

matched as the beginning of a word. For

example, typing "sync" is used as sync*,

matching "synchronize" or "syncing" but not

"resync". Enabling this option also activates

Live while typing so the results dynamically

change as you type. Press the ↩ Return key

to treat the last term as a complete word.

Ignore Diacritics: Ignores special marks on

letters, like umlauts or accents.

Fuzzy Word Comparison: This uses fuzzy-

logic to expand the possible matches

DEVONthink makes, typically misspelled

words. For example, hello and hullo

would be matched.

Related Words: Attempts to match

documents that are contextually related
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to the search terms, as is shown in the

Related Words section of the Concordance

inspector. For example, if you have several

documents about different types of fish

and searched for text:fish the matching

documents would likely also highlight

various species mentioned. Note this

option will not work with Partial matches

while typing and Fuzzy Word Comparison

enabled. Also, smart groups do not support

this option.

There is also a hidden preference,

EnableSearchFieldAutocompletion, to allow

DEVONthink to try to automatically complete

words you're typing. However, this option only

works when the search options Live while

typing and Partial matches while typing are

disabled.

Search prefixes: Anything you type into

the search field will be treated as searching

in all possible attributes. However, if you

want to focus on specific attributes, e.g.,

file types or tags, the search field supports

prefix operator searches, similar to Spotlight.

Common examples are searches like

name:DEVON or tags:tech;sync, separating

multi-valued attributes like tags with a

semicolon. There are a wide variety of

prefixes available, as well as different prefix

operators. A complete list of these items is

included in the Search Prefixes section of the

appendix.

In addition to search prefixes, DEVONthink

supports Boolean operators, parenthesis for

grouping terms, and quotes to match specific

terms. Read more about operators and how

to use them in the Search Operators section

of the appendix.

Search scopes: After you've done a search,

you will also see a bar above the search

results allowing you to choose the scope of

the search. The scope specifies "where" you're

searching. You will be shown All Databases,

Inboxes, the name of the current database,

and the name of the current group, if you're

currently viewing one. Choose one to expand

or limit where DEVONthink is searching. For

quickly switching scopes with a keyboard,

hold the ⌥⌃ Control keys and press 1 through

4 while a search is active. If you are searching

in a particular location and want to ignore

possible matches in the subgroups, enable

the Exclude Subgroups checkbox, as needed.

Advanced searching: To the right of the

search scopes, click the  button to open

the predicate editor, similar to what is used

in smart groups and smart rules.

If you have done a search you'd like to use

again, press the Save button. Enter a name

and DEVONthink will create a smart group

for you. If your search scope is in a group,

the smart group will be created there. If you

are searching a specific database, the smart

group is created in the root of the database.

Searching inboxes or all databases creates

a global smart group, shown in the Smart

Groups section of theNavigate sidebar.

AI: The AI button opens the Search Assistant.

This popover lets you describe your search

naturally, as if you're talking to someone. For

example, "Show me markdown documents

that mention turtles." This will be processed

with AI and provide the DEVONthink-specific

raw search syntax, e.g., kind:markdown

text:~turtles. This popover requires an

active AI model in order to it.
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Note: The search index contains

alphanumeric characters as well as the

following symbols:$€£¥%§

PATH BAR

On the left side of the main window, just

below the toolbar, is the Path Bar. This is a

specialized bar displaying a crumb trail to the

current location in the Navigate sidebar. For

example, if you are in a nested group, it will

show something like Coding > AppleScript

> WWDC > 416, always beginning with the

current database.

Each item in the crumb trail is a live link, so

you can click it to jump to any parent group or

back to the top level of the database. Long-

press a group to show its sibling groups. Or

open the context menu via a Control-click an

item to access them but also an Open button

to open the group in a new main window or

Reveal to open a new window with the group

selected.

This bar also has < and > buttons so you can

navigate back and forth between locations

you've visited in this window. Bear in mind,

these buttons only relate to the history of the

specific window. If you open a new window,

it will have no history so the buttons will

not function until you've navigated to some

locations. As an added feature, click and hold

one of these buttons to be shown a list of

previous locations you've visited, just like in a

web browser.

INFORMATION BAR

Another specialized bar, the Information

Bar displays the number of items selected

and the total number of items in the current

location. As mentioned previously, this bar

also hosts the Sort dropdown and the 

view icons.

SIDEBAR: NAVIGATE

The Navigate pane is the default sidebar

where you will access to your databases, tags,

items located in Favorites, etc. Additionally,

you have access to some specialized items:

global smart groups and smart rules.

Each section in the Navigate sidebar has its

own specific purpose: giving you access to

frequently used files, navigating database

groups, or viewing a list of similar files. The

sidebar will only show databases and groups.

Selecting one of these items will display

its groups and files in the item list. This

allows a clear view of the group structure

in the sidebar, while still allowing you to

interact with the contents in the item

list. Alternatively, you can view the group

hierarchies directly in the sidebar. Excluding

smart groups and smart rules, selecting

multiple items will show a union of their

contents in the item list.
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The sections in the Navigate sidebar can

be dragged to reorganize them as desired.

Sections you don't need to use as often

can be collapsed to reclaim the space or to

provide a bit of privacy.

UNIFIED ELEMENTS

By default, specific parts of databases are

shown gathered in specific sections, similar

to how Apple Mail displays the inboxes of all

accounts in the same section.

Globals: The Globals section provides quick

access to three locations common to all

databases: the Inbox, Tags, and the Trash.

If you click a top level section, e.g., Inboxes,

you will see a combined view of items in the

inboxes of all open databases. This can be

especially handy if you want a view of all the

tags you're using in your databases. Click the

disclosure triangle next to each section to

show the locations for each open database,

allowing you to access the locations on an

individual database level.

Inboxes: The inbox of a database, like the

real-world counterpart on an office desk,

is where incoming, unfiled items are kept.

Every database has one by default and you

can see the name of the database each inbox

belongs to. The Global Inbox, shown just as

Inbox, is a special, always-open database

present in every installation of DEVONthink.

This is highly useful when quickly capturing

data, e.g., web clipping, screen captures, etc.,

without stopping to file things. You can then

go back later and file these items at your

leisure.

Tags: The Tags section provides quick access

to all the tags you are using or tags within

individual databases. If you click the top level

tags, the item list will display all the tags

you've created. Open this group and click on

a database's name to show its tags. If you like

to create nested or hierarchical tags, you can

drag and drop existing tags in the sidebar or

the item list.

Typically you will use the Tags bar in the

View/Edit pane or the Info Inspector or

Info popup to apply or create tags. You can

also drag items in your database to the

individual tags. When you create a tag it will

automatically appear in the Tags group of the

database you're in. If you want to create new

tags to be used later, select the Tags group

for the database and choose Data > New >

DEVONthink 4.3.2 Documentation, page 130



Tag. Or from the context menu, Control-click

the database's top level Tags group or an

existing tag and select New Tag.

If you find yourself in a situation with multiple

tags you'd like to merge, select the Tags group

for the current database to view the tags in

the item list. You can then select the tags

there and choose Tools > Merge Items.

Removing entire tag groups can be done by

dragging and dropping to the sidebar's trash.

From the context menu, you can choose

Move to Trash. You can delete tags in the

item list as well. One thing to note: When you

delete a tag, the original file in the database

is preserved. What you see in the database's

trash is the replicant that was created in the

tag group when you added the tag.

Trash: Every database has its own individual

trash. This allows you to see, and potentially

retrieve, items you've deleted from your

individual databases. Just as with the real-

world trash bin, we do suggest you empty

your databases' trash regularly. It is not

meant as another filing location, and items

marked as missing will still register as a

problem for a database. Select the trash,

the top level or individual database's trash,

and choose DEVONthink > Empty Trash. The

command is also available in the context

menu, when Control-clicking a trash. Trashed

files are not deleted completely from the

machine but are put into the system trash.

Open Databases: This section is where you

see and access any databases you have

currently open. Click the database's name

to display items in the root of the database.

Clicking the disclosure triangle allows you to

show groups, and subsequently sub-groups in

the database. As mentioned above, selecting

a database or group will display its subgroups

and files in the item list.

NON-UNIFIED ELEMENTS

As the unified views may be less comfortable

for some people, DEVONthink allows you to

decide what database elements you want

to unify. Controlled by options in Settings >

General > Sidebar, you can enable or disable

unifying: Inboxes, Tags, or Databases.
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Inboxes: If you disable unifying the inboxes,

only the Global Inbox will be shown in the

Globals section. The inboxes of individual

databases will be shown in the item list when

the database is selected.

Tags: Similar to the inboxes, disabling this

option will display the Tags group with other

elements in the selected database.

Note: With Unify Inboxes and Tags both

disabled, the database's contents will

appear similar to how DEVONthink 2

displayed databases.

Databases: When disabled, DEVONthink

displays a database's name in the Open

Databases section of the sidebar but the

contents will be shown in a separate section.

The current database will be marked on the

left by an asterisk (*) and its groups will be

shown in a separate active database section

in the sidebar. This creates an isolated view

of that database regardless of the number

of databases that are open. Interacting with

elements in the active database section

displays contents in the item list, similar to

the Three Pane view from DEVONthink 2.

For switching between active databases,

select another database and the active

database section will display only the groups

and smart groups of that database. Also,

there are Previous Database and Next

Database commands in the Go menu.

When using the keyboard, hold the Command

key and press the up and down arrows to

view the contents of another open database

in the item list while showing the contents of

the previously active database in the active

database section. Press ⇧-↩ to change the

active databases section to the currently

selected database.

FAVORITES

There are many times we have specific

databases, groups, or documents we return

to, again and again. Shown at the top of the

sidebar by default, the Favorites section

allows you to create shortcuts to quickly

access any of these kind of items. Drag a

group or a document to this section's header

and you'll see a curved arrow on the cursor.

Drop the file and you have a new favorite.

An option to Add to Favorites is available in

the context menu commands of most items

in DEVONthink. Use Remove from Favorites

when Control-clicking on already favorited

items to remove them.

Select an item in Favorites to quickly access

it. If an item was last viewed without a

preview, it will be displayed in its own

window. If you see a favorite is greyed out,

it means the containing database isn't

open. Double-clicking the item will open the

database, if possible, and display the item.
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Favorited groups behave just like normal

groups, so you can drag items into a one for

quick filing. Use the ⌥ Option key and ⌘⌥

keys to duplicate or replicate items while

dragging and dropping to them.

RECENT DATABASES

The Recent Databases section provides quick

access to reopen closed databases. This will

list the last ten recently closed databases.

Double-click any databases you'd like to open.

SMART GROUPS

The global smart groups function the same

as local smart groups, i.e., the ones in your

individual databases, but generally their

scope is all open databases. This allows

you to have reusable searches targeting all

your open databases, e.g., all Markdown

documents in all databases created in the

last month. These global smart groups can be

modified to target more specific locations,

but such a smart group would be better

suited as a local smart group, i.e., in the

particular database. DEVONthink comes with

some pre-installed global smart groups:

Today: Shows all documents added or

modified today.

Recently Added: Shows all documents

added in the last week.

Due This Week: Shows all documents with

a due date set for this week.

Top Hits: Shows documents opened more

than five times in the last 30 days.

Unread: Shows all documents marked as

unread.

You can create a smart group from the

context menu or the + button at the bottom

of the sidebar. By default all open databases

will be targeted. However, if you have an item

selected in the Globals or Open Databases

sections, the smart rule will use that location

for the matching.

Control-click a smart group to Edit, Rename,

Duplicate, or Remove it. You can also copy a

link to a smart group, export it to the Finder,

or import previously exported ones. If you'd

like to convert an existing smart group into

a smart rule, ⌃-click the desired smart group,

hold the ⌥ key, and choose Duplicate as

smart rule.

If you have exported smart groups in the

Finder, double-clicking them will import them.

You can also drag them to the smart rules

section of the sidebar.

For more information on editing smart group

properties, global or local, see the Smart

Group Editor section of this chapter.

SMART RULES

Similar to smart groups, smart rules are

created, edited, and behave in a similar

fashion. However, they have one distinct

difference: they can act on the items

matched. The smart rule matches items just

as a smart group does but they perform

actions when certain events take place. This

makes them a very powerful way to add

automation to your DEVONthink life.

DEVONthink provides a few useful example

smart rules to get you started:

Automatic Locking: Locks unlocked

documents (excluding RSS articles), that
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haven't been modified in the last 30 days.

This requires user intervention.

Bates Number: A specialized rule that adds

the current database's name and a Bates

number to a filename. The original name is

preserved as a document alias.

Download Bibliographic Metadata:

Examines a PDF document and attempts

to extract metadata based on it's Digital

Object Identifier (DOI). The document will

be renamed per its title and various bits of

metadata may be added, e.g, ISSN, Journal,

etc., if found.

Filter Duplicates: Automatically puts

duplicated items in a database's trash

when you import them.

Reminders: Displays the name of a

document and plays the system "glass"

sound when a reminder on a matched item

triggers.

Unify Names in Dates: Detects dates in a

filename, retrieves the filename without

the date, the renames the file prefixing the

filename with the detected date as YYYY-

MM-DD.

Apply Chat Suggestions: A template smart

rule applying certain AI-derived values,

e.g., tags, title, or some custom metadata.

Duplicate and modify this to suit your own

needs.

Notification with Summary via Chat: When

used with the  event trigger, newly received

RSS articles are examined for urgency

and if so, they are summarized in up to 10

words. The summary is then displayed via

the macOS Notification Center.

Rename to Chat Suggestion: Uses a

document's text passed to your default AI

model to rename the file with a suggested

title.

If you Control-click a smart rule and choose

Edit, you will see the criteria, event trigger,

and actions for that rule. Like smart groups,

you can create a smart rule from the context

menu or the + button at the bottom of the

sidebar. The target of the smart rule also

follows the same behavior as a smart group:

all databases are targeted unless you have

an item selected in the Globals or the Open

Databases section of this sidebar.

Control-click a smart rule to Edit, Rename,

Duplicate, or Remove it. You can also copy

a link to a smart rule, export a smart rule to

the Finder for archiving or sharing, or import

previously exported rules. Double-clicking

exported smart rules imports them, and so

does dragging them to the sidebar.

In the context menu for a smart rule, notice

there is also a smart rule-specific command:

Apply Rule. This runs the clicked command

on any matching files. This means it will

performs its actions, even if the event trigger

is not set to On Demand. Be cautious about

using this command unless you are certain

you want to affect all matched items. There

is also an option to copy the item link for a

smart rule by choosing Copy Rule Link.

Also when you Control-click a selected smart

rule, you will see a Disable Actions or Enable

Actions option, depending on the state of the

selected rules. Use this to toggle the active

state of any selected rules. This can be useful

in debugging situations.

There are two commands in the Tools menu

related to smart rules:
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Tools > Apply Rules: This runs the actions

of a chosen rule on selected items, but only

ones matched by the smart rule.

Tools > Perform Rules: This performs the

chosen rule as defined, not acting on the

selection.

Drag and Drop: Lastly, you can drag and drop

items onto smart rules to apply their actions

to them. Dropped items will be acted on,

ignoring the location and criteria specified in

the smart rule. For example, you may have a

smart rule to add the date to the beginning

of the name of images imported into your

Global Inbox. However, you could drag and

drop a rich text file from a separate database

on to the smart rule and the date would

be prefixed to the name, even though the

location and file type do not match the rule.

For more information on editing smart

rules, see the Smart Rules section of the

Automation chapter.

ORGANIZING YOUR CUSTOM ITEMS

As you add more and more favorites, global

smart groups, and smart rules, you may want

to organize them for clarity and efficiency.

Control-click anywhere in each section and

choose New Group. The group is created and

ready to be named. Now you can drag and

drop the items into their respective groups to

more logically group them and minimize visual

clutter.

CONTEXT MENU

As there are many commands in the context

menu of this sidebar, please see the Context

Menu > Navigate Sidebar section in the

Appendix.

SIDEBAR: FILTERS

Providing a way to isolate files in the item list,

the Filters pane allows you to only show files

that share common attributes. This pane,

displayed at the bottom of the Navigate

sidebar can be shown or hidden via the Tools

> Filter menu or the quartet of icons at the

bottom of the Navigate sidebar. The pane can

be resized by moving the divider at the top of

the pane.

INFO

Displayed by selecting Tools > Filter > Info, the

Info filters pane let you shows only files that

share common dates, ratings, color labels,

etc.

Dates: Click the Date dropdown to choose

the type of date you want to filter on: Added,

Created, Modified, Opened, or Due. Click on

a date in the calendar display to only show

files related to the day and type of date
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you selected. Use the small arrows to move

backward and forward through time, and click

the circle between them to quickly return to

the last selected date.

Marks: Choose the type of mark, or a

combination of them, on which you want to

filter. For example, you can click the flag and

a rating of 3 to show only those files. You can

filter on these attributes: Flagged/Unflagged,

Read/Unread, Locked/Unlocked, Rating, or

Label.

File Location: Click the dropdown to choose

whether to display Imported, Indexed, or

both with Any.

TAGS

Choosing the Tags filter via Tools > Filter >

Tags displays a tag cloud derived from the

tags applied to items in the current location.

This makes it easy to identify commonly used

tags.

To filter the files, click any tag. You will

immediately see the tag cloud reduce in

number and only related tags are shown. This

allows you to drill down into files that share

common tags, but also exposes tags that

have been used with the previously selected

tags. If there are no tags on the files in the

current item list, No Tags will be displayed.

Note: The tags you choose will also be

shown in the Information bar above the

item list. Hovering over one of these tags

displays a  close button at the right side

of the tag. Click it to stop filtering on that

tag. You can also press the Reset button to

clear all filtered tags.

Control-clicking a tag in the tag cloud shows

these options:
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Reveal Tag: Displays the tag in the

database's Tag group.

Remove Tag: Removes the tag from

database's Tags groups and also from any

document it was applied to.

Related Tags: Displays the top two tags

most commonly used with this tag.

Selecting a tag from this list filters the files

on that tag.

Sort: Allows you to sort the tags by name

or count.

View>: Allows you to switch between cloud

and list view. In cloud view, the size of the

tag indicates a higher or lower number of

documents with that tag. The more items

with a given tag, the larger it displays.

MULTIMEDIA

Open the Multimedia filter via Tools > Filter

> Multimedia to present options for filtering

out multimedia files, e.g., images, audio, and

video in the current location.

To assist in filtering, these controls are

available:

Kind: Select the kind: Any, Image, Video, or

Audio.

Width & Height (pixels): Set a minimum

and/or a maximum pixel dimension for

the width or height of images. Selecting

and pressing the Delete key in a field will

reset it to zero or infinity (no maximum

specified).

Duration (seconds): Set a minimum or

maximum length of a video or audio file,

defined in seconds, e.g., 900 for 15 minutes

(15 minutes x 60 seconds).

MAP

Utilizing geolocation data from your files, the

Maps filter shows documents related by their

location.

Open this filter pane via Tools > Filter > Maps.

By default, the data used is based on where

a document was created. However, this can

be modified. See the Geolocation field in the

Info Inspector for more information on this.)
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The map functions similar to Apple or Google

Maps, allowing you to use familiar pinch

gestures or double-click or Option-double-

click to zoom in and out, panning, etc. The

map shows pins for all documents with

geolocation data in the selected location in

the Navigate sidebar. Selecting a pin in the

map displays the files with that geolocation

data in the item list.

SIDEBAR: READING LIST

With the seemingly perpetual growth of

our databases, we often add more items

than we can reasonably process at the

moment. Similar to the sidebar section

found in Safari (and many other browsers),

DEVONthink's Reading List provides a place

to access documents you've "set aside" for

later consideration.

There are two views in this sidebar: All and

Unread. The latter lists only unread items and

purges items from the view as soon as they're

viewed in the Reading List. The former lists

every regardless if they've been viewed or

not.

A simple way to set aside a document is via

drag and drop when the sidebar is visible. If

it's not open, you choose the Data > Add to >

Reading List menu item. This command may

also be available when Control-clicking items

in other places, like the item list. Newly added

items are displayed at the top of the list in

the Unread view.

Items in the Reading List function like the

items they're pointing to. This means they

can be moved to other locations by dragging

them to other locations. This includes

duplicating or replicating while holding the

⌥ Option key or ⌥⌘, respectively.

CONTEXT MENU

The context menu displays these item-

related commands:

Open in New Tab: Opens the clicked item in

a new tab.

Open in New Window: Opens the clicked

item in a new document window.

Mark as Read/Unread: Changes the read

state of the clicked item.

Reveal Item: Reveals the item in its current

location.

Move to Trash: Moves the item to the

database's Trash. Emptying the Trash

removes the file and its reference from the

Reading List.

Copy: Copies the selected item(s).

Select/Deselect All: Selects all or none of

the items, respectively.

There are also two commands specific to

the Reading List, noting these items can't be

undone:

Remove Item: Removes an item from the

Reading List.

Clear All Items: Removes all Reading List

items.
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For those interested in automation, you can

use the special item link x-devonthink-

item://readinglist to open the Reading

List.

SIDEBAR: IMAGE CAPTURE

The Import sidebar pane gives you access

to two common sources of external data:

scanning and email. Each section in this

sidebar provides controls to import from any

supported scanner or a compatible email

client, e.g., Apple Mail or Outlook. This makes

DEVONthink a reliable companion at home,

in an office, in the hands of an archivist,

and many other scenarios. We will cover the

scanning controls in this section. We have

also provided a more practical overview in the

Going Paperless in DEVONthink section.

Scanning documents is an important function

in many situations. The Image Capture

section of this sidebar provides a variety

of scanning controls to help you create

a searchable, paperless archive of your

documents.

SCANNING CONTROLS

The Devices section allows you to choose

and control a non-ScanSnap, Image Capture-

compatible (ICA) scanner.

Selected Scanner: If you select a scanner you

will be presented with controls and settings

to scan your documents. This allows you to

use your scanner directly in DEVONthink very

efficiently. This interface should be familiar

to anyone using Apple's Image Capture

application or scanning in Preview.

Overview: The overview of what's being

scanned. When using a Custom Size you

will define the scan area in this pane.

From: Choose where you'll be inserting

the paper into the scanner, Flatbed or

Document Feeder.

Mode: Choose the color type: Black &

White, Grayscale, or Color. For text only

documents, black and white is a good

choice.

Duplex: Enable double-sided scanning, if

available on the scanners.

Resolution: Set the desired resolution of

the scan. 200 dpi is sufficient for most

cases.

Size: Choose a pre-defined page size e.g.,

A4, or check Custom Size and manually

resize the scan area in the overview. It is

possible to drag multiple scan areas on

the same scan. You can also enter specific

measurements. Note switching to a pre-

defined size will clear any custom scan

areas.

Orientation: Change the orientation of the

final document, portrait or landscape.
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Name: Enter a name for the final

document. If left empty, a date stamp will

be used as an automatic name.

To: Choose where to send the document:

Imports,create a new binder or use an

existing one, or a group in a specific

database.

Destination: The chosen location in a

database will be shown here. You can also

choose a location to send binders to when

saving.

Kind: Choose the format for the final

document, e.g., PDF or TIFF. Multi-page

scans must use PDF.

Tags: Enter optional tags to be applied to

the document.

OCR: Enable OCR for the scan, if desired.

QUEUE

Select the Queue option to display the

scanning queue where you can pre-define

documents to scan. Define parameters for

each document, including: Title, Destination,

Type (PDF or Image), Separator, whether

OCR is enabled, and optional Tags for the

finished document. This section can be very

useful when batch scanning. The following

controls are shown in this view:

Scanner: Choose an available scanner.

Flatbed/Document Feeder: Choose where

you'll be inserting the paper into the

scanner.

Job List: Scan jobs and their parameters

are listed here.

Add/Delete: Add or delete scan jobs.

Remove Sent/All: Remove already

processed or all scan jobs from the list.

Configure: Set the global options for the

color type, resolution, page size, and duplex

scanning.

IMPORTS

This section contains individual scans or

binders, collections of scanned pages.

Process existing scans, create new binders, or

modify existing binders.

Document List: The main view of the

imports displaying a thumbnails of scanned

images and existing binders.

Create new Binder: Click  to create a

new empty binder.

Properties: Press  to change properties

of a selected scan or binder, e.g., where the

scan will be sent, the title, type, tags, and

optionally enabling OCR. You can also add a

Author or Subject for PDF output.

Edit: Click  to change the page

orientation or make image modifications

on a selected non-PDF scan. If the scan

is an image, double-click it to display the

image modification pane. Press Revert or

Done, as needed.

Delete: Press  to delete selected scan(s)

Save: Processes selected scans or binders

into their final documents.
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Select a specific binder in the sidebar to

show a thumbnail view of the pages it

contains. Rearrange the pages by drag-and-

drop or drag pages from one document to

another. Press the  button to use these

options:

Reverse Order: Reorder all pages from last

to first.

Shuffle Odd/Even Pages: Automatically

switch odd and even pages

Sort and Merge Documents: Choose two

documents to merge their contents. One

document is chosen as the starting odd

page, the other as the starting even page.

The pages are then interleaved into the

current document.

TRASH

Any scans or documents you've deleted from

the scanning interface will appear here. When

you have this selected, empty the trash with

the button at the lower right corner of the

window.

SIDEBAR: EMAIL

In addition to scanning, the Import pane also

provides the controls to archive emails from

Apple Mail and Microsoft Outlook. While you

can drag email messages individually from

your email client, the Email section of this

sidebar also allows you to import individual

messages or archive mailboxes directly into

your DEVONthink database.

Open the pane pane by choosing View >

Import. Here we discuss the controls used in

this section.

ACCOUNTS AND MAILBOXES

The lefthand section of the Email section

displays the active accounts and mailboxes of

Apple Mail or Microsoft Outlook, if installed.

Select your email client, then click the

disclosure triangle to show the accounts then

its mailboxes.

Mailbox View: When you select a mailbox in

a specific account, the window will display

more controls for filtering and importing

messages from that mailbox. The central view

shows the contents of a chosen mailbox. This

is where you can select individual messages

to import, if desired. This view is separated

into columns that can be sorted by clicking

the column headers. The basic columns

include From, To, and the Subject. If you

are choosing to show already imported

messages, there is a special column showing

those items. For emails marked as high

priority, the flagged column will also show

two exclamation points and the subject, etc.

will show in red. Control-click in the this view

to refresh its contents or import selected

emails.
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FILTER AND IMPORT

When a mailbox is selected, the righthand

side of the window shows options for filtering

the messages displayed. It also lets you

choose the location where the messages will

be imported.

Destination: Choose the destination

database for the imported messages or

mailboxes. Note: You can choose a specific

group in a database when using the Import

function. However, you can only choose a

specific database, and not a group, when

using the Archive Mailbox function. Emails are

archived into a special Emails group at the

root of the specified database.

Search: Use this search field to search for

messages by the sender or recipient's Name,

email address, or the subject line. Note this

only allows for a single term to be used.

However, the search is matching substrings,

so a search for jun would match "junk",

"jungle", and "jejune".

Show: Select options in this section to

further fine-tune the list of importable

messages, if desired. You can use:

Read: Show emails messages have been

read, unread, or either.

Flagged: Show messages that have been

flagged in the email application.

Priority: Show messages that have an

assigned priority

Date Range: Choose a range of dates to

display messages received between them.

Hide: Use these controls to hide certain items

from the mailbox view. All these options are

enabled by default, but can be selectively

disabled, if needed. However, when these

options are enabled it makes it easy to see

only new messages, ready for import.

Imported: Enabled by default, this hides

messages you've already imported into the

current database. As you can't import the

same message into a database multiple

times, changing the Destination changes

what messages are displayed when this

option is enabled. If you disable it, already

imported messages will show a checkmark

next to their name

Deleted: Hide messages you've put in the

account's trash.

Junk: Hide messages moved to the

account's junk mailbox.

The last two items are buttons for importing

selected emails from the Mailbox view or

archiving the currently selected mailbox. For

a practical overview of the email archiving

process, check out the Archiving Email

section of the In & Out chapter.

SIDEBAR: EXTRAS

The Extras sidebar gives you a place to check

for current information from us. It's an easy

way to stay up to date with some of the

goings on at DEVONtechnologies.

DEVONthink 4.3.2 Documentation, page 142



Support: Here you will find our recently

published tips, scripts, smart rules, and

templates.

Tips & Tricks: This shows recent blog posts

of handy tips about all things DEVONthink,

presented in a RSS feed style. To read the

full article, click the article's title.

Scripts and Smart Rules: From time to

time, we publish publicly available scripts

and smart rules. You will see a brief

description and a link that allows you to

install the script directly from this section.

Templates: We also offer templates for a

broad audience. This section lists recently

published ones. As with the scripts and

smart rules, a description and installation

link is provided.

If you'd like to quickly mark all items as Read,

Control-click and select the Mark All as Read

from the context menu.

For another view of the available scripts,

rules, and templates, as well as easy

installation and uninstallation, see the

Support Assistant.

DEVONtechnologies: This section provides a

list of blog posts regarding announcements,

updates, and promotions.

Note: For the sake of transparency,

DEVONthink does connect to our web

server to bring you this information.

DOCUMENT WINDOW

If you want to focus on a specific document,

you can use a document window. Double-

click a document in the item list to open it

in a document window. Alternately, choose

Data > Open or the Open command from the

context menu. The document opens in its

own window, isolated for editing, reading, etc.

These windows are great for concentrating

on a single document but are also convenient

for split screen work, allowing you to view

individual documents easily at the same time.

And document windows support Inspectors

so you can access specific tools like the

Thumbnails inspector while reading a PDF, for

example.

Bear in mind, many documents can be

displayed in document windows but that

doesn't mean they're editable. However,

you can still view and potentially search

such documents in one document window

while editing another in a separate window.

For more information on what formats are

natively editable, see the Documents chapter.
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Toolbar Items: Similar to a main window,

a document window has a toolbar at its

top. The default toolbar buttons may vary,

depending on the type of file being viewed in

the window. You can customize the toolbar

via View > Customize Toolbar, but note there

are fewer options than you have with a main

window. A list of available toolbar items is

available in the Toolbar Items section of the

appendix.

If the title is displayed in the toolbar,

Command-clicking it shows the document's

location, including the database it's stored

in. Use this to jump out to a containing group

or just to quickly determine the document's

location.

THE SORTER

The Sorter is a multi-purpose popup that

allows you to quickly add content to your

databases, even when DEVONthink isn't the

active application. Depending on the option

you choose in Settings > Sorter, it will appear

in the menubar at the top of your screen or

docked to the left or right side of your screen.

When shown as a menu bar icon, you can

choose to display it as the word DEVONthink

or a space-saving nautilus icon.

The Sorter can be opened manually or you

can jump directly to certain views via hotkeys

you set in the settings. For example, setting

a hotkey for Copy Selection opens the Take

Note view with the selected text already

added. Once the Sorter is open, you can

switch between these views by clicking the

icons at the top of the pane. Alternately,

hold ⌥⌘ and press 1 through 6 to quickly

open a specific view, e.g., pressing 4 opens

the Video Note view as it's the fourth view

available. Below we cover the different views

the Sorter provides for quickly capturing

data.

Note: The ⎋ Escape key can be used in all

views to quickly close the Sorter.

NAVIGATION

The Navigation view provides a convenient

list of the databases and groups in

DEVONthink.

To add files in the Sorter, drag over the

docked tab or menu bar item. The Sorter will

spring open. then drop items into specific

groups to quickly import them. Also equipped

with a handy search field, you can search

for and isolate groups for more targeted

importing. This view is composed of three

sections:

Search Field: Use the search field to help

quickly locate specific groups. This uses

substring matching, so you can enter

parts of words to find matches. The

view updates while you type for efficient

searching.

Favorites: Provides a convenient list of

the groups you've added to the Favorites
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section of the global sidebar. Drag items

onto your favorites to import them.

Control-clicking a group or database gives

you the option to Reveal or Open the item.

You can also double-click an item to open it

in a new window.

Databases: Provides a list of open

databases and access to their groups.

Behaves in the same way items in your

Favorites do.

Hotkeys: The Navigation view supports these

keyboard navigation with these keys:

Tab: Switch the cursor focus between the

search field and databases list.

Command-Option: Hold these keys when

dragging Finder files or folders to index

them.

Command: Hold this key when dropping an

item to move it into the database, putting

the original in the system trash.

Up/Down Arrows: Navigate up and down

through the database listing.

Left/Right Arrows: Open and close groups

containing subgroups. Hold the ⌥ Option

key while pressing the right or left arrow to

fully expand or collapse all the subgroups,

respectively.

CREATING FILES

The remaining views are focused on creating

documents, whether that's a simple plain

text file, a screen capture of an application's

window, recorded video, or clipping web

content. Every view supports these options:

Add: Saves the file in the specified format

in the chosen location. You can also press

⌘S to save the current content.

Reset: Displayed as a  backward pointing

circular arrow, click it to clear the view to

its default settings.

Info: Add metadata about the file here,

including: read status, locked state, flagged

state, rating, or color labels.

Tags: Enter tags for the file. Tag

suggestions will be made from the tags of

all open databases.

Location: Choose the location to save your

file from the dropdown list. The location of

the last saved file will be preserved for the

next note you create.

And whenever these controls are shown you

can move the cursor forward between fields,

e.g., between the body and URL, by pressing

⌃⇥. Hold the ⇧ Shift key to cycle backwards

through them.

TAKE NOTE

The Take Note view is for those times when

you just need to quickly write a note but

don't want to go back into your databases

just to create a new file. And to make your

note taking a little faster, define a Take Note

hotkey in the the Sorter settings.
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Allowing you to write notes in several

formats, the editing behavior depends on the

format you've chosen. Also, the appearance

of the text depends on the your choices

in the Editing settings. This view supports

these specific attributes:

Name: The title of your file. If left as

Automatic DEVONthink will attempt to

create a title from the first sentence of the

body.

Body: Enter your note text here.

URL: If there is a URL you'd like to associate

with the file, perhaps a link back to a

source, enter it here.

Format: Choose the format of the saved

note. Choose from: plain text, rich text,

formatted note, and Markdown.

If the Sorter is set to None in Sorter settings,

it will appear as a separate floating panel

having the same functions described above.

However, it has the added feature of hovering

over any open windows.

VOICE NOTE

Use this view to record a voice note directly

into your database. This creates recording in

.m4a format, saved to the location of your

choice. With simple controls, it's easy to

record impromptu audio.

This view has a few simple sections:

Audio Levels and Timer: At the top is a

sound meter to help visualize your audio

level as you record. The elapsed time

is shown as it records, convenient for

projects like rehearsing a presentation.

Begin/Stop Recording: Press the red

circular button to begin recording. Press

the black square button to end recording.

When you've stopped recording, you will be

shown these view-specific options:

Name: Enter a name for the audio file. If no

name is provided, a date and timestamped

name will be automatically given.

Playback and Volume: Playback your audio

to ensure it's good before you save it. Press

the Reset button to clear the audio and

record again.
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VIDEO NOTE

Use this view to capture a video from your

Mac's built-in camera. Videos are saved as

MP4 files for convenient compatibility across

platforms and devices.

Like the audio note, this is presented in very

simple controls:

Begin/Stop Recording: Press the red

circular button to begin recording. Press

the black square button to end recording.

Source: Choose the video and audio

source in the small downward facing caret

next to the record button. Any attached

compatible audio-visual devices should be

available here.

When you've stopped recording, you will be

these view-specific options:

Name: Enter a name for the video file. If no

name is provided, a date and timestamped

name will be automatically given.

Playback and Volume: Playback your video

before you save it. Or press the Reset

button to clear the video and record again.

Trim: Shown as scissors, click this to access

simple editing tools. You can drag the ends

of the yellow frame to change the start

and end of the video. Click and drag inside

the frame and a red line will appear. This

displays the time above the line.

SCREEN CAPTURE

Screen captures are a common way to

quickly gather information about things on

our computers. While the Apple provided

mechanisms still work, the Screen Capture

view allows you to quickly snap a screen shot,

add some metadata, e.g., tags or labels, then

save it directly into a specific location in your

databases. The captures will be saved as

JPEG files.
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This view has one simple section with three

options, also accessible via shortcuts:

Screen: Capture your entire screen (⌘1).

Window: Capture a specific window

(⌘2). Hover over a window and it will be

highlighted in blue. Click once to capture it.

Selection: Capture a specified area by

dragging a bounding box around the

desired area (⌘3). To reposition the area,

hold the space bar. To stop the capture

action, press the ⎋ Escape key.

After making the capture, these view-specific

options are shown:

Name: Enter a name for the screen

capture. If no name is provided, a date and

timestamped name will be automatically

given.

WEB CLIP

Use the Web Clip view to quickly clip the

current web page, a URL from your clipboard,

or enter a URL manually. Each option is also

accessible via shortcuts.

Default Browser: Displaying the icon of

your default browser, click this to capture

the current page. This shows the same

options as the Clip to DEVONthink browser

extension. (⌘1)

Clipboard URL: If you have copied a URL,

click this option to detect and capture it

(⌘2).

Manual: Click this to manually enter a URL

to capture (⌘3).

Before saving the clipping, you will see these

view-specific options:

Name: The name should be automatically

populated from the title of the web page,

but it can be changed manually, if needed.

When using the default browser option or

the Clip to DEVONthink extension, click the

Preview button and DEVONthink will attempt

to display a preview of the intended capture.

This can be helpful in trying to determine if

a capture will be successful. And if you hold

the ⌘ Command key, you will see the shortcut

keys for the Add and Preview buttons.
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WEB SHARING

DEVONthink comes with a built-in server for

broadcasting your databases on a network.

While the operation is covered in the In &

Out > Web sharing chapter, here we cover

the interface shown when accessing shared

databases in a browser window.

The layout of the web sharing should

immediately be familiar to users of

DEVONthink. While not as full featured as

the native application, it behaves in ways

similar to DEVONthink's main window. Here

we will give you an overview of the parts of

this interface.

Note: The permissions given by the

administrator of the shared databases

determine database visibility as well as

what actions you can take. Due to this,

some actions, e.g., creating new documents

or downloading documents, may not be

available. If you do not have permissions

to modify the database you're browsing,

the cursor will change to show the option is

disallowed.

SIDEBAR

A condensed version of the Navigate  sidebar

found in DEVONthink's main windows, this

provides access to the contents of any

shared databases. Some basic context menu

items, e.g., New Group, New Feed, Rename,

Move to Trash, and Empty Trash are available

when Control-clicking in the sidebar. At the

top is a button to show or hide the sidebar.

ITEM LIST

The item list behaves in many ways similar

to DEVONthink, showing the groups and

documents in the current location. All these

items can be selected and reorganized by

drag-and-drop, to groups in the sidebar

ones in the item list. Switch locations by

navigating the groups in the sidebar or

double-clicking a group in the item list. At

the top, the name of the current location

is shown. Clicking on it opens a popup

displaying the parentage of the current group,

going back to the database itself. Click any

parent in the dropdown to navigate directly

to it. To navigate back and forth through

locations you've visited, use the  and 

buttons in the path bar.

When dragging and dropping files into the

websharing interface, drop them on top of

existing documents in the group. If the group

is empty, drag and drop to the group in the

sidebar. Or click the  button at the top of

the item list and choose Upload Document.

Drag and drop a file onto the dialog or click

select and choose one. Make any changes you

need to and upload it directly to the current

group. To delete an item, select it and press

the  button.
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Again, taking its example from DEVONthink's

main window, Control-click items in the item

list to show these commands in the context

menu:

New: The submenu allows you to create

new items: plain text, formatted note,

Markdown, Bookmark, RSS feed, and

groups.

Get Info: Shows the Inspector pane for the

selected file.

Mark: Toggle the Flagged, Unread, or

Locked state of a selected file.

Rating: Adjust the rating for a selected file.

Label: Apply or remove a color label to a

selected item.

Upload Document: Use this to upload a new

document to the database.

Download Document: Download the

currently selected file.

Move to Trash: Move the selected item to

the database's Trash.

While you can't reorder the items manually,

the item list can be sorted by clicking on the

column headers. Click the header again to

toggle between an ascending or descending

sort. Control-click the headers to enable and

disable individual headers.

VIEW/EDIT PANE

When an item is selected in the item list, a

preview of any compatible file will be shown

here. The DEVONthink-native formats and

some non-proprietary text-based formats

can be displayed. You can even edit plain text

and Markdown documents. Just click in the

view/edit pane and begin editing.

Editing bar: The Editing bar above the view/

edit pane shows for certain types of files. If

the document can be edited in web sharing,

available tools will be shown. The bar also

allows you to move back and forth through

previously viewed files via the  and 

buttons.

Of special note is the behavior of formatted

notes, a web-based format. Tap the edit

button on the right of the Editing bar to

access some editing options, like adding bold

or italic type. You can also select text and

create a hyperlink with it. Lastly, you can

choose an image to insert into the document.

For the Markdown fans, you will see the

same navigation bar options, showing Edit,

Preview, and Side-by-Side modes.

Note: While it is a force of habit — and in

general, a good one to be in — you do not

need to press ⌘S after editing a file. The

changes are saved automatically.

INSPECTORS

Info: There are three inspectors available

in web sharing. Shown by clicking the 

button, you will find a condensed version of

the Generic and Data inspectors. If you have

permissions to make changes to the current

database, it is possible to change some of

the metadata, like ratings or labels. You

will also find a See Also inspector showing

suggestions of potentially related documents.

Clicking on an item in the results will display

that document in the view/edit pane. The

document selected in the item list is always

listed at the top, so you can return to it easily.
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TOOLBAR

There are a handful of toolbar tools in the

web sharing interface. Note a few items will

be discussed separately.

Show/Hide Sidebar: Toggles the visibility of

the sidebar.

Search: Search for files in the open

databases by entering search terms.

Search prefixes are supported so you

can use, e.g., kind:pdf name:manual.

When you do a search, a Search in scope

dropdown will appear so you can choose

to search the current location, current

database, or all available databases.

Add: The submenu allows you to create

new items: Plain Text Note, Formatted

Note, Markdown, Bookmark, New Feed,

and Group. You can also add items via the

Upload Document command.

Action: Displayed as , this menu shows

options similar to the context menu in the

item list.

Move to Trash: Put the selected item in the

database's trash.

User: Set the Appearance (Light, Dark, or

Automatic), Language (English or German),

or Logout.

Show/Hide Inspectors: Toggle the

Inspectors panes.

GENERATE IMAGE

Generate Image is a resizable panel where you

can create AI generated images based on a

description you provide. Enter your prompt,

choose your AI model and settings, press

Generate, and wait for your image. Images

will be shown but also displayed in a slide

strip of thumbnails under the main image.

Click on each to view and compare them. If

your AI model supports editing, e.g., the Flux

models, you can select a thumbnail, enter

changes for the image in the prompt field

and press the Edit button. The image will be

processed and changed per your instructions.

And if you have an existing image you want

to modify, copy it to the clipboard, open the

Generate Image window, click the display

area, and paste it in. Now enter your new

instructions and edit the image.

The controls on this panel are simple to use.

Name: Provide a name for the image. If

none is entered, the prompt will be used as

the name.

Prompt: This is the description of the

image you want created. Be as specific as

you need to be.

Model: This is the generative AI model you

specified in the settings.
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Aspect Ratio: Choose from predetermined

aspect ratios. Supported sizes are: 1:1,

16:9 (9:16), and 4:3 (3:4). The size

of the resulting image is controlled by

this setting, the generative model, and

optionally, the quality setting.

Quality: Choose whether to create a

Standard or HD image. Not supported by all

models.

At the bottom of the panel are buttons to

Generate (⌘G) a new image, Edit (⌘E) to edit

the current image, Save (⌘S) the document,

or Close and dismiss the image.

Take some time to craft your prompt to avoid

to much back and forth interaction. The more

specific you are, the more you can help steer

things toward what you imagine.

Note: This requires an API key for a text-to-

image generative AI model.

ANNOTATIONS PANEL

When annotating a PDF, a dark window will

appear for non-highlighted annotations.

Here you can edit certain properties of

an annotation. Choose the Tools > Mode >

Annotation Selection tool and double-click an

annotation to reopen this panel.

Type: Displays the specific type of

annotation, e.g., Rectangle.

Text: Shows the content of Text and Note

annotations.

Color/Fill Color/Remove Fill Color: Set the

border and background color or remove the

background.

Line Tools: Set the thickness, dashes, or

arrows on Line annotations.

Text Tools: Set the Alignment for Text

Annotations, e.g., center.

Icon: Choose the icon for Note annotations
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Link Type: Set whether a Link annotation

points to an external location, e.g., a web

address, or a page in the same document.

Destination: The URL or page number being

linked to.

See the section on PDFs for more

information on annotating PDFs.

GROUP SELECTOR

If you have set Files > Import > Destination

to Select group, this panel will appear when

importing items in certain ways, e.g., when

dropping files onto DEVONthink's dock icon

or importing via scripts with no specified

destination.

Name: Displays the name of the file being

imported. Edit, as needed.

Tags: Add optional tags.

Destination: Choose where to import

the document. This includes recently

used destinations as well as any favorited

groups.

Toggle Mini panel: Expand or collapse

displaying the databases list.

Search: Do a case-insensitive search for

the name of a specific group. This supports

substring matches, so you can find groups

much more quickly. For example, a search

with the first letter(s) of words, dt m

would match a group named DEVONthink

Manual.

New Group: Create a new group in the

selected location in the databases list.

When using the mini panel, this command

is the first item in the Destination

dropdown.

This panel remembers the last used location,

so if you're repeatedly importing to the same

location, you only need to tap the ↩ Return

key to immediately import an item.

Read more about getting files into your

database in the In & Out section.

POPOVERS

Popovers are a specialized panel that appears

on command and disappears after interacting

with it. These are usually used for quickly

viewing information about a selected item

but can also be used in some other ways.

For example, Database Properties is an

information popover you may already be

familiar with. Here we discuss a few more

DEVONthink offers, starting with information

popovers and followed by utility popovers.

One special feature of some of the popovers

is the ability to float above other windows.

When the popover is open, click and drag

at the triangular point of connection to the

window and tear it way. You can then move it

around as an independent panel. This will be

noted for the ones that support it.
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AI POPOVERS

There are three AI-based popovers in

DEVONthink providing summarizing and

transforming content or giving you access

to chat with your AI engine. Another one

transforms natural language queries into

DEVONthink's search language.

Chat: This tear-off popover gives you quick

access to interact with your chosen AI model.

Opened with the  button or Tools > Chat,

this provides the same functionality as

the Chat inspector. However, it functions

independently from the inspector,

remembering its own conversations. Ask

impromptu questions or make inquiries about

the selected document in the text field at

the bottom of the pane. You can press the

send button or press the ↩ Return key. The

text field displays the default chat model but

you can click the dropdown next to the it to

choose an alternate available chat model.

Enable Speak chat responses if you have a

need to hear the chat replies.

At the top of the popover are three buttons,

some having hotkeys for quicker use: Clear

(⌘K), Copy, and Save (⌘S). So if you want to

start a new chat, copy the current response,

or save a transcript of the chat, you have

those options.

Summarize and Transform: This popover is

used with a document displayed in the view/

edit pane. This popover can be opened via

the  button in the Navigation Bar or the

Summarize Documents via Chat command in

the Tools or context menu. When opened, the

current document's text will be processed

according to the Summaries section of the

AI > Chat settings, e.g., as Bullet Points. If

you choose another option, the text will be

processed again to match the chosen output.

Another option you may be surprised to find

is you can summarize an image! If you are

using a vision-capable AI engine, the image

will be analyzed and a description will be

shown in the popover. If you want to vary

the amount of detail, you can modify the

number of tokens in the Usage dropdown
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in the settings. This obviously changes the

token expenditure, up or down, based on your

choice, but it may be used to fine-tune the

summary.

If you instead press the  button in the

Navigation Bar, the document's text will be

assessed and you'll see a recommendation

for rewriting the text in a specific tone, e.g.,

Friendly. This often works well with selected

text. And be aware that processing entire

documents will increase the token expense.

At the bottom of the popover are keys to

Replace currently selected text in text-based

documents, Clear (⌘K) the summary, Save

(⌘S) the summary as a separate document,

or Retry (⌘R) generating the summary.

Search Assistant: Finally, this detachable

popover lets you enter a search query in

natural language and AI will convert it to

DEVONthink's search syntax. Put your cursor

in the toolbar search field, press the ↩ Return

key, then click the AI button in the search

options to open the popover. Type in your

query, like "What PDF files mention sync and

have ticket in the name?" may yield kind:pdf

text:sync name:~ticket.

Click the  button (⌘C) to put the suggested

syntax on the clipboard. Press Search (⌘F)

to run the search using the recommended

search terms. If you want to generate a new

suggestion, press the  button (⌘R).

Be aware the syntax generated by AI may not

be exactly optimal for your search. However,

it often can be used as a useful starting

point. Also note the default AI engine and

model affects the suggested syntax. You set

another model in the AI > Chat settings, e.g.,

Claude's Haiku versus Sonnet, to see how the

results may differ.

Graph: Utilizing DEVONthink's internal AI,

the Graph inspector can also be opened

as a tear-off, resizable popover for a more

convenient view of the document's various

connections to tags and other documents in

your database. When detached, this size and

position of this popover will be remembered

across launches and when using workspaces.
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INFORMATION POPOVER

Info: This tear-off popover displays

information about the currently selected

item. However, it is also dynamic, updating

the information as the selection changes. It

displays the contents of the Generic, Data,

Annotations & Reminders, and Properties

inspectors. Open this popover via Tools > Get

Info, ⇧⌘I, or pressing the  toolbar button.

Log: The tear-off popover is the minimized

version of the Log window, providing a quick

way to glance at application messages

without having to open a separate window.

Open this popover via the  toolbar button.

Note this button will only be enabled if there

are messages available to be viewed. You can

clear the log or press the Save button to save

the log, usually to send to our support team.

UTILITY POPOVERS

The utility popovers provide extra functions

for moving files, navigating databases, or

linking documents. Each popover has a search

field at the top for helping to narrow the

results. You can use an abbreviated search

syntax matching the beginning of words to

help speed the process. For example, if you

are looking for a group named "Household

Expenses" you could type hou exp to find

matches. After searching, double-clicking

a result will move the file to the selected

location. For keyboard navigation, you can

press ⇥ Tab to put the focus in the results list

then navigate with the arrow keys. Pressing ↩

will accept the choice and close the popover

automatically. There is also a plus (+) button

for creating a new group in the current

location when needed.

Move to: This popover allows you to organize

selected files quickly. Open this popover via

Data > Move To or pressing ⌃⌘M.

The default behavior of this popover is

moving files. However, the behavior can be

changed using command keys. Hold the ⌥
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key to duplicate files to a selected location.

Hold ⌘-⌥ to replicate the files to a selected

location within the same database. Note the

text in the popover will change to reflect the

kind of operation will take place.

Go to Group: This popover allows you to

quickly jump to another location. Open this

popover via Go > To Group or ⌃⌘G. One

special property of this popover is the ability

to act as a floating pane. Open the popover

then click and drag it away from the toolbar.

It will remain open as a searchable floating

pane you can use for quick navigation. You

can also drag and drop files to it, similar to

the Navigation view of the Sorter.

Go to Document: This popover allows you to

quickly navigate to a specific file. Open this

popover via Go > To Document or ⌃⌘O. Note

this popover does not support abbreviated

syntax, i.e., matching substrings or non-

contiguous words, as the fuzzy matching

would lead to far too many results. Given

a filename of DEVONthink sync timing

tests.md, timing tests would match;

DEVONthink timing would not.

Insert Link: Used when editing text-based

documents, e.g., rich text, this popover allows

you to search for and quickly insert a link to

that file in the current document. The type

of link inserted will be appropriate to the

current document type, e.g., a Markdown

document will have a properly formatted

Markdown link. Open this popover via Edit

> Insert > Item Link, the Insert > Item Link

context menu command, or ⌃⌘E in the

context menu while editing a compatible

document.

WIDGETS

For those old enough to remember, OS X

had a feature called the Dashboard where

you could install widgets, the precursors

to the widgets Apple introduced later

on their mobile operating systems. With

macOS Tahoe, Apple brought application-

specific macOS widgets to the desktop and

DEVONthink comes with a small contingent

of them.
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In the Finder, Control-click your desktop and

choose Edit Widgets. Scroll to DEVONthink

in the widget directory to view the available

options including: the Reading List, Favorites,

a tip from our blog, or view or load one of

your Workspaces. Click the green plus button

or drag and drop a widget to install and

position it. For widgets you don't need to

see all the time, you can add them to the

Control Center and popup it open, as needed.

Once installed, you can change a few of the

options. Control-click the widget and change

the size, from small to extra large. Choose

Edit… to bring up the configuration options.

For example, the Reading List widget lets you

choose between viewing from all the entries

or just the unread ones.

Not only do widgets let you see things, but

also open them. Click on a favorited item to

open it in DEVONthink. Or tap a workspace

to quickly load that set of databases and

windows.

PREDICATE EDITOR

The Predicate editor allows you to create

a set of criteria for matching items. When

you create or edit a smart group or smart

rule, this window is where you set criteria

to match and for smart rules, what actions

to take with any matched files. And while

displayed in a sheet instead of a separate

window, the Advanced search supports

creating predicates in a similar way.

SEARCH OPTIONS

When used with a smart item, the top

section of the editor contains a mandatory

name and search location, as well as a few

optional items.

Name: Enter a name for the smart item.

Search in: Select the location you want this

smart item to search.

Exclude Subgroups: Enable this to ignore

items in subgroups of the location selected

in the Search in dropdown.

Ignore Diacritics: Check this to treat

letters with diacritics, e.g., umlauts or

accented characters, the same as their

regular counterparts.

Fuzzy Word Comparison: Check this

to apply fuzzy logic to contents-based

criteria, ignoring simple typos so that

instances of "hello" and "hallo" are both

found.

Highlight Occurrences: When used with

contents-based matching, this will highlight

the terms in the text of selected search

results, if possible.

PREDICATES

The other section of the editor shows the

search predicates. The predicates are built

as a series of logical steps. At the top, define

whether All (Boolean AND) or Any (Boolean

OR) of the contained predicates need to

be true for an item to be matched. If you

need to create a more complex match, hold

the ⌥ Option key and click a ... button to

DEVONthink 4.3.2 Documentation, page 158

https://www.devontechnologies.com/blog


create a "compound predicate" also called

"branch". Each branch also has its own All or

Any option as well. This allows you to create

very targeted searches.

Criteria may be content- or attribute-

related. These contain the attributes you

want to match. For example, searching for a

specific word in PDF documents added this

week would require three criteria: Content,

Kind, and Date Added. Each criterion is

made up of three parts: the attribute to be

evaluated, e.g., Content or Date Modified,

an operator like begins with, and the value

to be matched. When using text-based

criteria, a placeholder will indicate if booleans

and wildcards are supported. Use the + and

- buttons to add more criteria to your smart

group or to delete them. Add as many criteria

as you need noting it's better to as specific as

possible to avoid false positives. Criteria can

be rearranged with drag-and-drop, if needed.

Example: To find all Microsoft Excel files

use the condition Extension ... is ... xslx. To

find items created in the last 7 days use the

condition Date created ... is ... Last Week.

Placeholders are a powerful option in

predicates, whether it's in a search, smart

rule, or batch configuration. A placeholder

can be used to get a document's item link,

the year and month of the current date,

or even the response from a Chat prompt.

When the search, rule, or batch configuration

runs, the placeholder is replaced dynamically.

You can access placeholders in the context

menu but at the right end of text fields for

certain criteria in the predicate editor, you

may see an ellipsis in a rectangle. This is the

placeholder popup where you can browser

and quickly choose the attributes you need.

Note: Full regular expressions are not

supported in criteria.

BATCH PROCESSING

If you need to make impromptu changes to

documents in your database, DEVONthink's

batch processing comes in handy. Opened via

the Tools > Batch Processing command, you

can build a collection of automations for a

variety of use cases.

CONFIGURATIONS

The Configurations section is where you

create or edit your batch processes. Select

a configuration and press Apply to run it

on selected items or edit and press Close

to continue editing or run it for later. The

configurations are all independent of each

other, so you can reorder them via drag
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and drop. Press the + button to add a new

configuration or the – button to remove a

selected one. For other configuration options,

click .

New: Create a new batch processing

configuration.

Duplicate: Copies the selected

configuration.

Remove: Delete selected configuration(s).

Rename: Rename the selected

configuration.

Import: Import batch processing

configurations, .dtBatchProcess files.

Export: Export the selected

configuration(s) for sharing, backup, or

archiving.

These commands are also available in the

context menu of the configurations.

ACTIONS EDITOR

On the right side of the window is where you

construct the actual batch process, adding

actions to affect the changes you want to

make. When you create a new batch process,

one action is added by default. Click the

dropdown to choose the appropriate action

and fill out any required information. Press

the + button to add more actions. Press the –

button to remove an action.

At the top of the actions section, there

is a numeric field, Start index/counter at.

That is used with the Counter and Index

placeholders. This is not a global value, but is

specific to the selected batch process. This

can be very useful if you are using a separate

numbering scheme for different projects.

Just create a configuration for each project

and assign its own starting number.

Read more about the available smart actions

that work with batch processing in the Smart

Rule Events and Actions section as well as

the available placeholders.

SCRIPT EDITOR AND
ASSISTANT

For those interested in scripting, a specialized

scripting interface is now included in

DEVONthink. With it you can draft a variety

of scripts in both AppleScript and JavaScript

(JXA). Covering the types of scripts used in-

application, you can start creating scripts and

open them in an external editor, as needed.

The Script Editor window can be opened via

Data > New > Script as well as the context

menu of the item list and the Action menu.

The window is composed quite simply. You

have a mandatory Name field. Following that

is an optional Info field where you can include

a description or instructions, appearing as

comments in the script. Next is the Type

dropdown where you choose one of the

types of scripts found in DEVONthink. The

supported types are:

Generic: This is a generic script containing

the boilerplate code for handling a
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selection of items. It can be used for many

purposes.

Reminder: This creates a draft reminder

alarm script in the Annotations &

Reminders inspector. The appropriate

handler is already included.

Smart Rule: Used with the Apply Script

smart action in smart rules and batch

processing, this contains the appropriate

handler and code to be used in smart

actions.

Output: Used in the Script with Input/

Output smart action, the template code

contains the handler ready to modify and

use.

Finally, at the bottom of the window, is the

editing pane where you can work on the

code. As you work, you can press the Compile

button, shown with a small hammer. This lets

you check if your code has any syntax issues.

And finally, the OK button will generate a

script file with the code for you to open in an

external editor, etc. Script files are saved as

text-based .applescript files that can be

edited in DEVONthink or opened externally,

e.g., in Script Editor.

You can read more about the various types of

scripts in the Automation chapter.

SCRIPT ASSISTANT

If you have set up access to external AI in the

Pro and Server editions of DEVONthink, you

may be able to use it to write or modify the

code. Below are the places you can find the

Script Assistant. Bear in mind, the code is a

draft and the script may not work correctly

in its initial form. However, the AI is aware

of several common scripting errors and will

attempt to correct them in its output. You

can ask it to refine the code.

Script Editor: Below the Type dropdown in

the Script Editor window is a field where you

can enter a prompt to be used for a script.

Click the icon to the left of the field and

choose an available AI model that supports

coding. After you write your prompt, press

the ↩ Return key and AI will try and draft a

script fulfilling the requirements you've set.
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Smart Actions: Another place you can access

external AI is when editing a smart item

script in a smart action, i.e., Apply Script

and Script With Input/Output. In a smart

rule or batch processing configuration, edit

the internal AppleScript or JavaScript. You

will see the AI model button to the left of the

Script Assistant field where you enter your AI

prompt to compose or improve the script.

Reminders: When setting an reminder

alarm on an item, you can add a reminder

alarm script. For the alarm, choose Execute

AppleScript or Execute JavaScript. Click

the button to the right to open the script

editor. Here you can directly compose a

reminder script or again, use external AI to

describe the script. Enter the prompt, press

↩ Return key, and let AI generate draft code

for you.

SETTINGS

The Settings window, opened via

DEVONthink > Settings, is where you

can access a broad range of settings for

customizing DEVONthink to your personal

needs.

Because the application settings are so

important, we have created a separate

chapter for them.

DATABASE PROPERTIES

The Database Properties popup provides

information and some controls for a specific

database. Select a database and open the

properties popup using File > Database

Properties. Here are the parts and controls

you'll see.
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General: This section provide per-database

controls for Spotlight integration, versioning,

and tagging.

Location: Shows the location of the

database in the filesystem. As the cursor

moves over the path it exposes any hidden

folder names. Double-click any part of the

file path to reveal it in the Finder.

Encrypted: This is enabled when using an

encrypted or revision-proof database.

Revision-proof: Enabled when the database

is revision-proof.

Create Spotlight Index: Check this option

to write Spotlight metadata for this

database. This allows you to use Spotlight

in the Finder to search for documents

in DEVONthink. If you are having issues

finding documents in a Spotlight search,

click the Rebuild button to recreate the

metadata.

Exclude Groups from Tagging: Disable this

option to use group tags in the database.

This is enabled by default.

Inherit Tags of Groups: Enable this to apply

a group's tags to its child items.

Case Insensitive Tagging: Check this

option to disallow tags with different

capitalization.

Options:

Name: Edit the database's name. Be aware,

changing the name here will also change

the name of the database file in the Finder.

Comments: Add comments about this

database. These comments are only used

in DEVONthink, i.e., not exported to the

Finder.

Protection: Click the padlock to add

or change the User and Password on a

database.

Note: The user credentials on a database

are not encrypting it nor is it locking the

database from being opened. It is used

when trying to import a database when

syncing. Anyone trying to import the

database from a sync location will need

to provide these credentials. For a locally

secured database, create an encrypted

database via File > New Encrypted

Database.

Statistics: This section displays some

statistics about the contents of the

database, e.g., counts of some different file

types, total size of the contents, and number

of words in the index of the database.

Additionally, it reports the number of indexed

or replicant items. And for an encrypted or

revision-proof database, the space used and

available is listed.
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DOWNLOAD MANAGER

DEVONthink's Download Manager panel

is a tool for downloading files or complete

web sites. Offline archives can make a local

copy of a site to use when your you're not

connected to the Internet. This panel also

supports URLs for local files, including POSIX

paths, a file://localhost/ URL, or a

file:/// URL. You even have the option to

either store the information in your database

or in a Finder folder.

PANEL ELEMENTS

Opened via Window > Download Manager

opens, the Download Manager panel consists

of:

A list of a items to be downloaded

A status bar at the bottom

A  button for adding items to and a 

button for deleting selected items from the

list

A  reload button

A Start/Stop button to enable or disable

downloads.

An  Action menu where you can set the

download location and access options.

ADDING FILES

There are a few different methods for adding

files to the Download Manager, one of which

likely fits your use case:

Drag and drop a URL from anywhere, e.g.,

from Safari's address bar.

If you have copied URLs, from bookmarks,

links in DEVONagent Pro, etc., you can

paste them into the panel.

Click the  in the panel and add the

URL manually. Optionally, You can enter

the Referrer, Username, and Password,

if known and required. And if the

Automatic option is enabled, DEVONthink

automatically creates a referrer when

downloading whole web sites.

When browsing web content or viewing

files with web links in DEVONthink, you can

add URLs via the context menu.

ACTION MENU

Most actions are available through the Action

menu or the context menu. Click the 

gear button or Control-click an item in the

Download Manager panel to display more

commands:

Add: Manually add a URL to the list.

Edit: Edit the parameters of a selected URL

in the list.

Retry: Attempts to reload an item that

failed to download.

Remove: Removes the selected items from

the list. Alternatively, you can press the

⌫ Backspace or ⌦ Delete key.

Enable/Disable: Checks or unchecks the

selected items. Only checked items will be

downloaded.
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Start/Stop Queue: Starts or stops the

download queue. Same as the play/pause

buttons at the bottom of the panel. Note

this will only pause queued items. Any in

progress downloads will continue.

Purge Queue: Manually removes all

downloaded items from the list.

Only Added Files to Thumbnail Gallery:

Offers various predefined option sets (see

below).

Download to: Choose where the

downloaded files are stored, either in a

Downloads group in a chosen database or a

Finder folder set in the panel's Options.

Options: Opens the options dialog sheet,

which allows you to specify in detail what

to download, which links to follow, and

where to store the downloaded files (see

below).

Pre-defined Settings: For your convenience,

DEVONthink comes with predefined option

sets that you can directly select from the

action menu.

Only Added Files: Downloads only the files

you have manually added to the Download

Manager.

Offline Archive: Downloads the files you

have added to the Download Manager

including embedded images, style sheets,

and scripts. Use this option set to archive/

download web pages with everything

necessary to display them properly.

Alternative: Create a web archive.

Subdirectory (Complete): Downloads the

files you have added to the Download

Manager including all embedded or linked

files. This option set follows all links leading

to (items in) sub-directories. For example,

use this option set to download a complete

web site for offline archiving.

Subdirectory (Images & Multimedia):

Same as above, but downloads only

linked images, linked multimedia files

including Flash and QuickTime movies,

and embedded images in the item's

directory and all sub-directories. Use this

set to download a complete web site for

offline archiving (without all linked Office

documents, PDFs, etc.)

Thumbnail Gallery: Downloads the files

you have added to the Download Manager

including linked images, embedded images,

style sheets, and scripts. Use this option

set to download a thumbnail gallery

including all full-size images linked to each

thumbnail for offline archiving.

OPTIONS

The options dialog defines which file types

are downloaded, which links it follows, where

it stores the files, etc.

Files: Check all file types you want the

Download Manager to download (plain

texts, rich texts, Office documents and

PDF files, style sheets and scripts, images,

embedded images, multimedia files, mark-

up language files, etc.) Use the Follow

Links pop-up menu to define how far

DEVONthink should follow links on the

downloaded HTML pages (see below).

Check Overwrite existing to update an

existing archive.

Overwrite existing files: Use this to update

an already downloaded page.

Folder: When you choose Download to >

Folder, DEVONthink stores all downloaded

items in the Finder folder you choose here.
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Click Set then browse to and choose your

preferred location in the Finder. Double-

click any part of the location to reveal it in

the Finder.

Download: Define how many connections

the Download Manager opens at the same

time. We recommend leaving this at  unless

you have a specific need to change it.

Automatically purge queue: Removes

successfully downloaded items during the

process.

Follow Links: These options define how

deeply DEVONthink follows links on the

downloaded HTML pages. This feature allows

you to control what gets downloaded--only

the actual pages or a complete web site.

DEVONthink supports the following options:

Off: Does not follow any links.

On Same Host: Follows links, but only as

long as they refer to the same web server/

web site. Files on other web servers will not

be downloaded.

In Same Directory: Follows links, but only

as long as they refer to items in the same

directory as the downloaded HTML page.

In Subdirectories: Follows links, but only

as long as they refer to items in the same

directory as the downloaded HTML page or

its sub-directories.

One Level: Follows all links regardless of

where they point, but only one level deep.

Links on pages linked to from the original

page are not downloaded.

Two Levels: Follows all links regardless of

where they point to, but only two levels

deep.

Note: Following links two levels deep can

result in very large downloads.

MCP MENU EXTRA

If you have enabled Launch at login in the

AI > MCP settings, an  icon appears in the

menu bar at the top of the screen. Click on

it to access information and controls for

DEVONthinks' MCP server.

About DEVONthink MCP: — the standard

About panel.

Settings…: Opens the AI > MCP settings.

Stop/Start Server: Pauses and resumes

the server without quitting it.

Server Running: Shows the status of the

server and the port while running.

48 Tools Available: Lists the number of

available MCP commands.

Copy Server URL: Copies to the clipboard

the URL to be used when setting up access

to the server.

Quit DEVONthink MCP: Stops the server

and its processes.

You can read more about the MCP server

in the Getting Started > AI in Practice and

Appendix > MCP Server sections of this

document.
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LOG

The Log panel is an informational window.

It displays a variety of messages, including

things like the number of emails imported,

warnings about database health, or errors

from script actions in smart rules. The panel

shows the date of the message, any affected

files, and a little information about what

happened. If you feel you are having sync

issues, this panel is the first place to look.

When doing any database or sync location

maintenance, this is where the results

are shown. You can also use this panel for

your own purposes with the log message

AppleScript command.

You can save the list to a text file with the

Save button, and clear the log with the

Clear button. To sort the log, click a column

title to sort on that column, changing from

ascending to descending each time you click

it. If you Control-click individual log entries

you will be shown options to reveal the

item in its location or move it to the trash.

Alternatively, double-click the entry to reveal

the file.

The Log window will appear with any

messages it has to show. If this becomes

distracting to you, uncheck Show log

automatically. You can always open the panel

at any time using Window > Log. However,

for important notifications, the log is always

shown automatically, regardless of this

setting.

ACTIVITY

The Activity panel shows a list of currently

running background processes, e.g.,

converting scans to searchable PDFs,

refreshing news feeds, downloading PDF

documents and web archives via our browser

extension, or sync activity. You can manually

open this pane via Window > Activity. You

can manually stop them to free computer

resources or for other reasons.

There is also an Activity pane at the bottom

of the Navigate sidebar. Providing a less

intrusive experience, this pane will appear

and disappear quietly on its own.

Note: The Activity window is only used if

it was opened by the user or if there is no

main window to show an Activity pane.

HELP

DEVONthink's extensive documentation is

available in its own window.

DEVONthink 4.3.2 Documentation, page 167



Opened via Help > DEVONthink Help, you

can easily navigate through an alphabetical

listing of its chapters and sections. You can

also click the chapter headers in the sidebar,

e.g., Getting Started, to read the introductory

text and the section links for that chapter.

Note the previous/next links in the section

footers link to the defined structure of

the documentation, not the alphabetical

list shown in the sidebar. And for your

convenience, the Help viewer remembers the

last page you were viewing.

As you're reading and clicking links to jump

to other parts of the help, you can navigate

backward and forward through visited

sections with left and right swipes. Zoom in

and out with a double-finger tap or pinch-

to-zoom. If you select text on a page, many

services are available, including several of our

own.

The toolbar of the Help window dynamically

displays the current chapter and section.

On the right, you have < and > buttons to

navigate to and from pages you've visited.

The toolbar also includes macOS Share and

Print buttons so you can share or print the

section you're currently viewing. You'll also

notice a toolbar search field. Supporting

wildcards and operators, do simple or

complex searches of the help, e.g., index*

NEAR sync . The sidebar will display a list of

matching pages with a relevance indicator for

each result.

Help Assistant: Of special note is the the

AI inspector on the right. Toggled via the 

button at the upper right, you can ask natural

questions about the documentation. You can

even ask for responses in another language.

This feature uses your default AI engine to

answer questions about the documentation.

It can use commercial LLMs, e.g., ChatGPT

and also OpenRouter, using GPT 4.1 Mini when
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chosen. To minimize costs, the cheapest

but still useful model from your provider is

automatically chosen. For your convenience,

the chat responses typically list links to the

appropriate pages in the documentation so

you can jump right to the desired pages. And

if are in need of auditory responses, you can

enable Speak chat responses.

SUPPORT ASSISTANT

The integrated Support Assistant combines a

welcome screen with a first launch assistant,

tips, installable extras, and a support page

that guides you through the available support

options.

WELCOME

This screen welcomes you when you start

DEVONthink for the very first time. It offers:

The option to subscribe the free

DEVONtechnologies newsletter, as well as a

number of welcome tips

The tip of the day

The extra of the day

Click the links at the bottom of the window

to access the other Support Assistant

sections. You can also check or uncheck the

Show this window when DEVONthink opens

checkbox at the bottom of the window to set

whether to show the Support Assistant each

time DEVONthink is launched.

FIRST LAUNCH ASSISTANT

The first launch assistant opens

automatically the very first time you open

DEVONthink, and guides you through the

first steps of using the application: creating

a new database, installing the add-ons, and

adjusting the preferences.
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GET SUPPORT

The Support screen guides you through the

three common steps for troubleshooting

DEVONthink. In addition, you can update

your details in DEVONtechnologies' customer

database, or buy an upgrade or a second

license.

INSTALL EXTRAS

On the Extras screen, DEVONthink lists all

available extras that you can download and

install from DEVONtechnologies' server. This

includes scripts, smart rules, and templates.

Browse the list of extras and install them

with the Install button. The last line of the

description shows where in the Scripts or

Data > New from Template menu the extra

will show up after installation. Remove

installed extras with the Remove button.

The extras are updated live from

DEVONtechnologies' server so it's a good

idea to check back from time to time. The

latest extra is also always mentioned on the

welcome screen. If you check the Install &

update extras automatically checkbox at the

bottom of the window, any updates to scripts

or templates you've downloaded here will be

updated as needed.

Note: If one of these categories does not

show up in your copy of DEVONthink, there

might be no extras of this type currently

available.
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TIPS AND TUTORIALS

Here you can find the latest tips and

tutorials to help you squeeze the best out

of DEVONthink. Tutorials can be slideshows

describing basic tasks in DEVONthink or

screencasts.

Both tips and tutorials are updated live from

DEVONtechnologies' server so it's a good idea

to check back on a regular basis. The latest

tip or tutorial is also always mentioned on the

welcome screen.
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The Inspector panes displayed on the right

side of a main window provide an incredible

amount of information and functionality

when working with files in DEVONthink.

Covering a range of options, from basic

metadata to setting reminders to in-

document search and replace functions. Each

of the Inspectors is individually covered in

this chapter.

INFO PANE

The Info pane, just like its counterpart in the

Finder, displays additional information about

a selected document or group, from icon and

name to comments and other metadata.

Open the Info pane by selecting Tools >

Inspector > Info > ….

Note: When you have multiple items

selected, some editable attributes can be

modified. For example, tags can be applied

to multiple files at once. However, if you

add tags to the same files separately, only

tags common to them will be shown if you

select them together again.

GENERIC

The Generic view shows additional basic

information about a selected document or

group, similar to what is shown in the Get

Info window in the Finder. Additionally, it

shows some other attributes like ratings,

color labels, and geolocation data. Here are

the attributes shown:

Icon and Name: Displays the name of the

selected item. To change the icon of the

item, select it and paste any image you

want over it. To change the name of the

item, use the Name field below.

Name: Displays the name of the selected

item. This is an editable attribute.

Original: Displays the name of a document

as it was originally imported or created.

This cannot be changed. A popup menu has

Copy and Rename commands, the latter

resetting the current name back to the

original name.

Aliases: Displays any aliases for the

selected item. Enter one or more words
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here, separated by semicolons, as

alternative targets for Wiki links. Generally,

Wiki links refer to the name of contents,

and aliases make this system even more

flexible.

URL: Displays a URL associated with the

selected item. This is an editable attribute.

While it is typically used for web addresses,

it also may contain other types; e.g., file

URLs, URL with custom schemes, etc. Click

the down arrow and choose: Launch to

open the URL, Copy to copy the URL to the

clipboard, or Remove to clear the URL.

Path: Displays the item's file's path in the

Finder. This is not an editable attribute.

Click the down arrow and choose: Launch

to open the file in the system default

application; Show in Finder to open a

Finder window with the file selected, and

Copy to copy the file path to the clipboard.

If you are indexing files, there is a Path

option that allows you to select a folder

or volume. If you have moved indexed files

to a new location, this option can be used

to select the new location, provided you

have not renamed any of the files before

updating the path.

Attached Script: Displays the name of a

triggered script that runs when you select

the item in the database. Click the down

arrow and choose: Select to choose a

triggered script to attach, or Remove to

remove the script from the item.

Added: Displays the date an item was

added to the database. This is not an

editable attribute.

Created/Modified: Displays the date an

item was created or modified. These are

editable attributes. Click the calendar icon

to choose a date and time. You can also

select individual parts of the date or time

and type or modify them with the up and

down arrows. When typing, press the ⇥Tab

key to commit the change.

Size: Displays the size of the item. For

groups and news feeds, this field shows the

size of all contained items.

Kind: Displays the kind of the selected

item. For documents, the file type will be

shown, e.g., Markdown.

Location: Displays the location of the item

in the database. This is an active item;

hovering over items will display their full

names and clicking them will navigate to

the clicked group.

Instances: Displays how many duplicates

or replicants of the selected item are in

the database. Click to show a pop-up menu

listing all instances and duplicates and their

enclosing groups. Select any item to reveal

it.

Format: For news feeds you can set the

default format in which new articles are

saved.

Color: Set a color for a selected tag or

group. Click the title Color for options to

clear, copy, or paste an item's color.

Geolocation: Displays geolocation data

based on the creation origin of the file;

i.e., the geographic location when the file

was originally created. This is an editable

attribute and can be changed if you'd like

the location to be relative to something

else, e.g., the site of a historic event.

Marks: Displays these attributes for the

selected item: Flagged, Read, Locked,

Rating, and Label.

Tags: Displays the tags applied to the

current item. Click the + button to add a

new tag. Tags will be suggested from the
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existing tags in the current database or

from all database tags if the document is

in the Global Inbox. Click an added tag to

reveal the Tag group, or remove it from the

selected item.

Exclude From…: These checkboxes allow

you to exclude an item from being used in

various ways. For example, you can exclude

temporary groups from classification to

increase the accuracy of the built-in artificial

intelligence. You can exclude an item from

these operations:

Chat: When enabled on any item, it will

no longer be accessible via any external

AI function, including database searches,

batch processing and smart rules,

summarizing documents via chat, etc.

Classification: When enabled on a group,

this will keep DEVONthink from suggesting

or using the group as a possible filing

location.

See Also: When enabled on any file,

DEVONthink will not include it as an item

potentially related to the current file.

Search: When enabled on any item, it will

no longer appear in toolbar search results,

smart groups, or smart rules.

Tagging: Used with group tags and  Tag

groups, this inhibits the Tag from being

applied to any item.

Wiki Linking: When enabled on any item,

it will not be detected by automatic

WikiLinking.

DATA

The Data view displays custom metadata

fields and their values. These custom fields

are defined by you in Settings > Data. All

available fields you have defined are shown in

this pane. Note some fields may be specified

as data types that include some extra actions

in this view. For example, if you create a

custom parameter with an Item Link data

type, you will have an option to reveal the file.

Item Link: Click the down arrow and

choose: Reveal to reveal the item in the

database.

Single-line Text: Type in a value or click the

dropdown menu to choose from a list you

defined in the preferences .

URL: Click the down arrow and choose:

Launch to open the URL or Copy to copy

the URL to the clipboard.
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ANNOTATIONS & REMINDERS

This pane contains Reminders, Finder

Comments and Annotations. It can be

shown via Tools > Inspectors > Annotations &

Reminders.

Reminders: While there are many reminder

applications, including Apple's own

Reminders, sometimes you just want to set a

quick reminder for an item, or multiple items,

in DEVONthink. The Reminders section allows

you set a reminder, including recurring ones

with optional alarms.

After choosing a schedule, set a date and

time for the reminder or to begin a recurring

reminder. For recurring alarms, the data or

time you set will be the beginning of the

alarms. Reminders can be set to:

Once: Only trigger an alarm once.

Hourly: Set an hourly reminder, triggering

at the minutes of time you set, e.g, 10:15,

11:15, etc. Set an interval for how many

hours should elapse before the next

reminder, e.g., 4 for every four hours.

Daily: Set a daily reminder, triggering at

the hour and minutes you set, e.g., daily at

9:35 AM. Set an interval for how many days

should elapse before the next reminder,

e.g., 2 for every other day.

Weekly: Set a weekly reminder, triggering

at the hour and minutes you set. Choose

a day of the week the reminder should

trigger on. Set an interval for how many

weeks should elapse before the next

reminder, e.g., 3 for every third week.

Monthly: Set a monthly reminder,

triggering at the hour and minutes you set,

e.g., daily at 9:35 AM. Set an interval for

how many months should elapse before

the next reminder, e.g., 1 for every month.

Choose Each and set which days of the

month you want a reminder, e.g., the 1st

and 15th of the month. Alternately, choose 

On the … to choose a regular interval like

the second Thursday of the month.

Yearly: Set a yearly reminder, triggering

at the hour and minutes you set, e.g.,

daily at 9:35 AM. Set an interval for how

many years should elapse before the next

reminder, e.g., 1 for every year. Choose

which months you want a reminder. Also,

choose On the … to choose a regular

interval like the last day of those chosen

month(s).

Alarm: Reminders are most useful when

you have an alarm to, well, remind you of

something. There are several alarms available

for a reminder:

Bounce Dock Icon: Bounce the icon in the

dock. This will only occur if DEVONthink is

not the active application.

Display Notification: Displays a notification

using the Notification Center, appearing

at the upper right of your screen. The

message shown can be a combination of

static text and placeholder text. It defaults

to the Name placeholder. Control-click

and choose Insert Placeholder to add
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additional placeholders. Note System

Settings > Notifications > DEVONthink

must be enabled for this alarm to display.

Notifications are also only shown when

DEVONthink is not the frontmost

application.

Display Alert: Displays an alert dialog when

DEVONthink is or becomes the active

application. If it's not frontmost, the dock

icon will bounce until you switch to it.

Like Display Notification, this contains

static and placeholder text, and defaults to

Name.

Speak Text: Using the Mac's speech

synthesis, this alarm will speak the

specified static and placeholder text.

Play Sound: Choose one of the system alert

sounds found in System Settings > Sound >

Sound Effects.

Send Mail With Item Link/Attachment:

Enter email addresses to which to send

the matching items. This can be a comma-

delimited list of addresses, names, or enter

the name of a group you've defined in your

contacts. The email contents will contain

either an item link to the selected file or it

will attach the file itself.

Add to Reading List: Add the file to

DEVONthink's Reading List.

Open: Open the document in an a

DEVONthink document window.

Open Externally: Open the document in the

system default application.

Launch URL: Opens the URL associated

with the document, if present.

Execute External Script: Run a selected

script. External scripts are stored in

~/Library/Application Scripts/

com.devon-technologies.think/

Reminders. Add your own scripts to this

location to make them available for use

with reminders.

Execute AppleScript/JavaScript: Run

an ad-hoc script written for the current

reminder. Press the … button to display a

popup pre-populated with a core script

in the chosen language. Edit this and

press the compile button at the lower left.

Embedded scripts are only available to the

reminder in which they are created. If you

want to use the same script with other

reminders, consider using an external script

instead.

As a bonus, reminder alarms will open

databases containing the item when an alarm

triggers.

Note: When setting a reminder on multiple

items, alarms are delivered individually. For

example, an alert notification will show for

each file, even if they were set for the same

time.

If you are interested in the use of scripts in

alarms, you can read more about them in the

Reminder Scripts chapter of the Automation

chapter.

Finder Comments: Similar to the Comments

in the Get Info pane in the Finder, the

Finder Comments field can be used to store

miscellaneous bits of information about the

selected objects.

Note: These comments will not appear in

the files in the Finder unless the files are

indexed or exported from the database.

Annotation Files: This pane displays or allows

you to create annotation files for a selected

document. Annotation files are separate files

where you can store notes about a specific
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document. These files can link back to the

original file for quick access. Commonly used

with PDF files, they can actually be used for

making notes with any document in your

database.

Above the annotation pane are a set of three

buttons:  to open the annotation file,  to

insert a back-link to the current document,

and  to insert selected text as a quote.

If an annotation file doesn't exist, you can

make one with the commands from the down

arrow in this section.

New from Template: Opens a submenu

containing three options: Create an

Annotation file from the default template,

choose a custom template added to

DEVONthink's internal Annotations folder,

or open the Annotations folder to access

any custom templates you've added.

New from Clipboard: Choose this option

to create an annotation with content from

the clipboard.

Open: Open the annotation file.

Reveal: Reveal the annotation file in its

current location.

Insert Back Link: This inserts a back link

to the original file into a new annotation

file. If no annotation file exists, one will be

created with this command.

Insert Still Image: Inserts a thumbnail from

the currently viewed video associated

with this annotation file. Playback must

be paused to use this command. If you

are using Markdown annotation files, we

recommend you have enabled Import

images to group in the Files > Markdown

settings to store the thumbnail as a linked

file.

Insert Quote: This inserts both the

selected text and a backlink to the page

or paragraph in the original file. If no

annotation file exists, one will be created

with this command. This option is only

supported by PDF, plain text, and rich text

documents.

If an annotation file is detected by

DEVONthink or you've just created one,

an editable preview of the file will appear

here. Clicking the down arrow reveals these

options:

Insert Back Link: Insert a link back to

the original document in the current

annotation file. With audio and video

files, the back link will include the current

playback time. With multi-page PDFs, the

back link will include the current page.

There is also a Insert Back Link button

above the editing pane.

Insert Quote: Inserts selected text an a link

to the current page. This command also has

an Insert Quote button above the editing

pane.

Insert Summarized Annotations: Inserts a

summary of the document's annotations,

similar to what is produced via the Tools >

Summarize Annotations commands. The

format of the summary is dependent on

the format of the annotation file.

Export: Exports the current annotation

file to the Finder in one of these formats:

PDF, rich text, plain text, or Word (.doc)

formats.

Remove: Moves the annotation file to

the database's Trash and removes the

reference from the original document.
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Insert Summary via Chat: Summarizes the

current document or its selected text and

allows you to insert the summary directly

into the annotation file.

Insert Transcription: Inserts recognized

text from an image or speech from a media

file. This is used when the text has been

transcribed to searchable text.

Settings: There are a few annotation-specific

options in the Files > General settings. Set

whether annotation files are created in an

shared Annotations group at the root of

the database or in the same group as the

referring document. Enable Move annotations

automatically to have an annotation file

"follow" the document it refers to if it moves

to another database. And with Rename

annotations automatically and Update name

of items links in the WikiLinks settings,

renaming the referring document instantly

changes the annotation file's name and the

backlink text.

Creating an Annotation File: DEVONthink has

a built-in default annotation file in rich text

format, suitable for general use. However, you

can create your own custom template in plain

text, rich text, or Markdown formats. These

files can be created externally and added

to ~/Library/Application Support/

DEVONthink 3/Annotations.noindex

or created in DEVONthink and exported

via File > Export > as Template to the

Annotations.noindex folder.

To create backlinks to the original file, there

are two placeholders for use in the body of

your template:

%documentName%: Resolves to the name

of the original document.

%documentLink%: Resolves to the item

link of the original document.

Rich Text: To create the backlink in a rich

text template, use the %documentLink%

placeholder and the document name will be

added as the link's text.

Markdown: To create the backlink in

a Markdown template, use the form:

[%documentName%](%documentLink%).

Plain Text: Since plain text files don't support

live links, you can use WikiLinks to create a

backlink. For example, if you are using the

Square Brackets WikiLink syntax, you could

use [[%documentName%]] in the body of the

plain text.

PROPERTIES

The Document Properties section gives you

access to certain format-specific metadata.

Supported formats are: RTF, PDF, audio

or video with metadata, or images. This

metadata can include some of the following:

Author

Company

Copyright

Title
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Subject

Keywords

Comments

Organization

Depending on the document type, you may

be able to edit or view these properties. More

fields may be available depending on the

document type.

There are two parameters supporting extra

actions:

Click the Title button and select Copy, or

select Set Name As to quickly change the

document's name.

Click Keywords and choose Convert to Tags

to apply the keywords as DEVONthink tags.

CONTENT

Navigating documents, like PDFs, can

sometimes be difficult when you are

just scrolling page after page, paragraph

after paragraph. Fortunately, the Content

Inspector provides two views that make it

easier to move through your documents:

a Table of Contents for various types and

Thumbnails for PDF documents.

TABLE OF CONTENTS

The Table of Contents shows an outline

view of PDFs with an table of contents,

chapters in .epub files, section headings of

Markdown documents, or sections in rich text

created with emboldened or underlined lines.

Browse the outline as you would in outlining

applications, expanding and collapsing

sections to access the desired pages. This

inspector also supports selecting multiple

pages, which could be useful if you need to

copy page links via the context menu.

For even quicker navigation, the table of

contents can be navigated via keyboard,

using the arrow keys to move around. Change

pages with up and down arrows. Expand and

collapse a section with the left and right

arrows or hold the ⌥ Option key to fully

expand or collapse sections.

When used with Markdown, rich text, and

PDF documents, you can drag and drop

sections and it will rearrange the text in the

document.

Context Menu: The context menu commands

available in this inspector depend on the type

of document:

PDFs:

Show/Hide Page Number: Toggles the page

number of each section on or off.

Select/Deselect All: Select or deselect all

the sections.

Rename: Change the name of a section in

a PDF outline. This change is only for your
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reference. It doesn't change the text in the

document.

Delete: Removes a section from a PDF

outline. This does not remove content or

pages from the document.

PDFs and supported types:

Copy Page/Section/Paragraph Link: Copies

the item link with the page number to the

clipboard. PDFs and .epub files support

page links. Markdown supports section

links. Rich text supports paragraph links.

THUMBNAILS

Used only with PDF documents, the

Thumbnails view show each page in a list

of thumbnails. This allows for a more visual

approach to moving through your document.

By default, the thumbnails are shown in a

single column but they can be displayed in

multiple rows if the sidebar is widened. This

view allows for actions like these:

Jump to or select any page by clicking on it.

Extend a range of selected pages by holding

the ⇧Shift key to select consecutive pages

or hold the ⌃ Control key to select non-

consecutive pages.

To quickly remove unwanted pages, press

the ⌫ Backspace key.

If you want to reorder some pages, select

a page then drag and drop it within the

thumbnails. A blue line will appear at the

place the pages will be inserted. This will

also work if you drag thumbnails from one

PDF to another.

Drag selected pages to another location in

your database and DEVONthink will create

a new PDF containing only those pages.

Context Menu: You also have several options

available in the context menu when you

Control-click in the Thumbnails view:

Cut/Copy: Cut or copy the selected

page(s) to the clipboard.

Copy Page Link: Copies the item link with a

reference to the current page.

Add to Reading List: Adds a reference to

the current page to the Reading List.

Add to Table of Contents: Adds an outline

item to the table of contents.

Paste: Pastes a copied PDF page into a

document.

Split Document: Splits the document

at the current page. A new document is

created from the preceding pages and

removed from the current document. This

item is unavailable when the first page of

the document is selected. Also, note this

action cannot be undone.

Reverse Page Order: Reverses the page

order of the document.

Insert Blank Page: Insert a new blank page.

Delete Selected Page(s): Delete the

selected page(s).

Rotate Left/Right: Rotate the selected

page(s) left or right.

Select/Deselect All: Select or deselect all

pages in the document.
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PDF Bookmarks: The Add to Table of

Contents command mentioned above allows

you to add bookmarks to specific pages.

If there is no table of contents, one will be

created. With the option of reorganizing and

renaming items, you can create a very custom

table of contents specifically for you.

DOCUMENT

The Document inspector provides specific

information about the current document.

This information is presented in four

specialized views: annotations, e.g., highlights

in a PDF, attachments like images in .rtfd

files, links detected in the document, and a

list of other documents mentioning the name

or an alias of the current one.

ANNOTATIONS

This inspector displays a listing of the

annotations in the current document,

including PDFs, rich text, Markdown, and even

web-based formats like formatted notes.

Each annotation is listed with the following

metadata: Page, Type in color, Content, and

the Date the annotation was added. In the

case of highlights, Text, and Note annotations

show the text in them. Rectangle annotations

will show what is on the page under it. Oval

and Line annotations display the Author set

in Editing > General settings.

Easily navigate the document by selecting an

annotation to jump to it. To reorder the list,

click the desired header, e.g., Type, to sort

on it. This makes it easy to navigate via the

document's annotations.

At the bottom of the view is a Details

section. This displays the content of Note

and Text annotations and can be edited

directly here. Details can be added to other

annotation types as well, but only supports

plain text entries.

Context Menu: The Annotations list offers

the following commands:

Copy: Copies the metadata and any text in

the Details to the clipboard as unformatted

text. This pastes as plain text or creates a

new sheet via Data > New From Clipboard.

Copy Annotation Link: Copies an item link

pointing to the selected PDF annotation.

Copy Page Link: Copies an item link to the

current page in a PDF.

Copy Paragraph Link: Copies an item link to

the annotated paragraph in Markdown and

rich text.

Delete: Deletes the current annotation.

Select/Deselect All: Quickly select or

deselect the items in the list.

DEVONthink 4.3.2 Documentation, page 181



ATTACHMENTS

This inspector displays any attachments or

embedded images in the current document.

For example, in an imported email, you can

see and access the attachments individually.

Bookmarks and HTML-based files, e.g.,

formatted notes, display linked images. In

Markdown, transcluded and locally linked,

e.g., relatively linked, images show in preview

mode; local, item, and WikiLinked images

display in source mode. You can navigate

the document by selecting an attachment,

jumping directly to it.

Context Menu: Opening the context

menu in the Attachments list offers a few

commands. Some are only shown in certain

circumstances:

Open In: Opens images in viewed

bookmarks in the system default browser.

Open in Tabs: Opens each image in a tab in

the current window.

Copy/Copy Name: Copy the attachment as

a file or just its name.

Delete: Removes the attachment from the

document, if the behavior is supported.

Open: Opens the selected attachment

in the system default application, e.g.,

Preview for images.

Select/Deselect All: Quickly select or

deselect the items in the list.

Add to Downloads: Add the attachment to

the Download Manager when viewing linked

images in web content.

LINKS

This inspector lists links detected in the

selected document. These may be web URLs,

file URLs, item links, and even DEVONthink's

WikiLinks. This provides a thorough list of

links you can view and even use. (You may

be surprised by the number of links in many

documents.)

The top section of this inspector is the Links

view, displaying a list of any outgoing links,

i.e., links to other files, websites, etc.

Select a link in the list to show the link

in the current document. But these links

are active. If the link is to a document in

DEVONthink, double-click a link to open

it in a document window or an external

application. Links to web pages launch in your

browser. And if the link is a URL scheme, e.g.,
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mailto:support@devontechnologies.com,

double-click it and it will start an email in your

default email application.

Context Menu: The context menu in the Link

list offers the following options:

Open In: Opens the link in the system

default browser.

Open In DEVONthink: If the link points to a

document in DEVONthink, this opens it in a

new document window.

Open in Tabs: Opens the linked document

in a tab in the current window.

Copy/Copy Name: Copy the attachment as

a file or just its name.

Delete: Removes the attachment from the

document, if the behavior is supported.

Open: Opens the selected attachment

in the system default application, e.g.,

Preview for images.

Select/Deselect All: Quickly select or

deselect the items in the list.

Add to Downloads: Add the attachment to

the Download Manager when viewing linked

images in web content.

The bottom section of the inspector is

the Incoming Links section. This shows

DEVONthink documents containing links to

the current one. Selecting a document here

will display it in the view/edit pane. Double-

click it to open it in a document window. You

can actually select these documents and drag

and drop them to another location. Be aware

the default behavior is moving them but you

can use hold modifier keys while dragging to

duplicate or replicate them instead.

In the Incoming Links section, the context

menu has these commands:

Open In DEVONthink: Opens the document

in a new document window.

Open in Tabs: Opens each image in a tab in

the current window.

Reveal: Displays the document in it

location in your databases.

Copy/Copy Name: Copy the attachment as

a file or just its name.

Select/Deselect All: Quickly select or

deselect the items in the list.

MENTIONS

This inspector is similar to the Incoming Links

pane of the Links inspector, however it works

with something called "mentions". Imagine

you have a document named "NASA". As

you're writing about the Apollo 13 mission

in another document, you include the

word "NASA". You have just "mentioned"

it. If you look at the NASA document, the

Apollo 13 document is now listed in this

inspector. Mentions also work with aliases on

documents and powerfully includes mentions

from any indexable file type, including PDFs.

Select a listed document to show a summary

of the mentions in the lower pane. Double-

click one to open it.
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Context Menu: The Mentions section

uses the suite of same commands as the

Attachments and Links views, but also one

special command: Copy Summary. This

copies the text from the Occurrences pane

for the clicked document. This can be used

to create a new document or pasted as rich

text.

CONCORDANCE

The Concordance pane, opened in the Tools

> Inspectors menu, gives you a tool for

analyzing the textual contents of documents.

When the inspector is open, selecting

different items will show varying results.

If one or more documents is selected, the

results will be inclusive of the text in all of

them. If there is no selection, the results

will be based on the text of documents in

the current location, whether a group or a

database. This also applies to selecting items

matched in smart groups, both local and

global.

These results are presented in two views: List

and Cloud.

LIST

The List view displays the concordance

results in a list, separated by these

parameters:

Word frequency

Number of groups with items containing a

specific word

Word length

Word weight (relevance, depends on the

contents of the database)

Alphabetical listing

Click the column headers to sort on a

given parameter. Select a word in the list

to highlight all occurrences in the current

document. Double-click a word to open a

database-wide search for the term.

Context Menu: The following commands are

available in the context menu of the List

view:

Copy: Copies the values for the selected

word to the clipboard.

Add to Tags: Adds the selected word(s) as

a tag to the selected items.

Select/Deselect All: Quickly select or

deselect the items in the list.

Exclude/Include Word: Use this to define

stop-words or to include them again.

Show/Hide Excluded Words: Select this to

show or hide any excluded terms. Excluded

terms will shown with a strikethrough.
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CLOUD

The Cloud view present the concordance as

a word cloud. The size of the terms is relative

to the frequency in the selection or database.

Selecting terms highlights the occurrences in

the current document.

Context Menu: The commands found in the

List view are also found in the Cloud view,

with two additions:

Export: When used with the word list in

the Cloud inspector, exports a PDF of the

word list.

Sort: Sort the word cloud by Name or by

Count.

RELATED WORDS

Of special note is the Related Words graph

shown under the List and Cloud views. Select

a word in the list or cloud and it becomes

the central term in a graph of related words.

These are words found throughout your

database. Double-clicking a node initiates

a database-wide search. The context menu

provides options for copying the word's

information, as well as excluding the word.

Additionally, use the Export command to

create a PDF of the graph.

Context Menu: The context menu of

this section contains a few of the same

commands: Copy, Add to Tags, Exclude/

Include Word, and Export. The last command

exports a PDF of the graph as shown.

AI

We all have many documents in our

databases and more seem to come in daily.

For the incoming documents, efficient filing

is often needed. For existing documents,

we may need to locate related documents.

These inspectors are driven by DEVONthink's

internal AI, the "brain" of our application.

It stays busy analyzing the contents and

locations of all the documents in your

databases and making connections between

them.
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SEE ALSO

Choose Tools > Inspectors > See Also to open

this inspector. When the inspector opens,

you will be presented with two sections,

Groups and Documents, each containing

suggestions to assist in filing the document

or recommending other related documents.

Groups: Based on analyzing the contents

of the current document, the AI cross-

references the contents and locations of

other files in the database. The results are

shown in the Groups section. This list offers

a range of suggested locations, displaying a

heat-mapped score of its relevance and the

location of the group. The highest ranked

suggestion is presented first. Obviously,

you can choose any of them. If there's a

group you'd like to use, double-clicking the

suggested group will file the document for

you. You can also click the Move to button,

press ⌃C, or drag and drop to file it in any of

the suggested groups. Lastly, if a suggested

group is in the same database as the selected

file, you can hold the ⌥ key and the Move to

button changes to a Replicate button.

Directly above the classify results is a

search field. If there is another group you're

thinking of that hasn't been suggested, type

part of the group name to filter the list of

suggestions. Then file into the location of

your choice.

Below the search field are two options to

help focus the results presented in the

two panes: Based on content, enabled

by default, makes its suggestions based

on content comparisons, while Based on

tags uses only the documents tags for

matching. Since results can be shown for all

databases, Current database only restricts

the suggestions to the active database.

On a related note, in the Data menu, you

will find two menu items using these

recommendations:

Move > Move to … again: Moves a selected

document to the location last used by

classification.

Classify to…: Classifies the selected

document to its top ranked suggestion

shown here.

Documents: Another benefit of the AI's

content analysis is the ability to offer

suggestions of documents that may be

related to the current document. These

files are listed in the Documents section

of the inspector. Like the Groups section,

this list shows the location of the document

and heat mapped score of the potential

relevance. Hovering over a result shows a

tooltip displaying its full title and location.

Select a document in the results to display it

in the view/edit pane. For your convenience,

DEVONthink always lists the original

document near the top of the list. This way

you can select it to go quickly back to the

original document. Double-click a document

to open it in a document window. Drag a

document from the list to move it to another

location. When dragging, you can create

duplicates by holding the ⌥ Option key.

You can also create replicants by holding

⌘ Command and ⌥ Option and dragging to

another location in the database.
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Context Menu:  The context menu items

available in these two sections are the ones

used the item list.

TAGS

As mentioned in the Tagging section in this

help, there are a variety of ways to apply tags

to a document. You can also filter items by

tag in the Tags filter pane. But knowing what

tags to choose isn't always obvious. Driven by

DEVONthink's internal AI, the Tags inspector

lets you view and modify tags as well as view

relationships between tags related to the

current document.

Open this inspector via the Tools > Inspectors

> Tags command. When the inspector opens,

you will be presented with two sections: the

Tags list and Related Tags.

Tags List: Select a document with this

inspector open. The tags list in the top

section displays: tags already applied,

potential tags, or both. Applied tags are

shown in blue; suggested tags in grey

with a dotted border. If you want to add a

recommended tag, double-click it. If you want

to add all the suggestions, press the Add All

(⌃A) button. Clicking the Remove All (⌃R)

button will clear all the document's tags.

And if you want to add tags not listed here,

enter them in the Tags field at the top of the

inspector. As you add and modify tags, the

recommendations will often change. This

helps fine-tune your tagging choices.

If you're working in the Global Inbox, the

suggestions come from any open database.

However, if you're working in a separate

database, only its tags are considered.

Related tags: The bottom section shows

the relationship between a selected tag

and other related ones. Tags applied to the

document are shown as light blue circles

with a solid border connected with a line.

Suggested tags are shown in grey with a

dotted border. Related tags are shown in

varying colors and sizes, depending on how

strong a relationship they have to the central

tag or the others. If a tag has been used with

other tags, they are connected with a line.

Double-click a tag to add it to the current

document.

Context Menu: The context menu in the Tags

list provides these commands, relative to

what is selected:

Get Info: Display the Info popover for the

selected tag.

Reveal: Show the tag in the Tags group of

its database.

Add/Remove All/Selected Tags: Add or

remove every listed tag or just selected

ones.
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Select/Deselect All: Select or deselect all

listed tags.

View as Cloud/List: Show the tags as a tag

cloud or list.

Sort by Count/Name: Sort the tags by

the number of documents in each tag or

alphabetically, both ascending sorts.

Export: Export a PDF of the listed tags as

shown. The resulting document shows the

tags just as they're shown in the inspector.

The context menu in the Related Tags section

contains the Get Info, Reveal Tag, and Export

commands.

Note: As this inspector is driven by our

internal AI, it doesn't suggest tags unless

there is at least one tag already applied.

GRAPH

In DEVONthink, documents connect to other

items in many ways but these relationships

aren't always obvious. Links, content, and

even tags create contextual relationships

that may be important to you. While these

are useful individually, you may want to

see these connections in one place. This

inspector examines a variety of connection

types for the selected document and displays

a network graph of how it is related to other

documents.

Open this inspector with the Tools >

Inspectors > Graph command. Now select a

document. The main area of this inspector

displays the network graph. The current

document is at the center, shown in a red

circle with related documents shown as

satellite nodes. Click the central node and

the connections (technically called edges)

highlight. Direct edges highlight in blue.

Connections between other nodes display

in grey. Now select a satellite node to see its

direct connections. Magnify the graph with

two-finger tapping or pinch-to-zoom. If you

want to jump to a certain item in the graph,

double-click it. It will open in the current

window with a new graph of its relationships.

To return to the previous document, choose

Go > Back or press ⌘[.

When you click on a node, the style of the

connection line is based on the connection

type. These types and styles of connection

lines are shown in a collapsible Show

Connections section at the bottom of the

inspector. For reference they are:

Connections:

Item Links: Documents containing items

links to other documents are connected by

a dotted line.

WikiLinks: Documents detected

dynamically as WikiLinks are displayed by

short dashed lines.

Mentions: Documents whose name is

used in other documents, as shown in the

Mentions inspector, are connected to the

current document by loose, long-dashed

lines.
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Tags: Tags applied to the document are

shown with tight, long-dashed lines.

See Also: Documents determined by

DEVONthink's AI as being contextually

related to the current document, as shown

in the See Also inspector, are indicated by

solid lines.

In the connections key, only available options

are enabled. For example, if there are no tags

applied, the Tags option will be disabled. For

any enabled type, toggle them on or off, as

needed.

Context Menu: If no node is selected, the

context menu supports creating a PDF of the

graph as shown via the Export command.

But if a node is selected, you also have these

options available:

Open: Open the document in a new

document window.

Open in Tabs: Open the document in a new

tab in the current window.

Show in Finder: Open a Finder window

showing the current file selected. Be

cautious using this command with

imported files.

Copy Item Link: Puts the unique URL for

the item on the clipboard.

Get Info: Open the Info popover for the

item.

Reveal: Reveals the item in its current

location.

QuickLook: Displays a QuickLook preview

of the item.

While network graphs like this are visually

interesting, when they become too complex

they lose practicality. DEVONthink strives to

strike a balance between depth and utility so

the graph can actually be used on a regular

basis.

CHAT

This inspector provides a place to "talk"

to your chosen AI provider. Make general

inquiries or possibly even questions about

the selected item or your database. And for

tools-compatible models, it can accept some

DEVONthink-related commands.

Open this inspector with the Tools >

Inspectors > Chat command. The main

area of this inspector is where your chat is

shown, displayed in a style similar to Apple

Messages. At the bottom is the query field

where you ask your questions and commands.

This displays the default AI provider you

chose in the AI settings. To the left of this

field is a dropdown menu where you can

switch to a different model, if available.

At the top of the inspector are a quintet of

buttons, each with a corresponding shortcut:

Clears the current chat to start a new one.

(⌘K)

Copies the entire chat to the clipboard as

tab-delimited text. This can be used in a
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spreadsheet application or to create a new

DEVONthink sheet.

Resends the last prompt. This can be useful

e.g., after changing chat models. (⌘R)

Saves the entire chat to the current

location with a name and format you

choose. Export formats include: Plain Text,

Rich Text, Formatted Note, HTML Page,

Markdown, Sheet, or Messages (JSON).

(⌘S)

Displays a list of recent chats, segregated

by date. Choose a previous chat to reload

it and its settings in the inspector. Also.

this will attempt to reveal or open the

document associated with the chat.

Context Menu: The context menu in the

search hits has these commands:

Copy Image/Subject: Copies an image or

the detected subject of an image to the

clipboard.

Capture Image/Subject: Save a document

from the image or the detected subject of

an image.

Copy/Save Chat: Copy the current chat to

the clipboard or save it as a new document

in your chosen format.

Resend Last Message: Resend the last

prompt entered. Often used after changing

models or for checking a previous response.

Save All Images: Saves images from the

current chat when multiple images exist.

SEARCH

The Search inspector provides in-document

searching for any document whose content

has been indexed. Accessed with the same

familiar ⌘F hotkey you use in most macOS

applications, you can not only search, but

replace found words.

Search and Replace: The top section of this

inspector is not only where you enter your

search terms, but also has controls for how to

match or replace words.

Search field: Enter your search terms here.

By default, substrings are matched, so

searching for board will match board,

onboarding, or clipboard. If you have

multiple words, they must occur in the

document in the specific order you enter

and only the last word supports substrings,

matched at the beginning of the word. You

also can't use quoted terms or advanced

options, like boolean operators..

Previous/Next Highlight: Steps through the

highlighted search hits.

Ignore Case: Choose whether capitalization

affects what words are matched.

Enable Operators & Wildcards: Allow use

of quoted terms and the advanced search

operators and wildcards, like NEAR. If you

enable this you can't match substrings,
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so you'll need to enter exact words or use

wildcards. If you use a proximity operator,

e.g., trouble* NEAR sync* the first and

second terms will show in yellow or green

highlights in the preview.

Replacement text: Enter a replacement for

the terms for which you're searching. Click

Replace to replace the current occurrence.

Choose  to replace all occurrences in the

document. Press In Selection to replace

words only in text selected in the view/edit

pane.

Search Hits: The results provide a convenient

list of the found words. This includes the

line number of each hit and the number of

occurrences found. It also includes part of the

surrounding text to help give some context

to the found words. Click a search hit to

navigate to and highlight the words in the

view/edit pane. Select a search hit and copy

it to the clipboard or drag and drop it to a

database or other document.

Context Menu: The context menu in the

search hits has these commands:

Copy: Copies the selected search hit(s).

Copy Paragraph/Page Link: Copies an item

link pointing to the selected paragraph

for rich text files or the page for PDF

documents.

Capture with Source Link: From a selected

search hit, this creates a new document via

the Sorter with the search term and a link

to its occurrence in the current document.

Add to Favorites: Adds the current

document to the Favorites.

Add to Reading List: Adds the current

document to the Reading List.

Select/Deselect All: Selects all or none of

the items, respectively.

Note: In-document searches only work on

the document displayed in the view/edit

pane.

VERSIONS

For those editing documents, versioning

provides a backup mechanism for your

edits. As you work and save a document,

the current contents of the document is

preserved as a separate version attached to

it. If you make a mistake or want to return

to a previous state of the document, you

can preview and restore a version from this

inspector.

As you work and save the document,

including automatic saves, e.g., when

switching to another document or

application, a new version is added to the

top of the list. Old versions move downwards

and the oldest is purged if you exceed the

maximum number of versions. To avoid

generating too many versions, a new version

is only generated if two or minutes have

elapsed since the last save.
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In order to use versioning, it must be enabled

in the Database Properties. This is a per-

database setting so make sure to enable it on

any database you want to use the feature.

Open this inspector via the Tools > Inspectors

> Versions command and select a document.

At the top of the inspector are two buttons

working with a selected version:

QuickLook: Opens a QuickLook window

showing what the selected version looks

like. This is useful when the view/edit pane

isn't open. While this window is open, use

the up and down arrow keys to view each

version individually.

Add Version: Manually create a new named

version. Note named versions are retained,

not purged when your maximum number of

versions is reached.

Restore Version: Replaces the contents of

the document with the contents of the

selected version.

Delete Version: Deletes the selected

version.

Beneath these buttons are the Flag column

and versions info. The version info displays

how many version exist for the document and

the aggregate total space these versions use.

Every version is locked by default. Select a

version and click the  column to flag it.

The main area of the inspector shows the

versions available for the selected document,

listed from newest to oldest. Each version is

listed with the data and time it was saved,

but also the size of the document for that

version. Versions contribute to the size of a

database so you should thoughtfully set the

number, maximum size, and how long they

should be kept in the Files > General settings.

Context Menu: The context menu in this

inspector contains the same commands

as the suite of buttons at the top. But it

also allows lets you clear everything via the

Remove All Versions command.
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MENUS

IN THIS CHAPTER

The Application Menu 193

The File Menu 195

The Edit Menu 199

The Data Menu 201

The Format menu 205

The Tools menu 207

The View menu 210

The Window menu 213

The Go menu 214

The Scripts menu 215

The Help menu 216

The Dock menu 217

A complete listing of all the commands

available in the menu bar of DEVONthink, the

Services menu, and the context menu of the

DEVONthink's Dock icon.

THE APPLICATION MENU

The DEVONthink menu is a utility menu,

similar to those found in other Mac

applications. It has commands that allow you

check the version via the splash screen or

check for application updates. You can install

our add-ons, access the settings, access the

Services menu, empty your databases' Trash,

and quit the application.

ABOUT & CHECK FOR UPDATES

About DEVONthink: Shows information

about DEVONthink including the version

number to whom the software is registered.

Check for Updates: Checks if updates

for DEVONthink are available. By

default, DEVONthink checks for updates

automatically, however you can change the

update settings in the Settings > General >

General. If an automatic update is pending

choosing this command shows a window with

additional information about the update.

ADD-ONS

This command allows you to install, or

reinstall, some of our extra support files and

scripts.
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The following options are available.

Google Chrome Extension: Opens the

Chrome Web/Store  page in Google

Chrome where you can install the browser

extension. You have to do this manually and

follow Google's rules.

Firefox Extension: Opens the Mozilla Add-

Ons page in Firefox where you can install

the Firefox add-on (similar to the Safari

extension). You have to do this manually

and follow Mozilla's rules.

PDF Services: Adds Save PDF to

DEVONthink to the PDF menu of print

dialogs. This allows you to print a PDF

directly to DEVONthink.

Additional Scripts: Installs the mail rule

scripts for Apple Mail, Folder Action scripts

, and Menu extra scripts.

Script Libraries: Installs some popular

third-party script libraries from Late

Night Software: CalendarLib EC, Dialog

Toolkit Plus, PrefsStorageLib, and

RegexAndStuffLib.

Global Inbox in Save Dialogs: Inserts

DEVONthink's Global Inbox into the

Finder's sidebar, making it accessible from

any Open or Save dialog in any application

on your Mac that can save a document.

Note: The name of the inbox is "Inbox"

regardless of your computer's language

preferences.

ABBYY FineReader OCR: Installs the

ABBYY Finereader OCR for creating

searchable content from images and PDF

documents without a text layer.

Note: The Safari browser extension is

now installed by default, but you'll need

to go into Safari's Settings > Extensions

and enable it. Also while extensions for

browsers like Opera, Vivaldi, and Brave

are not explicitly available, it is possible to

install them from the Chrome Web Store,

while in those browsers.

SETTINGS, TRASH, CACHE

Settings: Opens the application Settings.

Empty Trash: Empties the contents of all

open databases' trash to the system trash.

Empty Cache: Empties the web browser

cache. This frees up space and makes sure

that all data is freshly loaded instead of using

a cached copy.

PURCHASE & LICENSES

Purchase: Opens the DEVONthink product

page from where you can put the app

into your shopping cart. If this copy of

DEVONthink is already licensed, you will be

presented with relevant upgrade choices.

Enter License: Enter your purchased license

code here. It is best to use copy-and-paste

for transferring the license code from the

email message to the appropriate field.
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SERVICES

Services: The Services submenu gives you

access to special commands published by

DEVONthink, other Mac applications such as

TextEdit or Safari, or our own WordService or

CalcService utilities.

Hide DEVONthink: Hide all DEVONthink

windows.

Hide Others: Hide other application windows.

Quit DEVONthink: Quits the application.

THE FILE MENU

The File menu contains commands creating

and deleting databases. There are options

for adding or exporting files, as well

synchronizing them. Additionally, if you need

to do database maintenance, you will find

those commands here.

NEW & OPEN

New: Create new databases in your selected

location. Read more about each type in the

Building Your Database section.

Database: Creates a unencrypted

database.

Encrypted Database: Creates an AES-256

encrypted database file at a user-specified

size.

Revision-Proof Database: Creates an

archival database for storing information

that cannot be subsequently modified. This

creates a database that conforms to many

governmental and legal policies.

Open Database: Opens previously created

databases. You can select multiple

databases.

Open Recent: Presents a list of recently used

databases, which gives you quick access to

your frequently used databases. Choose

Clear Menu to remove all items from the

menu.

New Window: Opens a new main window for

a selected database.

IMPORT & EXPORT

Import: The Import submenu contains various

options for importing data, e.g.,selected files,

bookmark, contacts, and some data from

compatible applications. Some options will

import files into their own special groups at

the root of the database.

Files and Folders: Imports selected files

or folders to the current location. Finder

comments will be imported. Finder tags

may be imported if enabled in the Import >

Tags settings.

Bookmarks: Imports bookmarks from:

Brave, DEVONagent Pro, Firefox, Google

Chrome, or Safari. Bookmarks are imported

into a newly created group bearing the

name of the chosen browser. Only new

bookmarks are imported if you use this

command again.

Bookmarks from HTML file: Imports

bookmarks from an HTML file, e.g.,

exported from the Orion browser.

Contacts: Imports Apple Contacts

addresses selected in the import dialog

into a newly created group named

"Addresses". Contacts can be imported as

a sheet, as vcards (.vcf), or as bookmarks.
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Previously created groups are reused.

Tip: To import all addresses, select all

addresses in the group "All" and import

them. Address card bookmarks link to the

original card in the Contacts application.

Folders & Attachments from Notes:

Imports your notes from Apple Notes.

Export: The Export submenu presents

options for exporting selected documents

or groups to the file system. In addition,

the Export menu provides export methods

based on plugins. DEVONthink comes with

a number of standard plugins for exporting

documents in different formats. For these

formats, the export creates a single merged

document when multiple files are selected.

Document: Exports the currently viewed

document in its native format. For images

exported from a separately opened

document window, DEVONthink lets you

choose the desired file format or image

quality; e.g.,you can export a PNG files as a

JPEG file.

Files and Folders: Exports the selected

documents in their native format. Groups

are exported as Finder folders, preserving

the group structure you have built in

DEVONthink. DEVONthink tags are

applied as Finder tags to the exported

files. Internal metadata for the items is

preserved in .DEVONtech_storage files

in the exported folders. These files are

used for reimporting into DEVONthink. If

you will not be reimporting the exported

files, you can safely delete those files. Be

aware the addition date of reimported

items will change, if that is a critical piece

of metadata for your database.

OPML: Exports the selected items as one

OPML file.

PDF Document: Exports the selected items

as a paginated PDF. Hold the ⌥ Option

key to change allow the command to PDF

Document without Annotations.

RTF/RTFD Document: Exports the selected

items as one merged rich text file without

embedded items (RTF) or with them

(RTFD).

Text: Exports the selected items as one

merged plain text file.

Word 2007/97 Document: Exports the

selected items as one merged Microsoft

Word .docx (Word 2007) or .doc (Word

97) document.

Website: Exports the selected items as

standalone web site that you can upload to

your web server and share with colleagues.

In the presented dialog window, choose

the desired template, text encoding, and

whether DEVONthink should convert

diacritics and accented characters to

HTML entities or not. Check Create Index

Pages to create index.html pages with

cross-links to all included documents.

Markdown and formatted notes are

rendered to HTML, other file types that

cannot be displayed in a web browser,

e.g., Pages files, are converted to PDF

if possible. Cross-links are converted

correctly. For the export templates are

used that you can modify yourself.

HTML Bookmarks: Export the URLs of all

selected items and their children as an

HTML bookmarks file.

Template: Saves the selected documents

as a template, which can then be used

to quickly create new documents using

Data > New from Template. Export multiple
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documents and/or groups at once to

create e.g.,a project template. Data & New

from Template & Open Template Folder; 

can be used to organize templates.

Database Archive: Creates an optimized

ZIP file of the current database in the

selected location. This can be useful as a

secondary backup strategy. Databases are

exported in their original format, e.g., an

encrypted .dtSparse file. For encrypted

and revision-proof databases, you will

need to provide an encryption key before

exporting.

Metadata (JSON): Export the metadata of

the selected items as JSON data.

Share: This opens the standard Mac Share

menu.

INDEX AND UPDATE

Index Files and Folders: Link to files in

the Finder, leaving them in the current

location. See the In & Out > Importing &

Indexing section for important information

on indexing.

Update or Refresh: This command

dynamically changes, relative to what is

currently selected.

Update Indexed Items: Force DEVONthink

to check for filesystem events and newer

file dates on indexed items, and update

them as needed. This is often used when

indexing cloud-synced locations, e.g.,

folders in Dropbox, or when indexing items

on networked volumes, as some volumes

don't reliably support filesystem events.

Update Items: Similar to Update Indexed

Items but works with imported items.

Sometimes used after editing documents

in external applications when the

application or the database is closed. It

may also be needed when accessing a

database stored on a networked volume.

Refresh Feed: Manually refresh selected

RSS feeds.

SYNCHRONIZE

Synchronize: Synchronizes the selected

database with all its locations. Note, this

command will be disabled if the current

database has no active synchronization.

Holding the ⇧Shift key shows the Synchronize

All option to synchronize all actively syncing

databases.

Download Pending Files: Downloads the files

of selected documents if they are available

through one of the database's locations. Only

necessary if none of the database's locations

is set to synchronize indexed files.

DATABASE PROPERTIES & CLOSE

Database Properties: Opens the Database

Properties popup for the current database.

This panel presents a few options, statistics

about the database, and allows you to change

the displayed name, add comments, and add

a username and password.

Close Database: Closes a selected database.

If multiple databases are open, use Close

All to close them all at once. If you'd like to

keep the current database open but close the

others, use Close All Except. Note that closed

databases will not reopen on launch. Only

databases that were open when DEVONthink

quits will reopen on the next launch.

DEVONthink 4.3.2 Documentation, page 197

https://www.json.org


DATABASE MAINTENANCE

Like any database, DEVONthink databases

need a bit of maintenance from time to time.

All the commands you'll need for this can be

found here.

Verify & Repair: Verifies all database

structures and repairs them if possible. By

default, DEVONthink automatically verifies

the database structure every time you open

a database. If it finds significant errors,

DEVONthink will advise you to run this

command.

Use this command whenever you feel

it is necessary. If you're a heavy user of

DEVONthink, running a Verify & Repair once a

week or more often is a good idea.

Check File Integrity: Verifies the stored

checksum for each file in the database. The

results are reported in the Log window or

popover. Note: If you are indexing files and

they have not been updated, they will report

a checksum error. See also p. 82ff

Optimize Database: Creates an internal

backup of the database and then optimizes

the database structure. Optimizing removes

unnecessary internal elements from the

database and rebuilds the internal structure

to optimize performance. DEVONthink

also creates internal backups on a regular

basis. Hold the ⌥ Option key to display the

Restore Backup option. This allows you to roll

back the metadata to a previous date. This

option would only be used in troubleshooting

situations.

Rebuild Database: Completely rebuilds

the database by exporting all items to a

temporary folder in the file system, creating

an empty database, and reimporting all

items. This removes any structural problems.

Depending on the size of your database,

this can take from a few seconds to several

hours. This option is typically only used in a

troubleshooting situation.

Delete Database: Closes a selected database

and moves it to the Finder trash.

Note: For more information on database

issues, including reports in the Log window

or popover, see the Repairing a defective

database section.

PRINT

Page Setup: Sets your preferred page size and

printer settings.

Print: Prints the current document or view.

PRO/SERVER COMMANDS

These commands are only available in the Pro

and Server editions of DEVONthink.

Import

Images (with OCR): Imports images and

applies optical character recognition (OCR)

to create a searchable PDF. This makes all

written text searchable and available to

DEVONthink's AI functions. You can change

the setting in OCR settings.

References from Bookends: Imports

references from the Bookends application

as rich text documents. These are stored

in a Bookends group in the root of the

current database. When run, you will

have the choice to import the selection

in Bookends or references from one of

various collections. Several properties
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from Bookends are applied as custom

metadata, e.g., the abstract, authors, DOI,

etc., if available in Bookends. Keywords are

imported into the Keywords field. Already

imported references are updated, not

duplicated.

Unix Mailbox: Imports Unix mailboxes, like

those exported from Apple Mail.

Website: Opens the Download Manager

and downloads a complete web page/

site for archiving and offline viewing. By

default, groups created by the Download

Manager are excluded from tagging.

Export

Unix Mailbox: Exports selected emails as a

Unix mailbox, .mbox file, that can be shared

or imported into many email applications.

Database Audit Report: Exports a full

report accounting for all the documents

added to an revision-proof database. This

includes the original filename on import,

unique identifiers, deletions and their date

of deletion, etc. Exported as a .csv file for

use in other applications, e.g., Excel.

THE EDIT MENU

The Edit menu contains all commands and

options relating to editing. You'll find the

classic Mac cut/copy/paste and find/replace

commands here, as well as many more.

UNDO, CUT/COPY/PASTE, …

Undo/Redo: Use these commands to undo or

redo the last action, e.g.,to undo deleting a

file. Undo and Redo work for many actions.

Cut/Copy/Paste: Cut, copy, or paste as

standard behavior.

Copy with Source Link: Copies selected

text and a link to the current document.

This text and link can be pasted into other

applications.

Copy URL: Copies the URL of the selected or

frontmost document to the clipboard.

Copy Item Link: Copies a DEVONthink-

specific URL, called an item link, that links to

the selected document or group. These links

can be used to create a backlink to the item

in your database in applications that support

live hyperlinks. For certain file types, there

are alternate item links that appear when

holding the ⇧ Shift key. These alternate links

are discussed in the individual sections in the

Documents chapter.

Paste with Source Link: When copying text

from files in DEVONthink, use this command

to paste the text in rich text and Markdown

documents with a link back to the source

document.

Paste and Match Style: Pastes text from the

clipboard, matching the styles in the current

document. This can also be used when

pasting rich text into Markdown documents.

Delete: Deletes the selected piece of text.

Complete: Tries to auto-complete the

partial word before the insertion caret. This

standard Mac function uses the currently

active dictionary, chosen in the language

dropdown of the Spelling and Grammar >

Show Spelling and Grammar panel.

Select All/Deselect All: Selects or deselects

the complete content of the frontmost

document. Hold the ⇧Shift key to reveal the

Deselect All option.
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TAGS, SET NAME

Tags: Quickly apply tags to the current

document. This displays the Tag bar, if

necessary.

Set Name As: Applies the selected text as

the document's name.

FIND, SPELLING, INSERT

Find: This submenu contains standard

Mac find commands, like those available in

TextEdit. Searches on the current document

are displayed in the Search Inspector. Two

commands of note are:

In Database: Puts the cursor in the toolbar

search field of a main window.

Find: Opens the Search inspector.

Find Next/Previous: Steps through search

hits in the document.

Use Selection For Find: Uses the selected

text as the search term in the Search

inspector.

Scroll To Selection: In long documents, this

command scrolls the current document to

selected text.

Spelling and Grammar: Provides the standard

macOS functionality for checking text for

spelling or grammar errors. To choose the

language used for spell checking, or for

auto-completion (see above), open the

spell checker panel with Edit > Spelling and

Grammar > Show Spelling and Grammar and

choose your language of choice from the pop-

up menu.

Substitutions: Shows the standard

Substitutions settings panel where you

can toggle the options on and off manually:

Smart Copy/Paste, Smart Quotes, Smart

Dashes, Smart Links, Data Detectors, and

Text Replacements. Data Detectors analyze

shown text and make context-sensitive

actions available, e.g., when you hover

the cursor over a phone number or postal

address.

Note: The Spelling and Grammar

and Substitutions commands can be

temporarily applied to the current

document. If you'd like these to be

persistent choices, you can make global

changes in Settings > Editing.

Transformations: Use this submenu to change

selected text to all lowercase or uppercase, or

to capitalize every word.

Speech: Starts or stops speaking the

selected piece of text.

Insert: Inserts items, like pictures,

checkboxes, bulleted lists, etc. The options

available are dependent on the current file

type.

DICTATION & EMOJIS

Start Dictation: Starts the Mac's dictation

function.

Emoji & Symbols: Shows the standard Special

Characters panel for inserting characters and

emoji that you cannot enter directly with

your keyboard.

PRO/SERVER COMMANDS

These commands are only available in the Pro

and Server editions of DEVONthink:

Summarize via Chat: Opens the Summarize

and Transform popover and processes the

selected document or its selected text to
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present a summary. The default results are

set via the Summaries dropdown in the AI >

Chat settings.

Transformations > Transform Text via

Chat: This also opens the Summarize and

Transform popover and processes the

document or its selected text to present

alternate styles.

THE DATA MENU

The Data menu contains all commands that

deal directly with documents or groups. Here

you'll find commands for creating, labeling,

classifying or group new documents, and

more.

NEW DOCUMENTS & TEMPLATES

New: This submenu provides access to the

built-in items DEVONthink allows you to

create.

With Clipboard: Creates a new document

based on the contents of the clipboard.

Note: Some applications such as Microsoft

Word put data in multiple formats into

the Clipboard. DEVONthink tries to use

the most logical data when creating a new

document.

Take Note: Opens the Sorter to the Take

Note view. If the Sorter is not shown, it

opens the Take Note window.

Plain Text: Creates a new plain text

document.

Rich Text: Creates a new rich text

document.

Formatted Note: Creates a new formatted

note.

Markdown Text: Creates a new Markdown

text document.

HTML Page: Creates a new HTML page.

You can use the built-in macOS WYSIWYG

editor to edit the HTML page or switch to

its source code (from the navigation bar)

and edit it directly.

Sheet: Creates a new sheet. Add columns

to the new sheet by using the + button or

by pressing the ↩ Return key. Name the

columns and sort the sheets by dragging

them with the mouse. Click OK to create

the new sheet.

Script: Opens the Script Editor window

where you can draft scripts for various

purposes: Generic, Smart Rule, Reminder,

or Output. Supports both AppleScript and

JavaScript (JXA). In the Pro and Server

editions, AI can be used to help draft and

potentially resolve some common scripting

issues.

Bookmark: Creates a new bookmark. Type

the URL and optionally name it to create a

bookmark, just as any browser does. If you

don't type in a name, DEVONthink will set

one automatically.

Feed: Creates a new  RSS feed document.

The feed behaves like a special type of

group that contains RSS entries published

by the feed's author. Type the URL and

optionally enter a name. If you don't type

in a name, DEVONthink will attempt to set

one automatically. You can change the URL

later by selecting the feed document and

changing the URL field in the Info inspector.

Group/Tag: Create an empty group. This

option appears as Tag if you are currently in

the Tags group of a database.

Smart Group: Opens the Predicate Editor

to set up criteria for a local smart group.

DEVONthink 4.3.2 Documentation, page 201

https://www.microsoft.com/mac/
https://www.microsoft.com/mac/


New from Template: This submenu allows you

to access any installed templates, including

your own. There are two other commands to

note:

Open Templates Folder: Select this to

open ~/Library/Application Support/

DEVONthink/Templates.noindex in the

Finder. You can add your own documents to

be used as templates here.

More Templates: Opens the Extras section

of the Support Assistant to install any

available DEVONthink templates.

OPEN, LAUNCH, REVEAL, SEND

Open: Opens the selected document or

group in a separate document window. This

command opens a second main window

for the selected group. If you have selected

multiple documents, hold the ⌥ Option key

to display the Open in Tabs command. If

the View/Edit pane is visible, this opens the

selected items in new tabs. If the View/Edit

pane isn't visible, a new document window

will open with each selected document in its

own tab in the window.

Open with: Displays a list of applications

compatible with the current file type. Opens

the selected documents in the chosen

application. If your desired application is

not listed in the submenu, choose Other to

browse for it.

Launch URL: Opens the file, folder, or internet

location indicated by the URL field in the

Generic Info inspector. The URL will be

opened in the background if you hold the

⌥ Option key.

Reveal: Reveals the location of the frontmost

document in either the same main window, if

possible, or by opening a new one.

Show in Finder: Opens a new Finder window

with the item selected. Note this only works

for documents and indexed groups.

Send by Email/Reply: Creates a new message

in the system default email application and

adds the selected items as attachments. If

the selected item is an email message, the

command is Send Reply and a draft reply is

created instead. Note attaching files requires

having an email application that supports

AppleScript.

SAVE AND REVERT

Save/Save All/Revert To Saved: Saves the

frontmost document or all documents

to disk. Hold the ⇧ Shift key to show the

alternate menu item, Save All.

Revert To Saved: Restores the frontmost

document to the last saved version.

FAVORITES, READING LIST, REMINDERS

Add To: Commands in this submenu add

the currently selected documents to your

Favorites, the Reading List, or the current

PDF page as a bookmark to the Table of

Contents inspector.

Annotate & Remind: A dual purpose submenu

where you can set or remove a due date on a

selected item or directly create an annotation

file via a chosen template, linked to the

currently selected item.
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MOVE

Move to: The commands in this submenu let

you quickly move items in your database and

control imported and indexed files.

Move to…: Opens the Move To popover.

Move to (): Quickly move selected files to

the last destination used in the See Also

inspector.

Put Back: Returns an item to its previous

location, e.g., after accidentally moving

something to the database's Trash. Note

this only remembers the previous location,

so you cannot undo multiple moves.

Move Into Database: Use this command

to move an indexed file into the database.

Use this command with caution as it moves

the file from its current location into the

internals of your database. It does not copy

the file.

Move To External Folder: Use this

command to move a non-indexed item, e.g.,

imported or created in DEVONthink, out to

an indexed folder in the Finder.

DUPLICATE, GROUPS, AND CLASSIFY

Duplicate: Creates a duplicate of the selected

items. The name of the new item ends in

"copy", and because their contents are

identical both items are marked with the

icon for duplicates (or, depending on your

preferences, show their name in bold and

blue).

Group Items: Creates a new group containing

all the selected items. This is similar to

creating a new group and moving the selected

items into it. The alternate command Group

Similar Items, shown when the ⇧ key is held,

will attempt to file selected items with

similar content in groups.

Ungroup Items: The exact opposite of Group

Items. Moves all items in the groups one level

up and deletes the now-deserted groups.

Classify: Using DEVONthink's AI, this

command will move selected files to an AI

suggested location. If multiple locations are

available, this will replicate the item to them.

MARK, RATING, LABELS, TAGS

Mark: Allows you to mark the item as

flagged/unflagged, locked/unlocked, and

read/unread.

Rating: Allows you to set a rating, from no

stars to five stars.

Label: Allows you to mark the selected groups

or documents with one of seven labels you've

defined in the General > Labels settings.

Tags: This submenu offers special commands

for tagging items.

Convert Hashtags to Tags: Converts

hashtags into DEVONthink tags. The

hashtag must be prefixed with the #

symbol and entered as a single word

without spaces, e.g., #software-rules.

Convert Keywords to Tags: Converts

keywords, found in the Document >

Properties inspector for PDF or rich text

files, into DEVONthink tags.

Convert Properties to Tags: Converts the

Author property, found in the Document

> Properties inspector for PDF or rich text

files, into a DEVONthink tag.
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Convert Geolocation to Tags: Converts

available geolocation data into

DEVONthink tags.

Assign Existing Tags: Using DEVONthink's

internal AI to examine tags on similar

documents, the selected document will

have matching tags applied.

Add Vision Suggestions to Images: Adds

tags to selected images using Apple's

machine learning technologies.

CONVERT, THUMBNAILS

Convert: This submenu contains commands

for converting between some file formats,

e.g., between rich and plain text. Note the

options presented are dependent on the

type of the selected document. Also, due to

differences in the formats, any formatting

in the source document may not be able to

be perfectly preserved in the destination

document.

To Flattened PDF/A (with Annotations burnt

in): One of the available conversion options

important in many legal or professional

settings is the use of PDF/A. This is a type of

PDF used for long-term document archiving

and preservation. For example, contracts,

land deeds, birth or death certificates, etc.

would be good candidates for PDF/A. These

can be used in any DEVONthink database,

but would be perfect in an revision-proof

database.

Thumbnails: Use these commands to add,

remove, or update a thumbnail for the

selected files.

MOVE TO TRASH

Move to Trash/Move All Instances to Trash:

Moves the selected items to the trash. If

you have selected a replicated item, hold the

⌥ Option key and choose Move All Replicants

to Trash to move the selected item and all its

replicants to the database's trash.

PRO/SERVER COMMANDS

These commands are only available in the Pro

and Server editions of DEVONthink:

Group Similar Items: Shown while holding

the ⇧ Shift key, DEVONthink's internal AI

will attempt to gather selected documents

into groups based on their similarities.

Recognition: Process images and media

files to produce a transcript of any

detected text. The output, e.g., to

associated searchable text, is defined

by you in the AI > Transcription settings.

This also works with PDFs if the output

is set to Comment or Annotation. Scan

Barcodes detects barcodes in an image

or PDF document and records it as Info >

Data custom metadata, Barcode, on the

document. You can see a list of supported

barcodes here.

OCR: This menu contains options for

choosing an output format when doing

OCR on a selected compatible document

(JPEG, PNG, TIFF, PDFs with no text

layer). The currently supported output

formats are: Searchable PDF, RTF, Word

, and Web Archive. Additionally, there

are two special commands: to Comment

and to Annotation, which sets the Finder

comment or creates an Annotation file
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with the text. Neither command adds the

text layer to the selected document.

New

Generate Image: This opens the Generate

Image panel where you can use AI to create

images.

The Devonian Times: Creates an HTML

document with a summary of new items

provided via AI.

Rating and Label

Chat Suggestion: Examines the current

document and applies a rating or color

label to it.

Tags

Add Chat Suggestions to Documents:

Examines the selected document and

applies tags relevant to its content. Specify

if you only want to use existing tags in the

Files > Tags settings.

THE FORMAT MENU

FONTS, STYLES, ALIGNMENT, RULERS

The Format menu contains the commands

and options dealing with all aspects of text

formatting. Here you'll find the standard font,

alignment, and ruler commands, as well as

very special DEVONthink commands.

Note: Many commands in this menu

only work with rich text, Markdown, or

formatted notes. Plain text documents do

not allow formatting. (That's why they're

called "plain" text.) Some formatting

options are also available for editable PDFs

and web archives.

Font: Access fonts, change type sizes, and

copy/paste the style of selected text.

Show Fonts: Opens the macOS Font panel.

Bigger/Smaller: Increase or decrease the

size of selected rich text by 1pt.

Copy Font: Copies the font formatting of a

selected piece of rich text.

Paste Font: After using the previous

command, applies the copied font to

another selection of rich text.

Style: Control the formatting of selected rich

text and also some higher-end font control

like kerning and baseline shift.

Bold/Italic/Underline/Strike Through/

Outline: Apply the chosen formatting to

selected rich text.

Styles: The Styles command opens the

macOS styles editor. With it, you can step

through all the styles used in the current

document. If there's one you'd like to reuse,

add them to your favorites. Use the pop-

up menu to select a saved style and, if you

don't need it any more, delete it. You can

use saved styles from the ruler (see below).

Kern: Modify the spacing between

characters.

Ligature: Choose whether to use conjoined

characters, called ligatures, e.g., fi. This

only works with fonts having built-in

ligatures, typically classic serif fonts like

Baskerville.

Baseline: Shifts the selected text above

or below the baseline, including sub- and

superscripting.

Character Shape: Traditional Form

Dynamically shifts from Simplified to

Traditional Chinese characters.
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Alignment: Set the paragraph alignment:

Align Left, Center, Justify, or Align Right.

You can also set the Writing Direction for

the current paragraph or selected text, if

required.

Ruler: This submenu allows you to display

the ruler above the preview of rich text

documents. There are also two special

commands:

Copy Ruler: Copies the current ruler

attributes (tabs stops, indents, etc.) of a

selected piece of rich text.

Paste Ruler: After using the previous

command, applies the copied ruler

attributes to another selection of rich text.

Make Plain/Rich Text: Converts a rich text

document to plain text and vice versa.

HIGHLIGHTS

Highlight: In rich text documents, editable

PDFs, and web archives use Highlight to

highlight a selected piece of text just as you

would using with a colored pen on a piece

of paper. To remove highlighting, select the

highlighted piece of text and choose Highlight

again.

Highlight Color: Choose the desired highlight

color. While highlighting, this remains the

color used until you choose another.

LINKS, SPACING, LISTS, TABLES

Make/Remove Link: Converts the selected

text into an active link, or disables the

link. This command can be used to create

WikiLinks quickly.

Add/Edit Link: Use this command if you want

to add a specific link to some text. If the text

is already linked, the menu will display Edit

Link, allowing you to change or remove the

URL. The behavior you'll see when clicking

linked text depends on the target of the link:

If the text was a valid URL, the URL will be

the target of the link. Editing the link text

later does not change the target. Use the

Edit Link command of the context menu to

edit the link target.

Otherwise, DEVONthink treats the link as

a Wiki-style link. Clicking the Wiki-style

link jumps to a document with exactly

the same name as the linked text (or any

document with a Wiki alias of that name).

If there is no document of that name,

clicking the link creates a new rich text

document named after the linked text and

pre-filled by the template you set in the

Settings > Editing.

Spacing: This command allows you to adjust

the line spacing of selected text in rich text

documents. You can adjust the line height

to an exact value or define a minimum and

maximum height, adjust inter-line spacing,

and define the space before and after a

paragraph.

List: Inserts a list into a text document.

Specify the Prefix, Bullet/Number style,

suffix, and Starting Number as needed then

click OK. As an example with the first three

options, Document, 1 2 3, and :, yields a list

item of Document 1:.The Prepend enclosing

list marker is used with nested lists and adds

the prefix of the parent list to the sublist

items. If the lists are using 1., the sublist

would show 1.1..
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Table: Inserts a new table into a rich text

document and opens the table inspector

panel. Use the table inspector to adjust the

number of rows and columns, cell alignments,

cell colors, border widths, and colors. Also,

you can merge and split cells and create

tables within a cell.

HYPHENATION, LAYOUT

Allow Hyphenation: Enables or disables

hyphenation for the current rich text

document.

Make Layout Vertical/Horizontal: Enables

orienting and editing the document text

vertically or horizontally.

Wrap Lines: Toggle whether to wrap a

document's content to the width of the

view/edit pane or document window, or let it

exceed the width for sideways scrolling.

Typewriter-like Scrolling: Keeps the currently

edited line in the center of the window or

view/edit pane.

Wiki Linking: Toggles whether to display

WikiLinks in the current document.

WYSIWYG Editing: Toggles the WYSIWYG

view when editing Markdown documents.

BARS, COLORS, INVISIBLE CHARACTERS

Show Format Bar: Displays the Format Bar

under the toolbar, providing access to rich

text styles, font and paragraph attributes,

etc.

Show Editing Bar: Displays the Editing Bar

above the view/edit pane containing a suite

of format-specific tools. For example, rich

text formats display several common tools

including highlighting, toggling the ruler,

and displaying the color picker are shown.

For sheets, tools to add/remove/duplicate

records, as well as the column editor.

Show Colors: Shows the macOS color panel,

e.g., for changing the foreground color of

selected text in rich text documents.

Show Invisible Characters: Toggles display of

invisible characters such as spaces, tabs, and

line feeds. Shown invisible characters appear

in light gray.

THE TOOLS MENU

The Tools menu provides tools to get more

detailed information about your documents,

as well as some specialized commands.

INFO & FILTERS

Get Info: Opens the Info popover displaying

the views of the Info inspector.

Chat: Opens the Chat popover.

Graph: Opens the Graph popover which

shows the Graph detached from a main

window.

Inspectors: This submenu provides access to

the various inspectors built into DEVONthink.

You can also use Show/Hide to toggle the

visibility of the Inspectors pane.

Filter: The commands in this submenu

filter the list of files in the location you are

currently viewing. As you select options

in these panes, the list of files will change

accordingly. The filters are also covered in the

windows chapter.
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Info: Shows a pane with options for

filtering on dates, flagged state, unread

status, rating, or color label. When using

the calendar, you can click Any Date to set

which date you want to filter on: added,

created, modified, opened, or due.

Tags: Shows a tag cloud, with frequency-

based sizing, i.e., more frequently used

tags will be larger. Clicking on tags removes

unrelated tags from the cloud, only showing

tags that have been applied with the

current tag.

Multimedia: Displays options for filtering

multimedia files - images, audio, and

video - in the current location. Options for

minimum and maximum pixel dimensions

or durations are available.

Maps: Shows a small map showing pins

from geolocation data will be shown.

Clicking on a pin will show you files created

in that location. The behavior of this pane

is similar to Apple Maps, e.g., pinch to zoom

in and out, etc.

DOCUMENT COMMANDS

Annotate: This submenu provides access

to the PDF and image annotation tools.

Applicable to PDF documents you have:

Highlight Text, Underline Text, and Strike

Through Text. Next, the basic annotation

types are available: Oval, Rectangle,

Line, Note, Text, and Link. Note and link

annotations aren't available with images.

These tools are persistent, so you can select

one and use it in that mode until you change

to another tool.

Capture: This submenu provides options for

capturing the current document to a new

file in a few different formats: Bookmark,

Rich Text, Formatted Note, Markdown Text

HTML Page, Web Archive, and PDF (One

Page/Paginated). Captures are made to

the current group. Set as Thumbnail will

set a thumbnail for a currently viewed web

page, useful to create a clean thumbnail,

e.g., after dismissing cookie banners.

There is also an option to use the Clip to

DEVONthink command, just like in your

browser. Also note, the  option will try to

remove extraneous information before the

document is captured.

Note: The available options in the Capture

menu are dependent on the type of the

selected document.

Mode: The commands in this submenu

switch between three modes of interaction

in PDF documents: Move, Text Selection,

and Annotation Selection. When viewing an

image, Move and Image Selection are the

available commands.

Rotate & Flip: This submenu provides a

Rotate command for rotating an image or

PDF page right or left, or by 180 degrees. You

can also mirror images on their horizontal or

vertical axes via the Flip commands.

PDF: This submenu provides options for

modifying the structure of a PDF document:

Insert Blank Page, Delete Selected Page, and

Reverse Page Order.

Sheets: This submenu provides access to

the following tools for editing a sheet: New

Record, Duplicate Records, Delete Records,

New Column, Edit Columns, and Delete

Columns.
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ITEM LINKS AND IMAGES

Item Links: For documents supporting

item links and WikiLinks, there are three

commands in this submenu:

Convert WikiLinks to Item Links: Replaces

detected WikiLinks with the appropriate

item links.

Update Name of Item Links: Scans the

current document for item links and

updates the link text for any files whose

names have been changed. This only

updates the names of item links.

Verify Item Links: checks all item links in

the document and logs those no longer

pointing to a valid target, e.g., because the

referenced item is no longer available in any

database.

Import Online Markdown Images: Download

and link to local copies of images from web

content clipped as Markdown documents.

CREATE, SUMMARIZE, MERGE, SPLIT

Create Metadata Overview: Creates a sheet

with records for each selected file. The

columns contain data from the generic and

custom metadata of each file.

Create Table of Contents: Opens a submenu

to create a rich text or Markdown document

with links to the currently selected

documents.

Summarize Annotations: Creates a document

with all annotated text passages of the

currently selected documents. In case of

items located in multiple databases the

summary is created in the global inbox.

From the submenu, choose to create the

summary in a rich text document, Markdown

document, or a sheet.

Summarize Mentions: Creates a new

document containing a list of the documents

mentioning the name or alias of the selected

document. From the submenu, choose to

create the summary in a rich text document

or a Markdown document.

Merge Items: Merge the selected documents

into one. This creates a new file, preserving

the originals. Hold the ⌥ key to choose Merge

& Delete n Documents, removing the original

files after the merged document is created.

When merging documents, the order of the

merge will be the order shown in the item

list. The topmost selected document will

be the first page with the pages beneath it

following. The order of the documents can be

controlled by the current sort method used in

the item list. Also, the resulting file type of a

Merge operation depends on the types of the

selected files. Selecting mixed formats, e.g.,

a web archive and an image, usually results in

an RTFD file being created.

Split PDF: Use commands in this submenu to

split a PDF document into separate files. Use

into Chapters on a PDF containing a table

of contents to create separate per-chapter

files. Use into Pages to 'explode' the PDF into

individual single page files.

Split Document: Splits the current document

(PDF, plain or rich text) at the insertion mark

position in the document.
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RULES

These commands allow you to set or run

smart rule commands

Apply Rules: Apply the selected rule on

selected items that match the rule's

criteria, including the location defined in

the smart rule.

Perform Rules: Run the selected rule at any

time or in any location. This is not isolated

to the documents in the current location.

Batch Process: Open the batch processing

window or run an existing configuration.

PRO/SERVER COMMANDS

These commands are only available in the Pro

and Server editions of DEVONthink:

Chat: Opens the Chat popover.

Imprinter: Choose an imprint you have

defined in Settings > Imprinter to apply it

to the current image or PDF.

Import Email Attachments: Parses selected

emails and extracts the attachments

as individual files. This is useful if you're

not using the Message Content: Import

attachments option in the Files > Emails

settings.

Create Audit Report: Creates a locked

sheet with an itemized list of the

properties of selected documents. This

includes things like the name, original

name, when the file was added, the

content hash, etc.

Create Expense Report: Creates a sheet

summarizing custom metadata dates and

currencies of selected files. Totals for the

amounts will also be included.

Summarize Documents via Chat: Opens

the Summarize and Transform popover and

saves the summary in your chosen format:

Markdown, rich text, as a Finder comment

on the document, or an annotation file.

Start/Stop Server: Use this command to

start and stop the integrated web server.

Inspectors

Info > Data: Opens the Data inspector.

Concordance > List/Cloud: Opens the

Concordance inspectors.

AI > Graph: Opens the Graph inspector.

Chat: Opens the Chat inspector.

THE VIEW MENU

The View menu contains all the commands

for modifying the way DEVONthink displays

groups and documents.

SIDEBAR & LAYOUTS

Sidebar: The Sidebar view options allow you

to switch between the four different sidebar

views in a main window. You can toggle the

sidebar's visibility by selecting the same

option again.

Navigate: Open the Navigate sidebar,

giving you easy access to your databases,

favorites, and global smart groups.

Reading List: Open the Reading List

sidebar where you can maintain a list of

documents for later consideration.

Extras: Open the Extras sidebar to read up

on recent updates, announcements, and

promotions or discover the latest tutorials,

scripts, and templates.
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View: Choose one of the following options

to switch between different layouts for the

item list in a main window. All these views are

similar to options you find in Finder windows.

Icons: Displays items as icons.

List: Displays items in a list view with user-

specified columns shown.

Columns: Displays the item list as a set of

columns.

Preview: These options allow you to control

the position of the current document's

preview, or dismiss it altogether.

None: This creates a list only view.

Standard: This shows a preview under the

file listing.

Widescreen: This shows the preview to the

right of the file listing.

Quick Look/Slideshow: Opens the Quick Look

panel for the selected items which can be

useful for times when the view/edit pane

isn't displayed. Holding the ⌥ Option key

allows you to display the selected files in a

Quick Look slideshow.

SHOW TAGS & DETAILS

Show/Hide Tags: Shows or hides the Tags

bar.

Show/Hide Details: Switches between

displaying icons only or displaying icons

together with detailed information such

as kind, label, size, word count, creation

date, and modification date. Available in all

windows using icon or column views.

Show Only Documents: When checked, this

hides groups and smart groups in List and

Icons views. Note this is a per-database

setting, i.e., you can enable or disable it for

each open database.

COLUMNS & SORTING

List Columns: This submenu lists all columns

available to be displayed as column headers in

the item list.

Sort: This submenu lists all the attributes

that can be used to sort the current item

list. Choose Unsorted to manually sort the

items. DEVONthink remembers sort settings

for every group separately and uses those

settings when the group is displayed in its

own main window

Customize Metadata: Opens a panel showing

all the available metadata fields that can

be enabled as List view columns or used to

sort on. This includes all enabled custom

metadata.

FULLSCREEN & ZOOM

Full Screen: Displays either the current

document in a full screen mode optimized for

reading and editing, or the frontmost window

in full screen. There are two options available

here:

Document: Shows the current document in

full screen. Note this is a distraction-free

view, not the standard macOS fullscreen

view.

Window: Shows the current window in a

standard macOS full screen view.

DEVONthink 4.3.2 Documentation, page 211



Zoom: Depending on the document type,

you can zoom in or out of the document's

preview:

Actual Size: Displays the document

at actual size, calculated using the

resolution of the screen and the resolution

information of the image or PDF.

All Pixels: Displays the document at a 1:1

ratio so that one pixel of the image equals

one pixel on the screen (PDFs and images

only).

Zoom In/Out: Zooms in or out of the

document.

Zoom to Fit: Displays the document so

that it exactly fits either the height or the

width of the window/preview pane (PDFs

and images only).

Zoom to Width: Displays the document so

that its width fits the width of the window

or view/edit pane (PDFs and images only).

DOCUMENT & PDF OPTIONS

Document Display: This submenu contains

commands for displaying alternate views of

some documents. Note there are alternate

commands shown when used with sheets or

HTML and Markdown files.

Best Alternative/Preview/Table View:

Shows a QuickLook view, or a rendered

view for HTML-based and Markdown files,

the Table view for sheets.

Text Alternative/Source/Form View:

Shows a text-only view of some file types,

e.g.,Word or email. Also shows the page

source of HTML-based and Markdown files

or the Form view for sheets.

Side-by-Side: Shows a side-by-side view

of the rendered view and source for HTML

and Markdown files. Note this does not

apply to Formatted Notes.

PDF Display: This submenu lets you adjust

the way PDF documents are displayed:

Single Page, Two Pages: Shows a multi-

page document as single pages or two

pages facing each other (as in a magazine).

Continuous Scroll: When checked, shows

the pages of the PDF as one long scroll.

When unchecked, only one page is shown

at a time.

Book Mode: When checked, facing pages

start with one single page (the title page),

then facing pages. When unchecked, they

start facing.

Page Breaks: When checked, pages are

shown with a small break between the

pages. When unchecked, the pages appear

as a continuous document.

Crop Box, Media Box: Crops the page to

the crop or media box. By default, PDF

pages are cropped to the crop box.

TOOLBAR

Hide/Show Toolbar: Hides or shows the

toolbar of the frontmost window.

Customize Toolbar: Opens the toolbar

configuration sheet so you can change the

toolbar buttons of the frontmost window.
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PRO/SERVER COMMANDS

These commands are only available in the Pro

and Server editions of DEVONthink:

Import: The Import sidebar gives you

access to scanning and email archiving.

THE WINDOW MENU

Just like most every macOS application, the

Window menu lists all open windows of the

active application and gives you access to

commands for managing them.

Note: Some commands in this menu may

be under the control of the operating

system. For example, Move to iPad X is

created and handled by macOS. Also, some

commands may be present only in more

recent versions of the operating system.

These commands are not documented

here.

WINDOWS & TABS

Close/Close All: Close the current window or

all of them.

Zoom: Maximize the current window without

entering fullscreen. Hold the ⌥ Option key to

maximize all open windows.

Tile Window to Left/Right Side of Screen:

Enter Split View and tile the current window

to the chosen side. Hold the ⌥ Option key to

move the window instead. With the affected

window active, holding the ⌥ Option key will

allow you to choose Revert.

Minimize: Minimize the current window to the

dock. Hold the ⌥ Option key to minimize all

open windows.

New Tab: Create a new tab in the current

window, whether main or document windows.

Close Tab: Close the current tab in the active

window.

Select Next/Previous Tab: Switch to

subsequent or preceding tabs in the current

window.

ACTIVITY, DOWNLOADS, LOG

Activity: Opens the Activity window to

monitor the progress of processes, e.g., sync

activity.

Log: Opens the Log window to view

messages, warnings, and errors.

Bring All to Front: Gather any background

windows with the front most one. Hold

the ⌥ Option key to restore any windows

minimized to the dock and tile all windows in

the middle of the screen.

OPEN WINDOWS

Select any open window from the menu to

bring it to the front. The current window

is marked with a check mark; minimized

windows with a diamond.
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PRO/SERVER COMMANDS

These commands are only available in the Pro

and Server editions of DEVONthink:

Download Manager: Opens the Download

Manager window to add or monitor

downloading online assets.

THE GO MENU

For people who prefer to use the keyboard

for navigation, the Go menu contains all

commands for navigating the hierarchy

of your DEVONthink database, all with

keyboard shortcuts. Use these commands

to go backwards and forwards through your

documents, or to move back to the top level

of the group hierarchy.

DATABASES

Previous Database: Selects the previous

database in the Navigate sidebar.

Next Database: Selects the next database in

the Navigate sidebar.

GROUPS

Top Group: Returns you to the top level of the

database (also known as the "root").

Enclosing Group: Changes the view to

the parent folder of the current group or

document.

Selected Group: Changes the view to the

currently selected group.

To Group…: After classifying or moving

documents to a new location, use this

command to quickly jump to the last used

destination.

DOCUMENTS

First/Previous/Next/Last Document:

Navigates to the first, previous, next, or last

document of all documents in the current

group. This is useful when you have opened

a document in a separate window and want

to move to another document in the same

group.

To Group: Opens the Go to Group popover to

jump to another location in your databases.

To Document: Opens Go to Document

popover to quickly navigate to a specific

document.

To Line/Page/Time: Allows you to jump to: a

line in text-based documents, a page in PDF

documents, or a time in video and audio files.

To Link: Opens a link directly following the

cursor in plain text, rich text, and Markdown

documents.

Back/Forward: Moves backwards and

forwards through all documents/web pages

you have visited by following cross-links or

Wiki-style links.

Previous/Next Instance: Navigates

backwards and forwards through all instances

of a replicated document. Use these

commands to find out where the other

instances of a replicated item are.

Previous/Next Highlight: Navigates

backwards and forward through highlighted

passages in rich text or Markdown documents

or search hits in the Search inspector.

Next Unread Item: Navigates to the next

item with an unread status in the current

database.
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Complete News: Loads the article linked to in

an RSS article.

MOVE FOCUS

The following commands allow you to

quickly jump between the panes in a

window, e.g., from the view/edit pane to the

current inspector. The options available are

dependent on the visible UI elements, e.g., if

the inspectors aren't visible, the Move Focus

to Inspector command will be disabled.

Move Focus to Sidebar: The current

sidebar, e.g., the Navigate sidebar will

have focus. Note this command requires

Keyboard Navigation to be enabled in the

General > Interface settings.

Move Focus to View: The item list will have

focus.

Move Focus to Preview: The view/edit pane

will have focus.

Move Focus to Inspector: The current

inspector will have focus.

Favorites: Displays a submenu of items in the

Favorites section of the Navigate sidebar.

WORKSPACES

Workspaces: Workspaces allow you to save

the state of your open databases, as well

as the contents and positions of all open

windows, so that you can restore them later.

This is ideal if you are working with the same

set of windows over and over again. Save

these windows as a workspace and recall

them whenever you need them again. From

the Workspaces submenu you can:

Add: Saves the currently open windows

and open databases as a workspace.

Edit: Opens a window that allows you

to edit saved workspaces. Click on a

workspace name to change it, reorder by

dragging, and delete with the - button.

Update: Updates an existing workspace

to the current state of databases and

windows.

Choose: Choose a workspace from the list

of saved workspaces to load it.

THE SCRIPTS MENU

The Scripts menu is located left of the Help

menu and shows a stylized AppleScript 

symbol instead of a normal menu title. It

contains a collection of useful, predefined

AppleScripts you can use directly from within

DEVONthink.

Some of the scripts work without having

selected a document, while others require

you to select the document you want the
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script to interact with. In general, the script

will tell you what you have to do when you run

it.

We also occasionally provide optional scripts

for a variety of purposes. Select More Scripts

to open the Support Assistant and install the

ones you like. You can read more about the

pre-installed scripts scripts in the appendix.

If you're interested in scripting, check out the

Automation chapter.

THE HELP MENU

The Help menu contains commands

for opening the integrated help pages,

the support assistant, or visiting the

DEVONtechnologies website.

DEVONTHINK

Use these commands to open the integrated

help pages, get directions on installing the

browser extension and bookmarklets, or

access the list of changes to DEVONthink.

DEVONthink Help: Opens the internal

documentation.

Extensions & Bookmarklets: Opens the

section in the help with information about

our browser extension and bookmarklets.

Hidden Preferences: Opens the

documentation to the section about

hidden preferences.

Release Notes: Opens the What's New

section of the documentation so you

can see what's new, improved, fixed, or

removed in each release.

SUPPORT

Support Assistant: Opens the support

screen of the Welcome to DEVONthink

assistant with more direct links to the

DEVONtechnologies website, tips, and

tutorials. Note this function requires an

Internet connection.

Tutorials: Opens the Tips and Tutorials

screen of the Welcome to DEVONthink

assistant. The tutorials help get you started

by explaining everyday DEVONthink tasks

in step-by-step detail. Note this function

requires an Internet connection.

CONTACT

These commands take you directly to the

corresponding pages on our website or send

feedback directly us.

DEVONtechnologies: Quickly access our

home page.

Your Account: Opens the login page for your

DEVONtechnologies account where you can

get information on your licenses and the

devices they're registered to.
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User Forum: Jump into our user forum.

Frequently Asked Questions: Choose this

option to access many often asked questions

in the Questions & Answers section of our

website, pre-filtered for questions about

DEVONthink.

Contact Us/Report Bug: Use this to draft a

general email to us. When you need to report

an issue, hold the ⌥ Option key to show the

Report Bug. This creates a new message

in your default email client or Apple Mail

containing the console log and all related

crash logs in a ZIP archive, ready to be sent to

our customer support.

THE DOCK MENU

The Dock menu appears when you Control-

click DEVONthink's icon in the Dock or left-

click it and hold the mouse button for one

second or longer. When items are added

to a database, a badge appears on this

icon. Longer tasks, e.g., importing, indexing,

or running scripts, may show a progress

indicator on the dock icon.

It also contains the generic macOS

commands and an Options menu common to

all macOS applications. DEVONthink-specific

items are listed below:

Recent Databases: Quickly reopen a closed

database from this list.

Open Windows: Switch to any open window

from this list. The active window is displayed

with a checkmark next to it.

New Window: Open the selected database in

a new main window.

Take Note: Opens the Take Note panel.

Start/Stop Server: Starts or stops the web

server.
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The Settings window, accessed via the

Settings command in the application menu, is

where you find and change the global settings

for DEVONthink. There are a wide variety of

options available, from setting the default

font for new rich text documents to how

often RSS feeds should update or setting

up syncing your database. Now you can fine-

tune many aspects of the operations and

customize your experience.

GENERAL

GENERAL

Use the General tabs to set application/

interface appearance and behaviors as well as

defining label colors and names.

General:

Enable reminder alarms: Enable or disable

using alarms with DEVONthink Reminders.

Automatically mark items as read: Enable

this option to mark viewed item as

read, similar to applications like Apple

Mail. Disable this option if you prefer to

manually mark items as read.

Search Scope: Control the behavior of

toolbar searches, e.g., where to search and

coordination with the Search inspector.

Scope Location: Choose where to begin

the search: Last scope, Current Database,

All Databases, and Current Selection.

Automatically select search inspector:

Switches to the Search inspector if the
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view/edit and inspectors are already visible

during a search.

Dock: DEVONthink's dock icon will show a

number in a red circle. Choose what this

number represents to you: new items, unread

items, or unread news.

Usage: Enable this to send anonymized usage

data.

Alerts: Press the Reset button to again

display alerts previously dismissed with the

"Don't show again" option in dialogs.

Send anonymized analytics data: Sends

anonymous information about certain

activities in DEVONthink, e.g, a key denoting

an optional script you installed. See our

company's Privacy page for more information

on the data that may be sent.

Check for Updates: Choose how often you

want DEVONthink to check if a new update

is available or press Check Now to manually

check for an update.

INTERFACE

These options influence interface behaviors

for displaying and opening documents,

settings for the item list, and controls for the

Navigate sidebar.

Mouse Clicks: Control how groups, links, and

documents are handled when double-clicked.

Double-click opens groups in a new

window: Open a new window for a double-

clicked group. If unchecked, the group

becomes the current location in the item

list.

Double-click opens documents externally:

Open double-clicked documents externally

in the system default application, e.g.,

TextEdit for RTF documents. If disabled,

they will be opened and displayed in a

separate document window. If you hold the

⌘ Command key, the document will open in

the opposite way of this setting.

Click on links opens them externally: Open

URLs in document text with the system

default application. Use ⇧-click to open and

activate the default application. Note ⌘ or

⌥-clicks can be still used to open links in

new tabs or to add them to the Download

Manager, respectively.
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Behavior: Control the view of the item list

and its interactions with the view/edit pane.

Keep groups on top when sorting: Always

display groups at the top of the item list,

independent of the sort method, e.g., by

Date Added.

Retain view: Keep the current view settings

in a main window, e.g., Icons in Widescreen,

when switching to other databases. If

you change the view, e.g, from Icons to

Column view, that change is retained

when switching. A database's original view

settings will be restored after disabling this

option.

Preview group content: Display documents

contained in a selected group via the view/

edit pane.

Select (and display) new notes

automatically: Always make newly added

documents the active document.

Automatically reveal items: Always reveal

the active document's location in the item

list, for example when switching between

document tabs in a main window.

Document windows prefer fullscreen:

Open document windows in fullscreen

when opened from another fullscreen

DEVONthink window.

Enable tabbed browsing: Display

documents in tabs instead of document

windows. Check Always show tab bar if

you'd like to view the document title in a

tab bar even when only one document is

open.

Sidebar: Control the Navigate sidebar.

Automatically expand & collapse groups:

Automatically expand databases in the

Navigate sidebar and select the group for

the active location in the item list.

Keyboard Navigation: Enable keyboard

navigation with type-ahead, and arrow key

hoisting of groups in the Navigate sidebar.

Unify inboxes: Gather the inboxes of open

databases in the Globals section of the

Navigate sidebar. When disabled, each

inbox will be displayed in the root of its

database.

Unify tags: Gather the Tags group of all

open databases in the Globals section of

the Navigate sidebar. When disabled, each

Tags group will be displayed in the root of

its database.

Unify Databases: Display each open

database and its groups in the Open

Databases section of the Navigate sidebar.

When disabled, only the root of the open

databases are displayed while the groups

of the active database are shown in the

section below bearing the database's

name.

APPEARANCE

Appearance: Change the appearance of some

of the interface elements, including the item

list, the sidebars, and some of the inspectors.
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Alternating row colors in views: Color every

other row in the item list.

Display number of items inside groups:

Show the number of items in each group,

tag, or RSS feed.

Highlight bookmarks in views: Display

bookmarks in the item list as hyperlinks, in

blue and underlined.

Mark duplicates and replicants in color:

Display duplicated and replicated items in

your specified colors. When disabled, these

instead display a property icon to the right

of a document's name.

Show filename extensions: Display a file

type's extension at the end of its name in

the item list, e.g, devonthink manual.pdf.

Use dark background for documents:

Display compatible documents, e.g., rich

text, with the color scheme reversed when

your system is using macOS' dark mode.

When disabled, documents will display

normally regardless of the system's mode.

Labels: Choose the appearance of color labels

in the item list and Navigate sidebar. The

supported options are:

Classic: Tints the item's icon (like on Mac

OS 9).

Modern: Displays the item's name in a

colored bubble (like on older versions of OS

X).

Dots: Shows a colored bubble to the right

the item's name (like on macOS).

As flags: Displays a colored bubble in the

Flag column of the item list or to the left of

an item's name. In the Navigate sidebar, the

bubble appears to the right like the Dots

option.

Interface Font Size: To accommodate those

with impaired vision or wanting a larger

size font in some parts of the interface, the

sidebars, and some of the inspectors, there

are three font controls:

View Text Size: Set the size for the text

in the item list, the contents of sheets

in table view, and the Annotations and

Attachments tabs of the Document

inspector. Supports from 10 to 24pt.

Sidebar Text Size: Set the font size

DEVONthink used in the sidebars.

Supports from 10 to 24pt.

Chat Text Size: Set the font size in various

AI-directed elements, e.g., the Chat

inspector or the Summarize popover.

Supports from 8 to 15pt.

Note: Currently, there are no controls

for changing the font in the interface.

However, there are two hidden preferences

to switch to a monospaced font.

LABELS

Label: Set the name and color for color

labels you can apply to the files and groups

in your databases. Be aware these are global

settings, i.e., you can't have different labels

DEVONthink 4.3.2 Documentation, page 221



for different databases. Also, following

Apple's example, we only allow setting seven

color labels.

EDITING

The Editing tabs define all options that fine

tune DEVONthink's text editing behavior.

Everything from default fonts to text and

highlight colors as well as margins and

automatic text transformations, like smart

quotes.

GENERAL

Author: Enter the default name to be used

for metadata, placeholders, etc.

Ruler Units: Set the units used for the Format

> Ruler when editing rich text. Choose from:

Centimeters, Inches, Points, or Picas.

Rich Text Attachments: Control the behavior

of PDF and image attachments in rich text-

based formats.

Display PDF attachments of rich texts:

Display a scrollable preview of an attached

PDF in RTFD documents. When disabled,

it will display the PDF's icon, filename, and

the size.

Scale image attachments: Visually scale

large images to the width of the view/

edit pane when attached to rich text

documents and formatted notes. This does

not effect the actual dimensions of the

attached image.

Typewriter-like scrolling: Keeps the

currently edited line in the center of the

window or view/edit pane.

Spelling & Grammar:

Check spelling while typing: Spellcheck

while you write.

Check grammar with spelling: Check

grammar as well as spelling while you write.

Correct spelling automatically: Correct

misspelled words automatically.

Check and correct spelling in rich text

documents only: Limit spellcheck and

correction to rich text formats, including

web-based formats like formatted notes.

Substitutions:

Smart copy/paste: Insert or remove spaces

before and after cut or pasted text.

Smart quotes: Convert straight quotes

("inch marks") to typographer's quotes

("curly quotes") while you type.

Smart dashes: Convert characters, e.g.,

two hyphens into a proper dash.

Smart quotes and dashes in rich text

documents only: Limit converting quotes

and dashes to rich text formats, including

web-based formats like formatted notes.

Smart links: Detect web addresses and

turn them into clickable links.

Data detectors: Detect dates, times or

addresses in text, and show possible
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actions when the mouse cursor moves over

them.

Text replacement: Use the system-wide

text replacements when editing text.

FORMAT

Define the visual settings for plain text

formats, including Markdown source, and rich

text formats, including formatted notes.

Plain Text: Choose the Plain Text Font, as

well as the Background and Text colors. If

you have a plain text document selected, the

font and colors will dynamically update as you

make changes. There are also two settings for

controlling the width of the content:

Max. Line Width: Set the maximum width

of the contents (in points).

Margin: Set the document margins (in

points).

Line Spacing: Choose the spacing between

lines of text in points.

Line Height Multiple: Adjust the spacing

between lines as a multiple of the line's

height.

Rich Text & Note Font: Set the default font

for newly created rich text-based documents.

Changes do not apply to existing documents.

To change existing documents, use the

commands in the Format menu while editing

specific documents.

Full Screen: Choose the Text and Background

colors to be used when editing a document

in DEVONthink's fullscreen mode. These

settings will override the colors in non web-

based documents. The Width is a percentage

of the screen's width, defining the width of

the content in fullscreen view.

HIGHLIGHTING

Set the name and color for highlighting

text in compatible file formats, like PDFs.

Changing the colors will not change the

highlight colors already applied in existing

documents. Also, be aware these are global

settings, so you can't have different highlight

names and colors for each database.
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WIKILINKS

Toggle using WikiLinks, choose the link

detection method, what items can be

linked to, and if link names should update

when edited. Also, define template text

to pre-populate newly created WikiLinked

documents.

WikiLink Controls: To enable WikiLinking,

check the Automatic checkbox and choose

from the options shown here:

MashedWords: Commonly used to avoid

creating links from individual words, detect

concatenated capitalized words, e.g,

DatabaseSecrets.

Square Brackets: Detect or use

words in double square brackets, e.g.,

[[Barcelona]].

Names and Aliases: Matches documents

based on the name or any aliases defined in

the Generic Info inspector.

All Items/Only Documents/Only Groups:

Choose whether to match only documents,

groups, or both.

Case-insensitive Linking: Ignore

capitalization when detecting or using

WikiLinks. When enabled, Global Economy

and global economy both would match.

Open new documents in separate

windows: Openly newly created WikiLinked

documents in a new document window.

Update name of item links automatically:

Update the link text in documents

containing item links when the name of the

linked documents change.

Update name of WikiLinks in square

brackets automatically: Update the square

bracketed link text in documents when the

name of WikiLinked documents change.

Aliases Separators: Set the delimiting

character that separates multiple aliases

applied to a document. The default is

semicolon (;).

Template: Define template text used as

the content of a newly created WikiLinked

document. Add text and Control-click to

use Insert Placeholder to insert a token

that will be automatically replaced when

the template is created. The default title

contains several of these tokens already.

Check out the placeholders section of the

appendix for information on the available

choices.

For more information on creating WikiLinks

and other linking methods, see the Document

Linking section.

FILES

The Files settings contains controls for a

variety of things from imports to media

playblack, thumbnailing to Markdown

extensions, and much more.

DEVONthink 4.3.2 Documentation, page 224



GENERAL

The General settings control some

miscellaneous options, including filenaming,

the behavior of annotation and indexed files,

and versioning.

General: Control duplicate detection and

filesystem naming.

Stricter recognition of duplicates: Check to

have DEVONthink use document contents,

file type, file size, and the content hash of

the document, when detecting duplicate

files.

More compatible naming of files: Replaces

the characters |<>%?&*" when naming files

to improve the compatibility with other

filesystems and platforms, e.g., Dropbox or

OneDrive. Forward slashes and colons are

always replaced as these are reserved by

macOS.

Annotations: Control where to save

annotation files, if they follow when the

referred file is moved to another database,

and what file format they should be.

Location: Choose where to save newly

created annotation files: In shared group

or In same group. The shared group is

an Annotations group in the root of the

current database.

Move annotations automatically: Move

annotation files along with their referred

files when moved between databases.

Rename annotations automatically:

Changes the name of an annotation file

and the backlink's text in its contents when

the backlinked document's name changes.

Format: Choose the format for newly

created annotation files: Markdown, Rich

Text, or select Automatic to use the same

format as the referring file.

Indexed Items: Control the behavior when

mixing indexed and imported items in

indexed and non-indexed locations in your

databases.

Automatically move items to external

folder: Force imported or created items to

be moved to the Finder folder when placed

into an indexed group.

Automatically move indexed items into

database: Indexed items moved to a non-

indexed location in your database will be

moved into the database. This removes the

item from the Finder location.

Versioning: Control the number, maximum

size, and retention of document versions.

Max. Versions: Set the maximum number

of versions per-document from: 5, 10,

15, 20, 30, 50, or retain them all with

Unlimited.

Max. Size: Define how large an individual

version can be, either: 1MB, 2MB, 5MB,
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10MB, 20MB, 50MB, 100MB, 200MB, or set

no boundary with Unlimited.

Remove Versions: Choose when versions

should be automatically purged: After one

day, After one week, After two weeks,

After one month, After two months,

After one year, or keep them forever with

Unlimited.

PREVIEW

Control automatic loading of online data,

including indexed files stored online, as well

as what types of files should have thumbnails

created.

General: Control accessing online data,

including indexed documents stored online..

Automatically download cloud files:

Download the content of indexed files

whose contents are only stored online

when previewing them.

Automatically load bookmarks: Load

bookmarks when viewing using the built-

in web browsing functions. Disable this to

avoid loading problematic pages, e.g., poor

JavaScript, etc. When disabled, click the

Load Preview button in the view/edit pane

to load it.

Create Thumbnails: Choose the file types for

which DEVONthink should create thumbnails

or icons.

Generate from actual image: Create

thumbnails from image data, not an

existing thumbnail.

File Types: Choose the general file types

that should have custom thumbnails:

Images, Movies, PDF & Postscript

documents, Web Archives, Formatted

Notes, Bookmarks, Markdown documents,

and Other file types viewable via

QuickLook.

Create preview as icon: Applicable to

Other file types, the thumbnail is added as

an icon visible in the Finder.

IMPORT

Choose the default import option for items

added from external sources, e.g., drag and

drop, dock icon drops, etc. Control the text

encoding of certain file types and whether

to use creation and modification dates from

a document's contents. And lastly, decide

whether to automatically transcribe text or

detect barcodes from added documents.
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Destination: Choose how DEVONthink

decides where to file externally added items.

Select group: Display the group selector to

choose a specific destination group.

Global inbox: Automatically store the

added items in the Global Inbox.

Text Encoding: Choose the default encoding

used for plain text documents. Select

Automatic to let DEVONthink choose the

best encoding.

Use content creation & modificate dates:

Choose whether to use the filesystem

dates or dates detected in the content of a

document, e.g., a PDF.

Recognition: DEVONthink can use AI to

detect and save the content from certain

kinds of files automatically upon being added

to your database. Enable the options you

wish to use. For images and media files, the

AI provider and default output format are

chosen in the AI > Transcription settings.

Transcribe PDF documents: PDFs without

a text layer are automatically processed via

the Vision framework.

Transcribe Text & Notes in Images: AI

processes images and extracts text from it.

Transcribe Audio/Video Files: Detect and

transcribe from audio or video files.

Scan barcodes: Detect barcodes in PDF

documents and images. If a barcode is

detected, the value will be added to the

document's Barcode custom metadata in

the Data inspector.

TAGS

Decide how Finder tags are handled and what

types of automatic tagging you require.

Finder: Choose whether to import Finder

tags when adding files or export to Finder

tags when tagging indexed files or exporting

from DEVONthink.

Import: Decide which automatic tagging

options are appropriate for your situation.

Convert Hashtags to tags: Convert

document hashtags, e.g., #DEVONtech, to

tags.

Convert keywords to tags: Convert

embedded keywords from PDF documents,

RTF(D) files, and images to tags.

Convert properties to tags: Convert

embedded properties from PDF

documents, RTF(D) files, and media files to

tags.

Convert geolocation to tags: Convert a

document's geolocation names to tags,

e.g., "Orlando", "FL", and "United States".

Assign existing tags: Automatically tag

a document based on the tags of similar

documents or use the document's title and

text.
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Add Chat suggestions to documents: Use

AI to analyze and add tags to a document

and choose whether they should be limited

to existing tags.

Add Vision suggestions to images: Add

tags suggested by Apple's Vision ("Live

Text") framework to a document.

Read more about tagging in the Tagging

section.

EMAILS

Use these options to define how email is

imported and displayed inside DEVONthink.

Conversation: Decide if DEVONthink should

attempt email threading, grouping, and how

to handle copies of already imported emails.

Import complete conversations: Let

DEVONthink scan the Sent mailboxes

and include emails belonging to the same

conversation.

Group conversation threads: Combine

emails in a conversation thread into

their own group. This makes identifying

conversations easier and automatically

adds structure to the imported messages.

Previously imported will become

replicants: Import copies of emails as

replicants when they've been previously

imported, otherwise skip them.

Note: Due to a lack of emails standards and

decades of legacy emails, email threading is

not a guaranteed process.

Fallback text encoding: Specify the text

encoding to use for emails with no detectable

encoding.

Message Content: Control loading remote

images, decrypting emails, and whether to

import attachments.

Load remote images in messages: Load

images when viewing emails in Text

Alternative view. For more secure email

viewing, this is disabled by default.

Decrypt secure messages: Decrypt secure

emails before importing. These emails

will be stored in their decrypted state,

accessible by search, potentially including

Spotlight.

Import attachments: Include attachments

when importing emails.

Appearance: Set some basic controls for how

emails display in DEVONthink.

Use alternative view: Set the default

view of emails to Text Alternative view.

Otherwise, they will be viewed via

QuickLook (Best Alternative).

Use fixed-width font for plain text

messages: Display plain text messages

using a fixed-width font such as Courier

in Text Alternative view. This is useful if
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the messages contain tables or footers

formatted with spaces.

Color quoted text: Display quoted text in

color when viewed in Text Alternative view.

Assign colors for each level of quoting by

clicking the color wells.

Labels: Assign a color label corresponding

to a flag or high priority on emails. As items

can only have one color label, flags take

precedence over priority.

Hotkeys: Specify hotkeys to import selected

emails or mailboxes while in a compatible

email application, e.g., Apple Mail. You can

use the hotkeys previously used with our

late Apple Mail plugin: ⌃⌥⌘M for importing

messages, ⌃⌥⇧⌘M for importing mailboxes.

Read more about archiving email…

MARKDOWN

Choose options for the default mode when

selecting Markdown files, styling, or any

extensions to be used when rendering the

Markdown.

Markdown Display: Specify a default

view, whether DEVONthink should display

formatting and images when editing, and if

new lines should be assumed.

View: Set the default display mode when

viewing a Markdown document: Edit

Documents, Preview Documents, Side-by-

Side, or retain the previous view with Last

Used Display.

Syntax highlighting: Toggle the display of

formatting and detected elements in the

source code of a Markdown document.

WYSIWYG images & links: Display the

actual images and live hyperlinks in the

source code instead of raw Markdown, e.g.,

![](/img/piglet.jpg).

Force line breaks: Enable this to treat a

return as the end of a item without having

to add two spaces explicitly at the end of

the line.

Smart quotes and dashes: Automatically

convert straight quotes to typographer's

quotes and two or three dashes to en- and

em-dashes, respectively.

Import images to group: Specify a group

to contain linked images, whether they're

dragged and dropped, copied and pasted

from outside DEVONthink, or from web

content clipped as Markdown. See the

Documents > Markdown > Linking Images

section for more information.

Image Reference: Specify the type of link

to be used with images pasted, dropped, or

downloaded for Markdown documents.

Item Link: Always link images via an item

link.

Automatic: Images will be linked with

either item links or relative links, depending
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on the location of the image in the

database.

Style Sheet: Choose a default global

stylesheet to style your Markdown

documents, if desired. Supports online URLs,

item links to stylesheets in your database, or

click the Select button to access stylesheets

stored on your machine, e.g., in ~/Library/

Application Support/DEVONthink/

StyleSheets.

JavaScript: Choose a default JavaScript

file to be loaded with all your Markdown

documents, if required. The JavaScript can be

located anywhere, including an online script,

if needed.

Extensions: Check the desired extensions you

want to use in your Markdown documents:

MathJax support: Supports rendering

mathematical equations via the MathJax

extension.

Mermaid support: Supports rendering

diagrams via the Mermaid extension.

Prism support: Supports syntax coloring

of rendered inline code and code blocks via

the Prism extension.

Summaries: Use Markdown blockquotes

instead of highlights when creating summary

documents in Markdown via Tools >

Summarize Annotations.

Read more about working with Markdown

documents…

MULTIMEDIA

Choose options for media playback, display

modes and magnification for PDF documents

and images, the default width of clipped

PDF documents, and annotation sorting in

summaries.

Play Media: Play audio and video files

Automatically when viewing them, if they

should play on repeat via Loop, and their

Background Color.

Image Display: Set the default magnification

and background color for viewed images:

Actual Size, All Pixels, Zoom to Fit, and Zoom

to Width.

PDF Display: Choose how PDF documents

are displayed in windowed and fullscreen

modes, including the Background Color.

Use Automatically resize to change the

magnification when you view a document.

Note there is a correlation between the

display mode and the zoom option.

Single/Two Page: Display one or two pages.

Continuous: Display the document as a

long scrollable document, zoomed to width.

Non-Continuous: Display only one or two

page(s), zoomed to fit. Scrolling up or
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down changes the pages without displaying

previous or subsequent pages.

PDF Clipping Width: Specify a width in points

for captured or clipped PDF documents. The

default value is Automatic. Be aware the

styling on specific sites could override this

setting.

Summaries: Control if PDF annotations are

sorted by type, e.g., highlights or underlined,

in Tools > Summarize Annotations instead of

their order in the document.

Read more about working with PDF and

media documents …

SHEETS

Choose the options for displaying sheets and

and converting them to paginated PDFs.

Sheet Display: Choose the default view when

viewing a sheet: Table or Form. Form view is

only available in the Pro or Server editions.

Background Color: Set the background color

used in Form view.

Paginated PDF Conversion: Choose Table

View or Form View for converting a sheet

via the Data > Convert > to PDF (Paginated)

command.

Form view is only available in the higher

editions of DEVONthink.

Read more about using with sheets…

SORTER

Control the Sorter's location and assign

hotkeys for note creation and clipping.

Appearance: Display the Sorter in the

menu bar, as a docked tab on the side of

your screen, or not at all.

Position: Choose the onscreen position

when set to display as a docked tab.

Menu Extra Title: Display DEVONthink or

a nautilus icon when set to display in the

menu bar.

Screen Capture: Play the system default

screen capture sound.

Visibility: Display the Sorter at full or

reduced opacity when docked.

Hotkeys: Set system-wide hotkeys for: Take

Note, Copy Selection, Clip to DEVONthink,

and Search. To change the hotkeys, click

the Click to record shortcut button, then
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press the hotkey that you want to use. Press

the ⎋ Escape key to cancel recording a new

shortcut.

Note: Modern versions of macOS require

you to give explicit permissions for the

behaviors of the hotkey functions listed

above. You can read about this in the

Installing, Privacy Options, Updating,

Uninstalling > macOS Privacy Options

section.

Read more about using the Sorter

RSS

DEVONthink comes with built-in RSS

capabilities that enable you to add RSS feeds

to your database and have DEVONthink

update them automatically. Use these

preferences to define how often DEVONthink

checks for new articles, whether to skip

duplicates when updating feeds, when to

remove older articles, and which CSS style

sheet to use for displaying the articles.

Updating Feeds:

Check for updates: Set how often you want

DEVONthink to refresh your feeds. Choose

a time-based option from 5 minutes to

hourly to once a day, when opening or

after synchronizing a specific database, or

checking manually.

Convert categories and hashtags to tags:

Some RSS articles have tag metadata

to help people more easily navigate the

publisher's site. Check this option to

convert these to DEVONthink tags. Note

this can add a great number of tags to your

database.

Skip identically named articles: The same

article can be delivered when using multiple

RSS feeds from one site. Enable this option

to avoid downloading duplicate articles.

Show chat summary in notification center:

Display a AI-generated summary when new

articles arrives.

Remove Articles:

Remove articles: Set how often older

articles are removed from the feed. Check

Also unread articles to remove them, even

if they're unread.

Remove immediately instead of moving

to the trash: Immediately delete the RSS

articles from your database.

Also unread articles: Remove all articles at

the specified interval whether they've been

read or not.

Note: Feeds or articles locked via Data >

Mark > as Locked will not be removed.

Feed Format:

Feed Format: Choose a file format for

the downloaded articles. (RSS articles are

presented as HTML files, by default.)

Use clutter-free layout: Remove extraneous

items from web archive and single-page

PDFs.
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Feed Style Sheet: Choose a custom or built-

in stylesheet for use with HTML articles

(Feed Format: Automatic) articles. Store

your own RSS stylesheets in ~/Library/

Application Support/DEVONthink/

StyleSheets.

WEB

The web preferences resembles the settings

of most web browsers. Use these preferences

to define how DEVONthink's displays HTML-

based documents browsing web pages.

Web Content: These settings define how

DEVONthink treats special web contents:

Enable ...: Check these options to use

installed third-party plugins, Java applets,

or JavaScript scripts used by a web page.

Block ...: Check Block pop-up windows to

block pop-up windows, which are often

advertisements; check Only automatic

JavaScript windows to block only pop-up

windows opened by JavaScript. Uncheck

this option if the web page you're visiting

uses pop-up windows for actual content.

(Some web content management systems

do this.) Check Block zooming to keep web

sites from automatically zooming windows

to full size. Check Block advertisement to

attempt to block advertisements when

possible.

Zoom text only: Magnify only the text, not

the images when using the View > Zoom

commands.

Images: These settings define how

DEVONthink displays graphics in web pages:

Display images when the page opens:

Check this option to display web pages

with images. Just remember, if unchecked,

you may miss some information.

Animate images, Loop animation: Check

these options to run web graphics

animations and to run animated graphics in

a loop.

Scale images to fit: Check this option

to scale (large) images to fit the current

window.

Accept Cookies: "Cookies" are little text files

with information that web pages store on

your computer used to recognize you as a

returning customer, among other things.

While most are harmless, you may want to

control what is being stored on your hard

disk.

Always: Accept all cookies.

Never: Don't accept any cookies.

Only from sites you navigate to: Accept

cookies, but only from web sites you

navigate to (not from other sites, such as

ad trackers).

Delete cookies on quit: Delete all stored

cookies when you quit DEVONthink.

Fonts: Set the fonts you want to use for

displaying web pages; set separately for

variable-width and fixed-width text.
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Note: Hold the ⌥ Option key to restore the

default fonts.

Style Sheet: Select a custom stylesheet to

be applied to HTML-based content with no

specified styling. Store your own stylesheets

in ~/Library/Application Support/

DEVONthink/StyleSheets. Be aware this

could lead to displaying undesirable styling in

some cases.

Text Encoding: Select your desired text

encoding for displaying web pages. Automatic

tries to choose the best available encoding.

If this does not work for you, choose a more

appropriate text encoding for your language

group.

SYNC

DEVONthink allows you to keep your

databases in sync with multiple Macs and iOS

devices running DEVONthink To Go. Set up

your sync location, choose which databases

are synced, and how often they're synced.

LOCATIONS

The Locations column lists all available sync

locations, whether these are the built-in

options, ones you've added yourself, or ones

detected on your network, e.g., WebDAV

services. Activate or disable sync locations

via its checkbox. Inactive or inaccessible

locations are shown in grey. And if a sync

location is using encryption,  will appear to

the right of the name.

Use the buttons below the Locations list for

more options:

Add Location: Add a new sync location

with the + button e.g., to add another local

sync store.

Remove Location: Remove a selected sync

location with the - button. It is generally

a good idea to clean the location before

removing it.

Show Info: Display a popup with editable

details of the selected sync location.

The Locations Action menu also is used for

information, troubleshooting, and removing

chosen sync locations.

Reveal in Finder: Opens a Finder window

revealing a selected local sync sync store.

Verify Location: Used in troubleshooting

situations, this quickly verifies the integrity

of the sync data of the chosen sync

location. Hold the ⌥ key to select Verify

Location Thoroughly.

Clean Location: Also used in

troubleshooting, this removes all the sync

data in the selected location.
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SYNC LOCATION OPTIONS

When setting up a sync location or editing

the options on an existing one, you will see

some of these options in the Info popup

for the location. The options shown are

dependent on the specific sync method:

Encryption: The key used to encrypt

the sync data (AES-256). This is not

mandatory, but recommended. There are

no length or character requirements.

Sync Store Name: The name of the sync

store, ideally with no spaces for broader

compatibility, e.g., DTSync or work_2025.

If you are setting up an already active sync

location, e.g., you've already synced from

another device, click the dropdown menu

to choose from a list of existing stores.

Synchronize label names & colors:

Synchronize label names and colors using

this location. Be aware, changes to the

colors and names on any syncing machine

will sync to the others.

Synchronize reading positions: Synchronize

reading and playback positions using this

location. This can help you keep your place

in PDFs you're reading or audio/video you're

playing.

Synchronize custom metadata definitions:

Synchronize custom metadata definitions

found in the the higher editions of

DEVONthink and actively used on

items in your databases. If you are

collaboratively syncing, you may want to

disable this option to avoid the other party

from receiving your specific metadata

definitions.

Synchronize content of indexed files:

Synchronize the content of indexed files. If

you uncheck this option only the metadata

about the document will be synchronized.

This is generally only used in special

circumstances.

Verify uploaded items: Verify all uploaded

items to make sure the sync data is intact.

Usually only necessary with unstable

network connections/servers or in case

you experience troubles with defective

files.

URL: The URL of a WebDAV server, often

including a port and folder where the

sync store is located, e.g, https://

herax.local:65501/DEVONsync. The path

is case-sensitive.

User name: The user name for the service.

Password: The password for the service.

DATABASES

With a sync location selected, the Databases

column lists all currently open databases as

well as all databases available remotely in the

selected location. The Local section lists all

open databases and a message about their

sync status, e.g, the timestamp of the last

sync. The Remote section lists all databases

available for import or currently not open on

the machine. When attempting to import the

latter, the local database will be opened by

DEVONthink.

Start and stop syncing a specific database

to the selected location. Uncheck databases

you want to discontinue syncing with the

selected location, but be aware this does

not remove the sync data. See the Clean

Database command below.

Use the buttons below the Databases list for

more options:
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Import Database: Select a remote

database and click  to download the data

of the database and save it locally. The

database will be automatically configured

to sync with this location. Alternatively,

you can double-click a remote database to

import it.

Synchronize Database: Select a checked

database and click  to manually sync the

database with this location.

Refresh List: Refreshes the list of remote

databases available in the selected

location.

The Databases Action menu also contains

commands for importing, manually

synchronzing, troubleshooting, and removing

sync data.

Import Database: Import a database in an

unencrypted state. It is possible to import

an encrypted database as an unencrypted

one, if the situation warrants it.

Import Encrypted Database: Import a

database as an encrypted database.

You will need to specify the maximum

database size and an encryption key. This

option also can be used when importing an

unencrypted database.

Import Revision-Proof Database: Imports

an revision-proof database. This can

only be used to import an revision-proof

database.

Verify Database: Used in troubleshooting

situations, this quickly verifies the integrity

of the sync data of the chosen database.

Hold the ⌥ key to select Verify Database

Thoroughly.

Clean Database: Also used in

troubleshooting situations, this removes

the sync data for the chosen database

from the current sync location.

Refresh List: Manually update the

Databases list.

Sync messages: Under each listed database

in the Databases list, is a message about its

sync state. You will see one of these:

Not yet synchronized, upload database:

This database has never been synced to

this location.

Not yet synchronized, merge with remote

database: This database has been synced

to this location from another device, but

not yet from this Mac.

Last Synchronization,…: This database has

been synced to this location at the time

shown.

SYNC OPTIONS

Sync Options: The settings at the bottom of

the pane control the behavior for all active

sync locations, from how often to sync to

how sync conflicts are handled.

Synchronize: Choose if you want to

synchronize automatically, manually,

or in fixed intervals. Check On Quit or

Deactivation to automatically synchronize

when you quit DEVONthink or when you

switch to another application.

Max. Connections: Choose the maximum

number of connections DEVONthink

should open. The faster your internet

connection the higher you can usually go.

The recommended value is 16. Note the

maximum number is controlled by the

service you're using.

Conflicts: Choose how to solve the conflict

if an item was changed both locally and
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remotely before either device synced.

Use latest document preserves the most

recently changed document. Duplicate

documents keeps both versions of the

conflicting item and appends "copy" to the

end of one's filename.

BONJOUR OPTIONS

Click the button Bonjour Options to control

if and how other instances of DEVONthink or

DEVONthink To Go can connect to your Mac.

Your Mac becomes the sync server, the other

devices the clients.

Enable incoming connections: Allow

other devices connect to your copy of

DEVONthink and synchronize.

Open databases automatically: Open a

database automatically when a client

device requests syncing with an unopened

database.

Port: Set the port number used for

incoming connections, if you need to assign

a specific port. If not, leave this empty and

DEVONthink will choose a random port for

you.

Password: Create a password to be used

by client devices needing to connect to

this Mac as a server. This password is

mandatory. This password also encrypts

the client-server connection at all times.

Read more about synchronization…

AI

From setting up your default chat engine and

deciding what kind of permissions you give

it when searching or working with your Mac,

the AI view is where you set these options.

For creating AI-based images, see the Image

Generation view. And if you need to detect or

convert speech to text in images and media

files, see the Transcription view.

CHAT

Choose your AI model and settings specific

to it, as needed. Also set from where the

model can get information, if it can effect

changes to your database, and what kind of

summaries you'd like it to return.

Chat Setup: Specify what large language

model (LLM) you want to use and set up

any required parameters for it. Note several

of the controls here are dynamic and the

options will change depending on what LLM

you've chosen.

Provider: Choose from the list of

supported chat engines, e.g, ChatGPT,
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Anthropic's Claude, or even one you are

running locally.

API Key: Enter the personalized key you

were provided by your AI service provider.

URL: Enter the URL of a locally running

LLM server. This option will only appear as

needed.

Model: Choose from the list of models

for a specific LLM, e.g., Gemini Flash 8B.

Each model may show one of several icons

showing its capabilities:  for reasoning,

 for vision,  for tooling,  for deep

search,  for coding support, and  for

cost, with the icon's boldness indicating

higher or lower costs.

Context Window: This is the number

of tokens the LLM can process and

"remember" in a conversation. A larger

context window means more data is

passed or remembered. However, if you're

trying to run a local LLM, larger context

windows use more RAM. This also displays

how many tokens have been used, sending

and receiving responses. Bear in mind, this

setting can be set per model as each has

its own context window size.

Usage: Choose an option to balance cost

and quality of results, from fewer tokens

with less precision to more tokens but a

higher chance of useful results.

Role: Define an optional default "persona"

or instructions for the AI, e.g., "You are

an undergraduate professor presenting

to your class. Use Markdown formatting

with sections and subsections but no lists.

Include links to your sources." This is used

in automation, like AI assisted scripting.

Assistant: Certain AI models have access

to "tooling" and may be able to accept

DEVONthink-related commands. You need to

decide what behaviors you will allow it to use

on your Mac and with your databases.

Allow property & content changes: Decide

whether the chat assistant can make

changes to your database, e.g., add tags to

a document or create a new one for you.

Allow download of web pages: Allow AI

to download the content of web pages to

examine as part of its querying process.

This may be considered an insecure option.

Allow screenshots of window: Allow the AI

assistant to capture and examine a screen

capture of DEVONthink's window for use

in queries. Requires a compatible AI model,

e.g, Claude Sonnet.

Load remote images automatically: Control

whether linked images in web content is

downloaded for examination. This may be

considered an insecure option.

Max. Recent Chats: Set the number of

remembered chats you can revisit in the

Recent Chats popup in the Chat assistant.
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MCP

The MCP settings provide controls for

setting up DEVONthink's MCP server,

allowing connecting to and working with your

databases while outside our application.

Privacy: Enable Redact sensitive content

to remove or obscure recognizable private

information like credit card numbers, email

addresses, phone numbers, etc. before the

content is sent to the AI model.

MCP Server: If you are integrating with

Claude Code or other HTTP-based MCP

clients, enable Launch at login. Note that

Claude Desktop and Cowork launch their

own instance of the server as they need it.

Accept connections: Choose From the

Mac only to restrict access only to local

use, From the local network to connect to

devices on your network, or Any device to

allow even remote connections. The last

two options require a valid TLS certificate

and bearer token.

TLS Certificate: Choose an existing

valid TLS certificate you have installed.

Note that self-signed certificates aren't

supported.

Bearer Token: Connecting other devices

requires a bearer token for authentication.

Press the Create button to generate one

specifically for DEVONthink's MCP server.

Port: The port the server is using, even

when running locally. A default port is

assigned but can be changed to a different

unused port, as needed.

URL: Select and copy this URL to use in

other applications or on other devices

accessing the MCP server.

Connectors: If you are chatting or using

Cowork in Claude Desktop, click Install

for Claude Desktop. If you have installed

the Claude Code command-line interface

(CLI), enable Install for Claude Code. For

OpenAI's Codex access, enable Install

Codex Desktop & CLI. To use the Hermes

Agent, including via Ollama, click Install

for Hermes Agent. Each option will only

be enabled if the respective application is

installed.

Log: To access information about what's

happening with the MCP server, click the

Log button.

You can read more about using the MCP

server in the AI in Practice > Assistants

section.
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SEARCH

The Search settings control where you want

external AI to search. For example, when

researching medical issues, you may want to

let it search PubMed but not Wikipedia. The

options are: in your Databases, on the arXiv,

PubMed or Wikipedia websites, or on the

Web, in general.

Regarding web and Wikipedia searching, you

can also choose a specific engine for deep

research: DEVONthink, Perplexity, Exa AI, or

ollama.com for web searches. The commercial

services provide quick results but utilize

indexed content. DEVONthink's results are

returned more slowly but are up to date. Also,

be aware the commercial services require an

account and an API key.

SUMMARIZATION

Model: Choose a specific AI provider and

model for summarization or Default to use

the Chat model.

Language: Choose a specific language to use

for the summary or leave it as Automatic to

use the system's primary language.

Style: Determine what summary format you'd

like in response to asking chat to summarize a

document. The choices are:

Text: Gives you a brief synopsis in a few

paragraphs.

Bullet Points: Returns a list of the main

points.

Key Points: Provide a distilled response of

the main topics.

Table: Create a table of columns and rows,

often used for correlating pages or links to

text.

Custom: Provide a summary defined by a

template you define in this settings pane.

Custom Prompt: Create your own prompt

defining what kind of response you'd like,

including how you'd like the summary to be

structured. Use the special placeholder %@ to

refer to the information being summarized.
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IMAGE GENERATION

Choose and set up a text-to-image AI model.

These controls are dynamic and their options

change depending on the model you choose.

Image Generator Setup:

Model: Choose a supported text-to-image

model, e.g, Flux Pro or Nano Banana 2.

Aspect Ratio: Choose a predefined aspect

ratio for the images. Supported sizes

are: 1:1, 16:9 (9:16), and 4:3 (3:4),

depending on the chosen model.

Quality: Decide whether to generate

Standard or HD images, if available.

API Key: Enter the API key you received

from the image generation provider, e.g.,

Replicate.com for the Flux generator.

TRANSCRIPTION

AI speech-to-text processes incoming media

files and processes them per these settings.

For example, an .mp3 file could be transcribed

into a separate annotation file for future use.

For each type of text recognition, images

or audio/video, choose where to store

the recognized text via the Destination

dropdown. The available options are:

Searchable Text: This is similar to Apple's

Live Text feature in that a text layer isn't

added to the document, but instead

is stored in the database's index and

associated with the file.

Annotation: Create an annotation file with

the transcribed text.

Comment: Add the transcribed text as a

Finder comment on the file.

Images: Decide what live OCR engine you

want to process images added to your

database:

Fast Apple Vision text recognition: Quickly

detect text in images using Apple's Vision
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framework. Often sufficient for many use

cases.

Accurate Apple Vision text recognition:

Detect text in images with an emphasis on

accuracy over speed.

Text recognition via chat: Uses your chosen

Chat model to detect text in images,

provided the model supports image

analysis. When enabled, you can choose a

vision-capable AI model, if desired.

Audio & Video: Choose the transcription

engine you want to process media files added

to your database:

Local Apple SpeechAnalyzer transcription:

Transcribe audio on your Mac with Apple's

SpeechAnalyzer framework.

Remote OpenAI Whisper transcription:

Transcribe audio remotely with OpenAI's

Whisper service.

Remote Mistral Voxtral transcription:

Transcribe audio via Mistral's Voxtral Mini

model.

Note: On macOS 10.13.5 Ventura and

10.14 Sonoma, Apple's audio transcription

engines are Local Apple Speech

transcription and Remote Apple Speech

transcription The local engine may be less

accurate and requires Siri or Dictation

to be enabled on your Mac. However, you

aren't required to share the information

with Apple. Also, OpenAI's transcription is

done via GPT-4o.

Add timestamps to transcription: Examines

the speech and inserts timestamps at certain

points.

Transcription Language: Choose the language

of the media file to be transcribed. Only used

with OpenAI's Whisper.

API Key: Enter the API key you received from

your AI transcription provider, e.g., OpenAI.

DATA

Define custom metadata fields that are

meaningful to you, your company, your

research group, or even your family! These

attributes can be assigned to items in

your database, extending the search and

organization possibilities.

Custom Metadata: The Custom Metadata

column contains a range of built-in fields,

ready to use or modify, as needed. These

cover a variety of common uses and you can

easily add your own for your use cases.

Enable any field by checking the checkbox

next to it. Use the buttons below the Custom

Metadata column for extra options:
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Add: Click the + to create and name a new

custom field.

Remove: Click the - to remove any field.

When deleting a field, a warning will be

displayed. This warning can be suppressed.

Action: Select any field and click  for

more options, including duplicating,

renaming, or removing the selected field.

You can also restore the default metadata

fields from this menu.

Note: These options are also available from

the context menu.

The order of the fields is also the order in

which they appear in the Generic inspector.

Drag the attributes to reorder them, as

needed.

Properties: Each custom attribute has its

own properties, like the type or a set of

predefined values to choose from. View and

set the properties of a selected attribute in

the section on the right.

Identifier: This is a special name used

in automation. The term is created by

DEVONthink and cannot be entered or

modified manually.

Type: This is the specific type of the

current field. Choose one of twelve data

types, such as Date, Boolean, Decimal

Number, or Languages.

Format: Only displayed with certain data

types, you can choose some pre-defined

formats, like Percent. With the Currency

option, you will have an option to enter a

currency symbol.

Values: Only displayed with the Single-

line Text and Set types, define a list of

items to choose from. These choices will

be displayed in a dropdown menu when in

use. Add and remove the items with the

+ and - buttons. Control-click an item to

change it. If you'd like to resort the items

to alphabetical order click the opposing

arrows button.

Please refer to the Data section in the

Appendix for more detailed information on

the data types.

Note: Like many types of metadata

applied to files by various applications,

custom metadata is not cross-platform.

On macOS, it is stored in the extended

attributes upon exporting the file.

OCR

DEVONthink contains an optical character

recognition (OCR) module that allows you to

import scanned documents and make them

searchable. These documents are "read" by

the embedded OCR engine and stored as PDF

files that contain an additional (invisible)

text layer containing the searchable text.

Use these options to control the engine,

including the output format, resolution, what

language(s) to use, and what to do with the

originals.
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OCR Processing:

Convert Incoming Scans: Choose the

file format for images or PDF files

received from a known scanning software,

e.g., ScanSnap Home: searchable PDF,

RTF document, Word document, or

WebArchive. Use No Action to disable OCR

for incoming scans, e.g., if the scanning

software has already done OCR.

Original Document: Check Move to Trash to

move the original documents to the trash

after OCR is completed.

Enter metadata after text recognition:

Opens a metadata panel, post-OCR, where

you adjust any of the properties: title,

author, subject, tags, and creation date.

Document Controls:

Compress PDF: Create smaller PDFs

by applying compression to the final

document. Compression only applies when

adding metadata post-OCR or preserving

annotations from an original PDF after

OCR.

PDF Resolution: Set the desired resolution

for the image layer in the PDF from 150 to

600 dpi. On M-series Macs, you can also

choose As source to retain the originally

scanned resolution.

Page Orientation: Detect and correct the

page orientation.

Deskew: Correct angled pages in the final

document.

Language Controls:

Custom Dictionary: Check Use Dictionary

to use a custom dictionary of acceptable

words. For example, you may have an

unusual spelling of someone's name in

some documents. You can enter the name

as an acceptable choice for the OCR engine

to choose from. Click the Configure button

to add custom entries for OCR detection.

Note you can only have one dictionary,

specified for the language chosen in the

Language dropdown.

Primary Language: Set the most common

language of the documents you scan.

Secondary Languages: Add other languages

to match the language of specific

documents you're processing.

DEVONthink comes with more than 150

different language dictionaries. Adding extra

languages can improve the accuracy of the

text recognition. Select a language from

the Available column on the right and add

it to the Selected column using the right-

to-left arrow button. Deactivate a language

by selecting it in the Selected and pressing

the right-to-left arrow. You can select a

maximum of four secondary languages. Note

the primary language and the secondary

languages are treated equally.

IMPRINTER

Imprints are custom bits of data that can be

stamped onto images or the pages of PDF

documents. Imprints can be used in a variety
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of ways, from stamping when an invoice was

paid to adding specialized numbering. With

the ability to include placeholders, you can

create many kinds of watermarks for your

documents.

Every imprint is created as a configuration,

saved to use again and again. There are three

parts to an imprint: the configuration, the

appearance, and the location. We'll cover all

three here.

CONFIGURATIONS

The Configurations column is where you

create a new imprint or edit one you've

already created. Select one and edit any of

the parts or appearance or use the buttons

below this column to create a new one.

Add: Click the + to create and name a new

configuration.

Remove: Click the - button to remove a

selected configuration.

Action: Select any field and click  for

more options, including duplicating,

renaming, and deleting the selected

configuration. A special item in the menu,

New Combined is discussed below.

Preview: Click this button to display an

example of the imprint with the current

settings.

New Combined: Found in the  action menu,

this option allows you to create new imprints

from your existing ones. This extends the

usefulness of existing imprints.

From the action menu, select the New

Combined option. Two panes will be

displayed: Combined and a Configurations

panes. In the righthand pane, select an

existing configuration and click the < button

to add it to the Combined pane in the

center. DEVONthink remembers the location

and styling of the individual imprints in

a combined configuration. To remove an

item from the Combined pane, select it and

press the > button. It will reappear in the

Configurations pane on the right. Combined

items will be displayed in the order you add

them. To see what the imprint looks like,

press the Preview button.

APPEARANCE

Add and style the components of the imprint

with these controls.

Title: This is the body of the imprint. Type

any static text you want to appear in the

imprint. Control-click > Insert Placeholder

to define sections of the watermark with

placeholders. Tabs and linebreaks are also

entered as placeholders. If you need to

rearrange the parts, you can easily do this

via cut and paste.

Font: In the Font options, choose the

font, weight, color, and other styling for

the watermark. If you choose the outline

style, you can choose the Thickness of the

outline.

Border Style: Choose and style a pre-

defined border, if desired. When using a

border, you can also specify the border

Color and Thickness and an optional Fill

color.

Note: There is only one font style for each

imprint. You cannot have mixed styles, e.g.,

displaying one word larger or in a different

color.
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LOCATION

In the Location tab, choose and fine-tune the

position of the watermark, as well as on what

pages it will appear.

Position: Set the anchor point for the

imprint's location on the document, e.g,

clicking the center point centers the

imprint horizontally and vertically on the

page.

Offset X/Y: Fine-tune the position of the

watermark. Negative values are to the left

(X) and down (Y), positive values are to the

right (X) and up (Y), relative to the anchor

point of the imprint.

Rotate: Set your imprint on an angle, if

desired.

Occurrence: Choose what pages the

imprint should appear on. Use Custom to

have the imprint appear on specific pages.

Note: Be aware imprints currently cannot

be removed from the document. Especially

while you're fine-tuning your imprint, it's a

good idea to enable Duplicate item before

imprinting. This will imprint a copy of the

current document.

SERVER

Set up the web sharing services, define users

and their per-database permissions, and

run/monitor the web server. Enter the web

server's parameters and behavior in the

General tab. In the Users tab, administer

users and their per-database permissions and

monitor or access connection information.

Note: When using the server in

administered networks, e.g., public,

corporate, or educational scenarios,

you may need to consult with the IT

department for successful operation.

GENERAL

Start on Launch: Set the web server to run

when DEVONthink launches.

Convert images & PDF documents to

searchable PDF: Control whether images

and non-OCR'd PDFs added to the web

sharing interface are automatically

converted to searchable PDFs.

Session Expiration: Define the length of time

before an idle session times out.
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Bonjour Settings: Use these settings to

define your web server's identity, everything

from the name and port, to creating a

certificate vouching for the "safety" of the

server's activity.

Bonjour Name: Enter a distinct name for

your web server to clearly identify it to your

users.

Bonjour Domain: Set the Bonjour domain

if necessary. Leave this field empty unless

you know what you're doing.

Port: Set a static port if the server will

be accessed regularly, or from outside

your network. If this field is left empty,

DEVONthink will assign a random, unused

port eachtime the web server launches.

While setting a static port is suggested,

non-standard ports can be prohibited on

some networks, so consult with your IT

department.

Security:

TLS Certificate: If you have a TLS

Certificate, select it from this dropdown.

P12 Certificate: If you have been issued a

P12 file, import it by clicking the Load P12

file button.

Self-signed Certificate: Create a self-

signed certificate for DEVONthink. The

certificate is created as DEVONthink

Server.

Allow insecure HTTP connection on

port: DEVONthink's server runs on SSL

connections for secure browsing. If you

have a compelling reason to use the older

http protocol, check this box and enter the

port to be used.

USERS

User List: The Users tab on the left allows you

to add, remove, and modify users, as well as

set their per-database permissions. Currently

logged-in users will show a green circle to the

right of their name. If you have DEVONagent

Pro installed, it will be added as a default

user. This allows it to search DEVONthink's

databases in the same way it searches other

websites.

Add: Click the + button to add a new user.

Remove: Click the - button to remove a

user.

Password: Select a user and enter a login

password.

Database Permissions: The Database list

on the right allows you to set per-database

permissions for individual users. All open

databases will be listed in this pane, followed

by the available permissions. Select a user

and enable the permissions they need to

have. For broader changes, Control-click the

permissions for a database to set or revoke

all permissions on the database.

The available permissions are:
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Read: Allow the user to access the

database. When unchecked the database

will not be visible to the user in web

sharing.

Download: Allow the user to download

documents from the database.

Write: Allow the user to modify the

contents of certain editable file types, e.g.,

plain text.

Add: Allow the user to add items to the

database.

Organize: Allow the user to move around

documents and groups in the database.

Delete: Allow the user to delete items from

the database.

Technical Info: If you need more information

on the activity of the web server, you can find

some deeper details here.

Server Details: The section under the

Databases pane shows some basic

technical data about DEVONthink's server

activity.

Log: In cases where deeper technical

information about the server's activities is

required, click the Log button in the lower

right corner. The log file will open in macOS'

Console application.

Server URLs: When the server is running,

two URLs will be listed at the bottom of the

window: one is the Bonjour URL, the other

is based on the machine's IP address. Click a

link to open it on your machine. Control-click

a link to copy or share the link to your users.

Read more about Web sharing…
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DEVONthink was created with robustness

in mind. But any computer hardware or

software, regardless of how carefully

developed and built, can write defective data

or destroy files. If you have some general

questions about DEVONthink, sales and

licensing, etc., please check out our Questions

and Answers section on our site. If you

experience specific technical problems with

DEVONthink or its databases, please check

the following sections.

We hope the information in this chapter can

help resolve an issue, or at least give you

some information to work with!

FIRST STEPS

When you run into an issue with DEVONthink,

your first reaction should be, "Hmm… I wonder

what that was." and see if it happens again. If

it recurs, the next things you should do are:

Reboot: Reboot your machine. Rebooting

a machine can often cure a host of issues,

closing down rogue processes, releasing

memory, etc. We suggest rebooting your

devices at least once a week, just to

mitigate potential issues.

Update: You should ensure your operating

system is up to date. We are not

advocating "upgrading" the OS, like from

Sonoma to Sequoia. We are talking about

"updating". So if the current version of your

OS is 15.3.1 and you're running 15.2, get your

machine up to date. (And yes, this nicely

facilitates a reboot in the process!)

Ask: Check through this chapter or jump

over to our forums to see if anyone else has

experienced your issue.

Report: If you don't find an answer in

the appropriate sections in this chapter,

please do the following: Hold the ⌥ Option

key and choose Help > Report Bug.

This creates a draft email, ready to

send to us, containing troubleshooting

information and logs. You can also send

us full-resolution screen captures (or

screencasts), if they'd be helpful in

illustrating the issue you're experiencing.

NOT YOUR FIRST STEP

When some people have an issue, they

immediately try uninstalling and reinstalling

the application. That is a very bad idea and

almost always wastes time and energy on

something with that likely has a simple and

logical solution. And not only is reinstalling
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rarely effective, it also removes important

troubleshooting information that could have

been useful in resolving an issue.

So if you run into a problem do not reinstall

the software. Contact us as we've indicated

so we can assess the situation. If we come to

a point we feel reinstalling is appropriate, we

will instruct you to do so.

FILE ISSUES

WHY DOES DEVONTHINK NOT RECOGNIZE

MY FILES?

DEVONthink supports importing many

different file types. However, here are

thousands of types and we can't guarantee

trouble-free importing or usefulness with

every type.

If DEVONthink does not recognize a file, make

sure the file has a proper file name extension.

DEVONthink needs a file name extension to

determine the file type. Add the correct file

name extension to your files, e.g., .txt for

plain text files, etc.

There are only a few files that are explicitly

not importable: Finder aliases or other

databases, e.g., dtBase2, or items located in

the internals of other databases.

WHY DOES DEVONTHINK NOT DISPLAY MY

DOCUMENT CORRECTLY?

DEVONthink uses Apple's Quick Look

technology to display previews of many

file formats. If a document is not properly

displayed, especially if it is a proprietary

file format, it may be you don't have a

QuickLook plugin installed for this file type

or the application that created the file is not

installed on your Mac (and supports Quick

Look). Control-click the file and choose Show

In Finder to reveal it. With the file selected

in the Finder, press the spacebar to open a

Quick Look window to determine if the item

is viewable.

WHY CAN'T I SEARCH MY FILE?

Merely importing a file doesn't mean it's

immediately searchable. For example, images

are not content-searchable unless you've

used AI transcription, set to Searchable Text

or Comments.

For proprietary formats, you need to

have a Spotlight importer installed. These

components come from third-parties,

typically the developer of the format or

an application that can edit it. If there is

a Spotlight importer available for the file

format you're adding to your database,

DEVONthink may be able to use it to gather

some information about the document. The

kind and amount of information is dependent

on how the importer was developed.

MISBEHAVING FILES

PDFs: PDFs have been around so long, it

would seem they'd be easily supported in

DEVONthink. However, the truth is there are

many bad PDFs out there. If you encounter a

bad PDF, try acquiring a new copy of the file.

If you're having an issue annotating or editing

a PDF, it's possible it is encrypted or read-

only. This will be indicated with either a 

or  property icon in the Navigation bar.
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You may be able to clear a read-only status

with the Data > Convert > To PDF (Paginated)

command.

If the file is encrypted in such a way as to

inhibit changing the document, DEVONthink

will honor the restrictions imposed by

the document's producer. However, one

potential solution for this problem is Michele

Balistreri's PDFKey. It allows you to print

protected PDFs. Use PDFKey to "print" a PDF

file into a new PDF that is both printable and

editable, which allows DEVONthink to extract

the text for searching and classifying.

DEVONthink uses Apple's PDFKit framework,

the same as found in their Preview

application. If you have an issue with a PDF

in DEVONthink, check to see if you have the

same issue in Preview. Other applications,

including those from Adobe where PDFs were

invented, are using their own frameworks so

their behavior isn't directly comparable.

Text Files: If you have an issue with plain

or rich text documents, open them in

TextEdit and see if the behavior is the same.

DEVONthink uses macOS' text engine, so if

there's an issue in our software it's likely you

will see the same issue in TextEdit.

EMAIL IMPORT ISSUES

Messages aren't imported or can't be filed:

Email messages are imported with a special

identifier (UUID) that helps DEVONthink

keep track of messages that have already

been imported. Since a UUID must be unique,

you can't have more than one file with that

identifier. If you try to import the same

message into a database, you will receive

a logged message stating "n emails already

imported".

Importing takes a long time or stalls:

Importing email is not a trivial process. Not

only does it copy the message into your

database, but it also reads and analyzes the

entire contents of each one. Importing a large

mailbox will logically take much longer than a

smaller one. One possibility is to split a large

mailbox into multiple smaller ones. Importing

smaller batches often proves to be less taxing

on the machine's resources. And you don't

have to import an entire mailbox at once.

Most email is handled via IMAP servers where

your emails are stored, potentially so you

can access them from different devices.

Some of your emails and their headers will

be stored on your Mac but the content can

be periodically removed by Mail, leaving only

the headers. This means Mail has to contact

the email server and download the email

(and its attachments) before it can pass

it along to DEVONthink. This can slow the
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import process a great deal. And depending

on the retention policy of the email server, it's

also possible some emails may no longer be

available.

Having emails local to the machine is ideal

and can be accomplished by using an On

My Mac mailbox in Apple Mail. For example,

you could create a 2024 mailbox, search for

emails from that year, and move or copy

the emails to it. Be aware that moving the

emails may remove them from the email

server, but that depends on the email service

provider. Also, if you're archiving emails, it

may be desirable to remove them. If not, you

can copy them. As was already mentioned,

smaller mailboxes will be more performant, so

dividing up the emails into logical mailboxes

like our yearly example, is a good idea. Going

forward you could set up mail rules in Apple

Mail to copy or move to local email folders

when they're received.

Regarding attachments, again local is ideal.

In the settings for your email account in

Apple Mail, there is an option to download

attachments. If you're going to be importing

emails and attachments, it's best to

download them all.

One thing to consider is the space being used

on your machine. A few things: The On My

Mac mailboxes aren't necessarily permanent.

After you have archived one successfully into

DEVONthink, you could remove the mailbox.

You could also relocate the database to an

external hard drive.

Some emails fail when I drag and drop: Your

email in Apple Mail is actually a database.

Very active databases, with many additions,

deletions, reorganizing, etc., can inherit

inconsistencies over time. If you are receiving

a message that a drag and drop into

DEVONthink failed, it could be due to such

an issue in Mail. Choose Mailbox > Rebuild

Mailbox and let it finish. Then try the drag

and drop again. You can also try dragging and

dropping to the Finder first, then into your

database.

Why can't I import from email application

X?: Inter-application communication,

something at which DEVONthink excels, isn't

universally developed. In order for more true

automation between applications to occur,

the developers need to implement robust

and reliable mechanisms, like AppleScript.

Some apps may provide simple URL schemes

but they are limited in use and capabilities,

often only able to process one file at a time.

Better results can usually be had by merely

dragging and dropping. For email clients with

a good AppleScript dictionary, the potential

for streamlined workflows is increased.

UNLOCKING A DATABASE

If you open DEVONthink and see an icon of a

crossed pencil to the right of the database's

name, the database has a file permissions

issue. This makes the database readable,

but not writeable, so you can't modify the

contents in any way.

A permissions issue like this is uncommon

but generally caused by three events, in

order from most to least common: restoring

from Apple's Migration Assistant, restoring

from Time Machine, or an operating system

or hardware error. Doing things like using

Migration Assistant will not always cause a
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permissions issue, but if you have a crossed

pencil icon and you've recently migrated to a

new machine, this would be the likely cause.

The first thing you can try is to select the

database in DEVONthink then choose File

> Rebuild Database. Do not interrupt the

process or let the machine power down while

it's working.

If that doesn't resolve the issue, try this:

Step 1: Close the database in DEVONthink.

Step 2: Locate your database. If it's the

Global Inbox, it's located in ~/Library/

Application Support/DEVONthink. For

other databases, do a Spotlight search for

kind:database dtBase2.

Step 3: Select the database file and press

⌘I to show the Info pane.

Step 4: At the bottom, you'll see Sharing &

Permissions. Click the lock icon to unlock

it. You will be prompted to enter your

administrative password. (This is the

password you use to log into your account

on your Mac.)

Step 5: Make sure the account marked

(Me) is set to Read & Write.

Step 6: Click the Action menu and choose

Apply to enclosed items, if it is available,

then close the Info pane.

Step 7: Double-click the database file to

reopen it in DEVONthink.

If this does not resolve the issue, please

contact our support team.

OVERFILLING A DATABASE

If you are using an encrypted or revision-

proof database, you define the maximum size

it can grow to when you create it. This is a

hard limit, no different than the size of the

internal disk on your Mac. Finite space can't

hold infinite documents, so you need to be

aware of how much space you have available.

If you add more data than it can hold, you will

receive errors in the Log window of popover.

If you run into this situation, please contact

our support team.

Another thing to be aware of, there needs to

be enough space available to do maintenance,

like a database rebuild. To keep an eye on the

space, periodically select it in DEVONthink,

then choose File > Database Properties. At

the bottom of the statistics you will see the

space consumed and the available space to

work with.

SYNC ISSUES

DEVONthink's synchronization was designed

to run in self-maintenance mode. If you are

having issues syncing your DEVONthink

databases, the first place to look is Windows

> Log. Most sync related errors and reports

will be shown here.
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Below we cover some things you can check

for the type of sync method you're using as

well as some common questions you may

have.

THINGS TO TRY FIRST

Here are a few simple things to try when you

have a sync issue:

Check your network connections, including

trying to log into a remote service.

Reboot the computer

For non-Bonjour and non-iCloud sync

locations, make sure you're entering the

correct store name. When logged into

a remote service, the Sync Store Name

dropdown should list available sync stores

to choose from.

Make sure you're using the correct

encryption key  for the sync location.

Make sure you have sufficient space

for sync data when syncing using cloud

accounts.

VERIFY & CLEAN

Verifying: If there is an issue reported with

syncing, e.g., broken structures or missing

manifests, you should first verify the sync

data to see if it's intact and consistent. The

results of a verification will be reported in the

log window.

Cleaning: If the verification fails, you can

then clean the sync location or database to

remove the sync data in that location. The

results of the clean will be reported in the

Log window. After a successful clean, you can

upload the database(s) again. And just to

ease anyones' mind, cleaning a sync location

has no effect on the local databases on your

devices. Sync data is not your database and

is separate from the local databases on your

devices, Mac and mobile.

Before you clean sync data: Isolate one

syncing device and do the maintenance there.

Before you do, disable the sync location

or specific database on the other syncing

devices. After the clean and resyncing is

finished, you can then enable the sync

location on the other devices again.

To verify or clean sync data, open  Sync

settings. These commands are essentially the

same but are applied to either an entire sync

location or a specific database.

Sync Location: To clean or verify all

the sync data from a specific location,

Control-click it and choose the appropriate

command. For a verification, hold

the ⌥ Option key and choose Verify

Location Thoroughly to perform a deeper

verification of the sync data. For a remote

sync location, there may be a pause while a

connection is established.

Database: To clean or verify the sync data

for a specific database, select the sync

location to display the databases list.

Control-click the specific database and

choose the appropriate command. For a

verification, hold the ⌥ Option key and

choose Verify Database Thoroughly to

perform a deeper verification of the sync

data. Repeat this with any databases, as

needed.

Both these actions can be used at any time,

for preventative purposes or just to get a

fresh start with syncing. Also, you may see

unwanted databases in the Remote section

of the databases list for a sync location.
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Cleaning the location will remove these

databases too. But if you want to keep the

sync data for your current databases, you can

Control-click and clean specific databases in

the Remote section.

BONJOUR

Bonjour syncs are generally transparent,

but it can only be used on a local network

that allows Bonjour traffic and non-standard

ports. Many public networks disallow this

kind of traffic to protect their customers.

Also, corporate networks will often disallow

this traffic for security reasons.

Note: Bonjour connections cannot be used

over VPN. This is technologically infeasible,

at least at the moment.

Make sure you have entered the correct

Bonjour password that you set in the

server Mac's Bonjour options.

Make sure DEVONthink is running on the

other Mac or iOS device and both devices

are awake.

Make sure only one device is acting as the

Bonjour server for a given database. You

should not have two devices with incoming

connections enabled trying to serve the

same databases.

Make sure the databases you want to

synchronize are open on the other Mac, or

enable Settings > Sync > Bonjour Options:

Open databases automatically on the

server Mac.

Restart the other Mac, the iOS device, or

both.

Make sure this computer is connected to

the same network as the other syncing

device.

Make sure any firewalls or applications

like Little Snitch are allowing traffic from

DEVONthink.

Check if there are any routers or switches

involved. The more switches and routers

the less reliable the connection due to

port filtering, conflicts, or other unknown

factors.

Restart your router.

If you find yourself on a network that

disallows Bonjour syncing, it is possible to

connect your iOS device to your Mac via your

Lightning cable. This creates a simple ad-

hoc network that will allow Mac-to-mobile

syncing. If you are in a corporate situation,

please discuss this with your IT department

to ensure you're not violating any security

policies. They may also issue an exception

for a specific port you could use for Bonjour

syncing. If they do, you'd enter it in the Port

section of the Bonjour options.

ICLOUD

Since your devices are generally signed into

your Apple ID, using iCloud for syncing is

the easiest to set up. However, it should be

understood it can only be used for personal

syncing. Collaborative syncing is not possible

unless all participants are sharing an Apple ID.

If you are using an iCloud (Legacy) sync, the

data is synced locally first. iCloud processes

will then upload the changes to Apple's

servers and propagate the information about

it to all other devices. It generally happens

smoothly and in the background but it means

you can't expect the changes to be ready on

other devices as soon as DEVONthink has
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finished synchronizing to iCloud. If you are

using a CloudKit sync, DEVONthink deals

directly with Apple's servers.

Here are a few things to check:

Make sure you have enabled DEVONthink

in System Settings > iCloud > iCloud Drive >

Apps Using iCloud on each device.

Make sure all syncing devices are logged

into the same Apple ID.

Note: Be aware iCloud can stall. This is a

sporadic, but documented, issue that can

cause your devices to get out of sync. This

is not under our control, nor can we even

detect or anticipate it.

WEBDAV

Our support for WebDAV services allows

you to use cloud services that are WebDAV-

enabled. This also presents some self-hosting

opportunities, even with some NAS devices.

However, they can sometimes be technically

more difficult to implement. Here are some

things to check:

Make sure the service or device you're

trying to connect to is reachable. This is

especially true when self-hosting. If you see

errors in the 500 range in the Log window,

it's a problem at the server.

Make sure you are using the proper

protocol in the URL, http:// or https://.

Make sure the URL is complete. This will

be specific to the device or service you're

using. If you're running your own WebDAV

server, you should set up a folder shared

by WebDAV as the location for your sync

data. For a Synology NAS, for example,

you have to add the target volume to the

path (a valid URL would look like: http://

diskstation.local:5005/DTSync). Be

aware the folder name is case-sensitive, so

dtsync is not DTSync. Refer to the service

or manufacturer's instructions for the

proper URL construction.

Make sure you have entered your user

credentials correctly. If you see 400-

series errors, there is an issue with your

authorization.

Note: WebDAV implementations vary so

it's not possible to guarantee compatibility

in all situations. For self-hosting, Apache

implementations are the most compatible.

DROPBOX

Dropbox is our longest supported sync

method and is generally reliable and a good

performer. However, there are a few things to

consider.

According to Dropbox' rules, you cannot sync

across user accounts. They don't allow you

to share the Apps folder or its subfolders

between accounts. Also, they only allow our

sync engine to be logged into one Dropbox

account at a time. If you have a work and a

personal account, you can only sync to one

with DEVONthink.

Log into your Dropbox account to make

sure it's reachable. If you see errors in

the 500 range in the Log window, it is a

problem with the remote server.

Make sure you are connected to the correct

Dropbox account. The active account will

be shown under the sync location's name in

the sync preferences.
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Collaborative syncing may be possible using

a common Dropbox account, i.e., using the

same username and password for syncing.

But again, you can only sync to one active

Dropbox account at a time.

COMMON QUESTIONS

I enabled the sync and nothing's happening:

Our sync engine will not sync, upload or

download, without being told to. We believe

in opt-in processes whenever possible.

Merely enabling a sync location just sets up a

location to be ready to receive and transmit

data. You need to enable individual databases

to sync. You also need to do this on each

device you want to sync. If you have enabled

databases to sync, check Window > Log for

errors.

I'm seeing a message about an invalid

encryption key: When you set up a sync

location, you have the option of entering an

encryption key. This is used to scramble and

descramble the sync data so it's stored in an

encrypted state. Once you've synced the first

time, this value, even if you aren't specifying

a key, is stored for that sync location. This

value must be entered on other devices

syncing with this sync location.

You can't add, remove, or modify the

encryption key value for a sync location

after the first sync. If you want to make a

change, you must clean the sync location

first. Disable the sync on all devices but one,

then clean the location. After the clean,

Control-click the sync location again, choose

Show Info, and make the modification to the

key. After the first sync, this will be the value

stored for the location. After the clean and

resync from the one device, you must change

the value on the other syncing devices, then

re-enable their syncs.

I am seeing a message about missing

manifests: Missing manifests are bits of

transactional sync data that cannot be

located by the sync engine. When this occurs,

it can't validate the information about what

has been synced. This is not an issue with

the databases; it's missing sync data. See

the Verify & Clean section above regarding

verifying and cleaning the sync data.

It's telling me I have a duplicate database

UUID: As noted in the glossary, a UUID is

a unique value given to all DEVONthink

databases. If you copy and rename a

database file in the Finder, this UUID is

preserved and DEVONthink sees two

databases with the same UUID. This will not

sync correctly. Please contact our support

team for assistance on resolving this.
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REPAIRING A DEFECTIVE DATABASE

DEVONthink databases are packages

containing your files and the indices

containing metadata, thumbnails, etc. These

package files are normally robust and trouble-

free but problems sometimes can arise. If

your database starts behaving strangely, or

if DEVONthink finds inconsistencies during

start-up, it is time for some housekeeping.

In this section we look at the most common

issues and their usual causes, followed up by

explanations of the maintenance commands

in the File menu.

MISSING AND EMPTY FILES

All documents in a DEVONthink database

have a path the file system where their

content file is located. This path is stored

for every document, imported or indexed. If

DEVONthink can't find a file at a path stored

in its index, it will be reported as missing.
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The most common causes of missing files

are: indexed files being moved in the Finder,

the indexed parent folder being renamed,

or the indexed parent being moved. In the

first case, the file isn't in the location it was

indexed from. Moving the file back into place

will resolve this issue. In the second case,

the path no longer exists as the names in

the path have changed. Changing the name

back will resolve this. For the third case you

may have had to relocate the folder for space

or other organizational reasons. Select the

indexed parent group in your database and

open the Generic Info inspector. Click the

dropdown arrow next to the Path field and

choose Select. In the Open dialog, locate the

indexed folder in its new location and press

the Choose button. DEVONthink will update

the paths for the contents of the folder in its

new location.

Regarding indexed items, it's also possible

for out-of-date items to be reported as

missing, especially in cloud-synced locations.

Remember that items indexed in cloud-

synced locations may require a manual

update via File > Update Indexed Items since

a filesystem event may not be triggered by

the cloud software. Also DEVONthink tries to

make sure it doesn't cause any conflicts with

those applications.

The second most common cause of missing

files is people modifying the internal contents

of a database. Some Finder replacement

applications, like PathFinder, allow you to

access package files like normal folders.

The internals can also be accessed by other

methods, like the command line or the

Finder's context menu. If you delete or

reorganize anything, you can easily cause

missing files.

Empty Files: Empty files, also known as

zero-byte files, are just that: files with no

content and listed as having zero bytes for

the file size. DEVONthink is aware of certain

file types that can legitimately have empty

files, but will report ones that can't, e.g.,

images. These aren't very common but are

sometimes caused by a crash, incomplete file

transfers, or temporary files created by some

applications. They are handled in the same

way as missing files.

Dealing with missing or empty files: Missing

files are reported in DEVONthink's Window

> Log. To deal with these files, Control-click

the item in the Log window and choose one

of two options:

Reveal: Reveals the item in the expected

location in the database. If the view/edit

pane is visible, the expected file path is

shown beneath a document thumbnail.

This path is especially useful when dealing

with missing indexed files as it shows the

path in the Finder from which the file was

indexed. If the path shows the file inside

a Files.noindex directory, you may use the

following option if the file is of no concern

or contact our support team.

Move to Trash: If the missing file is of no

value to you, this command moves the

file to the database's Trash. Then choose

the DEVONthink > Empty Trash command

to completely remove the file from the

database.
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ORPHANED FILES

Just as with any database application,

controlling the data flow in and out is a

critical process. DEVONthink should be the

gatekeeper of the files in its databases. If an

external agent, whether an application or a

user, adds files outside DEVONthink, they

will cause an internal inconsistency and lead

to orphaned files when following the steps

below.

The most common cause of orphaned files

is a simple and common one: attempting to

create revisions. Say you open a file, a Word

document, in an external application. As

you are reading it, you decide to make some

changes. You type your edits, and select File

> Save As (or File > Duplicate the file first).

The application most commonly will open

the Save dialog in the location of the original

file, in this case, inside the internals of the

database. You have just created an orphaned

file DEVONthink knows nothing about. So the

question becomes, how do I create a revision

without causing this issue? One simple way

is…

Duplicate: Duplicate the item in

DEVONthink first.

Rename: Rename the duplicated item.

This can be quickly done by immediately

pressing ↩ Return, typing the change, then

pressing ↩ again.

Open and Edit: Now you can open the new

file and make your edits.

The other common cause is the same as

with missing files: getting into the database

package and adding files manually.

Note: Modifying the internal contents

of a database outside DEVONthink is

unsupported behavior and can lead to

broken or inconsistent databases. You

should only get into a database's internals

when instructed to by our support team.

PENDING FILES

You may see a message in the Log window

about "n items to be uploaded" or you may

see a  icon to the right of an item's name.

These are pending, meaning the metadata for

the item is in the database but the content is

not. As this is something that can propagate

to other devices, it shouldn't be ignored.

A common cause is indexing files and syncing

while the files aren't available. For example,

indexing files on a connected hard drive then

ejecting the drive or indexing cloud synced

files that have been evicted from the local

machine by the cloud service. Syncing while

the content is unavailable pushes only the

metadata from the database. This means

another device, Mac or mobile, won't have

contents available to download, leaving

them with pending files. This also should

underscore why it's important to read and

understand the In & Out > Importing &

Indexing section before committing to it.

To address this, start with a toolbar search

for item:pending in your database to help

isolate the files. If none, are found, try

emptying the trash in DEVONthink. If any

pending files found and you don't need them,

move them to the databases' Trash and

empty it. Also, make sure the indexed files are

available, whether in your cloud-synced folder

or by connecting the volume from which you
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were indexing. You may need to select the

indexed parent and choose File > Update

Indexed Items to reconnect them with their

contents.

If needed, check the database on other

devices to see if the items are intact. If they

are, you could put them on an external drive

and replace them in the affected database.

In the worst case scenario, you would need to

restore from your backups.

FILE INTEGRITY

Another report you may see in the

Log window is regarding file integrity.

DEVONthink scans and stores a checksum for

each file in a database. This value is updated

as the files change. However, if you use the

utility command File > Check File Integrity,

it may report an integrity error. This means

the stored checksum doesn't match the

newly scanned checksum. This may indicate

a problem with the file itself. However, this

error will also be reported for indexed items

that are not up to date. Using Files > Update

Indexed Items may resolve the issue with

indexed files.

XLS Files: Though much less commonly used

but still prevalent in legacy files, Microsoft

.xls files will report a checksum error after

you've opened and closed them, even without

modifying the document. Converting these

the newer .xlsx format is recommended.

We will now look at the maintenance options

available, from the simplest health check to

trying to recreate a damaged database.

VERIFY & REPAIR

One of the first options to explore is File

> Verify & Repair Database. This checks a

database's consistency to ensure it's healthy.

If prompted there are problems, press Repair

and DEVONthink will try to correct it. It will

report missing files and import orphaned

ones. But be aware this will not fix missing

or empty files. That is handled as described

above.

If Verify & Repair Database was able to

repair your database, use File > Optimize

to optimize your database and have

DEVONthink create an internal copy of the

index.

Note: Verify & Repair isn't just for

emergencies. Running this command on an

occasional basis is not a bad idea. In fact,

if you're a fairly heavy user of DEVONthink,

running it weekly or bi-weekly does no

harm. It's just a routine checkup.

REBUILD YOUR DATABASE

A deeper maintenance routine, a database

rebuild is typically used with more serious

database errors, e.g., with reports of file

errors. It can also be used when searches,

classification, etc. are clearly and consistently

behaving erratically.

To rebuild the database from scratch,

use File > Rebuild Database. During the

rebuild process, your files are exported and

reimported, recreating the internal index

afresh. You should not interrupt this process

or let the machine power down while it's

working. And for safety, a new restore point
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is created at the beginning of the rebuild

process. A progress report or errors can be

viewed in the Log window or popover.

The Rebuild command won't be available

if a database is actively syncing. Also, bear

in mind you'll need to have sufficient hard

drive space to do a database rebuild. While

DEVONthink uses clever mechanisms to

reduce overhead and disk usage, you should

still be mindful of the available disk space.

This includes when you're dealing with an

encrypted or revision-proof database. If the

Rebuild command isn't enabled, you may

have insufficient disk space to run it. Try

emptying the database's Trash and recheck if

the command is enabled..

RESTORE INTERNAL BACKUPS

DEVONthink doesn't do file backups but does

an internal metadata backup for support

purposes. Weekly, it creates a copy of a

database's metadata, saving it as a restore

point. Only two restore points are kept, with

the oldest one being purged.

A less frequently used mechanism, it can be

useful after a crash, especially if the crash

occurred during a drag and drop of a large

number of items between databases. When

the database is opened and appears to be

empty, restoring an internal backup could

resolve this with a few mouse-clicks.

To restore the metadata files from a

previously saved internal backup, hold the

⌥ Option key and select File > Restore

Backup. DEVONthink presents you with a list

of all available backups. Choose the latest

one or the one with a size that appears to

be correct and click Open. This swaps the

current set of metadata files with the chosen

backup metadata (the current set becomes

the backup, the backup becomes the current

set) so that data is never overwritten. Run

File > Verify & Repair to ensure everything

is healthy. If everything looks good, you can

manually use File > Optimize to optimize your

database create a new restore point.

RECOVER OR MANUAL REBUILD

If your database is constantly crashing, it's

possible it is – or is becoming – damaged. In

this case, there are two options to consider:

Restore From Backups: Restoring a database

from your external backups is usually a quick

and effective way to get back up and running.

As noted in the linked section, if your data

is important to you then diligent backups

should be high on your priorities.

Manual Rebuild: If you find yourself in the

unfortunate situation where you have no

backups, it may be possible to rebuild a

damaged database manually, following these

steps:

Locate the database (.dtBase2 file) in the

Finder.

Rename the file by adding, e.g., an x to the

beginning of the name.

Control-click the database and choose

Show Package Contents in the context

menu.

Copy the most recent backup folder where

your database is located.

Copy the Files.noindex folder into the

copied Backup folder.

Rename the copied Backup folder to the

previously used name and add the file
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extension .dtBase2, okaying the extension

when prompted.

Double-click the new database file to open

it in DEVONthink.

Use File > Verify & Repair to ensure that the

database is operating properly.

RECOVER FILES

In a worst case scenario, if you do not have

a current backup of your documents and a

manual rebuild didn't work, you can rescue

your files manually, but you will lose any group

structure. To manually copy your files from

the defective database, show the database

package in the Finder, Control-click it, and

choose Show package contents from the

context menu. Copy the Files.noindex

subfolder to a safe location, e.g., the desktop.

If you look inside the folder, you will see a

series of subfolders — one per file extension,

e.g., .rtf — with subfolders in each. Your

imported documents are stored within those.

It is possible to create a new database and

import this folder but you will have to rebuild

the database's structures and apply any

metadata again.

CONTACT SUPPORT

If none of the above steps helped solving

the problems you have with your database,

please contact us with a precise-as-possible

description of your problem.

CRASHES AND STALLS

DATABASE WARNING

You may have seen the warning dialog

above. Except in specific circumstances,

it's not usually the database being opened

simultaneously. Instead it occurs most

commonly after a crash or a force quit. When

you see this dialog, press Continue. The

database will be automatically checked to

ensure it's consistent and healthy and you

will be prompted if there are issues. If there

are none, you may not see anything happen.

Select File > New Window or press ⌥⌘N to

open a new window and you're back to work!

CRASHES AND STALLS

As much effort as we put into building a

stable and robust application, the variables

involved make a "perfect application"

impossible. Even changes made by Apple can

cause occasional unexpected behavior. If you
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have a consistently repeatable crashes or

stalls, please report it to us. But please try to

reproduce the crash or stall before reporting

it.

Crashes: A crash is an unexpected

termination of the application. You're working

and suddenly you're looking at your desktop.

If DEVONthink crashes but you can relaunch

the application without incident, hold the

⌥ Option key and choose Help > Report Bug.

If DEVONthink crashes on startup, there is no

opportunity for you to use our bug reporting

mechanism. However, you can manually

retrieve the crash logs:

In the Finder, hold the ⌥ Option key and

select Go > Library.

Open the Logs/DiagnosticReports folder

and locate the most recent crash report for

DEVONthink. (The date and time is in the

filename.) Drag it to your desktop.

Open a support ticket and attach the crash

log as well as details about what you were

doing at the time of the crash.

Stalls: Sometimes known as "beachballing",

"the rainbow cursor", or the "pinwheel of

death", it accompanies your application

not responding to mouse-clicks or a frozen

interface. Certain actions can sometimes

cause this, e.g., indexing files on a networked

volume or adding a very large volume of

documents at once. Make sure to give the

application a little time to work. You should

not rush to force quit the application, ever.

But if the stall goes on for a sustained period

of time, say over five to ten minutes, then you

may need to, but again, this depends on what

you were doing that precipitated the stall.

Before you force quit, please follow these

instructions:

In the Finder, do a Spotlight search for

Activity Monitor.

Select our application in the list of

processes —  it should show (Not

Responding) with the name in red.

Press ⌥⌘S to run a process sample on it.

When the sample window opens with the

report, press the Save button and save it

to your Desktop.

Use our bug reporting mechanism or

the support ticket link mentioned above

and attach the stall report along with a

description of what was happening at the

time of the incident.

PROBLEMS USING SERVICES

WHY DO THE SERVICES MENU COMMANDS

SHOW NO SHORTCUTS?

They should; however, the keyboard shortcuts

for Services menu commands are only

requested by the supplying application.

macOS assigns these shortcuts and has

ultimate control over which application

or service gets what. If the DEVONthink

Services menu items do not have shortcuts

assigned, it is likely that macOS assigned

these shortcuts to another command, or

that they are used by the current active

application.
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WHY DO SPECIFIC SERVICES NOT APPEAR

IN THE MENU?

The operating system relies on information

supplied by the current application to

determine which services should be shown

in the Services menu. For some applications,

often those developed for both Mac and

Windows, this information may not be

what's anticipated. When this occurs, certain

services may not be present. For example,

selecting text on a web page in Firefox will

display the service DEVONthink: Take Plain

Note. The same text on the same page

in Safari will show that option as well as

DEVONthink: Take Rich Note.

SLOW FINDER DIALOGS

If you find the Open or Save dialog in

applications on your Mac are opening or

performing slowly, it may be that you have

too many tags in your system. Having 5000

tags or more in your filesystem can cause the

Finder to stall as it tries to process them.

As noted in the Finder Tags and Tagging

Sources subsections, tags can come from

several sources. These tags can also be added

to your Finder tags, perhaps unknowingly.

Tags are added to the Finder tags from

DEVONthink in one of three ways:

Spotlight Index: In the Database Properties

popover for a given database, there is a

Create Spotlight Index option. If this is

enabled, DEVONthink includes tags as part

of the Spotlight metadata, enabling you to

use Spotlight searches like tags:support

in the Finder. However, this also adds to

the tags processed by the Finder. If you

disable the Spotlight index for a database,

the tags for that database will immediately

be removed from the Finder tags,

Indexed files: If you're indexing files,

any tags you apply in DEVONthink are

automatically applied to the files in the

Finder.

Exporting files: If you export files to the

Finder, the tags are added to the Finder

tags as they're part of the metadata of the

files. The exports include using the File >

Export > Files and Folders command, drag

and drop from DEVONthink to the Finder,

or doing a File > Rebuild Database.

Regarding the last two items, you can

prohibit DEVONthink from exporting tags to

the Finder. Disable Export Tags in the Files

> Tags settings. Note this is a global setting,

affecting all databases. Also, disabling this

option will not remove already exported tags

from the Finder.

Deleting tags in the Finder: While disabling

the Spotlight index for a database will

immediately remove Finder tags from the

system, the other options will not.

To manually remove tags, in the Finder press

⌘, to open the settings. Select the Tags view.

Here you will see a complete list of Finder

tags. Select the tags you want to remove and

press the minus button. You will be prompted

to approve the deletion. Note: This does not

remove any files. It only removes the tags.
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Automation. No matter how efficient we

are, there is always some process that could

be done more quickly, and sometimes more

accurately. This may be as simple as renaming

a file, or as complex as filing, emailing, and

archiving. While not everything can be

automated, and careful thought should go

into your automation plans, DEVONthink

offers a level of automation capabilities rarely

rivaled in other Mac applications.

AppleScript: Recognizing the need for

effective real-world automation, DEVONthink

has extensive support for AppleScript.

Not only used in the scripts you can install

from DEVONthink > Install Add-Ons, they

are also at the core of several pre-installed

templates. Additionally, in conjunction with

other AppleScript-enabled applications,

the potential for automation on your Mac is

extraordinary. This mature but easy to learn

technology is the one we will focus on. See

also p. 267ff

Smart Rules and Batch Processing:

DEVONthink also offers two for those with

little to no programming experience: smart

rules and batch processing. Smart rules

are conceptually similar to smart groups

but allow you to run pre-defined smart

actions when certain events happen. Batch

processing also uses smart actions but

works on selected items for more impromptu

automations and also allows you to save

often used configurations. The variety

of smart actions available makes them

accessible to all users, while still providing

other powerful options. This includes smart

action scripts. See also p. 274ff

AI Assisted Automation: If you are using

an AI model in DEVONthink, there are

some automation options available to

you. Whether you're asking a question or

examining a document, it's possible to

leverage artificial intelligence in ways not

possible before now. A pair of smart actions

for batch processing and smart rules, as well

as some new script commands, help integrate

an AI engine into your processes. See also p.

279ff

Smart Templates: Templates are an often

overlooked feature in DEVONthink, providing

a way to create reusable documents
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to be added on demand. But beyond

simple document templates, there are

more capable templates you can create:

powerful templates, including ones driven

by scripting, that will create entire group

structures, import items, accept user input

for dynamically created items, and more. See

also p. 281ff

Item Links and URL Commands: While not

an automation technology in itself, item

links and URL commands are item-specific

identifiers in DEVONthink that can be used in

automation. Item links provide a way to refer

to files by a unique and unchanging value

while URL commands can initiate certain

actions, like starting a search, while outside

of the application. See also p. 289ff

JavaScript: In addition to AppleScript,

JavaScript for Automation (JXA) is

supported. We advocate AppleScript for

its ease of use by new and less-experienced

programmers but if you prefer to code in

JavaScript, you certainly can.

On a side note, our AppleScript dictionary

supports the do JavaScript command. With

it you can interact with web-based content

viewed in a DEVONthink window. With a bit

of creativity, some pretty amazing things can

be done!

AppleScript Objective-C: Sometimes

referred to as "ASOC", this is a powerful

hybrid of the two languages. As it's not very

accessible to many lay-coders, we don't

generally recommend or publish scripts solely

written in it. However, as DEVONthink is a

native macOS application, you surely can use

use ASOC in your scripts, if you're inclined to

use it.

Terminal: For those who are into other

technologies, like Python, bash, Ruby, etc.,

the question arises: Is there a command line

interface (CLI) for DEVONthink? The answer

is no. However, you can still use a do shell

script command in AppleScript when needed.

Actually, the combination of the shell and

AppleScript creates even more opportunities,

as their individual strengths compensate for

the other's weaknesses.

APPLESCRIPT

AppleScript is an automation technology

introduced by Apple in 1993. Over the years it

has matured and become the friend of many

Mac users wanting to exert more control over

their computing experience. Written in an

easy to learn, almost conversational language,

it offers a tremendous amount of power with

less effort than many languages. DEVONthink

has very robust AppleScript support and

comes with many built-in scripts. These, and

those you write or obtain, make it possible

to automate nearly every aspect of the

application, and to integrate the application

with almost every other macOS application

that supports AppleScript.

INSTALLATION

Add-On Scripts: All add-on scripts that

come with DEVONthink are automatically

installed or updated when you open a new

version of DEVONthink for the first time.

You can, however, manually (re-)install them

by choosing DEVONthink > Install Add-Ons.

The scripts from this panel are installed in a

number of locations:
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Script Menu Extra Scripts: These scripts

are accessed from the global Script menu

when you are in specific applications, e.g.,

Safari. They are installed in an application-

specific subfolder of ~/Library/Scripts/

Applications. See also p. 285ff

Folder Action Scripts: These scripts are

used to created hot folders in the Finder.

They are installed in ~/Library/Scripts/

Folder Action Scripts. See also p.

286ff

Apple Mail Rule Scripts: These scripts

are for use with Apple Mail Rules. They

are installed in ~/Library/Application

Scripts/com.apple.mail. See also p.

284ff

DEVONthink Scripts: The internal scripts

found in DEVONthink's Scripts menu are

installed in ~/Library/Application

Scripts/com.devon-technologies.think.

The scripts will be found in one of four

directories:

Menu: These are the scripts found in

DEVONthink's Script menu. See also p.

271ff

Toolbar: These scripts are available to add

as toolbar buttons. See also p. 274ff

Reminders: These scripts will be executed

when a reminder is triggered with an alarm

of Execute External Script. See also p.

273ff

Smart Rules: These scripts are used as

External Scripts in the actions of smart

rules. See also p. 274ff

Additional scripts, like those you write

yourself, can be put into any of these

folders to be used in these contexts. Other

scripts that may include integration with

DEVONthink can be located wherever it's

convenient.

SCRIPT SHORTCUTS

Many people like mousing around their

applications, while others like to use their

keyboards. If you want to add keyboard

shortcuts to scripts in this menu, you have

two options:

System Preferences: Open System

Settings > Keyboard > Shortcuts > App

Shortcuts. Add a shortcut for DEVONthink,

enter the exact name of the menu item,

and assign a hotkey.

Append Filename: Locate the script in

the Finder and append three underscores

followed by abbreviated command keys and

characters. For example, eMail Current

URL___Cmd-Alt-F2.scpt. The command

key abbreviations are as follows: Cmd

stands for ⌘ Command, Alt or Opt for

⌥ Option, Ctrl for ⌃ Control, and Shift

for the ⇧ Shift key.

LEARNING APPLESCRIPT

While this documentation is not an

AppleScript language guide, all the scripts

that come with DEVONthink are editable

and can be explored or modified as you see

fit. The separate sections in this chapter

provide any required terminology and a

simple example script or two. Additionally,

there are some great resources available

online and in print. For the official archived

documentation, refer to Apple's AppleScript

web site. Some additional resources are listed

below:
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Online:

DEVONtechnologies Community

MacScripter

AppleScript, the Language of Automation

Books:

AppleScript: The Missing Manual

AppleScript: The Definitive Guide

Note: When using more modern versions

of macOS, you will be prompted by the

operating system to allow DEVONthink

to "control" other applications. If you've

seen such a prompt and didn't allow it,

open System Settings > Privacy & Security

> Automation to enable it. Please make

sure to allow the automation requests for

DEVONthink to ensure your scripts will run

successfully.

BASIC APPLESCRIPT
TERMINOLOGY

AppleScript is not a difficult language

to learn. Its plain English approach of

"talking" to applications and elements is

easily understandable. However, like any

language, there are some variations in the

words you can use; dialects, if you will.

AppleScript is implemented by the developer

of an application, so the commands and

parameters may be conceptually the

same as another application's, but using a

different term. This is certainly not meant

to be a complete guide to AppleScripting

DEVONthink, but what follows are some

common terms or concepts you're likely to

encounter. The examples here and in this

chapter are meant to give you basic ideas

about scripting DEVONthink.

TALKING TO DEVONTHINK

In AppleScript you "talk" to programs like

DEVONthink using a tell statement,

typically referring to an application

either by its name, "DEVONthink 4",

or its bundle identifier, "com.devon-

technologies.think". While these forms

will work, we strongly recommend to talk to

DEVONthink using the application ID DNtp, as

seen in the following statement:

Example:

tell application id "DNtp"

close current database

end tell

DEVONTHINK'S DICTIONARY

AppleScript-capable applications have their

commands, elements, and properties listed

in an AppleScript dictionary. DEVONthink

includes a large dictionary as a great

reference for you. To view the dictionary,

open the Script Editor application, select File

> Open Dictionary and choose DEVONthink

in the appearing window. You can also add

DEVONthink to your Script Editor library.

Select Window > Library, click the + button

and choose DEVONthink. This way you keep

DEVONthink's dictionary at hand.

Note: Using the in your script is optional,

but including it can make the script seem a

bit less robotic. You can also use possessive

forms, if they feel more comfortable to you.

For example, all the lines in this script are

functionally the same:

Example:

tell application id "DNtp"

set flag of children of current group to

true
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set the flag of the children of the

current group to true

-- Possessive Forms

set the flag of the current group's

children to true

set the current group's children's flag to

true

end tell

As noted above, the dictionary is the best

place to find specific terminology to be used

with DEVONthink.

Again, this isn't a course on AppleScript, but

there are a few DEVONthink-specific things

you should understand when scripting our

application.

Records: Almost every item in a DEVONthink

database is a record, a record with

properties. Do a search for "record" in the

dictionary and you'll see it's a fundamental

unit with a wide range of properties

associated with it. This means you won't be

writing code like, get the second rich

text file…. You will be dealing with records

with a particular type, in this case rtf.

There are many commands specifically for

use with records: create record with,

exists record with…, etc. Also note there

are some commands that require the term

record. For example: move, delete, and

convert. You will see a dictionary listing move

record, so you can see the command isn't

merely move, it's move record.

Parents and Children: Another concept to

understand is parents & children. Generally

speaking, these classes deal with the

container or the contents of some object.

The parent of an object is the group

containing it. The children of a group are

the immediate contents of that group. It

does not include the children of sub-groups.

Children can be documents or groups;

parents can only be groups, tag groups, or

RSS feeds.

Example:

tell application id "DNtp"

set thisGroup to current group

name of (the children of thisGroup whose

(type is XML))

end tell

DEVONTHINK WINDOWS

While there are standard windows in

DEVONthink, it is better to refer to them by

their proper classes. A document window (or

content window) is a standalone document

window. A main window (or viewer window)

is a main window. However, they are both

subsets of the think window class so it's

often useful to use this term to cover either

case.

USING LOCATIONS

One of the common tasks people want to

perform with AppleScript is importing files

to a specific group. In order to direct the files

to a given location, you need to reference it

properly. Below are three general options for

choosing a location:

incoming group: This targets the Global

Inbox, or the inbox of a database when

using incoming group of current

database.

current group: This targets the currently

selected group in the current database.

display group selector: This shows the

group selector so you can choose a location

on demand.
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There are many times you want to direct files

into a specific group. That group may not

be the current group you're in and you may

not want to choose a destination each time.

Here are two common ways of specifying

a particular group in your database to be a

destination group in your script:

get record at…: This command allows you

to set a variable by specifying a group's

location in your group structure. The

location is a text string, always beginning

with a forward slash denoting the root of

the database.

get record with UUID…: When using an

item link, you can use the alpha-numeric

string from the reference URL to point to

a specific item. (This command works with

both groups and documents.) This form is

very useful since it doesn't change when an

item's name or location changes.

Example:

tell application id "DNtp"

set myGroup to get record at "/Inbox/New

Files"

import "~/Desktop/001.txt" to myGroup

set groupTwo to get record with uuid

"98BBF96D-7743-46C6-9EB4-51C6EF68373C"

import "~/Desktop/002.txt" to groupTwo

end tell

WORKING WITH A SELECTION

Many times you want to process items you

have selected in DEVONthink. What class you

use depends on the selection.

selected records: Use this term when items

are selected in the item list.

root of think window: When a group

selected in the Navigate sidebar, it is not

the "selection". It sets the root of the

window.

As a practical example of working with a

selection, imagine you want to generate a list

of names and dates for use in a document

you're working on. Below is a handler

commonly seen in DEVONthink scripts:

repeat with thisRecord in (selected

records) … end repeat: This is a very

common handler, used when processing a

selection, single or multiple items.

Example:

tell application id "DNtp"

if selected records is {} then return

set nameList to {}

repeat with thisRecord in (selected

records)

copy ((name of thisRecord) & ": " &

(creation date of thisRecord as string) &

return) to end of nameList

end repeat

create record with {name:"Files",

type:text, content: (nameList as string)}

in incoming group

end tell

If you have external AI set up and a code-

compatible model, you can use DEVONthink's

Script Assistant. Choose the AI model and

enter a description of the desired script in

the prompt field, then press the ↩ Return key

to compose and refine a script.

INTERNAL SCRIPTS

The Scripts menu of DEVONthink, located to

the left of the Help menu, gives you access

to a large number of pre-made scripts, with

more scripts available. These scripts are not

only useful for every day use, but are also

great for learning how to script DEVONthink.
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All the scripts we provide are editable using

the Apple's Script Editor, though we do

suggest making copies to work on. They

are located in ~/Library/Application

Scripts/com.devon-technologies.think/

Menu. Open this folder in the Finder with

Scripts > Open Scripts Folder command. Add

your own scripts to the menu by adding them

to the appropriate subfolder in this directory,

even creating subfolders of your own.

A complete listing of the installed scripts is in

the Appendix.

SCRIPT LOCALIZATION

If you need to support multiple languages in

your scripts, it is possible to vary the content

of messages based on the language in which

DEVONthink is running.

You must have saved your script as a script

bundle, a .scptd file. In the Contents >

Resources directory of the bundle, add

a folder with the two character country

code for the language, followed by .lproj,

e.g., fr.lproj would contain French

strings. Add your own definitions in a

Localizable.strings and put it in this

directory. Define a word or phrase in

your language, followed by the translated

phrase. For example, in a strings file in a

de subdirectory, enter: "This is a new

day!"="Heute ist ein neuer Tag!";.

In your script, you'd enter a command like,

display alert (localized string "This

is a new day!"). If DEVONthink is running

in German, you'd see the German message.

Localization is also available for smart

templates. See the Template Localization

section later in this chapter.

TRIGGERED SCRIPTS

Triggered scripts are AppleScripts that you

attach to an item in DEVONthink (a group

or document). Instead of being bound to

a set interval like a reminder alarm, these

scripts are executed every time you select

the item. Such a script could change some

metadata, force an update of indexed items,

or many other habitual actions you may need

to perform. So with some creativity and a bit

of scripting, you can add your own custom

behaviors when interacting with items in your

database.

Items with attached scripts show an

AppleScript property icon behind their name.

And a toolbar search for item:scripted will

show you items with attached scripts.

Triggered scripts can be stored anywhere,

but are typically located in a folder within

the ~/Library/Application Scripts/

com.devon-technologies.think/Menu

directory. Adding or removing a triggered

script from an item in DEVONthink is done

via scripting, using the attached script

property for a selected record. Here is a code

snippet you can use to attach scripts to

selected items:

Example:

property dtScripts : (POSIX path of

(path to library folder from user

domain) & "Application Scripts/com.devon-

technologies.think/" as string)

tell application id "DNtp"

if (selected records) is {} then return

set chosenScript to choose file with

prompt "Choose a triggered script to

attach to the selected item:" default

location dtScripts of type {"scpt",

"scptd"} without multiple selections

allowed
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repeat with theRecord in (selected

records)

set attached script of theRecord to

chosenScript

end repeat

end tell

TERMINOLOGY

Triggered scripts are defined by a specific

handler: on triggered(var), where var is

the variable representing the item the script

is attached to.

Example:

on triggered(theRecord)

tell application id "DNtp"

display alert "" & (name of theRecord as

string)

end tell

end triggered

REMINDER SCRIPTS

Reminders have several pre-built alarms

available for notifications. Reminder scripts

are AppleScripts run by an alarm set on a

specific reminder for an item. By using or

writing your own, you can extend notification

possibilities of your reminders. Bear in mind,

you can only specify one alarm per reminder.

ADDING AN EXTERNAL SCRIPT

To add an external script as an alarm for

a reminder, choose Execute External

Script. The next dropdown lists any available

AppleScripts, located in the ~/Library/

Application Scripts/com.devon-

technologies.think/Reminders directory.

Add any of your own scripts to this directory

to make them available for any alarm you set.

ADDING AN EMBEDDED SCRIPT

Sometimes you only need to add a script for

a specific purpose, not general use with all

reminders. DEVONthink allows you to quickly

write an ad-hoc AppleScript specifically for

the current reminder.

To write an embedded script for a reminder,

choose Execute AppleScript/JavaScript

as the alarm. Click the … button and a popup

will appear with a pre-built handler in place.

Add your code as necessary, then press the

compile button, the one with the stylized eye,

to make sure it compiles correctly. If it does,

you will see the code format itself subtly. If

not, you will hear a system alert. Click outside

the popup to dismiss it. When the alarm goes

off, the script will be executed.

Note: When a reminder is set to Once, the

reminder is removed and the embedded

script lost after the alarm goes off. If you

have code you'd like to potentially use

again, put it in an external script.

TERMINOLOGY

Triggered scripts are defined by a specific

handler: on performReminder(theRecord),

where theRecord is the variable representing

the item the alarm is set for.

Example:

on performReminder(theRecord)

tell application id "DNtp"

set label of theRecord to 1

say (name of theRecord as string)

end tell

end performReminder

Debugging Tip: When testing an external

reminder script, use the Once interval and set

the alarm time. Your intuition may be to look
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at the clock and set the alarm a minute or

two ahead. However, if you set the alarm to

a time before the current time, it will trigger

instantly. This makes for easier testing before

you commit to the true interval you'll use.

If you have external AI set up and a code-

compatible model, you can use DEVONthink's

Script Assistant. Choose the AI model and

enter a description of the desired script in

the prompt field, then press the ↩ Return key

to compose and refine a script.

TOOLBAR SCRIPTS

Scripts can also be added to the toolbar

of any DEVONthink window. While there

is a limited amount of space available in

a window's toolbar, this is a handy way to

launch commonly used scripts with one click.

To add a toolbar script place the script

into the folder ~/Library/Application

Scripts/com.devon-technologies.think/

Toolbar. In order for the script to be

available for use in the toolbar, you must quit

and relaunch DEVONthink. Then Control-click

the toolbar of a DEVONthink window and

choose View > Customize Toolbar. Drag your

script into the toolbar and it's ready for use.

TERMINOLOGY

Unlike some other script types, there are no

special handlers required for a toolbar script.

You only need valid AppleScript talking to

DEVONthink.

Example:

tell application id "DNtp"

open tab for record (content record)

end tell

SMART RULES AND BATCH
PROCESSING

Not everyone is a coder, perhaps even

you. But that doesn't mean you don't have

automation needs. DEVONthink has two

related technologies that allow you to

process your data by constructing a chain of

predefined commands: smart rules and batch

processing. While the former are for more

transparent background processes and the

latter for handling selected items, both share

common traits and methods. Understanding

one leads to understanding the other.

SMART RULES

Smart rules are smart groups‚ evolved. Built

in the same style as smart groups, smart

rules don't just show items matching criteria,

they can act on them! From something

as simple as adding (or changing) a color

label, to modifying a filename then filing

a document in another location, smart

rules provide some powerful automation

possibilities. And they're not just for the

technically inclined. No programming

experience is needed for almost every action

available.

Smart rules are conceptually simple and can

be summed up as follows: When this event

occurs > do this action > on items matched >

in this location. Smart rules are made of four

parts:

A location: This is where the smart rule will

look for matching items.

Matching criteria: Like a smart group, you

can specify criteria to be matched. The

smart rule will only act on the matched

items.
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An action: This is the action the smart rule

performs when the event occurs.

An event: This is an event that causes an

action to occur, e.g., an "On Quit" event.

If used in a smart rule, a specified action

would run when you quit DEVONthink.

Create a smart rule: Smart rules can be

created in one of two ways:

Click the + button at the bottom of the

sidebar and choose New Smart Rule. The

Search in dropdown will target the current

location.

Control-click an item in the sidebar and

choose New Smart Rule from the context

menu. This will specifically target that item

in the Search in dropdown.

Note in either case you can change the

Search in parameter to target other

locations, including all open databases.

Note: Smart rules are considered global

objects and can be created only in the

Navigate sidebar of a main window. If you

want to create a smart rule for a group

in the item list, choose Data > Reveal to

display it in the Navigate sidebar.

When you create a new smart rule, you will be

shown the predicate editor, just as you see

with smart groups. Just follow these simple

steps to define the parameters of the rule

(with an example):

Name: Give the rule a name, like Label

Edited Screencaptures.

Location: Set the Search in dropdown to

target your desired location, like a group

you add screen captures to. The more

specific the better; a good idea is to use

e.g., a database's inbox.

Matching: Add any criteria to be matched,

e.g., Name begins with screen and Kind

is Image.

Event: Choose an event to trigger the

smart rule, like specifying On Save to run

the smart rule when matched items are

saved in DEVONthink

Action: Choose an action for the smart

rule, perhaps Change Name to add "_edited"

to the name.

This rule shown above would add "_edited"

as a suffix to the name of any edited images

whose name begins with "screen".

One step further‚ chained actions: If you

hadn't noticed, there's a + button to the

right of the action you specified. And yes,

that means you can chain multiple actions

in a smart rule! For example, we could add

an action to open the edited imaged in the

system default application after it has been

renamed.

Understanding the input: In a smart rule,

there always is only one input. You can't use

conditionals or split the actions into a parallel

process. A matched document is passed

along through the entire process. So if you

have a smart rule processing Markdown files

and one of your actions is Convert to Rich

Text, the resulting rich text file is created

but not passed on to the next actions. The

originally matched Markdown is still the

input. However, there are two actions that

allow switching the input: Duplicate &

Continue and Convert & Continue. The

items created by these actions become

the input for the following actions. In our
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example, these actions would pass on the

resulting rich text document as the input for

the rest of the rule.

Order of operations: If you have more than

one smart rule targeting the same location

and/or types of files, they will run in the

order they appear in the Navigate sidebar.

The topmost rule will execute first, then

the second, and so on. Be aware one rule

could make a change that affects whether

an item is matched by subsequent rules. If it

does, those rules logically will not process the

items. Drag related smart rules into the order

they should run or stop and reconsider how

your rules are set up.

Chaining smart rules: Creating smart

rules with more limited functions is often

useful. For example, a rule that just files

documents based on a certain custom

attribute can be used on selected documents

or by drag and drop to the rule. Now say

you have another rule with more complex

functions, e.g., moving a document into a

database, doing OCR, then adding custom

metadata. Provided it's using the same

custom metadata, instead of adding the

same actions as the previous rule, add the

Apply Rule action and choose the filing smart

rule. Now add another smart rule that should

also file things based on the same custom

metadata but in a different location. Use the

Apply Rule action there as well. Now both

rules can use the filing smart rule's actions

without having to redundantly add their own

actions. This is a powerful way to extend the

functions of a smart rule while also using the

simpler functions, when needed.

Working Safely: In smart rules, the actions

are executed based on the event handler

you're using. For testing, set the event trigger

to On Demand. This way you can select the

rule to see its matches, then Control-click it

and choose Apply Rule to run it and see the

effects on the matched items. Once things

are working as expected, you can add other

event triggers to suit the situation.

Also be aware the effects of smart rules

are very broad, i.e., they affect all the items

they match. While you are testing, it's a good

idea to put some limiting criterion in place.

For example, instead of matching all images

in all databases, try matching images in a

specific group or only images that begin with

"Screen".

BATCH PROCESSING

Smart rules are useful for repetitious actions,

usually happening in the background. For

times when you need to make impromptu

changes on specific items, e.g., prefixing

a date to the name of several documents,

batch processing is the best option.

Select a few documents to process, then

choose Tools > Batch Process. The Batch

Processing window appears where you

can create your chain of actions, just as

described for smart rules. Then press OK and

the documents are modified. And if this is

something you'll do often, you can create new

reusable configurations as you need them.

Note not every smart action is available in

batch processing. However, for most actions

the available ones are more than sufficient.
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EXPORTING AND IMPORTING

If you want to share or backup individual

smart items, it is easily done. The simplest

way to export a smart item is to drag and

drop it to the Finder. Smart rules export

as .dtSmartRule, batch configurations as

.dtBatchProcess files. You can also choose

Export from the context menu for a smart

rule or batch configuration. And lastly, you

can export from the action menu in the Batch

Process window.

To import these items, you can simply

double-click the exported file to reinstall it.

Alternately, for smart rules, you can also drag

and drop directly into the Smart Rules or

choose Import from the context menu. For

batch configurations, you can drag and drop

to the Configurations section of the Batch

Process window or choose Import from the

context menu or action menu.

If you want to share or independently

backup all these smart items, you can

find the BatchProcessing.plist and

SmartRules.plist in the ~/Library/

Application Support/DEVONthink

directory.

For your reference, there is a complete list

of available Events and Actions. For those

interested in the using script-based actions,

continue to the next section…

SMART ITEM SCRIPTS

Smart item scripts are AppleScripts or

JavaScripts run by specialized actions in a

smart rule or batch processing. These actions

allow you to extend the possibilities beyond

the already powerful pre-defined actions.

There are three actions you will use: one

simply runs code on matched items, the

other can also handle incoming and outgoing

data, and one handles input.

SCRIPT ACTIONS

Apply Script: This action runs AppleScript

or JavaScript for Automation (JXA) code on

the matched items. It runs as a standalone

action, not receiving or passing along any

data to its surrounding actions. It is often

used for specific functions not available in

the pre-defined actions. For example, using

a specific tag on a document for filing or

setting metadata. This action also has the

advantage of being able to quickly process

multiple documents.

Set Script Input: This optional action

functions as a variable, a temporary container

for a value to be passed on to the Script

with Input/Output action. The input can be

set from many sources, like a chat response,

a document's aliases, etc. However, it only

accepts strings, numbers, or URLs.

Script with Input/Output: This powerful

action contains a script handler that receives

input and can also send information to

actions that follow it. Getting information

from other steps in your process opens up

new opportunities for deeper automation.

To accept input from a previous action, use

the Set Script Input action. If you're using

output from the action, it can be accessed

with a Script Output placeholder.

If you examine some of the built-in scripts,

you can see examples of input and output.

For an example output only, the Coordinates

script gets the latitude and longitude from
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the geolocation of a record, something for

which there is no specific smart action. So

it returns those values to be used with a

subsequent action via the Script Output

placeholder, perhaps one that sets custom

metadata. For an input example, see the

Annotation – Append Text script. It

receives input from a Set Script Input

action to be added to the end of the

document's annotation file.

EXTERNAL SCRIPTS

External scripts are accessible to any rule

or configuration. So if you have code that

would be useful in more than one process,

saving them externally is a good idea. To run

an external script, add the action, select

Externaland choose one of the installed

scripts.

In the ~/Library/Application Scripts/

com.devon-technologies.think/ directory

you can find the scripts for the Apply

Script action in Smart Rules and those

for Script with Input/Output in Script

Output. And of course you can add any of

your own scripts.

We have compiled a list of the pre-installed

scripts, for everyday use and your education.

EMBEDDED SCRIPTS

If you are writing a script for a specific

smart rule or batch process, you can use an

embedded script. The code is part of the

action and can't be used by another other

smart rule or configuration.

To create an embedded script, add an Apply

Script action then choose AppleScript or

JavaScript. Click the Edit Script button

and a popup will appear with a pre-built

handler in place. Add your code, and press the

compile button, the one with the stylized eye,

to make sure it compiles correctly. If it does,

you will see the code format itself subtly. If

not, you will hear a system alert. When done,

click outside the popup to dismiss it.

For those new to scripting, there is a pre-built

handler for each type of action.

TERMINOLOGY

Apply Rule: These scripts are defined by

this handler: on performSmartRule(var),

where var is the variable representing items

matched by the smart rule.

Example:

on performSmartRule(theRecords)

tell application id "DNtp"

repeat with theRecord in theRecords

if (name of theRecord as string) contains

"Piglet" then

set state of theRecord to true

end if

end repeat

end tell

end performSmartRule

Script with Input/Output: These

scripts are defined by this handler: on

scriptOutput(theRecord,theInput)You

can see there are two parameters for the

handler: theRecord and theInput. In order

to use the input parameter, it must be

proceeded by a Set Script Input action.

Here is an example of the handler:

Example:

on scriptOutput(theRecord, theInput)
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tell application id "DNtp"

set name of theRecord to (its name & "-" &

theInput as string)

return name of theRecord

end tell

end scriptOutput

EXTERNAL DEBUGGING

While there isn't a step-by-step logging of all

actions in a smart rule, when you are using a

script action, errors will be reported in the

Log window or toolbar button. However, if

you're writing the script in Apple's Script

Editor, here are two core snippets you could

use to develop and test the script:

Example:

tell application id "DNtp" to my

performSmartRule(selected records)

on performSmartRule(theRecords)

…

end performSmartRule

tell application id "DNtp" to my

scriptOutput(selected record 1,"")

on scriptOutput(theRecord,theInput)

…

end scriptOutput

After you have the script working, you can

copy and paste it into the script in your

smart item.

If you have external AI set up and a code-

compatible model, you can use DEVONthink's

Script Assistant. Choose the AI model and

enter a description of the desired script in

the prompt field, then press the ↩ Return key

to compose and refine a script.

AI ASSISTED AUTOMATION

Artificial Intelligence has been integrated

into many aspects of DEVONthink and

automation is certainly included. Here we will

look at a few different options for using your

AI model.

SMART ACTIONS

There are two specific smart actions available

to use in smart rules and batch processing:

Chat - Query and Chat - Continue if.

These actions are simple to use and require

little more than creating a good prompt.

Each action works in conjunction with a

subsequent one. You make your query and

receive a response, then you use another

action to do something with it.

Chat - Query: This action allows you to

enter a pre-made prompt or ask a question.

This action can be used with or without

a document, as the need fits. And if you

defined a Role in the AI > Chat settings, it will

be used to shape the response in this action.

Without Document: Enter an open prompt

just as you would in the Chat popover.

With Document: Enter a prompt to be used

with the selected document as your would

in the Chat inspector. You can explicitly

choose Text, Vision for images, or Auto to

let the AI decide.

The response you get back from your AI

model is stored in a special placeholder:

Query Response. Depending on the nature

of the question and answer, you may be able

to use this placeholder directly with another

action. Or you may use it in another action

further along in the chain of actions.
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Chat - Continue if: This is a conditional action

allowing you to enter a prompt for your AI

and get a yes or no in return. If the response

is yes, the following actions will be run. If

not, it will stop running. As a simple example,

you could ask if the selected document

mentions scripting. If it does, use the Apply

Script:Tags - Add Most Important Words

action to tag it.

RELATED ACTIONS

There are a few smart actions that can

provide flexibility to or extend the usefulness

of the AI responses in automation. Note

they aren't specific to the higher editions of

DEVONthink or only for AI actions.

User Input: Only used in batch processing,

this action opens a dialog for you to enter

text. Enter the question or comment to be

answered in the dialog. Ask a question, enter

an answer. The results of this action are

stored in the User Input placeholder. One

way this can be used with the AI actions, is to

create a dynamic prompt for a Chat — Query

action that contains reusable instructions,

e.g., formatting, etc. It can also be used with

the next action: Set Script Input.

Set Script Input: Discussed in the previous

section, this acts as a variable. It can accept

input from many actions, including the User

Input action. Regarding AI, it will accept

input from the Chat Response placeholder

so you can pass it on to the next action:

Script with Input/Output

Script with Input/Output: Also discussed

in the previous section, this action accepts

input provided by the Set Script Input

action and uses it in the embedded or

external script you choose. In regards to AI,

this action can pass its return value to one

of the chat actions via the Script Output.

SCRIPTING

Another way DEVONthink has integrated

AI into its automation tools is via script

commands. You can view DEVONthink's

AppleScript dictionary for more information

but here is a brief introduction to the

commands.

display chat dialog: Provide a prompt and

the specifier, e.g., a window or document to

process, and this opens the Summarize and

Transform popover with your AI's response.

Optionally, add a role and a window name.

Example:

tell application id "DNtp"

display chat dialog think window 1 name

"Top five words" role "Provide the response

in Markdown formatting. Include the

frequency of each word in parentheses.

Add a short summary. Include any

misspelled words and their corrections at

the end." prompt "What are the five more

frequently used words in this document?"

end tell

download image for prompt: If you need to

create an image programmatically instead

of using the Generate Image window, you

can use this command. Specify the engine,

noting the options like size are governed by

the engine you're using. See the AI > Images

settings for more information. Also the image

is returned as a data class.

Example:
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tell application id "DNtp"

set imageData to download image for

prompt "A 1934 canary-yellow Ford sitting

at a stop light next to a red Ford Fusion.

High noon on a small town main street."

engine FluxPro aspect ratio "16:9"

set newImage to create record with

{name:"Fords", type:picture} in current

group

set data of newImage to imageData

end tell

get chat models for engine: Displays the

available models for a specific AI engine.

Example:

tell application id "DNtp" to get chat

models for engine Claude

-->{"Claude 3 Haiku", "Claude 3.5 Haiku",

"Claude 3.5 Sonnet", "Claude 3 Opus"}

get chat response for message: This can be

used in many different ways, when provided

with your prompt and many options, e.g.,

engine, role, temperature, etc. You can also

include a reference to a selected record or

a list of them. Here is a simple interactive

example of document creation:

Example:

tell application id "DNtp"

set theInput to text returned of (display

dialog "Tell me about…" default answer "sea

turtles")

set aiReply to (get chat response for

message "list seven interesting facts about

" & theInput & " in a Markdown table. Don't

number the items. Don't use emoji. Include

live hyperlinks to the sources. Add only " &

theinput & " as the headline and include a

picture after it.")

set newDoc to create record with

{name:(paragraph 1 of aiReply as string),

type:markdown, content:aiReply} in current

group

end tell

Obviously, this command is far more powerful

than just making Markdown documents

about sea turtles! But this hopefully provides

a view of the syntax.

SMART TEMPLATES

Some of the DEVONthink provided templates

are "template packages" (.dtTemplate) and

"smart templates" (.templatescriptd).

Stored in the ~/Library/Application

Support/DEVONthink/Templates.noindex

directory, both types of templates provide

a great deal of flexibility and power, like

allowing for inclusion of language resources.

With some creativity and scripting know-

how, you can set up everything from

commonly used group hierarchies to daily

journal entries and much more.

TEMPLATE PACKAGES

The simpler type of automated templates

DEVONthink supports are: template

packages. These are folders with the file

name extension .dtTemplate that contain

one or multiple .lproj folders, one for

each supported language. Depending on the

system language, you can let DEVONthink

import the files in the correct language.

If you inspect the contents of a template

package, e.g., Classifications > Decimal Filing

System.dtTemplate, you will see the project

folders and their assets as a great example of

this type of template.
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SMART TEMPLATES

The more advanced type of automated

templates are smart templates. These are

not simple files, but actually AppleScript

packages containing script code, and often

including related assets that can be inserted

into your database. This allows for some very

powerful actions like:

The script can add information to the built-

in template, e.g., the current date and time

or data from the web.

The script can act intelligently on data

on the clipboard: If it's a simple text, it

adds the text; if it's a URL, it adds it to a

different area of the document and makes

it clickable.

The script can check if a certain application

is installed, e.g., OpenOffice, before adding

a document.

CREATING TEMPLATES

Template Packages: To create your own

template package, you can duplicate an

existing template, Control-click it, choose

Show Package Contents and edit the

internals as needed. Also note exporting

multiple selected files will yield a template

package.

Smart Templates: To make your own

smart templates, have a look at the

prefabricated smart templates. Duplicate

a .templatescriptd file, like the "Note"

template. Control-click it, and choose

Show Package Contents. You can inspect

and modify the supporting assets and the

main.scpt file to fit your needs.

TEMPLATE PLACEHOLDERS

Placeholders in templates are simple control

codes that are replaced by DEVONthink

when a template file is imported. These

placeholders can be used in your files,

including simple templates, or folder

names of your templates packages. When

used in files, they are typed in the text of

DEVONthink-native files; e.g., plain or rich

text, Markdown, etc. These can be manually

typed or you can Control-click in the text and

choose Insert Placeholder. Below is a list of

valid placeholders:

%time%: The current time

%date%: The current date

%shortDate%: The current date in short

format

%longDate%: The current date in long

format

%monthname%: The month name of the

current date

%weekday%: The week day name of the

current date

%day%: The day number of the current

date

%month%: The month number of the

current date

%year%: The year number of the current

date

%author%: The Author set in the Editing >

General settings

%username%: The user's name

%fullUsername%: The user's full name

%organization%: The user's organization

from Contacts

%emailAddress%: The user's email

addresses from Contacts
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%host%: The host name

%databaseName%: The database name

%databasePath%: The database's path

%groupName%: The name of the parent

group

%topGroupName%: The name of the top

group

%clipboard%: The clipboard contents as

plain text

%styledClipboard%: The clipboard

contents as rich text

%clipboardLink%: The clipboard contents

as a clickable rich text link if the clipboard

contains a valid URL

Note: There are more placeholders from

the context menu than can be used in a

template. For example, the placeholder

%record_locality% relates to an existing

record, so this placeholder will not be used

when creating a file from a template.

Custom Placeholders: One more powerful

feature of smart templates is the ability

to define custom placeholders, extending

the possibilities beyond the list shown here.

This allows you to add a custom placeholder

in the text of a template, then define the

replacement value for that placeholder in the

main.scpt. As a great example, check out the

use of the custom %project% placeholder in

the Project smart template. Notice the use of

the placeholder in the enclosed rich text file

and the script.

TERMINOLOGY

With the internal script of a smart template,

there are no special handlers required.

However, the internal script must be located

in the Contents/Resources/Scripts folder

inside the package, and it must remain

named main.scpt. Beyond that, you only

need valid AppleScript.

TEMPLATE LOCALIZATION

If you need to support multiple languages

in your templates, it is possible to have the

name and/or content change based on the

language in which DEVONthink is running.

You can add your own definitions in .strings

files in the Contents > Resources directory

of a template package. Here are the files that

can be used:

LocalizedNames.strings: Contains

definitions of the localized name of the

item created by the template. The syntax

defines one name per line: "en"="My

Project"; or "de"="Mein Projekt";.

Localizable.strings: This file must be

contained in a subdirectory of the

Resources folder, named with the country

code and .lproj extension, e.g., fr.lproj

would contain French strings. Contains

localized definitions of words or phrases,

e.g., the content in a document created

by the template. The syntax defines

one word or phrase per line: "Daily

Journal"="Tageszeitung";.

TOOLBAR TEMPLATES

To add any template to the toolbar, place

the template into the folder ~/Library/

Application Support/DEVONthink/

Templates.noindex/Toolbar. In order

for the script to be available for use in

the toolbar, you must quit and relaunch
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DEVONthink. Choose View > Customize

Toolbar, drag your template into the toolbar

and it's ready for use.

APPLE MAIL RULES

When considering importing emails into your

DEVONthink databases, the question of

"automatic" email importing invariably comes

up. While this isn't fully possible yet, there is

a mechanism in Apple Mail that can provide

some level of "automatic": Mail Rules.

Found in Apple Mail's Settings > Rules,

these are a rules consisting of criteria to be

matched and an associated action (similar

to smart rules). As incoming emails are

detected, Mail will check for matches in a rule

and execute any actions you've specified in

the rule.

One of the actions available is Run

AppleScript. Selecting this option shows a

dropdown with any installed Mail Rule scripts.

These scripts are installed in ~/Library/

Application Scripts/com.apple.mail

folder. If you write or obtain other scripts for

use with Mail Rules, they can also be placed

in this directory. The scripts provided by

DEVONthink are:

Mail Rule - Add attachments to

DEVONthink: Adds the attachment of the

message it acts on as separate documents

to DEVONthink.

Mail Rule - Add links to DEVONthink: Adds

detected links in the messages as individual

bookmarks in DEVONthink

Mail Rule - Add messages to DEVONthink:

Adds the messages it acts on to

DEVONthink.

Mail Rule - File messages & attachments:

Adds the messages it acts on including all

attachments to DEVONthink.

Mail Rule - File messages & attachments

hierarchically: Adds the messages it

acts on including all attachments to

DEVONthink, recreating the mailbox

structure.

TERMINOLOGY

A full lesson on writing scripts for Mail Rules

is beyond the scope of this help, but you can

open and explore the installed scripts.

Do note there are two required handlers:

using terms from application "Mail"

and on perform mail action with

messages theMessages for rule theRule,

where theMessages is a variable representing

the items matched by the rule. Here's a

simple example:

Example:

using terms from application "Mail"

on perform mail action with messages

theMessages for rule theRule

tell application "Mail"

repeat with thisMessage in theMessages

display alert "" & (subject of

thisMessage)

end repeat

end tell

end perform mail action with messages

end using terms from

Note: Mail Rules are controlled by Apple

Mail, not DEVONthink. While they generally

behave as expected, we can't control

whether the rules will be triggered in Apple

Mail.
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APPLICATION SCRIPTS

AppleScript is perfectly suited for integrating

different applications, interchanging

information, and creating workflows.

DEVONthink comes with a number of

scripts that exchange information between

DEVONthink and other AppleScript

supporting applications, like Safari or Mail.

The Script Menu Extra Scripts provided by

DEVONthink are installed in an application-

specific folder in ~/Library/Scripts/

Applications, e.g., ~/Library/Scripts/

Applications/Safari. These scripts are

accessible from the global scripts menu in

the menu bar at the top of your screen while

you're in the specific application.

MAIL SCRIPTS

Importing email into your DEVONthink

databases is a possible use of AppleScript.

Using AppleScript-enabled email

applications, especially those with a robust

scripting dictionary, increases the potential

for processing emails. This can help you

quickly file those emails directly into

DEVONthink.

DEVONthink comes with scripts for Apple

Mail, Microsoft Entourage, and Microsoft

Outlook. Just select a message or mailbox in

a supported email application and choose the

desired script from the global scripts menu.

DEVONthink provides the following scripts:

Add attachment(s) to DEVONthink: Adds

the attachments of selected emails to

DEVONthink.

Add mailbox(es) to DEVONthink: Adds the

selected mailboxes to DEVONthink.

Add mailbox(es) & attachments to

DEVONthink: Adds the selected mailboxes

to DEVONthink. Attachments are imported

separately.

Add message(s) to DEVONthink: Adds the

selected mailboxes to DEVONthink.

Add message(s) & attachments to

DEVONthink: Adds the selected mailboxes

to DEVONthink. Attachments are imported

separately.

WEB BROWSERS

Depending on the capabilities of the web

browser you're using, you may be able to

use application scripts. We have included

a handful of simple scripts that can be run

while browsing in Safari or DEVONagent.

Add abstracts to DEVONthink: Creates a

sheet containing information about items

in a DEVONagent search. This includes

the title, score, summary, and URL of each

result. (DEVONagent only)

Add linked images to DEVONthink: Detects

images on the current page and adds them

to your database.

Add tabs to DEVONthink: Adds bookmarks

for active tabs the browser.

Add linked images to DEVONthink's

downloads: Detects images on the current

page and adds them to DEVONthink's

Download Manager.

Add links to DEVONthink's downloads:

Detects URLs on the current page and adds

them to DEVONthink's Download Manager.
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OTHER APPLICATIONS

Obviously we haven't covered all the possible

applications or scenarios on your machine,

and we are sure you have ideas we haven't

thought of. If you have an application you'd

like to integrate with DEVONthink, check if

it has an AppleScript dictionary. If it does,

the potential exists to communicate between

the applications. But also be aware the

commands, elements, and properties you

can work with are coded by the developer of

those applications.

FOLDER ACTIONS

Folder actions are scripts that you can attach

to folders in the Finder. These act on all items

you add to these "hot folders." When you

add items, the operating system detects

the added files and runs any folder actions

attached to the folder.

The actions supplied by DEVONthink are

installed in ~/Library/Scripts/Folder

Action Scripts, and you can add your

own scripts to this directory, as needed.

For everyday use and exploration, here

are the folder action scripts provided by

DEVONthink:

DEVONthink - Import: Imports files into

your databases.

DEVONthink - Import & Delete: Imports

files into your database, and moves the

files to the trash afterwards.

DEVONthink - Import to selected group:

Imports files to the currently selected

group.

DEVONthink - Index: Index files to your

database, creating links to the original

items in the Finder.

DEVONthink - Index to selected group:

Index files to the currently selected group

in your database.

These built-in actions also include this line

to run an available smart rule on imported or

indexed items: perform smart rule record

theRecord trigger import event. You can

enter the name of a specific smart rule in

your own scripts, as needed.

DEVONthink - Import, OCR & Delete:

Imports files into your database, converts

them to searchable PDFs if necessary, and

moves the files to the trash afterwards.

This built-in action include this line to run an

available smart rule after OCR has finished:

perform smart rule record theRecord

trigger OCR event. You can enter the name

of a specific smart rule in your own scripts, as

needed.

ATTACHING A FOLDER ACTION

To attach a folder action script to a folder, do

the following:

Control-click a folder in the Finder.

Select Services > Folder Actions Setup

from the context menu.

From the list of available actions, select

the folder action script click Attach.

Manage folder actions: To manage all your

folder actions, Control-click a folder and

choose Services > Folder Actions Setup from

the context menu. Use the Folder Actions
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Setup utility to see which folders have scripts

attached, and to remove folder actions from

folders.

Note: Modern versions of macOS will

require you to allow the Folder Actions

Setup application to run. This notification

is controlled by the operating system, not

DEVONthink.

TERMINOLOGY

While we can't provide specific training

on how to create folder actions, check out

Apple's documentation. However, the on

adding folder items to folderVariable

after receiving filesVariable is the

handler most commonly used in our folder

action scripts. Here is a simple example:

Example:

on adding folder items to theFolder after

receiving theFiles

repeat with thisFile in theFiles

tell application id "DNtp"

set newRecord to import thisFile to

incoming group

if exists newRecord then tell application

"Finder" to delete thisFile

end tell

end repeat

end adding folder items to

Folder actions, like any computer processes,

are treated very literally. When processing

files with a folder action, it's best to move or

delete the files from the watched folder. This

keeps the action from trying to reprocess

files.

Also, while folder actions can still be a useful

option, many can be replaced by indexing a

Finder folder and processing their contents

with smart rules. You can use the Move into

Database action to import the document

into your database, keeping the Finder folder

clean for subsequent additions.

SHORTCUTS AND AUTOMATOR

Apple's Shortcuts and Automator

applications were created to help non-

programmers take some control of their

machines. They allow you to visually

string together simple steps to create an

automated process. Though much more

limited due to their linear nature and lack of

debugging tools, they may still be useful for

some situations. Additionally, they let you

create other types of items like workflows,

services, or Quick Actions.

DEVONthink doesn't offer specific

Shortcut or Automator actions. However,

as DEVONthink has a deep and robust

scripting dictionary, the Run AppleScript

action in those applications opens up some

automation opportunities. The key to

integration with DEVONthink is passing or

receiving file paths via scripting.

Note: While Shortcuts is newer, the tips

presented here generally apply to both

applications. And while we may investigate

DEVONthink-specific questions regarding

Shortcuts or Automator, we do not offer

support specifically for them.
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GETTING INFORMATION INTO DEVONTHINK

As an example, importing selected files in the

Finder can be accomplished by passing file

paths to DEVONthink. To do this, use a Get

Selected Files in Finder action before

this Run AppleScript action:

Example:

on run {input}

tell application id "DNtp"

repeat with thisFile in input

import (POSIX path of thisFile) to

incoming group

end repeat

end tell

end run

SENDING INFORMATION OUT OF

DEVONTHINK

For passing items from DEVONthink, this

Run AppleScript action provides a list of file

paths to be processed. This action should be

placed before the third-party application's

actions.

Example:

on run {}

tell application id "DNtp"

if (selected records) is not {} then

set fileList to {}

repeat with thisRecord in (selected

records)

if (path of theRecord is not "") then

copy ((path of theRecord) as POSIX file)

to end of fileList

end if

end repeat

end if

if fileList is not {} then return fileList

end tell

end run

Note: In Shortcuts, the records' path likely

needs to be passed as a POSIX file.

Automator prefers POSIX paths, so use

copy (path of thisRecord) to end of

fileList instead. Also, you need to ensure

the selected items are not groups or smart

groups as they don't exist in the filesystem.
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WARNING: Be very cautious when using the

paths from DEVONthink. Actions like moving,

deleting, renaming etc. would compromise

your database. Immediately following the

AppleScript action, use a Save action with

the AppleScript Result in Shortcuts or the

Copy Finder Items action in Automator to

keep from modifying the underlying files in

your database.

ITEM LINKS

Every database, group, or document in your

DEVONthink database has a URL (uniform

resource locator) associated with it. While

web URLs typically begin with http:// or

https://, DEVONthink's URLs take the form

of x-devonthink-item:// followed by a long

alphanumeric ID. These are most commonly

used for backlinks and deeplinking, even with

external applications. But item links can

also be used as a type of automation when

extended with URL parameters.

You can get this item link manually by

selecting a document or group and choosing

Edit > Copy Item Link. You then can manually

extend the copied URL with the following

parameters, as needed:

app: Used in conjunction with

the openexternally parameter,

specify the name of the app to open

the referenced file with, e.g., x-

devonthink-item://E35A4AFF-

BD90-4131-9D54-62849E0EF4DE?

openexternally=1&app=preview.

length: Specify the number of characters

from the start parameter. Used in

selection links.

openexternally: Opens the referenced

item in the system default application,

e.g., opening a PDF in Preview. Used with a

value of 1, e.g., openexternally=1.

opentab: Opens the referenced item in a

new tab in the current main window if a

document is already being viewed. Used

with a value of 1, e.g., opentab=1

page: Opens a PDF to the specified page.

Usage: page=<integer>.

reveal: Reveals an item in the item list

instead of opening it in a new window.

Usage: reveal=1.

search: Directly jumps to the first

occurrence of the search string in

the specified document. Usage:

search=<string>.

start: Specify the starting character on the

current page. Used in selection links.

time: Directly jumps to the specified time

in seconds in a video or audio document.

Usage: time=<float>.

Example:

x-devonthink-item://<recordID>?reveal=1

x-devonthink-item://<pdfID>?page=5

x-devonthink-item://<textFileID>?

search=iPad%20Pro

x-devonthink-item://<movieID>?time=43.5

Note: The first parameter after the ID is

always added after a question mark (?),

additional ones after an ampersand (&),

and any values must be percent-encoded.

TERMINOLOGY

Manually getting item links can be useful

for some hard-coded cases, but there

are many times you want to get them

programmatically. There are two AppleScript

properties for a record related to item links:
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reference URL: This is the item link as

described above.

UUID: This is the unique identifier of the

item, i.e., the long alpha-numeric string in

the reference URL.

Here is an example of getting and using an

item link to create a Markdown compliant link

on the clipboard:

Example:

tell application "DNtp"

set recordName to name of content record

set recordURL to reference URL of content

record

set the clipboard to ("[" & recordName &

"](" & recordURL & ")")

end tell

The terminology for using item links can

depend on the capabilities of the application

you're scripting. Here is an example, using a

hard-coded URL, with an application that can

open URLs:

Example:

tell application "Opera"

tell window 1

make new tab with properties {URL:"x-

devonthink-item://929D101B-35AC-474C-801C-

D8818C48DB80?line=125"}

end tell

end tell

P.S.: For the shell scripters, the URLs can be

used with an open command.

URL COMMANDS

URL commands are similar to item links

but instead of pointing to a file, they

execute special commands in DEVONthink.

Though not as powerful as AppleScript,

these commands can be used in special

circumstances.

TERMINOLOGY

The URLs are constructed from a single

command and optional parameters, with the

following format:

x-devonthink://<command>?
<parameter=value&parameter=value&...>

Note: The first parameter after the ID is

always added after a question mark (?),

additional ones after an ampersand (&),

and any values must be percent-encoded.

Listed below are the commands and

parameters available:

Commands:

createFormattedNote: Creates a

formatted note.

createHTML: Creates a new HTML

document.

createMarkdown: Creates a Markdown

document.

createPDF: Creates a PDF.

createRTF: Creates a rich text document.

createWebArchive: Creates a web archive.

createBookmark: Creates a new bookmark.

Note: Use the location parameter set

to a URL with the commands above to

download the page in the specified format.

createGroup: Creates a group.

createText: Creates a new plain text

document.

clip: Opens the Clip to DEVONthink panel.
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note: Opens the Take Note panel.

search: Initiates a search in the open

databases.

Parameters:

title: The title of the item to be created

(string).

comment: A Comment to be added

(string).

location: The URL linking to the content,

e.g., the URL of the website for the

bookmark (URL).

tags: Tags to be added (comma separated

strings).

destination: The UUID of a group where the

item shall be created (string).

source: The HTML content for HTML

documents (string, only used by

createHTML and createFormattedNotes).

text: The text content for text documents

(string, used by createText and

createMarkdown).

width: The page width (integer, only used

by createPDF).

paginated: Paginate the created PDF

(boolean, only used by createPDF).

hide: Hide and deactivate application after

executing the comment (boolean).

noselector: Skip group selector (boolean).

query: The query to search for (string, only

used by search).

reader: Post-process the page (integer, 0 =

no post-processing, any other value = post-

process).

referrer: The URL that referred to the item

(URL).

selection: The selected text (string, only

used by createRTF).

Example:

x-devonthink://createRTF?title=New

%20bookmark&location=http%3A%2F

%2Fwww.devontechnologies.com&noselector=1

Note: These are not x-callback-urls. An

x-callback-url is a specific type of URL

scheme that returns a value to the calling

application.
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In the appendices you will find a wealth

of additional information that helps you

getting familiar with DEVONthink, such as a

glossary of commonly used terms, a listing

of the Boolean operators used in searches,

commonly found context menu items, and

much more.

GLOSSARY

Become familiar with these terms to get the

most out of working with DEVONthink.

INTERFACE ELEMENTS

Get familiar with the names of part of

DEVONthink windows.

Bars: Smaller sections of a window

providing specialized information or

controls, e.g., the Information Bar found

just above the item listing. It shows

information about the selection as well as

buttons to sort or change the view.

Context menu: The menu that appears

when you Control-click something.

The context menu gives you access to

frequently used commands that deal

directly with the clicked object. Specific

context menu items are discussed in their

respective sections, but there is a list of

commonly seen commands in the Context

Menu Items section of this appendix.

Inspectors: Specialized panes at the right

of a main window, providing information

about the current selection as well as

functions like See Also & Classify.

Item list: The list of items in the current

location, viewable as a list, icons, columns.

Items can be documents, groups, or smart

groups.

Popover: A specialized type of window

that appears at a specific location, e.g.,

the toolbar, opened via a toolbar button or

menu command. Database Properties is a

type of popover.

Sidebars: The panes found at the left

side of a main window, comprised of the

DEVONthink 4.3.2 Documentation, page 292



Navigate, Reading List, Import, Extras

sidebars.

View: The layout of the item list and

view/edit pane in a main window, either

Standard or Widescreen. You can change

the layout using the commands found in

the View  menu.

View/Edit pane: The pane in main windows

where the content of selected documents

is shown or edited. This pane can be hidden

by choosing View > None.

Window: DEVONthink uses three different

types of windows: main, document, and

other. Main windows show lists of items

and, in some views, also the contents of

the selected document, whereas document

windows can be opened for individual

documents.

DOCUMENTS & GROUPS

Database: A collection of all documents

stored in DEVONthink. You can create and

open as many databases as you like.

Document: A file in the database; for

example, a plain or RTF text, a PDF, or an

image (.jpg, .tiff, .png, etc.). Technically a

document is an entry in a database with

text, RTF, or image content, sometimes

simply referred to as "content".

Default destination: The default

destination group for incoming data. Set in

Settings > Files > Import.

Duplicate: A copy of a file, either explicitly

created or detected by DEVONthink's AI.

Group: A collection of documents or other

groups inside the database. Similar in

appearance and behavior to a folder in the

Finder. See also p. 201ff

Global Inbox: A special database serving as

a destination for incoming data. The Global

Inbox is always opened when DEVONthink

is started and accessible through the

sidebar. The Global Inbox can be set as the

default destination in Settings > Files >

Import.

Inbox: A special group for data coming in

to a database. Every database has an Inbox

group.

News feed: Also referred to as RSS, a

news feed is like a web page, but split

into multiple articles. A feed reader or

web browser can split the feed "page"

into its parts and show each of them as

a separate news item and/or store it in a

local database. DEVONthink stores feeds in

a database and displays them like a group.

The contents are updated live from the

internet as the connected feed changes.

Older news bits are kept, while fresh news

bits are added and marked as unread.

When you add a bookmark that points

a feed, DEVONthink tries to add it as a

proper feed document if possible.

Replicant: A document or a group that

appears in more than one place in the

database. Unlike an alias in the file system,

a replicant is not a real document pointing

to another file (usually the original);

rather it is a second entry in the table of

contents for the very same document.

Consequently, there is no original; when

you replicate a document you'll end up with

two replicants.

Sheet: A collection of records or structured

sets of data, presented in a spreadsheet

style, similar to data viewed in Apple

Numbers or Microsoft Excel. Alternatively,

the data can be displayed in form view,
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similar to browsing records in, e.g.,

FileMaker.

Smart group: A special type of group with

a set of search criteria saved with it. This

is similar to "Saved Search" folders in the

Finder. Every time you visit this smart

group, DEVONthink runs the attached

search and displays it as the content of the

group. DEVONthink creates a number of

pre-defined smart groups when you create

a new database.

Trash: A temporary location in a database

for deleted files. Similar to the Trash in

the Finder, all trashed items are stored

until you explicitly delete them using

DEVONthink > Empty Trash.

TAGS

Group tag: Groups within a database that

apply their name as tags to their contents.

Items moved out of these groups will not

retain the group tags. Group tags appear

grey in all tag lists.

Ordinary tag: Tags created through the

Tag bar or other means are created in a

special top-level Tags group. They are called

"ordinary tags" and appear blue in all tag

lists.

See the Iconology section for icons specific to

these two items.

ITEM PROPERTIES

Flagged/Unflagged: Items can be checked

or unchecked for your personal use, e.g.,

for creating a to-do list, maintaining a

shopping list, or writing a list of project

tasks.

Locked/Unlocked: Items can be locked

to keep them from being unintentionally

deleted (groups, documents) or modified

(documents).

Read/Unread: Items can be marked read

or unread, which is useful for captured or

automatically downloaded news items or

documents that you want to read later.

Both unread items and groups containing

unread items are shown in bold.

UUID: Each database, group, or document

in DEVONthink receives a unique identifier

(UUID) when it's created. This is a read-

only alphanumeric string that refers only to

the particular item. The UUID allows you to

reference an item regardless if its location

or name changes, and is usually found in

item links.

See the Iconology section for icons specific to

the flagged, locked, or unread states.

SYNCHRONIZATION

Sync location: Sync locations are used to

keep your databases on all your devices in

sync. They summarize all information about

which databases to sync through what kind

of connection (e.g., direct connections to

DEVONthink on a Mac, WebDAV, CloudMe,

Dropbox etc.) and with which sync store.

Bonjour (Direct connection): A sync

method for syncing one device to another

Mac or mobile device running DEVONthink

or DEVONthink To Go, respectively.

Unlike other sync methods, there is no

intermediary storage location for the sync

data. It is direct - device to device.
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Sync store: A sync store is a special folder

containing sync data. These can be direct,

local, e.g., on your Mac or a thumb drive, or

remote, as used with cloud services.

Encryption key: A user-defined word used

to "scramble" or "unscramble" your sync

data when syncing. When used, your sync

data is stored in an encrypted state in the

sync store.

Local database: A database that exists and

is open on this device.

Remote database: A database that is not

open on this device, or exists at the sync

location, e.g., on Dropbox, but has not been

downloaded to this device.

Pending document: A document for which

only the metadata is locally available.

This is usually caused by choosing not

to synchronize indexed files for the sync

location.

WebDAV: A type of web server used

by some cloud services, some network

attached storage devices, sometimes

running locally. It can often be used by

DEVONthink for syncing.

AI

AI model: An umbrella term for different

types of AI, e.g., text generation with

ChatGPT, image generation via DALL-E.

API Key: This is a personal key provided by

an AI provider, e.g., OpenAI, that lets you

access and use their servers and data to

chat with. You enter this into the AI > Chat

settings.

Context window: The context window

is how much information an LLM can

process. This can include the content of

previous queries. Consider it the short

term memory of an LLM. The larger the

context window, the more information it

can use to generate appropriate responses.

Generative AI: A type of AI capable of

creating images, videos, music, etc.

DEVONthink supports image creation.

Hallucination: An incorrect or irrelevant

AI response. This is less common as large

commercial LLMs improve but still possible

as the responses aren't validated. This is

much more common when trying to run a

local LLM with a small model.

LLM: The acronym for Large Language

Model, focused on text processing and

generation. ChatGPT and Claude are LLMs.

Prompt: This is the question or command

you set to your AI chat, e.g., via the Chat

inspector, Chat popover, or even AI

assisted automations.

RAG: The acronym for Retrieval Augmented

Generation, this is the process by which

a document is parsed by an AI model into

a specialized database. This database is

then used to answer questions about the

specific document. These are generally

only available in commercial AI models, like

Claude.

Role: A "persona" sent to the AI used to

direct the responses, representing you, the

AI, or both. For example, your role could

be "I am in an undergraduate anatomy

class…" or "You are presenting to a roomful

of young astronomers…".

Speech-to-Text: A type of AI capable of

converting speech in audio and video files

into text. DEVONthink supports this.

Tokens: Tokens are how words are

processed by AI. Some words are treated

as a token; others are split into separate

tokens. This is controlled by how the LLM
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is built. Bear in mind, you typically pay per

token when using a commercial AI service

though the cost-per-token is usually small.

Tools: AI capable of accepting

DEVONthink-specific commands, e.g.,

document creation, database searching,

etc.

Reasoning: AI using a deeper, recursive

approach to responding to a question,

often returning a preamble of its "thinking".

Vision: AI capable of analyzing images, e.g.,

summarizing an image.

ICONOLOGY

Additional icons behind item names, e.g., in

main windows, indicate that the item has

been indexed instead of imported, is locked,

has a comment or annotation attached,

is encrypted, e.g., PDFs or encrypted

databases, or has a triggered script attached.

Groups also serving as tags show a tag icon.

Depending on your preferences, replicants,

duplicates, or replicated duplicates are

indicated with a little grey icon instead of

appearing in color.

Item has encryption applied, e.g.,

encrypted PDFs, and encrypted database,

or an encryption key has been specified for

a sync location in Settings > Sync.

Database is an revision-proof archive.

Item is unread.

Item has been flagged.

Item is indexed, not imported.

Item is locked.

Item has a comment.

Item has an associated annotation file.

Item has a reminder set.

Item has outgoing item links.

Item has incoming item links.

Item has a script attached.

Item has an attachment (email messages

only).

Item is pending—synced but its content is

not (yet) downloaded.

Item is a duplicate.

Item has one or more replicant(s).

Item is a duplicate, but also has one or

more replicant(s).

TOOLBAR ITEMS

DEVONthink provides a wide variety of

toolbar items, giving you quick "push-button"

access to many everyday tools.

DEFAULT ITEMS

The following toolbar buttons are available in

the default set you see when you first launch

DEVONthink:

Sidebar: Show and hide the global sidebar.

Preview: None:  Hides the document

preview.

Preview: Standard:  Shows the document

preview below the item listing.

Preview: Widescreen:  Shows the

document preview besides the item listing.

New: Adds documents in DEVONthink-

native formats. Similar to Data > New.

Actions:  Contains the context menu for

items selected in the item listing..

Open:  Opens the current item in a

DEVONthink window if possible.

Open externally:  Opens the current

document in the system default

application.
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Share:  Opens the macOS Share menu for

the selected items. This does not apply to

groups.

Mark: Flagged:  Changes the flagged state

of the selected item.

Mark: Read:  Changes the read statue of

the selected item.

Mark: Locked:  Changes the locked state of

the selected item.

Label:  Changes the label color of the

selected item.

Synchronize:  Initiates a manual sync of the

current database.

Search:  This is the main search bar,

accessing all or specific groups and

databases.

Log: Opens a popover showing available

messages from the Log window.

Get Info:  Opens a popup from the button

displaying a number of commonly used

inspectors.

Show/Hide Tags:  Shows or hides the Tags

bar under a document's preview.

Show/Hide Inspectors:  Shows or hides the

Inspector panes.

ADDITIONAL ITEMS

In addition to the default set, there are many

other specific buttons available, shown in the

order found in the View > Customize Toolbar

sheet:

Scripts: Provides access to the contents of

the Scripts menu.

Quick Look: Opens a Quick Look preview

for the selected document.

Zoom: Changes the magnification of the

document being viewed: +, -, or click 1 for

actual size.

Zoom to Fit: Sets the magnification of the

current item to fit the bounds of the view/

edit pane.

Zoom to Width: Sets the magnification of

the current item to the width of the view/

edit pane.

Full Screen: Displays the current document

in DEVONthink's full screen mode.

Groups: Group: Creates a new group in the

current location.

Groups: Smart Group: Creates a new smart

group in the current location.

Group: Groups the selected items into a

new group.

Ungroup: Ungroups the selected group and

deletes the now-deserted empty group.

Classify: Attempts to classify the current

item.

Plain Text: Creates a plain text file in the

current location.

Markdown Text: Creates a Markdown file in

the current location.

Rich Text: Creates a rich text file in the

current location.

Formatted Note: Creates a formatted note

in the current location.

Sheet: Creates a sheet in the current

location.

Bookmark: Create a bookmark in the

current location.

Launch URL: Opens a URL associated with

the current item in the system default

browser.

Add to Reading List: Adds selected

documents to the Reading List sidebar.

Save: Explicitly save changes to a

document.

Delete: Moves the current item to the

database's trash.
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Print: Prints the selected document. If

a document cannot be printed, the item

listing will be printed.

Import: Imports files into the current

location.

Export: Provides access to the contents of

the File > Export menu.

Update: Manually updates (indexed) items

in a database.

Show in Finder: Opens a Finder window

revealing the document's location in the

filesystem. Be cautious with this button.

When used on imported files, it will reveal

them in the internals of the database. You

do not want to modify these internal files

in the Finder. This option is best used on

indexed files.

Reveal: Reveals a file in its location in a

database. Used with items selected in

smart groups or search results.

Merge: Merges multiple files into one,

leaving the originals intact.

Merge and Delete: Merge multiple files into

one, putting the originals in the database's

trash.

Batch Process: Open

Optimize: Does an internal optimization

and backup of a database's metadata.

Verify: Checks the integrity of the

database and repairs items it can. Please

refer to the troubleshooting chapter for

information on database maintenance and

repairs.

Database Archive: Creates a compressed

archive of a selected database. This works

the same as the File > Export > Database

Archive command.

Send by Email: Creates a new message

in your default email app and attaches

selected items. Be aware the ability to

add attachments depends on the inter-

application capabilities of the email

application.

Take Note: Opens the Take Note view,

either in the Sorter or a Take Note panel.

Synchronize All: Initiates a manual sync of

all open and actively syncing databases.

Chat: Opens the Chat popover.

Imprinter: Provides access to any imprints

available in the Tools > Imprinter menu.

OCR: Runs OCR on a compatible file, e.g.,

PDFs or images, producing the selected

output type.

CUSTOM ITEMS

If you are creating scripts or templates, they

will be available to add to the toolbar after

quitting and relaunching DEVONthink. See

the appropriate sections for information

on where to save these files for use in the

toolbar.

INTERFACE SHORTCUTS

For some people, navigating an application

via keyboard shortcuts feels much more

efficient. Below are some shortcuts for

getting around the interface. Some are

common to most Mac applications; others

are specific to DEVONthink. And if you're

looking for hotkeys for command shortcuts,

we also have those listed.

There are a few keys found only on extended

keyboards. Here are the equivalents available

on laptops using the Function key:
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Extended Keys:

Home: Function-Left arrow

End: Function-Right arrow

Page Up: Function-Up arrow

Page Down: Function-Down arrow

WINDOWS

Control-Tilde (~): Cycles through open

application windows. This is a common

macOS shortcut.

Control-Tab: Cycles focus between the

sidebar, item list, view/edit pane, the Tags

bar, and inspectors, depending on what

elements are visible.

Escape: Cancels processes, closes dialogs

or Quick Look previews, etc., depending on

the context.

Command-}: Cycles to the next tab.

Command-{: Cycles to the previous tab.

Note: Hold ⇧ to cycle in reverse order.

DOCUMENT LISTS

Navigating items:

Up/Down arrow: Navigates up and down in

all views. Use ⇧ to select multiple entries.

Left/Right arrow: Expands or collapses the

selected groups in horizontal split, vertical

split or List views, or navigates to previous/

next item in other views.

Option-click (the triangle in front of a

group): Expands or collapses all groups that

are contained within this group as well.

Option-Left/Right arrow: Expands or

collapses the selected groups and all their

children the item list.

Selecting items:

Shift-click: Selects consecutive items.

Shift-arrow: Extends the next consecutive

item to the current selection.

Command-click: Adds a non-consecutive

item to the selection.

Manipulating items:

Return: Renames documents.

Backspace: Deletes selected items.

Command-Drag: When dragging items from

the Finder, this moves, not copies, the file

into the database.

Option-drag: Duplicates items to the drag

destination instead of moving it.

Command-Option-drag: Creates replicants

for the items at the drag destination.

Dragging items from the Finder to

DEVONthink with ⌥⌘ pressed indexes the

item. Dragging items into documents with

⌥⌘ held inserts a link to the item.

Item List:

Command-Shift-O: Opens a selected

document in the system default

application.

Tab: Jumps to the first or next editable

column when using the item list in List

view.

Space: Opens the standard Quick Look

panel showing a preview of the selected

items.

Option-Space: Opens a full screen Quick

Look slideshow.

Command-bracket: Using [ and ], goes

backwards and forwards through the

visited locations.
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VIEW/EDIT PANE

The first section of shortcuts are generally

applicable to documents like Markdown, rich

text, etc. Keys more specific to other formats

are listed separately.

Home/End: Goes to beginning or end of

any view.

Page up/down: Scrolls one page up and

down in any view.

Space/Shift-Space: Scrolls one page down

or up in non-editable views, e.g., web pages,

images, or PDF documents.

Command-click: Opens the target of a link

in a new tab or separate window.

Command-Shift-click: Opens a link in a new

tab and activates it. This requires enabling

tabbed browsing in Settings > General.

Option-click (a link): For HTML-based files,

adds the clicked URL to the Download

Manager panel.

Option-click (a word): Initiates a search

with the clicked word as the search term.

Option-drag: Selects text using a

rectangular selection ribbon.

Command-Option-drag: Inserts a cross-

link for groups or documents dropped

into a rich text document. Dragging files

or folders from the Finder to a rich text

document with ⌥⌘ pressed creates links to

them.

PDFs and Images:

Control-Shift-Command- +: Zooms in.

Control-Shift-Command- —: Zooms out.

Command-0: Display at actual size.

Command-=: Zoom to fit.

Control-Command-W: Zoom to width.

Command-drag: Scrolls the visible area

with the mouse.

Sheets:

Return: Moves one cell down for editing.

Shift-Return: Moves one cell up for editing.

Tab: Moves one cell to the right for editing.

Shift-Tab: Moves one cell to the left for

editing.

Arrows: Moves the editing selection.

Escape: Stops editing.

Multimedia:

Spacebar: Start and stop playback.

Left/Right Arrows: Move forward or

backward one frame or .25 second.

Option-Left/Right Arrows: Jump to the

beginning or end of the file.

Shift-Left/Right Arrows: Move forward

or backward in 15 second intervals. The

Shift-interval is customizable in the hidden

preferences.

Command-Left/Right Arrows: Change

forward or reverse playback speeds.

Option-Forward/Reverse buttons: Hold the

Option key and click the forward or reverse

buttons to change playback speeds in .1

increments, e.g., 2.1, 2.2, etc.

Up/Down Arrows: Adjust the playback

volume. Hold Option to switch between

mute and full volume.

Note: These keys operate when a

multimedia file is playing in a document

window. They are not global controls, i.e.,

they will have no effect on an audio file

playing in a minimized window.

THE SORTER

Views: You can jump to a specific view by

pressing Option-Command and 1 through 6,

starting at the Navigation view.
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General Note Creation and Clipping:

Command-S: Saves the entered data.

Equivalent to clicking Add.

Escape: Clears any entered data.

Equivalent to pressing the retreating circle

icon.

Voice and Video Note:

Spacebar: Start and stop recording.

Screen Capture:

Command-1: Capture the entire window.

Command-2: Capture a highlighted window.

Command-3: Capture a selected area.

Both of the next two functions use the Web

Clip view. However, when opened via the

Clip To DEVONthink browser extension, the

hotkeys have different functions.

Web Clip:

Command-1: Clips from the default

browser.

Command-2: Clips from a URL you've

copied to the clipboard.

Command-3: Type a URL to clip and any

associated data, e.g., comments, tags, etc..

Clip to DEVONthink:

Command-F: Toggles the Clutter-free

option.

Command 1-9: Chooses the format to clip

to (in order from 1): Plain Text, Rich Text,

Bookmark, Formatted Note, HTML Page,

Markdown, Web Archive, PDF (One Page),

and PDF (Paginated).

CONTEXT MENU ITEMS

DEVONthink's menus are full of powerful

commands. But many of them are also

found in its context menus, shown when

you Control-click certain elements in the

application. This provides quicker access

to certain functions, streamlining your

experience. As the name implies, the

commands are contextual so the available

functions depend on what is selected or

clicked on. For example, the OCR commands

are only shown if an image or PDF document

is in your selection. Below is a list of common

menu items available in the context menus

for documents and windows.

ITEM LIST

These context menu items are commonly

shown when you Control-click in an item list.

As other interface elements, e.g., the AI >

See Also have item lists, you will find many of

these commands when you Control-click in

them too.

New Documents: You will see the Data > New

and New from Template commands when

using the context menu in the item list of a

main window.

Add To: Commands in this submenu add

the currently selected documents to your

Favorites or the Reading List.

Apply Rules: Runs a chosen smart rule on

selected items matching the location and

criteria of the rule.

Batch Process: Choose an existing

batch processing configuration or open

thenBatch Process window.

Classify to: Classifies the selected item

to the best matching group shown in the
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See Also inspector. If multiple items are

selected, this changes to Classify.

Convert: This submenu displays options for

converting from one file type to another.

The options shown here are dependent on

the type of file selected.

Copy Item Link: Copies a link to the current

item.

Copy URL: Copies the URL of the selected

document to the clipboard. This only

appears when one document is selected.

Duplicate To: Duplicates the selected item

to the group you select from the submenu.

Get Info: Opens a popup containing more

detailed information about the currently

selected file or group.

Group Items: Groups multiple selected

items in an item list.

Label: Changes the label of the selected

item.

Launch URL: Opens the URL in the selected

item's URL field. Hold the ⌥ Option key to

choose Launch URL in Background. This

keeps DEVONthink in the foreground.

Mark: Change the flagged, locked, or read

status of the selected item.

Merge n Documents: Merges the selected

documents. This command only appears

when more than one document is selected.

Hold the ⌥ Option key to use Merge &

Delete n Documents

Move Into Database: Moves an indexed

item into the database. Use this command

with caution as it moves the file from its

current location into the internals of your

database. It does not copy the file.

Move To External Folder: Moves a non-

indexed item, e.g., imported or created in

DEVONthink, out to an indexed folder in

the Finder if located in an indexed group in

your database.

Move To: Moves the selected item to the

group you select from the submenu.

Move to Trash: Moves the item to the

Trash. Holding the ⌥ Option key changes

this to Move All Replicants to Trash to clean

up unwanted replicants.

Open: Opens the selected item in a

separate main window or document

window.

Open in Tabs: Hold the ⌥ Option key to

access Open in Tabs. If the view/edit pane

is visible, this opens the selected items

in new tabs. If the pane isn't visible, a

new document window opens with each

selected document in its own tab.

Open With: Opens the selected item in an

external application.

Put Back: Moves an item back to its

previous location, if possible, e.g.,

after trashing, moving, or classifying a

document.

Rating: Allows you to set a rating, from no

stars to five stars.

Replicate To: Replicates the selected item

to the group you select from the submenu.

Remind Me: Adds a due date or clears a

reminder from the selected document.

Reveal: Shows and selects the selected

item in its location in DEVONthink.

Send by Email: Attaches the selected item

into a draft email, if supported by your

email application.

Share: Opens the Share menu.

Show in Finder: Shows the selected item

in the Finder. Be cautious when using this

command with imported items.

Tags: This submenu offers special

commands for automatically adding or
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removing tags. See the Tagging > Tagging

Sources section of the manual for more

information.

Thumbnails: This submenu allows you to

Create, Update, or Remove the thumbnail

for a file.

Ungroup Items: Ungroups a group, leaving

its contents behind. The group is not

preserved.

Group Similar Items: Groups selected

documents into contextually related groups

when holding the ⇧ Shift key.

Imprinter: Choose an imprint you've

defined in Settings > Imprinter to apply it

to the current image or PDF.

OCR: Choose the output file type and

convert to the chosen format via OCR.

Recognition: Use AI to process images,

including barcode detection, or transcribe

media files to text.

Note: These specific commands are only

shown when a selection contains files that

can be processed by them: Imprinter, OCR,

and Recognition. This includes selected

groups containing these documents.

NAVIGATE SIDEBAR

New Databases: No matter what section of

the Navigate sidebar in which you open the

context menu, you will see these commands:

New Database, New Encrypted Database,

New Revision-Proof Database. This makes it

easy to spin up a new database at any time.

The commands listed alphabetically below

may be seen when opening the context menu

in the various sections of this sidebar. Again,

the commands are contextual so where you

open the menu or what is selected dictates

the available commands. For example, the

Add to Favorites command logically isn't

shown when Control-clicking an item in the

Favorites section.

Note: Context menu commands for the

other sidebars as well as the inspectors are

covered in their respective sections.

Add to Favorites: Add the selected item to

the Favorites section.

Copy Database Link: Copies the unique

URL for the selected database.

Close Database: Closes the chosen

database. In the case of encrypted

databases, the encrypted volume will be

ejected as well.

Copy Database/Item Link: Copies the

unique URL of a selected item or database..

Database Properties: Opens the Database

Properties popover for the selected

database.

Delete Database: Deletes a database. This

doesn't have to be the active database.

This command also requires confirming the

deletion.

Empty Trash: Empties the Trash of all open

databases.

Expand/Collapse All: Opens or closes all

the subgroups within a selected group.

Get Info: Opens the Generic Info popover

for the selected group, including inboxes.

Label: Applies a color label to the group,

not its contents.

Mark: Sets the locked, flagged or read state

of the contents of the group.

Move to Trash: Moves the selected group to

the database's Trash.

New Database/revision-Proof/Encrypted:

Create a new database of the chosen type.
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New Feed: Create a new RSS feed in the

selected group or database.

New Group/Tag: Creates a new group or

tag, relative to the selected item.

New Smart Group/Smart Rule: Create a

new group or Smart rule.

New Window: Opens the selected item in a

new main window.

Rename: Change the name of the chosen

database. This can also be done in the

Database Properties.

Reveal: Display the location of the item and

select it in the item list.

Show in Finder: Reveal the data in a Finder

window.

DOCUMENT CONTENTS

The context menu is shown in the view/edit

pane for documents provides commands

based on whether there is a selection or

not. Some commands are also only available

when a limited number or words or links are

selected in the text. Also, some are relative to

the file type, e.g., shown for PDF documents.

Format-specific commands are described in

their respective sections in the Documents

chapter. This includes special item links, like

page links.

The following alphabetical list covers context

menu commands you may see when working

with documents in the view/edit pane.

Note: Proprietary formats viewed via

QuickLook won't display a context menu

unless they support the View > Document

Display > Text Alternative view.

Add Link to Reading List: Adds a link to the

Reading List.

Add Link: Allows you to enter a URL for the

selected text, converting the text to an

active link.

Add tag [word]: Tags the document with

the selected word (only available if the

word is not already a tag of the document).

Capture with Source Link: Opens the

Sorter with the selected text and a link to

the document.

Convert to Item Link: Converts a selected

WikiLink into an item link. An alternate

command, available when holding the

⌥ Option key, Convert All to Item Links 

converts all WikiLinks in the current

document into item links. These commands

only apply to plain text, rich text, and

Markdown documents.

Copy Link: Copies a clicked link to the

clipboard (only available for selected links).

Edit Link: Edit or remove the URL of a

selected link.

Insert Link To: Inserts a link to an item

you select in the submenu when no text is

selected.

Insert Placeholder: Inserts a predefined

placeholder or one specified as custom

metadata in Settings > Data.

Highlight: Highlights the selection with

the current highlight color. Using this

command on a selection again removes the

highlighting.

Link To: Converts selected text into a link

to a group or document you select in the

submenu.

Look Up [word]: Looks the selected text up

in macOS's Dictionary.

Make Link: Converts selected piece into a

WikiLink. The destination of the WikiLink
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is a document with the same name as

the selected text. If no document with

that name exists, clicking the created link

creates it using the template you have set

in the Settings > WikiLinks.

Open Link in Browser: Opens the selected

link in the default browser or application.

Open Link in DEVONagent: Opens the

selected link in a DEVONagent Pro browser

window.

Open Link in New Tab: Opens the selected

link in a new tab in DEVONthink.

Open Link in PhotoStickies: Opens a link in

PhotoStickies.

Open Link: Opens the selected link.

Quick Look Attachments: Opens a

QuickLook window for both item links

and WikiLinks in plain text, rich text, and

Markdown documents. Selecting a text

block with multiple links opens a QuickLook

window for all detected links.

Remove Link: Use this to remove the link

status of selected text.

Search with Google: Searches for the

selected text in Google.

Search [word]/Selected Phrase: Searches

for the selected word or phrase in your

open databases.

See Related Text: Displayed like search

results, this shows a list of documents

related to the selected text passage. This

option is only available when more than

one word is selected.

See [word]: Opens a drawer with

documents related to the selected word.

Set Name As: Sets the name of the

document to the selected piece of text

(needs to be less than 256 characters).

Services: Displays the macOS Services

menu.

Share: Shares selected text via the

available sharing extensions.

Add Link to Downloads: Adds a link to the

Download Manager.

Summarize via Chat: Opens the Summary

and Transform popover for the selected

text.

COMMAND KEYS

Below are the the factory default shortcuts

for the commands in DEVONthink's menus.

The main commands, those visible when you

open the menu, are listed first. Shortcuts for

submenu commands are listed separately.

Any alternate commands, e.g., those that are

available when holding the ⌥ Option key are

listed directly after the related command.

This listing uses Apple's standard command

key symbols:

⌘ The Command key, usually next to the

Space bar.

⌥ The Option key.

⌃ The Control key (usually labeled with

"ctrl").

⇧ The Shift key.

⎋ The Escape key (usually labeled with

"esc").

⇥ The Tab key.

↩ The Return key.

There are also a few commands using buttons

only found on extended keyboards. These are

listed by name. However, there are equivalent

key combinations available on laptops using

the Function key:
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Extended Keys:

Home: Function-Left arrow

End: Function-Right arrow

Page Up: Function-Up arrow

Page Down: Function-Down arrow

THE APPLICATION MENU

Shortcuts found in the DEVONthink menu.

Preferences: ⌘,

Empty Trash: ⇧⌘⌦

Hide DEVONthink: ⌘H

Hide Others: ⌥⌘H

Quit DEVONthink: ⌘Q

Quit and Keep Windows: ⌥⌘Q

THE FILE MENU

Shortcuts found in the File menu, including

the New Window, Export, and Close

Database submenus.

Index Files and Folders: ⌥⌘X

Update (Indexed) Items/Refresh Feed:

⌥⌘S

Synchronize Database: ⌃⌥S

Synchronize All Databases: ⌃⌥⇧S

Database Properties: ⌥⌘P

Verify & Repair Database: ⇧⌘Y

Check File Integrity: ⌃⇧⌘Y

Optimize Database: ⇧⌘K

Restore Backup: ⌥⇧⌘K

Page Setup: ⇧⌘P

Print: ⌘P

New Window

New Window: ⌥⌘N

Close Database

Close current database: ⇧⌃⌘W

Close All: ⇧⌃⌥⌘W

THE EDIT MENU

Shortcuts found in the Edit menu, including

the Find, Spelling and Grammar, and Insert

submenus.

Undo: ⌘Z

Redo: ⇧⌘Z

Cut: ⌘C

Copy: ⌘X

Copy with Source Link: ⇧⌘C

Copy Item Link: ⌃⌥⌘C

Copy Page/Selection/Paragraph Link:

⌃⌥⇧⌘C

Paste: ⌘V

Paste & Match Style: ⌥⇧⌘C

Complete: ⌥Escape

Select All: ⌘A

Deselect All: ⇧⌘A

Tags: ⌃Return

Set Name As: ⌃⌘I

Emoji & Symbols: ⌃⌘Space

Find

In Database: ⌥⌘F

Find: ⌘F

Find Next: ⌘G

Find Previous: ⇧⌘G

Use Selection for Find: ⌘E

Scroll to Selection: ⌘J

Spelling and Grammar

Show Spelling and Grammar: ⌘:

Check Document Now: ⌘;

Insert
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Bullet: ⇧⌘B

Date: ⇧⌘D

Item Link: ⌃⌘E

THE DATA MENU

Shortcuts found in the Data menu, including

the New, Open With, and Mark submenus.

Open: ⌘O

Launch URL: ⌃⌘U

Reveal: ⌘R

Save: ⌘S

Save All: ⇧⌘S

Duplicate:

Move To: ⌃⌘M

Move to… Again: ⌥⌘T

Group Items: ⌥⌘G

Group Similar Items: ⌥⇧⌘G

Ungroup Items: ⌥⌘U

Move To Trash: ⌘Delete

New

New From Clipboard: ⌘N

Plain Text: ⌃⌥⌘N

Rich Text: ⌃⌥N

Group/Tag: ⇧⌘N

Open With

Default application: ⇧⌘O

Mark

As Flagged: ⌥⌘K

As Unread: ⌘K

As Locked: ⌃⌘K

THE FORMAT MENU

Shortcuts found in the Format menu,

including the Font, Style, Alignment, and

Ruler submenus.

Make Rich/Plain Text: ⇧⌘T

Highlight: ⇧⌘L

Make Link: ⇧⌘M

Typewriter-like Scrolling: ⌥⌃T

Wiki Linking: ⌥⌃L

WYSIWYG Editing: ⌥⌃E

Show/Hide Format Bar: ⇧⌘F

Show/Hide Editing Bar: ⇧⌘E

Font

Show Fonts: ⌘T

Bigger: ⇧⌘=

Smaller: ⌘—

Copy Font: ⌥⌘C

Paste Font: ⌥⌘V

Style

Bold: ⌘B

Italic: ⌘I

Underline: ⌘U

Strike Through: ⌃⌘S

Styles: ⌃⌘T

Alignment

Align Left: ⌃⌥⌘L

Align Right: ⌃⌥⌘R

Ruler

Show/Hide Ruler: ⇧⌘R

Copy Ruler: ⌃⌘C

Paste Ruler: ⌃⌘V

THE TOOLS MENU

Shortcuts found in the Tools menu, including

the Inspectors, and Filter submenus.

Get Info: ⇧⌘I

Chat: ⌃⌘A

Graph: ⌃⌘H
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Inspectors

Show/Hide: ⌥⌘I

Generic: ⌃1

Custom: ⌃2

Properties: ⌃P

Annotations & Reminders: ⌃3

Table of Contents: ⌃4

Thumbnails: ⌃5

Annotations: ⌃6

Attachments: ⌃7

Links: ⌃8

Mentions: ⌃9

See Also & Classify: ⌃S

Search: ⌃U

Filter

Info: ⌃I

Tags: ⌃T

Multimedia: ⌃M

Maps: ⌃G

Flip

Rotate Right: ⌃⌘R

Rotate Left: ⌃⌘L

Batch Process

Batch Process: ⌥⌘B

THE VIEW MENU

Shortcuts found in the View menu, including

the Full Screen, Zoom, and Document Display

submenus.

Navigate: ⌥⌘1

Reading List: ⌥⌘2

Import: ⌥⌘3

Extras: ⌥⌘4

as Icons: ⌘1

as List: ⌘2

as Columns: ⌘3

None: ⌘5

Standard: ⌘6

Widescreen: ⌘7

Quick Look: ⌘Y

Show/Hide Tags: ⌃⌥⌘T

Show/Hide Details: ⌥⌘L

Show Only Documents: ⌃⌥⌘D

Full Screen

Document: ⌘F7

Window: ⌃⌘F

Zoom

Actual Size: ⌘0

All Pixels: ⇧⌘X

Zoom In: ⌃⇧⌘=

Zoom Out: ⌃⌘—

Zoom To Fit: ⌘=

Zoom To Width: ⌃⌘W

Document Display

Best Alternative/Table View/Preview: ⌃⌘P

Text Alternative/Form View/Source: ⌃⌘X

Side-by-Side: ⌃⌘Y

THE GO MENU

Shortcuts found in the Go menu. Note a few

commands are marked with the extended

keys mentioned at the beginning of this

section, e.g., Home.

Previous Database: ⌥⌘R

Next Database: ⌥⌘E

Top Group: ⌥⌘Home

Enclosing Group: ⌥⌘up arrow

Selected Group: ⌥⌘down arrow

To Group…: ⌘L

First Document: ⌘Home

Previous Document: ⌘Page Up
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Next Document: ⌘Page Down

Last Document: ⌘End

To Group: ⌃⌘G

To Document: ⌃⌘O

To Page/Line: ⌥⇧⌘P

To Link: ⇧⌘↩

Back: ⌘[

Forward: ⌘]

Previous Instance:

Next Instance:

Previous Highlight:

Next Highlight:

Next Unread Item: ⌘↩

Complete News: ⌥⌘↩

Move Focus to Sidebar: ⌃⌥⌘S

Move Focus to View: ⌃⌥⌘V

Move Focus to Preview: ⌃⌥⌘P

Move Focus to Inspector: ⌃⌥⌘I

Workspaces: Workspaces you create will be

automatically assigned a shortcut of ⌥⇧⌘1,

⌥⇧⌘2, etc. up to the ninth workspace.

THE WINDOW MENU

Shortcuts found in the Window menu.

Close: ⌘W

Close All: ⌥⌘W

Minimize: ⌘M

Minimize All: ⌥⌘M

New Tab: ⌃⌘,

Select Next Tab: ⌘}

Select Previous Tab: ⌘{

Activity: ⌥⌘A

THE SCRIPTS MENU

Shortcuts found in the Scripts menu. As the

script menu is segregated into subfolders by

design, there are no top level commands with

shortcuts at the factory settings. However,

there are a few built-in scripts with default

shortcuts:

Date

Verify & Optimize Databases: ⌃⌥⌘Y

Download

Linked Images of Page: ⌥⌘J

Open Linked Images in Tabs: ⇧⌘J

METADATA

DEVONthink stores a large number of

metadata fields internally when importing

documents from the file system, e.g., from

PDF, RTF, MP3, EXIF/IPTC, HTML, and email

messages as well as from all files that deliver

metadata through the Spotlight metadata

importer. Here's a partial list of theoretically

supported fields:

FILE METADATA

General Metadata:

Title

Headline

Subject

Creator

Producer

Editor

Contributor

PDF Metadata:

Author

Title

Subject

URL

Keywords
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RTF Metadata:

Author

Title

Comment

Subject

URL

Keywords

Organization

Copyright

Email Metadata:

Authors

Author email addresses

Recipients

Recipient email addresses

Email addresses

Media and Publication Metadata:

Album

Composer

Contributors

Publishers

Editors

Organizations

MultiMarkdown Metadata:

title

description

author

comment

subject

organization

keywords

publisher

email

copyright

generator

dc.title

dc.creator

dc.subject

dc.description

dc.rights

dc.contributor

dc.keywords

dc.publisher

og:title

og:description

geo.position

ibcm

CUSTOM METADATA

Another powerful feature of DEVONthink

is custom metadata fields. Specified in the

Settings > Data, you can define fields that

are meaningful to you, your company, your

research group, or even your family!

When you create a custom metadata

field, you give it a name. DEVONthink uses

this name to create an identifier for use

in automated processes. This identifier

is created automatically and cannot be

changed.

Data Types: When you define a custom field,

you choose a data type for it. So what's a

"data type"? It's simply a type of value; like "a"

is a character and "42" is a (the!) number. The

following data types are supported, including

any interface items associated with them,

e.g., checkboxes or dropdown menus:

Boolean: This is a true or false value.

Displayed as a checkbox.

Countries: A dropdown menu providing

a list of country names. Supports an

Undefined state

Languages: A dropdown menu providing a

list of languages. Supports an Undefined

state
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Integer: A whole number, e.g., with no

fractional part, like 17.

Decimal Number: A fractional number,

represented with a decimal point.

Date: Can be specified as Date & Time or

Date.

Identifier: Any alphanumeric value,

specified as needed, e.g., a customer or

patient number.

Single-line Text: A dropdown providing a

list of terms you defined for the field in the

Data preferences. You can also type in a

new value.

Multi-line Text: Enter a small paragraph of

text. Line breaks can be typed by pressing

Option-Return.

Rich Text: Same as Multi-line text but

supports basic formatting, e.g., bold or

italic text.

Set: Similar to the Single-line text, this

shows a dropdown with values pre-defined

for the field in the Data preferences.

However, new values can't be entered

outside the preferences. Supports an

Undefined state.

URL: Accepts any valid URL, including

filesystem URLs.

Link: A special dropdown that allows you to

choose an item in your databases. a link for

the chosen item is used.

Note there are metadata attributes that

support an Undefined option: Countries,

Languages, and Sets. This can be used

anywhere custom metadata is displayed, e.g.,

in an item list column or the Data inspector.

You can search for this by leaving the term

empty, e.g., mdcountry= is equal to "The

Country attribute is Undefined."

Note: The Countries and Languages lists

are lengthy, but not necessarily exhaustive.

For Multi-line Text and Rich Text, only one

line will be displayed in its column in the

item list.

Predefined Custom Metadata: In Settings

> Data, we have provided some custom

metadata fields to get you started. These are

ready to use and explore and serve as great

examples of the data types discussed above:

Date

Company

Author

Abstract

Status

Serial Number

ISSN/ISBN

Digital Object Identifier (DOI)

PubMed ID

PMC ID

Barcode

Format

Category

Subcategory

Genre

Country

Language

Price

Tax

Tip

Decimal
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SEARCH OPERATORS

DEVONthink is well known for its powerful search functions. Not only does is support search

prefixes, but also extended operators like booleans, parentheses, and wildcards. The syntax

of the operators is compatible to DEVONagent and EasyFind, the Finder, Spotlight, common

search engines as well as common programming languages such as C, C++, Objective-C, Java, and

JavaScript. The complexity of the query is unlimited.

Case-Insensitivity: You are free to use capitalization as you wish, e.g., for proper names, but

DEVONthink will ignore case when interpreting the query. However, the operators listed below are

case-sensitive, so age before beauty is not the same as age BEFORE beauty.

White Space Handling: Words linked by non-white separators (e.g., page-index or page_id) are

treated like phrases put into "quotes". Words separated by hyphens are handled like word1word2

OR "word1 word2". Characters separated by dots are considered to be abbreviations and

therefore handled like words separated by hyphens, e.g., the term t.a.t.u is equal to "t a t u"

OR tatu.

WILDCARDS

To make searching more flexible, you can replace parts of words with wildcards. For example, you

can search for plural forms of words without having to type, e.g., "dog" and "dogs". The available

wildcards are:

?: Matches exactly one character.

*: Matches none, one, or multiple characters.

[a-z]: Matches one character of the range a through z.

[abc...] or [a|b|c|...]: Matches one character out of the given list of characters.

[^...]: Matches one character that is not contained in the given list or range.

~: The contains operator for matching substrings, essentially equal to a string bounded by

wildcards before and after, e.g., *ink*.

Note: The wildcards presented here are not full regular expressions.

Example: Searching a document containing this text: DEVONtechnologies makes great

software:

text:~tech matches as the tech is contained in one of the words.

text:tech does not match as there is no word tech.

text:tech* does not match as there is no word beginning with tech.

text:*tech does not match as there is no word ending with tech.

text:*tech* matches as tech is found in a word with text before and after it. However, unless

you have a specific purpose, using the contains (~) operator is more succinct.
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Searching a document with the text: He made a cake. She is making cookies. They live in

Madeira:

text: ma[dk]* matches "made", "making", and "Madeira".

text: ma[dk]? matches only "made".

Given a document named 2024-2-14_Big Light Electric:

name:[0-9] would only match "2".

name:[0-9][0-9] would only match "14"

name:[0-9]* would match all the numbers, regardless of length.

name:[0-9][0-9]* would match two or more numbers, e.g, "14" and "2024".

name:19[0-9][0-9] If you were looking for documents only in the 1900s, this would match,

e.g. "1914".

name:202[0-9] big would match this document or others from the 2020s, e.g., "2021-3-9_Big

Light Electric".

BOOLEAN OPERATORS

The operators (often called Boolean operators) are words or symbols that establish logical rules

for the terms in the search query. If no operator is given, DEVONthink infers AND. The available

Boolean operators are:

term1 AND term2: Contains term1 AND term2

term1 BUT term2: Contains term1 AND term2

term1 OR term2: Contains term1 OR term2

term1 XOR term2: Contains term1 or term2, but not both

term1 EOR term2: Contains term1 or term2, but not both

NOT term: Does not contain term

"term1": Contains the string of words term1, in exactly this form

Besides the classic Boolean operators, DEVONthink uses a number of operators that usually are

found in high-end databases. Use these operators as a replacement for AND and "quotes" to fine

tune your query.

term1 OPT term2: term1 is required, term2 is optional. If term2 is also found, the found

document ranks higher in the search results.

term1 NEAR term2: term1 occurs 10 words or less before or after term2

term1 NEAR/n term2: term1 occurs n or less words before or after term2

term1 BEFORE term2: term1 occurs before term2

term1 BEFORE/n term2: term1 occurs n or less words before term2

term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)

term1 NEXT/n term2: term1 occurs n or less words before term2 (synonym for BEFORE/n)

term1 AFTER term2: term1 occurs after term2
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term1 AFTER/n term2: term1 occurs n or less words after term2

~term1: Contains term1, also as part of a word

For convenience, some of these operators can also be abbreviated using commonly used symbols:

AND: &, &&, +

OR: |, ||

XOR: ^, ^^

NOT: !, -

Operators are evaluated in the following priority: parenthesis > phrase/hyphens > (NOT)

BEFORE/AFTER/NEAR/NEXT > NOT > AND/OR/XOR/EOR. Terms with same priority but without

parenthesis are evaluated from left to right.

EXAMPLES

By using any or all of the operators and rules laid out above you can create complex queries that

find the exact information you're looking for. Here are some example queries that show how the

operators are used.

Example: Devonian Dinosaurs

This query looks for all documents that contain the words "devonian" and "dinosaurs".

Example: (Steve NEAR Jobs) AND iMac BUT NOT MacBook OPT Pro

This query looks for documents that contain the words "Steve" and "Jobs" no farther ten words

away from each other, as well as the word "iMac" (no specific position relative to Steve and Jobs),

but not the word "MacBook". The word "Pro" does not need to occur, but if it does, the document

is ranked higher in the list of search results.

Example: Paracetamol NEAR (~effect OR impact) AND ((side OR second*) NEAR/2

~effect)

This query looks for documents containing the word "Paracetamol" near (within 10 words) to

words either starting with "effect" (and so also "effects") or "impact". In addition, the document

needs to contain the word "side" or any word starting with "second" located within two words

range of any word starting with "effect".

SEARCH PREFIXES

DEVONthink supports a wide variety of

searchable attributes. These include common

attributes, like names or tags, but also

include document or DEVONthink-specific

items, like word counts or custom metadata

you've defined.
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Similar to searching with Spotlight or some

other applications, the use of search prefixes

is not only supported, but encouraged.

These take the form of a prefix and a prefix

operator, e.g., name:, followed by the search

term.

SEARCH PREFIXES

These prefixes are automatically applied

when you choose criteria in the advanced

search editor but they can also be manually

entered in the search field. In the following

list, we show the human-readable names

you'd see in the criteria editor. In parentheses

are the corresponding raw query values you'd

type in a toolbar search or use in scripting.

Content: Text contents in a file. (text)

Metadata: The metadata for a file.

(metadata)

Name: The name of an item. For

documents, this is distinct from the

filename and does not include the file

extension. (name)

URL: The associated URL. (url)

Finder Comment: Spotlight Comments.

(comment)

Author: The name of the sender of an

email. (author)

From: The email address of the sender of

an email. (docAuthorEmailAddresses)

Recipient: The name of a recipient of an

email. (docRecipients)

To: The email address of a recipient of an

email. (docRecipientEmailAddresses)

Title: The title of a file. The title may be

distinct from its name, e.g., a song title for

an MP3 file. (docTitle)

Comment: The RTF-specific comments for

a file. (docComment)

Headline: A headline applied to some files.

Rare. (docHeadline)

Subject: The subject line from an email.

(docSubject)

Description: The description found

on some files, typically images.

(docDescription)

Keywords: The PDF or RTF specific

keywords for a file. (docKeywords)

Organization: The company specified in

imported links or vCards from the Contacts

application. (docOrganization)

Copyright: Copyright information in the

metadata of a file. (docCopyright)

Album: The album information from media

metadata, e.g., MP3 files. (docAlbum)

Composer: The composer information

from media metadata, e.g., MP3 files.

(docComposer)

Creator: The process or application used to

create a file. (docCreator)

Producer: The producer of a file, usually

applied to media files. (docProducer)

Aliases: Aliases applied to an item.

(aliases)

Tags: Tags applied to an item. (tags)

Label: The color label of an item, from 0 (no

label) though 7 or by name, e.g., Important.

(label)

Rating: The star rating of an item, from 0

(unrated) through 5. (rating)

Width: The width of a document in points,

i.e., the width multiplied by 72. (width)

height: The height of a document in points,

i.e., the height multiplied by 72. (height)

length: The number of pages in a file or

length of a media file in seconds. (length)
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size: The size of an item in bytes, KB, MB, or

GB, e.g., size >= 50 MB. (size)

wordcount: The number of words in the

contents of a file. (wordcount)

charactercount: The number of characters

in the contents of a file. (charactercount)

hits: The number of times a file has been

viewed or opened. (hits)

filename: The name of the file in the

file system, including the file extension.

(filename)

extension: The extension of a file, e.g., txt.

This also supports an Any Extension option

to filter filenames having or lacking an

extension. (extension)

kind: Supports any, group, smartgroup,

tag, ordinarytag, grouptag, text,

rtf, formattednote, markdown, html,

webarchive, xmlfile, propertylist,

image, pdf for all PDF documents, pdf

+text matching PDF documents with

a text layer, quicktime, video, audio,

bookmark, feed, news, script, sheet,

email, and other. (kind)

Item prefixes: These special prefixes are

for state-based queries, like if items are

replicants or contains aliases. They all follow

the form of item:<specified state>, e.g.,

item:locked.

You can specify the state of items, i.e., is or is

not. The available options are as follows:

Replicated: Matches items that are

replicants. (replicated)

Duplicated: Matches items that are

duplicates. (duplicated)

Indexed: Matches items that are indexed,

not imported. (indexed)

Pending: Matches items whose contents

aren't downloaded and available. (pending)

Tagged: Matches items with tags applied.

(tagged)

The other option is specifying whether items

do or don't contain a certain property. For

example, you can search for items containing

aliases and the item:<specified state>

syntax is also used. This includes the negated

form. Here are the searchable properties:

Aliases: Matches items with aliases.

(aliased)

Annotation: Matches items with an

associated annotation file. (annotated)

Comment: Matches items with a Finder

comment. (commented)

Data: Matches items with child items,

e.g., a group with items contains data. An

empty group can be found via item!:data,

meaning the item does not contain data.

(data)

Metadata: Matches items with metadata.

(metadata)

Reminder: Matches items with a due date

set. (reminded)

Script: Matches items with a script applied

in the Info inspector. (scripted)

Thumbnail: Matches items with a

thumbnail applied. (thumbnail)

URL: Matches items with a URL set in the

Info inspector. (url)

Marked: Item states shown in the Flag

column in the item list, e.g., locked, can

be searched for. When choosing criteria

in the Advanced options of the toolbar

search, choose the Marked criterion. If

using a raw query string, the search prefix is
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item:<specified state> and it's negated

form, item!:<specified state>. Here are

the marking options available:

Flag: The flag state of an item. Supports

flagged or unflagged.

Unread: The unread state of an item.

Supports read or unread.

Locking: The locking state of an item.

Supports locked or unlocked.

Dates: Dates are a very commonly used

property in searches, for example, if you're

looking for a document you created two days

ago. Here are the date-based properties you

can search for. See the Date Operators in the

next section for the syntax you can use with

these.

added: The date the item was added to the

database. (added or additionDate)

Date Created: The date the item was

created. (created or creationDate)

modified: The date the item

was last modified. (modified or

modificationDate)

opened: The date the item was last

opened. (opened or openingDate)

due: The due date set in a Reminder for an

item. (due or dueDate)

Miscellaneous Properties: There are also

more esoteric attributes you can search for,

like the number of attachments in emails, or

the detected language of a document.

Original Name: The original name of

a renamed document, before it was

renamed. (md_originalname)

Attachments: The number of attachments

in an email or the number of resources

added to an RTFD file. (md_attachments)

Annotations: The number of annotations

set in a PDF file. (md_annotationcount)

Encryption: The encrypted state of a PDF.

This is a Boolean value denoted numerically,

e.g., md_encrypted==1 when a file is

encrypted. (md_encrypted)

Incoming Item Links: The number

of item links to a document from

other documents in DEVONthink.

(md_incomingItemLinkCount)

Outgoing Item Links: The number of item

links to other documents present in a

document. (md_outgoingItemLinkCounts)

Language: An abbreviation of the detected

language in the contents of a file. For

a list of values, select a language in the

criteria and note the abbreviation to use.

(md_language)

Country: An abbreviation of the country in

the geolocation data for a file. For a list of

values, select a country in the criteria and

note the abbreviation to use. (md_country)

Postal Code: The postal code detected

in the geolocation data for a file.

(md_zipcode)

Administrative Area: The state, province, or

region detected in the geolocation data for

a file. (md_area)

Locality: The city detected in the

geolocation data for a file. (md_locality)

Custom Metadata: Any custom metadata

attributes defined in the Data settings are

also available as search prefixes. The search

prefix you will type is a concatenated form

of the attribute's name, prefixed with md. For

example, an attribute of Total Cost would

have a search prefix of mdtotalcost.

There are also two special prefixes you can

use:
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scope: This limits where you are searching.

It supports selection (the current group

or database), referring to a database by

name (in quotes), and inboxes. If no scope

is specified, the search applies to all open

databases. When used, scope: should be

the last parameter in the query.

any: When used, this allows you to specify

whether to return results matching any of

the criteria. This can only be used when

specifying more than one search prefix,

e.g., tags and filename.

Example:

added>=2019-03-10 scope:selection

tags:sync; methods scope:"Tech

Stuff"

any: name:test OR imprint {any:

tags:blue; red}

Sub-criteria searches: Yes, you may have

noticed in the last example a tags search in

curly braces. This creates sub-criteria for the

search. This obviously extends the search

options to allow creating even more complex

forms.

PREFIX OPERATORS

Many times prefixes end with a colon, e.g.,

tags: but some use other forms, depending

on the available options in the criterion.

For example, words can "begin with" some

characters, but a size is greater or less than a

value. If you select a criterion you would see

what options apply. Use the keys below to

map the option to its operator.

Matches, Is, Is Not:

: is equal to the term matches. With strings-

based queries, it allows for wildcards to

be used. It is also used for state-based

queries, like Kind. The negated form, :! is also

supported.

== is equal to the term is. This must be an

exact match of the search term. These can

be used in strings and number-based queries.

The negated form, != is also supported.

Example:

Kind is Group → kind:group

Item is indexed → item:indexed

Item is not Replicated → item:!

replicated

Extension is XML Document →

extension==XML

Language is not English → language!=en

String Matching: These are operators that are

used with string-based queries, like names or

text content. These queries also support:

:< is equal to begins with.

:> is equal to ends with.

:~ is equal to contains. (The tilde is the

second key down on the top left of an English

keyboard.)

Example:

Subject begins with party →

docSubject:<party

Locality ends with field →

md_locality:>field

Name contains tech → name:~tech

Number Matching: In addition to the == and

!= operators, numbers can also use these

operators:
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< is equal to is less than and <= is is less than

or equal to.

> is equal to is greater than and >= is is

greater than or equal to.

Example:

Word Count is less than 1000 →

wordcount<1000

Size is greater than 10MB → size>10 MB

Hits is greater than or equal to 1 → hits>=1

Range Matches: For certain numerical

attributes, you can use a range matching

syntax, attribute:lowerLimit-

upperLimit. For example,

wordcount:500-1000 matches files with

between 500 and 1000 words. This is

identical to the longer form syntax of

wordcount>=500 wordcount<=1000.

Range matches can be used with: width,

height, duration, length, hits, wordcount,

charactercount, and size prefixes.

Date Operators: These are operators used

with date-based queries, like the creation

date of files.

< is equal to before and <= is before or on.

> is equal to later and >= is later or on.

:# is equal to within last and :!# is not within

last. These searches default to days, but you

can also use weeks, months, or years, e.g.,

modified:!#1weeks. Note you always use the

plural form of the time component.

For dates-based queries, : is equal to is and

:! equals is not.

For greater compatibility, some other

combinations of operators are allowed.

due:<=2020-01-03 is equivalent to

due<=2020-01-03.

Named Relative Dates: You can use these

terms for relative dates: Today, Yesterday,

This Week, Last Week, This Month, Last

Month, This Quarter, Last Quarter, This Year,

and Last Year. Use these with is, before (or

on), and after (or on) operators.

Example:

Date Created is after January 31, 2019 →

created:>=2019-01-31

Date opened is not within last 5 days →

openingDate:!#5days

Date Due is not Today → due:!Today

Date searching allows for some flexibility in

formats. Time is not a required parameter,

but can be specified. These searches are all

equivalent:

Example:

added>10 march, 2019

added>March 10, 19

added>2019-03-10 08:30:00 -0500

PLACEHOLDERS

One of the most powerful features of

DEVONthink is the ability to insert data

dynamically. A placeholder is a bit of code

DEVONthink interprets when used in these

scenarios, replacing it with a specific value.

You may have an imprint with a Name

placeholder defined in the title. When the

imprint is used on a PDF, the placeholder is

converted to the name of the file!
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To extend the possibilities even further,

you can combine static text and multiple

placeholders to achieve truly custom results.

You can use these in a variety of ways: smart

rules and batch processing, Reminder alarms,

custom imprints on images and PDFs, in

WikiLink templates, and more.

Below is a list of placeholders currently

available. Following each description is the

raw placeholder that can be used when

creating templates in external applications

or using the import template AppleScript

command:

Note: Please be aware not all placeholders

can be used in all situations. For example,

you can't use the Location placeholder in

a document template as the document

doesn't have a location until after it's

created. Testing is strongly encouraged.

Generic Info:

Name: The name or title of the document.

(%recordName%)

Proposed Name: A suggested name derived

from a document's title or from the first

line of the document if no title is present.

(%recordProposedName%)

Name Without Date: Returns the filename

after parsing out any detected dates.

(%recordNameWithoutDate%)

Aliases: Any aliases applied to the

document. (%recordAliases%)

Finder Comment: Any Finder

comments applied to the document.

(%recordComment%)

File Name: The filename in the file system.

(%recordFilename%)

File Extension: The extension

of the document's filename.

(%recordPathExtension%)

Kind: The kind of the file, e.g., group or rich

text document. (%recordKind%)

URL: The URL in the Info pane.

(%recordURL%)

Item Link: The unique URL of the

document. (%recordLink%)

Location: The location in the database; e.g.,

/Inbox/Research. (%recordLocation%)

Tags: Tags applied to the document.

(%recordTags%)

#Tags: Tags applied to the document but

returned as hashtags. (%recordHashTags%)

Counters:

Index: An incrementing number relative to

the number of items being processed, e.g.,

by a smart rule or imprint. (%recordIndex

%)

Counter: Similar to the Index, this number

is zero-padded. (%recordCounter%)

Bates Number: Inserts a Bates number.

(%recordBatesNumber%)

Page Count: The total number of pages in

the document. (%recordPageCount%)

Item Locations:

Group Name: The name of the group

containing the document, e.g., /001/a/b/

myfile.txt would report b as the group

name. (%groupName%)

Top Group Name: The name of the top level

group in the root of the database, e.g.,

/001/a/b/myfile.txt would report 001 as

the top group name. (%topGroupName%)
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Database Name: The name of the database

containing the document. (%databaseName

%)

Database Path: The filesystem path of the

database. (%databasePath%)

Document Attributes:

Original Name: The persistent original

name of a renamed document. Typically

used in revision-proof databases.

(%record_originalname%)

Attachments: The number of attachments

in a document, e.g., a rich text document or

email. (%record_attachments%)

PDF Annotations: The number of

annotations in the active document.

(%record_annotationcount%)

Incoming Item Links: The number

of documents containing item

links to the active document.

(%record_incomingItemLinkCount%)

Outgoing Item Links: The

number of documents linked

to in the active document.

(%record_outgoingItemLinkCount%)

Geographic Info:

Language: An abbreviation of language

detected in the document's indexed

contents. (%record_language%)

Country: The country in the geolocation

data for a document. (%record_country%)

Postal Code: The postal code derived from

the geolocation data for a document.

(%record_zipcode%)

Administrative Area: This is state, province,

or region in the geolocation data for a

document. (%record_area%)

Locality: The city in the geolocation data

for a document. (%record_locality%)

Formatting:

Tab: A tab character. (%tab%)

Line Break: A line break (return) character

for multi-line text. (%newline%)

Detected Values: The following placeholders

get their values from the name or content

of a matched document. For example, the

Document String is the result of a Scan Name

or Scan Text smart action.

Document Amount: This is an monetary

amount detected in the name or content

of documents, typically receipts or

invoices. (%documentAmount%)

Document String: This is a string detected

in the name or content of documents.

(%documentString%)

Digital Object Identifier: The unique digital

object identifier of the active document, if

available. (%digitalObjectIdentifier%)

International Standard Book

Number (ISBN): The detected

ISBN number of a document.

(%internationalStandardBookNumber%)

Date Placeholders: There are several types

of date-specific placeholders to choose

from. You can choose from several built-

in formats, e.g., the short date, or create

your own with individual date component

placeholders. Due to the repetition of date

placeholders, the raw value of every individual

placeholder isn't listed here. However, below

are the date component raw values. Note

some formats will appear relative to your

geographic location, e.g., Jan 1, 2001 for

the medium date would be common in the

US.
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Calendar Components:

01/01/2001: The short date format.

(%shortDate%)

Jan 1, 2001: The medium date format.

(%date%).

2001/01/01: The ISO date format.

(%sortableDate%)

Saturday, Jan 1, 2001: The long date

format. (%longDate%)

01: The zero-padded number of the date.

(%day%)

Saturday: The name of the day. (%weekday

%)

01: The zero-padded number of the month.

(%month%)

January: The name of the month.

(%monthname%)

2001: The full year. (%year%)

01: The short year. (%shortYear%)

Time Components:

Time: The current time shown in 12 or 24

hour format, depending on your system

settings, e.g., 11:59:59 AM. (%time%)

Hour: The hour of the time. (%hour%)

Minute: The minutes of the time. (%minute

%)

Second: The seconds of the time. (%second

%)

Listed below are the supported date

types with their raw prefix provided. The

placeholders in the previous list relate to

the current date, so entering (%month%)

would give you the current month. To use

other kinds of dates, e.g., Newest Document

Date, use the raw value, then add the date

component from the list above with the

first letter capitalized. For example, getting

the month of the newest document date

would be: %newestDocumentDate% and month

yielding newestDocumentDateMonth.

Current Date: Today's date. There is no

prefix to the raw placeholders for current

date.

Addition Date: The date the item added to

the database. recordAddition…

Creation Date: The date the item was

created. recordCreation…

Modification Date: The date the items was

last modified. recordModification…

Date: This is a date detected in the

document's contents, e.g., in a receipt. For

PDFs only the first four pages are used.

documentDate…

Newest/Oldest Document Date: The

newest or oldest date detected in the

document. For PDFs, only the first four

pages are used. newestDocumentDate… and

oldestDocumentDate…

On a side note, you can string together

multiple date and time component

placeholders, e.g., to create a Zettelkasten

timestamp string like 20010101115959.

Clipboard:

Clipboard: Inserts plain text content from

the clipboard. (%clipboard%)

Clipboard Styled: Inserts rich text content

from the clipboard. (%styledClipboard%)

Clipboard Link: Inserts a link from

rich text content on the clipboard.

(%clipboardLink%)
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Computer Properties:

Predefined Author: The Author specified in

DEVONthink's settings. (%author%)

Username: The shortname of the current

macOS account. (%username%)

Full Username: The longname of the

current macOS account. (%fullUsername

%)

Organization: The company name, if

defined by the (Me) contact card in macOS

Contacts. (%organization%)

Email Address: The primary email address,

as defined by the (Me) contact card in

macOS Contacts. (%emailAddress%)

Host: The hostname of the machine.

(%host%)

Properties: Some files have specific

properties, e.g., the author of an email.

These are displayed in the Info > Properties

inspector. Here are the supported properties

and their placeholders, including the raw

value.

Author: The name of the sender of an

email. (%kMDItemAuthors%)

From: The email address

of the sender of an email.

(%kMDItemAuthorEmailAddresses%)

Recipient: The name of a recipient of an

email. (%kMDItemRecipients%)

To: The email address of

a recipient of an email.

(%kMDItemRecipientEmailAddresses%)

Title: The title of a file. The title may be

distinct from its name, e.g., a song title for

an MP3 file. (%kMDItemTitle%)

Comment: The RTF-specific comments for

a file. (%kMDItemComment%)

Headline: A headline applied to some files.

Rare. (%kMDItemHeadline%)

Subject: The subject line from an email.

(%kMDItemSubject%)

Description: The description found

on some files, typically images.

(%kMDItemDescription%)

Keywords: Keywords typically

applied to PDF, rich text, or images.

(%kMDItemKeywords%)

Organization: The company specified in

imported links or vCards from the Contacts

application. (%kMDItemOrganizations%)

Copyright: Copyright information in the

metadata of a file. (%kMDItemCopyright%)

Album: The album information from media

metadata, e.g., MP3 files. (%kMDItemAlbum

%)

Composer: The composer information

from media metadata, e.g., MP3 files.

(%kMDItemComposer%)

Creator: The process or application used to

create a file. (%kMDItemCreator%)

Producer: The producer of a file, usually

applied to media files. (%kMDItemProducer

%)

E-mail: Email addresses detected in a

document. (%kMDItemEmailAddresses%)

Contributor: People or organizations

who contributed to the document.

(%kMDItemContributors%)

Publisher: The organization who published

the document. (%kMDItemPublishers%)

Editor: People or organizations involved in

editing a document. (%kMDItemEditors%)

Custom Metadata: This menu lists any

custom metadata attributes you've defined

in the Data settings. In order to use raw

placeholders, add the md prefix to the
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identifier of the custom attribute shown

in the settings. For example, mddoi for the

Digital Object Identifier attribute.

SMART ACTION PLACEHOLDERS

These placeholders are used for automation

in smart rules and batch processing.

User Input: The response returned from a

User Input smart action.

Script Output: The output from the Script

with Input/Output smart action. This

placeholder is always a string, even if e.g.,

the script returned an integer.

Chat Suggestions: These placeholders are

specific to smart actions so are only available

in smart rules and batch processing. The

values for the placeholders come from

your AI provider. The AI engine will examine

a document and return the value for the

placeholder, e.g., the amount on a receipt.

Many of these are described above: Title,

Filename, Tags, Rating, Authors, Company,

Address, Geolocation, and Date. However,

there are some specific placeholders for AI:

Amount: This may be a monetary value

similar to the price but could also be

quantities, e.g., from a shipping manifest.

Price: The monetary value on a document.

Query Response: Uses the reponse

returned from a Chat - Query smart action.

Suggested Date: Uses an AI-derived date

from the contents of the document.

Summary: Returns a summary of the

current document.

TEMPLATES

Below are listed the pre-installed templates that come with DEVONthink. You are free to inspect

or modify these templates to suit your needs, but we do recommend making a duplicate to

preserve the original.

More templates are available by selecting Data > New from Template > More Templates, the Help >

Support Assistant, or via the Extras sidebar.

Note: Some of the included templates are just simple files. Others are smart templates,

packages that contain assets and scripts that provide powerful template generation. See the

Automation chapter for more information on them.

Accounts & Passwords:

Email Accounts: Adds a sheet to record technical details of an email account details.

Online Account: Adds a sheet for storing website account details.

Serial Number: Adds a sheet for storing product serial numbers.
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AI TEMPLATES

The templates in this category all utilize AI models to return results, create documents or

images, etc. The availability and quality of output is governed by the choices and services set in

DEVONthink's AI settings.

Document Assistant — Markdown/Text: Generate a Markdown or rich text document based on

a prompt regarding selected documents.

Meeting Notes – Markdown/Text:

Mixture-of-Agents – Images: Creates images with multiple generative image engines you have

API access to. Bear in mind, this may incur extra costs, depending on the provider you're using.

Mixture-of-Agents – Markdown/Text: Sends a prompt to multiple AI engines for which you

have access, e.g., ChatGPT and Gemini. The resulting document will be Markdown or rich text,

with the individual LLMs response and a summary of all the responses.

Research Report - HTML/PDF: Utilizes deep research and thinking on the topic you enter and

creates a nicely formatted document with an overview of it. Currently only supports ChatGPT,

Claude, Mistral, or Gemini and the appropriate model is automatically selected.

Short Story — Illustration: Generates an image using the contents of a selected file, bookmark,

PDF document, or video as the prompt.

Short Story — Markdown/Text: Creates a story outline in Markdown or rich text based on a

selected document. It includes some basic character development, themes, and other details.

The Devonian Times: Creates a "newspaper" page summarizing some of the top new stories in

the world. This serves as a good example of web searching and AI-controlled formatting.

Classifications:

Decimal Filing System: Adds ten groups for the decimal filing system used by many European

companies for filing (scanned) paper documents.

Dewey Decimal Classification: Inserts a group with sub-groups that builds the first levels of the

Dewey Decimal Classification. Use this feature for databases that contain knowledge spanning

many subjects.

Library of Congress Classification: Inserts a group with sub-groups that builds the first

levels of the Library of Congress Classification. Use this feature for databases that contain

knowledge spanning many subjects.

Education:

Cornell Notes – Markdown/Text: Adds a topic-centric document for writing Cornell notes.

Available as Markdown or rich text documents.

Cornell Notes (Education) – Markdown/Text: Adds a course-specific document for writing

Cornell notes. Available as Markdown or rich text documents.

Lab Notes – Markdown/Text: Adds a lab report document including standard scientific method

sections. Available as Markdown or rich text documents.
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References: Adds an empty sheet for recording citation information such a DOI, authors,

journal, publication year, etc.

Reference (from Bookends): Adds selected references in Bookends as rich text.

Reference (from Endnote): Adds selected references in Endnote as rich text. Note: Endnote

should be in the same Space as DEVONthink.

Quotes: Adds a sheet for recording quotes along with the author, source, comments, etc.

Quote (from clipboard): Adds a rich text document for a quotation or citation. The clipboard

content is automatically inserted and, if it's an Internet address (URL), it is automatically made

clickable.

Articles: Adds a sheet for keeping track of articles.

Booklets: Adds a sheet for keeping track of booklets.

Books: Adds a sheet for keeping track of books.

Manuals: Adds a sheet for keeping track of manuals.

Proceedings: Adds a sheet for keeping track of proceedings.

Technical Reports: Adds a sheet for keeping track of technical reports.

Theses: Adds a sheet for keeping track of theses.

PubMed – Markdown/Text: Runs a query in PubMed and imports up to 100 abstracts

formatted as rich text or Markdown documents.

Productivity:

Daily Journal – Markdown/Text: Adds Journal group with month and day subgroups, containing

a file with a daily quote, some news headlines, and space to write your thoughts. Available in

Markdown or rich text. This template is a good example of smart templates.

Note: Adds a new note. If the clipboard contains text, it is automatically inserted.

Phone Note: Adds a new phone note, automatically inserting the current date and time.

Project: Adds a simple project group structure including an "About this project" document. The

smart template asks for a project name; retrieves your name, department, email address, and

phone number from your contact card; and adds this information to the "About this project"

document.

Task List: Adds a simple task list.

Weekly Review: Adds a formatted note displaying checklist items and space to review the

week.

Registers:

1—31: Adds 31 groups, numbered 1 through 31.

A—Z: Adds 26 groups, named A through Z.

Days of the Week: Adds groups for the days of the week.

Months: Adds groups for the twelve Christian months.
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Smart Groups: These templates create smart groups, not individual documents. Note these are

local smart groups so they only search in the database in which they're located.

Email: Displays any email.

Email with Attachments: Displays emails with attachments.

Images – Large/Small: Displays images based on their pixel dimensions. Large images are 1280

x 960 or larger, Small images are smaller on these dimensions.

Images/Music/Videos: Displays any media file.

Due or Flagged: Display flagged items or items with a due date this week.

Last Month/Week/Year: Displays documents modified within a given period.

Documents with Annotations: Adds a smart group displaying files with annotations, e.g.,

highlights.

Large Documents: Add a smart group displaying documents larger than 5 MB.

PDF (not searchable): Add a smart group displaying all PDF documents that don't contain

machine-readable text.

Star Ratings (1-5): Add a smart group displaying items with a rating of one or five stars.

Toolbar: By default this contains no templates. Add your own templates to ~/Library/

Application Support/DEVONthink 3/Templates.noindex/Toolbar. These can be added to

the DEVONthink windows using View > Customize Toolbar.

Read more about using and creating templates in the Documents chapter…

MARKDOWN EXPLORED

Markdown is a fairly simple "language" to

learn. For many people, just typing and

using a handful of control characters will be

sufficient. However, it has become a very

feature-rich format supporting things like

outlines, images, tables, linking, etc., perhaps

even some things surprising to you.

Over time multiple "flavors" of Markdown

have been introduced. DEVONthink

Markdown utilizes standard Markdown but

also supports features from some other

flavors: MultiMarkdown, CommonMark,

CriticMarkup, and GitHub Flavored Markdown

(GFM). Here you can read about many

possible features, but also realize it's not

exhaustive. There many be extra features

for an element, but we'll leave the deeper

investigation to you!

Basic formatting: Get started by simply

typing, creating paragraphs. These will

usually be your most common element.

But as you write, you may want to add

some emphasis to certain content. To add

formatting, surround the content with

control characters showing the Markdown

parser the words should be rendered with

specific formatting. Here are the three most

common styles you'll use:

Italic: *italic*.

Bold: **bold**.

Bold-Italic: ***bold-italic***.
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With these basics, you can quickly capture

ideas or write longer-form content in plain

text, but with some extra flair. However, the

possibilities only increase from here.

Extended Formatting and Elements:

Often used in academic or professional

writing, some specialized formatting is

also supported. The first two are standard

Markdown; the remainder are CriticMarkup.

Subscript: ~subscript~.

Superscript: ^superscript^.

Highlight: {==highlight==}.

Underscore: {++underscore++}.

Strikethrough: {--strikethrough--}.

Addition: {++text to add++}

Deletion: {--text to delete--}

Substitution: {~~replace this~> with

this~~}

Comment: {>>comment<<}

Lists: Whether for an outline, shopping list,

taxonomies, or record your top ten movies,

creating lists is easily done. These are the

supported types:

Ordered (Numbered) List: 1.

Manufacturers

Unordered (Bulleted) List: * Monday or -

Plan.

To Do List: -[ ] Call insurance

company. Remember to leave a space

between the square brackets. To mark an

item as complete, put an x between them.

As you type each line item, pressing the

↩ Return key will add a new line item ready

to enter the next one. Press the key twice to

close the list. Lists can be indented to create

nested lists by pressing the ⇥ Tab key or

adding one space per-level at the beginning

of a line. To outdent a list, remove spaces

from the line's beginning.

Tables: Creating tables is supported, even

building them in a semi-visual manner. The

cells of the table are separated by the pipe

| character. (A pipe at the beginning and

end is optional.) The top of a table is defined

the header line: the number of columns

denoted by pipes, usually with column

header names, e.g., Name|Location||Age.

The next line is the column alignment line:

three hyphens, again separated by a pipe,

like :---|:---|---|:---:. The colons :

control if the cell content is left, right, or

center justified. Then you enter each row's

cell's content, e.g., Jason|Marana|AZ|48,

on separate lines. You can also include an

optional table caption in square brackets

immediately before or after the table, like

[Friends and Family].

Example:

Movie | Year | First Week Box Office

:--|:--:|:--:

Star Wars: A New Hope | 1977 | $1,554,475

The Empire Strikes Back | 1980 |

$6,400,000

Return of the Jedi | 1983 | $45,311,004

Sections: As your content becomes more

complex, you may want to split the content

into sections. Create a section by typing

# followed by a space and the title of the

section, e.g., # Milky Way. This creates an

"h1" heading. Sections up to six levels deep

are made by using the requisite number of

hashtag symbols. So your first subsection

would be ## Planets, creating an "h2"

heading. You can use these headers to

navigate the document in the Table of
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Contents inspector. Additionally, you can

include a table of contents in the document

by entering {{TOC}} where you want it to

appear. You'll also find more information in

the Cross-Reference Linking section below.

Everyday Extras: Here are a few more

common elements you may find useful in your

writing:

Horizontal Rules: Add a separator line by

typing three dashes or asterisks on a line:

***.

Blockquote: Enter attributed quotes

by preceding each line in the quote

with a greater than symbol: >I think,

therefore I am.. You can also nest

blockquotes with multiple > symbols.

Code block: Insert inline code in a

sentence: `code terms`. Note: Those are

backticks, found on the tilde (~) key.

Fenced code block: Create separate blocks

of code: ``` - triple backticks on a line

above and below the code. For syntax

coloring of code, see the Prism.js extension

described in the Markdown Extensions

section below.

Emoji: For a little extra personality, you can

type Slack-style emoji, like :grinning:,

directly in a Markdown document.

ADVANCED MARKDOWN

DEVONthink Markdown also supports some

"advanced" features found in some other

Markdown flavors. From academia to design

to business uses and more, these give you

some specialized tools to work with.

Footnotes: Footnotes are supported in our

parser and automatically insert a numbered

footnote link in the text. These are two of the

supported footnote styles:

Reference: Uses a label, [^label], pointing

to a particular footnote matching the same

label, [^label]: Footnote text, typically

added at the bottom of the document.

Inline: The footnote text is used as the

label, automatically creating a numbered

footnote, e.g., [^The tax authority

responded on the 15th.], and adding

the footnote link in the text.

Callouts: A feature found in GitHub Flavored

Markdown, a callout or admonition is a

specially styled blockquote element to call

attention to some text, e.g., a tip or warning.

The syntax is >[!Type]Optional Title

followed by the message, preceded by the

greater than symbol. The supported types

are: INFO, NOTE, TIP, IMPORTANT, CAUTION,

WARNING, DANGER, QUESTION, EXAMPLE, QUOTE,

SUCCESS, FAILURE, and BUG. The callout's text

can contain rich content, like formatting,

links, lists, etc.

Callouts can be collapsible and have an initial

state when the document is viewed., opened

or closed. After the closing square bracket,

include a plus + for open or a minus - for

closed, e.g., >[!INFO]-What is subzero?.

The MkDocs and Python-Markdown callout

syntax is also supported.

Abbreviations: Abbreviations are content

appearing in tooltips when you hover

over words with definitions. To define the

abbreviation text, use the syntax: *[Word]:

tooltip text. Create the abbreviation
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*[NASA]: National Aeronautics and

Space Administration and the full title

will appear when you hover over NASA in the

preview.

Note: Abbreviations, footnotes,

bibliographic entries, etc. can be defined

anywhere in the document but they're

most commonly put at the bottom of the

document.

Metadata: DEVONthink Markdown supports

MultiMarkdown-style metadata headers

as well as YAML/frontmatter. With it you

can add non-displaying information about

the document, like authors, dates, and even

linked stylesheets as metadata.

To use the feature, format the first line of

the document with a colon, e.g., Author:

DEVONtechnologies. Add as many metadata

fields as you wish but they must be in a block

at the top of the document. Pre-defined

fields in the Info > Properties inspector

can be populated with this metadata, e.g.,

keywords: support,markdown. If you're not

using metadata and want the first line of your

document to contain a colon, add a single

blank line at the top of the document and the

subsequent lines will be treated as normal

paragraphs.

Metadata can also be used as variables in

the content of the document by entering

the attribute's name prefixed with a percent

sign, inside square brackets. So if you enter

product: widget-002 in the metadata, you

would type [%product] in the text and it will

render as widget-002 in the preview.

MARKDOWN EXTENSIONS

DEVONthink supports some Markdown

extensions to provide a few specialized

features in the output. These can be toggled

in the Files > Markdown > Extensions settings.

MathJax: Markdown is often used

in academic situations, many using

mathematical equations in their writing.

DEVONthink supports the Mathjax extension

that will beautifully render coded equations.

Inline Math: Surround the equation with

single dollar signs, e.g., $E = mc^2$. The

alternate \(…\) syntax can be used.

Display Math: Begin and end the equation

with lines containing double dollar signs.

The alternate, \[ and \] syntax can be

used.

MathML: Raw MathML elements can

be added to the document, both

inline and display: What if <math

xmlns=“http://www.w3.org/1998/Math/

MathML”><mi>A</mi><mo>≠</mo><mi>B</

mi></math> ?

Note: If you need to include a rendered

dollar sign, escape it: \$.

Mermaid: Diagrams can be created in

Markdown documents using the Mermaid

extension. Add a line of three backticks as

shown```mermaid. Add the diagram code as

needed and close the diagram with another

line of three backticks. There are several

diagram types available and the syntax is

discussed on their website.

Prism: For those writing code in their

Markdown, DEVONthink supports Lea Verou's

Prism extension. Just add a line of three

backticks ```language- and the language
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you're using, for example, ```language-

applescript. Remember to add a line of

three backticks under the code to close it.

This displays syntax highlighting of code

blocks in the rendered output.

Note: Not all languages supported by Prism

are available. Additional languages may

be added in the future if there's sufficient

interest in them.

LINKING

Document linking is an important feature

for a wide range of purposes, e.g., linking

Zettelkasten documents, building a custom

bookmarks page, or adding some images

to brighten up a page. Markdown has rich

support for linking a variety of link types.

*External Links* Links to external items,

e.g., web pages and documents, are very

commonly used in Markdown. The basic forms

are:

Web: Link to a web page: [link text]

(URL) creates a hyperlink from the link

text. Use <URL> to display the full URL

Document: Link to another document

via hyperlinked text:  [document title]

(link).

Image: Link to an image: ![alt text]

(URL). Note you can set a default link type

for images in the Files > Markdown > Image

Reference popup.

URL Schemes: Add application-specific

URLs, even DEVONthink's item links. As

an example, you could add a [Jenny]

(facetime://867-555-5309) URL that

launches a FaceTime call.

Note: Be aware, the URL must be URL-

encoded, e.g., spaces are represented with

%20.

Document links will either show a filename,

with or without a path, or an item link.

Depending on where the linked document is

located or how it was created, e.g., pasting an

item link.

Sibling Link: Links to an item in the same

group as the Markdown document: !

[link](item.png).

Relative Downward Link: Links to an item

in a sub-group of the group containing the

Markdown document: ![link](group/

item.png). Upward links are not possible

as a document may have multiple parents.

Absolute Link: Links to an item outside

the Markdown document's parent group: !

[link](/group/item). For example, if you

have common resources in a specific group,

you can link to them using this format, e.g.,

![Logo](/Inbox/Company Resources/

logo.png).

Item Link: Links to a specific item by its

UUID, not requiring a location:  [link

text](x-devonthink-item://…)

While it's good for you to know and

understand the link syntax, DEVONthink has

ways to make linking easy and more efficient.

See the Documents > Markdown documents

section for information on linking.

Cross-Reference Linking: If you are using

sections in your Markdown, you can create

links to jump to those sections. Assume we

have a document with sections:
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Link via name: [Notes][] uses the

section's name to jump to the section.

Link with text: [some ideas][Notes]

hyperlinks text to a section, e.g., "some

ideas" to the "Notes" section.

Link with custom ID: Define a heading

with a custom ID in braces, preceded by

a hashtag symbol, # Notes {#lab-01}.

Spaces are invalid in the ID. You then

reference the section via a link like

[findings][lab-01]. This can be useful if

you have redundant section headings in a

document.

Citations and Bibliographies: For academic

writing, support for citations and

bibliographic references is built-in. When you

first create a citation element, a References

section will appear at the bottom of the

preview and clicking the citation jumps to

that section.

To insert a citation link, in square brackets

enter an ampersand @ (Pandoc) or a

hashtag #, immediately followed by an

abbreviation: [@dt42026,p42]. Now define

the bibliographic entry with the link and text,

e.g., [#dt42026]: DEVONtech *DEVONthink

4 Manual*(2026), noting you use a hashtag

for the definition. If you need to include

multiple citations, add see and encompass

them all in the square brackets, e.g., [see

@dt42026;cf. @west2017].

STYLING

There is a default style built into DEVONthink

and it's usually good for quick and easy

composition. If you want to make some

changes, adjust margins, line width and

spacing, and choose a specific Markdown font

via the Editing > Format settings.

More complex styling is done with CSS

(Cascading Style Sheets), using either

internal styling or externally referenced

stylesheets. If you have a specific stylesheet

you'd like to use globally, you can specify

one in the Files > Markdown > Style Sheet

settings. This will apply the style to all your

Markdown documents. If you're creating

documents for different purposes or building

a style you like, here are options for in-

document styling:

Internal styling: You can add styling directly

to your document, often placed at the end,

inside a styling block, <style type='text/

css'> … </style>. Do not include spaces

between elements you're styling.

HTML Link: When using an external

stylesheet, whether in a database, on

your Mac, or online, you can add this

style link to your document:  <link

rel='stylesheet' type='text/css'

href='css/styles.css'/>

XHTML Link: Another option to use with

an external stylesheet is using a metadata

XHTML link, e.g., CSS: css/styles.css.

This needs to be at the very top of the

document.

You can also search online to find thousands

of tutorials on CSS, as well as many styles. Do

note many of the styles are very complex and

often made specifically for certain types of

web layouts. It's often better to investigate

how to style specific things, e.g., tables, as

the need arises.
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WEBSITE EXPORT TEMPLATES

For exporting selected groups or files as

a website, DEVONthink uses templates

available in ~/Library/Application

Support/DEVONthink/Websites/ to create

HTML files from documents. In the save

dialog that appears when you use File >

Export > as Website, click the Show Options

button, choose a template, and set your

options. Then choose your location and

export. Listed below are the available

templates but feel free to duplicate and

modify them to suit your own needs:

Default

Footer

Footer+Header

Header

Header+URL+Comment

These templates are constructed of the

placeholders listed below. Each placeholder

will be replaced with actual information

during the export. The placeholders will only

be replaced in documents that are converted

to HTML during export, namely plain text,

rich text, Microsoft Office/OpenOffice

documents, scripts, chat logs, and sheets.

%charset%: The character set of the

document. Rarely used.

%comment%: The Finder Comments of the

document.

%content%: The body content of each

document.

%databasePlusLocation%: The name of

the containing database and the group

location of the document.

%modification%: The modification date of

each document.

%stylesheet%: Any custom stylesheet

applied to a document.

%title%: The title of the document.

%url%: The URL of each document.

%tags%: Tags applied to each document.

SCRIPTS

DEVONthink is well known for its automation

capabilities and to that end comes with

many built-in scripts. Below is a list of the

DEVONthink supplied scripts available to you.

SCRIPT MENU

This is a list of the pre-installed scripts in

DEVONthink's Scripts menu, presented as

they appear in the submenus there:

Chat:

Create Image Prompt: Generate an Image

Diffusion prompt from the key point or

selected text in a document.

Correct Spelling: Correct spelling in a

document based on the context of the

words.

Insert Response: Insert an AI response to a

question you ask.

Transform Text: Generate changes to

selected text based on your instructions.

Some formats, e.g, rich text, support

replacing the text.

Translate Text: Translate selected text

to the language in which DEVONthink is

running. This does not correct spelling

errors.
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Comments:

Append Selected Text: Adds the selected

text to the comments of the current

document.

Assemble: Collects the comments of the

selected documents and creates a new

document listing them.

Convert to Tags: Converts the tag

contained in the comments field to real

tags if the comments field of the selected

document contains tags separated by

commas.

Speak: Speaks the comments of the

selected documents.

Data:

Move Duplicates to Trash: Moves all

duplicates of the selected document to the

trash.

Find & Remove Similar Contents: Finds and

removes similar documents.

Group With Duplicates: Creates a group

with duplicates of the selected documents.

Group With Replicants: Creates a group

with replicants of the selected documents.

Verify & Optimize Databases: Runs a

verification on all open databases and

optimizes them if they verify successfully.

Errors are alerted and logged to Window >

Log.

Check file integrity of databases: Runs a

checksum comparison on all items in open

databases to check for any discrepancies

in the current and stored values. Errors are

alerted and logged to Window > Log.

Download:

Linked Images of Page: Adds linked images

of a displayed web page to the database.

Open Linked Images in Tabs: Opens a

document tab for each linked image in a

web page viewed in DEVONthink.

Images of Page: Adds the images of a

displayed web page to the database.

Links of Page: Adds links contained on a

displayed web page to the database.

Download as…: Converts bookmarks to

one of these formats: Formatted Notes,

HTML Pages, PDF Documents (One Page

or Paginated), and Web Archives. There

are also versions for creating clutter-

free documents as formatted notes, web

archives, and PDF documents (One Page

and Paginated).

Edit:

Count Characters: Counts the characters

in the current selection.

Count Words: Counts the words in the

current selection.

Replace text in documents: Enter text

to find and replace in plain and rich text

documents.

Execute:

AppleScript: Executes an AppleScript

script.

Perl: Executes a Perl script.

Shell: Executes a shell script.
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Export:

Listing: Saves a UTF-8 text file containing

a text listing of the names of all contents/

groups of the current database.

Daily Backup Archive: Creates a

compressed backup (.Zip) of each open

databases. All backups are stored in

~/Backup and their filename includes

a datestamp for easy tracking and

identification. These can be useful for

copying to external media or uploading

to a cloud service as a secondary backup

strategy. Note: When using this script with

an encrypted database, the database will

be compressed in an unencrypted state.

Feeds:

Nature -- Hubble News: Downloads the

latest Hubble news.

iTMS -- Added Albums: Downloads covers

of albums recently added to the iTunes

Music Store.

Format:

Body Normal: Formats selected text as

"Body Normal".

Body Small: Formats selected text as

"Body Small".

Header Capitalized: Formats selected text

as "Header Capitalized".

Header Main: Formats selected text as

"Header Main".

Header Secondary: Formats selected text

as "Header Secondary".

Remove Attachments: Removes

attachments from RTFD files.

Remove Links: Removes linked text from

the contents of a selected rich text

document.

Source: Formats selected text as "Source".

Reset Spacing: Resets the line and

paragraph spacing of selected rich text.

Images:

Copy Info to Comment: Copies basic image

info to the comment field.

Flip Horizontal / Vertical: Flips the image

horizontally/vertically.

Rotate Left / Right: Rotates the image

left/right.

Landscape to Portrait: Rotates only

landscape images to portrait.

Portrait to Landscape: Rotates only

portrait images to landscape.

Scale to 1024 pixels: Scales the image to

1,024 pixels.

Scale to 200%: Scales the image to 200

percent.

Scale to 50%: Scales the image to 50

percent.

Import:

Man Page: Imports a UNIX manual page as

a plain text document.

Perldoc: Imports the documentation of Perl

pages, modules, functions, or programs.

Reminders:

Add as Event to Calendar: Adds a new

event to Calendar linking back to the

selected item in DEVONthink.

Add as To Do to OmniFocus: Adds

the selected item as a to-do item to

OmniFocus.

Add as To Do to Reminders: Adds

the selected item as a to-do item to

Reminders.

Add as To Do to Things: Adds the selected

item as a to-do item to Things.
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Note: These are scripts for integrating with

external applications. For scripting internal

reminder scripts, see the Reminder Scripts

section of the chapter about automation.

Rename:

Append Selected Text: Appends the

selected text to the title of the currently

selected item.

Change Case: Change the case of selected

text to titlecase.

Replace Text: Replaces a text passage in

the titles of selected documents.

To Webpage Title: Sets the titles of the

selected documents to the names of the

web pages pointed to by their URL fields.

To Subject: Sets the titles of the selected

documents to the subject lines of the email

messages if the selected documents are

email messages.

Sheets:

Add Multiple Records: Adds up to 999

empty records to a sheet.

Column Sum & Mean Value: Calculates the

sum and average of a table column.

Row Sum & Mean Value: Calculates the sum

and average of a table row.

Check sums in last column: Checks the

sums in the last column on validity.

Tabs:

Open Bing: Open a new tab for the Bing

search engine.

Open Google: Open a new tab for the

Google search engine.

Open Location: Open a new tab for a

location you specify.

Note: The last script does no URL

validation, though DEVONthink's dictionary

makes it possible to script this too.

Thumbnails:

Flip Horizontal / Vertical: Flips the

thumbnails of selected documents

horizontally or vertically.

Rotate Left / Right: Rotates the

thumbnails of selected documents left or

right.

Landscape to Portrait: Rotates landscape

thumbnails to portrait.

Portrait to Landscape: Rotates portrait

thumbnails to landscape.

Note: While these scripts work with all

image formats including PDF, they should

not be used for PDF documents. They will

only work on the first page of the PDF and

destroy all embedded metadata.

SMART ITEM SCRIPTS

These are scripts available to smart items,

i.e., smart rules and batch processing. They

are divided by the two available actions:

Apply Script and Script with Input/

Output.

Apply Script:

Add Favicons: Attempts to apply the

favicon for a web-based document, e.g., a

bookmark.

Add Web Page Image: Attempts to apply

a web page's image as the document's

thumbnail.

Close All Databases: Closes all open

databases except the Global Inbox.

Close All Documents: Closes all document

windows.
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File Items Using @Destination in Name:

If a filename is suffixed with @ followed

by a group name, it will be used to file

the document into a matching group. For

example, a document named Marriott

stay@Expenses would be filed in an

"Expenses" group. If a group isn't found, it

will be created in the Inbox of the parent

database.

Reminders - Next Week: Set a reminder for

a week from the current time and date.

Reminders - Remove: Remove an applied

reminder from the matched item(s).

Reminders - Tomorrow: Set a reminder for

the same time tomorrow.

Tags - Add Most Important Words: Adds

the top five words from the concordance of

the document. Assessed by weight.

Assign Document Date & Amount: Adds

a detected date and amount to the

document as custom metadata.

Downloads - Add Embedded Images: Add

embedded images in a web-based file to

the Download Manager. Used with HTML-

based files, e.g., web archives, etc.

Downloads - Add Linked Images: Add linked

images to the Download Manager. Used

with HTML-based files, e.g., web archives,

etc.

Downloads - Add Podcasts: Add detected

podcast links to the Download Manager.

Used with podcast RSS feeds containing

download links.

Download Bibliographic Metadata:

Attempts to retrieve the digital object

identifier (DOI) of the document and set

the title and metadata.

Script with Input/Output:

Annotation - Append Text: Gets text from

a Set Script Input action and either

creates an annotation file with the text or

appends it to an existing one.

Annotation - Get Text: Gets the text from

an existing annotation file, if one exists.

Checksum: Returns the content hash for

the record.

Coordinates: Returns the latitude and

longitude from the geolocation data on the

item.

Daily Quote: Gets a random daily quote

from an English and a German site.

Image Size: Returns the width and height

of an image.

Latest News: Returns a random headline

from the New York Times or Tagesschau.

Name - First Number: Returns the first

number in a record's name.

Name - Last Number: Returns the last

number in a record's name.

Text - Lowercase/Uppercase: Returns the

text of a Set Script Input placeholder to

lower or uppercase.

Text - Random String: Returns a 16

character string of random letters and

numbers.

Web Page - Description: Returns the

description from the metadata of a web

page, if available.

Web Page - Keywords: Returns the

keywords from the metadata of a web

page, if available.

Zettel-ID: Queries Markdown metadata

and returns the value for a Zettel-ID

attribute.
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You can read more about how to use these

scripts in the Smart Rules and Batch

Processing section of this manual.

SMART RULE EVENTS AND
ACTIONS

DEVONthink provides many powerful

actions for use with smart rules and batch

processing. Smart rules run when certain

events happen, e.g., when you open a file or

DEVONthink syncs. These are called event

triggers and are listed first. Following that are

the available actions for both functions.

EVENTS

When an action is triggered is almost as

important as the action itself. Actions can be

triggered when any of these events occur:

On Demand: Run only when Apply Rule is

selected in a context menu or Tools > Apply

Rules.

On Startup: Runs when DEVONthink

launches.

Before Synchronization: Runs all actions

before DEVONthink begins synchronizing

to any sync location.

After Synchronization: Runs all actions

after DEVONthink completes synchronizing

to any sync location, i.e. all uploads,

downloads, and changes are committed.

On Quit: Runs when DEVONthink quits.

Every Minute: Runs the specified actions

every minute.

Hourly/Daily/Weekly: Runs the specified

actions on an hourly, daily, or weekly

schedule.

On Workdays: Runs on Monday through

Fridays.

On Weekends: Runs on Saturday or Sunday.

On Creation: Runs when a new document is

created in the specified location.

Via Sorter: Runs when creating various

note types via the Sorter.

Before Saving: Runs before saving a

matched document.

After Saving: Runs after saving a matched

document.

On Imprinting: Runs when any matched

document has been imprinted.

On Import: Runs when documents are

added to the specified location.

On Clipping: Runs when documents

are added via clipping, e.g., via menu

commands, the Sorter, DEVONagent,

bookmarklets, or AppleScript.

On Download: Runs when items are

downloaded via DEVONthink's Download

Manager.

On Scan: Runs after a scanning operation

has completed.

On OCR: Runs after an OCR operation has

completed.

On News: Runs when an RSS feed refreshes

and receives new articles.

On Upload: Runs when an item is uploaded

through DEVONthink's web server.

On Open: Runs when a matching item is

opened in a new document window or

viewed in a main window.

On Open Externally: Runs when a matching

file is opened in an external application.

On Edit Externally: Runs after a document

is edited in an external application and

saved.
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On Launch URL: Runs when the URL

associated with the item is launched.

On Reminder: Runs when an alarm set on a

matching item's Reminder comes due.

On Renaming: Runs after matched items

are manually renamed.

On Commenting: Runs after modifying

Finder Comments on an item, including

changes made to indexed items in the

Finder.

On Labelling: Runs when a label is added to

or changed on an item.

On Flagging: Runs when an item is flagged.

On Rating: Runs when the Ratings on an

item are modified.

On Moving: Runs when matched items are

moved to the specified location.

On Classifying: Runs when matching items

are classified by DEVONthink.

On Tagging: Runs when matched items are

tagged

On Replicating: Runs when matched items

are replicated.

On Duplicating: Runs when matched items

are duplicated.

On Convert: Runs when an item is

converted to a new format.

On Moving into Database: Runs when

indexed items are moved into the

database, becoming imported items.

On Moving to External Folder: Runs when

imported or created items in a database

are moved to external locations, becoming

indexed items.

Before Trashing: Runs before a database's

Trash is emptied.

You can add and remove multiple event

triggers by pressing the + or - buttons.

For example, you could use an On Import

and an On Moving event trigger to act on

imported items or items being moved in your

databases.

ACTIONS

The power in smart rules and batch

processing is found in the actions.

DEVONthink provides actions that cover

simple tasks, e.g., prefixing a filename, all the

way to ultra-powerful AppleScript injection

via external or embedded scripts. Since you

can chain multiple actions together, the

possibilities are nearly endless.

Note batch processing supports a smaller

number of actions than smart rules. Here's a

list of available actions with those also usable

in batch processing marked with (BP):

Bounce Dock Icon: Causes DEVONthink's

dock icon to bounce. This will only trigger

when DEVONthink isn't the active

application.

Display Notification: Shows a message

via the Mac's Notification Center.

Notifications need to be enabled in

System Settings > Notifications for Display

Notification to operate correctly.

Display Alert: Shows a message in an alert

window.

Speak Text: Using your computer's voice

synthesis, it will speak the message you

specify.

Play Sound: Plays a selected system alert

sound.

Send Mail: Enter email addresses to send

the matching items. This can be a comma-

delimited list of addresses, names, or enter
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the name of a group you've defined in your

contacts.

Add to Reading List: Add the matched

items to the Reading List.

Open: Opens a file that triggered or was

produced by a smart rule in a document

window.

Open Externally: Opens the matched file in

the system default application.

Launch URL: Opens the URL shown in the

Generic Info inspector for a matched item.

Apply Rule: Perform the actions of another

smart rule on items passed by the current

smart rule. The items passed by the initial

smart rule must match the criteria of the

second smart rule to trigger it. This can be

useful after performing smart rule actions

like OCR or executing scripts, helping to

avoid redundant or scheduled smart rules.

Stop evaluating rules: Stops the rule from

proceeding to subsequent actions. Most

often used while developing and debugging

a smart rule.

Find & Replace: Scans one of several

attributes or custom metadata fields for

specified text and replaces it with another

value you provide. You can scan a matched

item's: Name, URL, Aliases, and Finder

Comments as well as custom metadata

with a Single/Multi-line Text or an Identifier

data type. Supports case-sensitivity. (BP)

Item scanning: Supported both in smart

rules and batch processing, the next actions

allow you to scan the name or text of a

document and use the results when found.

Each of the actions also has a parameter you

specify for the type of data you're scanning

for. These actions and parameters can be

used with subsequent actions that support

placeholders, e.g., Scan Text: Date →

Document Date with Change Modification

Date. If the action returns no results, actions

using the results will not be executed.

However, unrelated actions in the smart rule

chain will be executed normally.

Scan Name: Scans the name of the file.

(BP)

Scan Text: Scans the contents of the file.

(BP)

The following four parameters are used with

the Scan Name and Scan Text actions. With

String, Date, and Amount, a prefix and/or

suffix before/after the wildcard has to be

specified.

String: An asterisk (*) wildcard specifies

data to be captured. Other terms added

will be used to help locate the desired

string. In subsequent actions, use the

Document String placeholder to represent

the captured string.

Date: Similar to String parameter, use the

desired format of the Document Date

placeholder to represent the captured

string in subsequent actions.

Amount: Similar to String parameter,

use the desired format of the Document

Amount placeholder to represent the

captured string in subsequent actions.

Regular Expression: Items in parentheses

are captured; items outside parentheses

are ignored. You can specify multiple

captures in an expression. Using the

captured text in subsequent actions is

specified by using backslash, \, and the

number of the capture, starting at 1. Note

we use Apple's NSRegularExpression which

supports the ICU regular expression syntax.
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Example:

Using the String parameter, Invoice *

would capture 0012345 in a file named

Invoice 0012345..

Using the Date parameter, *  would

capture the date in a file named

2020-01-01.

Using the Amount parameter, $* would

capture the dollar amount detected.

Using the Regular Expression parameter,

Bill To: ([A-Za-z0-9 ,]+) would

capture the name of the person or

company billed. \1 would be used in the

subsequent action.

Scripting and Chat: These commands are

used for adding script actions processes

or integrating an AI model, e.g., ChatGPT,

into your automations. You can read more

about these actions in the Smart Rule Scripts

section.

Apply Script: Run a script on the matched

or selected items. Choose a script from

installed External scripts. Or choose

AppleScript/JavaScript and write your

code in the embedded script editor popup.

Embedded scripts are only available to the

smart rule they are created in. (BP)

Set Script Input: Choose a property, e.g.,

the aliases of a file or a chat response, and

create a variable for use in a smart rule

script. (BP)

Script with Input/Output: Receives the

value of a Set Script Input variable and

uses it in the script. Outputs from a

return command to a Script Output

placeholder, if passing the results on

to subsequent actions. Either action is

optional. (BP)

Chat - Query: Receive an response from

a specified AI model to your prompt.

Optionally, include a document related to

the query. (BP)

Chat - Continue if…: A special conditional

action that controls whether subsequent

actions should be executed based on a

"yes" or "no" response to an AI query. (BP)

Batch Processing Only: There is one action

found only in batch processing: User Input.

As batch processing is a more impromptu

mechanism, it's a good place to allow user

interaction. This smart action opens a dialog

for you to enter information, e.g., to type

a prompt, enter a name, etc. The result is

stored in the User Input placeholder, used by

a variety of actions.

Change Name/Aliases/Comment/

URL/Label/Rating: Change the specific

attribute of the matched file. For items

with an existing attribute, e.g., a comment,

a placeholder will preserve the existing

value. (BP)

Mark: Toggle the state of read/unread,

flagged/unflagged, and locked/unlocked.

Note you cannot change more than one of

these attributes with one action, but you

can chain more than one Mark action in the

smart rule. (BP)

Change Creation/Modification Date:

Change the creation or modification date

of matched files to: current, addition,

creation, modification, or the document

date. (BP)

Add Tags: Add tags to the matched files.

As you type, tags from all open databases
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will be suggested. Press the semicolon (;)

key to commit the tag. (BP)

Add Tags from Document: Adds existing

tags if they are detected in the matched

document's contents. (BP)

Remove Tags: Removes specific tags you

enter. (BP)

Remove All Tags: Removes all tags from the

items. (BP)

Tags: Adds or converts tags to matched

documents from these commands:

Convert HashTags, Convert Keywords,

Convert Properties, Convert Geolocation,

Add Vision Suggestions to Images, and

Scan Barcodes.

Move/Replicate/Duplicate: Move, replicate,

or duplicate a matched file to a chosen

location.

Duplicate & Continue: Duplicates matched

files and applies subsequent actions to the

copies.

File: Allows you to file items into a group.

Specify subgroups using a forward slash,

e.g., 2019/DEVONtech would create or file

into the DEVONtech subgroup of a 2019

group in the current group. You can use

placeholders to define the location. (BP)

Classify: Using DEVONthink's internal AI,

you can classify matched items to the

Same Database or Any Database. Pro and

Server users can also use AI to determine a

filing location via the Via Chat option.

Move Into Database: Moves indexed items

into the database, essentially importing

them. Note this removes the file from the

original location in the filesystem.

Move To External Folder: For an item

located in an indexed group, this moves the

file to the indexed folder in the Finder.

Check Bookmarks: Checks the URL of the

matched items. Any issues are reported in

the Log window or the Log popover.

Convert: Attempts to convert files

into plain/rich text, formatted notes,

Markdown, HTML, web archive, or PDF.

Convert & Continue: Converts a file and

applies subsequent actions to the newly

created file.

Thumbnails: Adds, updates, or removes a

matched file's thumbnail.

Move to Trash: Move the item to the

database's trash. The items are not

removed from the database until the trash

is emptied.

Delete: Be very cautious with this option.

Delete truly deletes a file. It is not sent to

the database's trash. It is not sent to the

Finder's trash. It is completely deleted.

The following smart actions are only available

in the higher editions of DEVONthink. You will

find them throughout the list of actions in

the dropdown menu as you're creating your

smart rule.

Recognize: Processes a compatible media

file based on your choices in the AI >

Transcription settings.

OCR: This will perform OCR on a file, if

possible. Choose a format to generate a

new file in the selected file type. Note the

file type selected will override the option

set in Settings > OCR > Convert incoming

scans to. Choose Apply to convert a
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matched file directly to a PDF with OCR.

This action does not generate new files.

OCR & Continue: Performs OCR on a file,

producing a new document, and applies

subsequent actions to the newly created

document.

Imprint: Apply the selected imprint to any

matching files, if possible.

Import Email Attachments: Import

attachments from matching emails.

Custom Metadata: If you have specified

custom metadata fields, you will have options

to change values with an action. For example,

if you had a Boolean field named "Done", you

could have the action set this field to true

when the action is triggered. (BP)

AI MODELS

AI models are constantly evolving, with new

models appearing, updating, and sometimes

disappearing. While a complete compendium

of models and capabilities is impossible to

create and maintain, here is a list of the

commercial models currently supported,

listing the size of the context window and

supported functions, e.g., vision.

The icons for the functions are as follows: 

for vision,  for tooling,  for thinking, and

 for deep search.

Apple Intelligence:

foundation-model: 4096 tokens

OpenAI:

gpt-nano: 400000 tokens    

gpt-mini: 400000 tokens    

o3: 200000 tokens    

o4-mini: 200000 tokens    

gpt-frontier: 1050000 tokens    

Anthropic:

claude-haiku: 199999 tokens    

claude-sonnet: 999999 tokens    

claude-opus: 999999 tokens    

Google:

gemini-flash-lite: 1048576 tokens    

gemini-flash: 1048576 tokens    

gemini-pro: 1048576 tokens    

Mistral:

magistral-small-latest: 131072 tokens

   

magistral-medium-latest: 131072 tokens

   

mistral-small-latest: 262144 tokens

   

mistral-medium-latest: 262144 tokens

   

mistral-large-latest: 131072 tokens  

Perplexity:

sonar: 131072 tokens  

sonar-pro: 199999 tokens  

sonar-reasoning-pro: 131072 tokens

   

sonar-deep-research: 131072 tokens  

OpenRouter:

amazon/nova-2-lite-v1: 1000000 tokens

   

amazon/nova-micro-v1:128000 tokens 

amazon/nova-premier-v1: 1000000 tokens

 

amazon/nova-pro-v1: 300000 tokens  

baidu/ernie-4.5-300b-a47b: 123000 tokens

DEVONthink 4.3.2 Documentation, page 343



baidu/ernie-4.5-vl-424b-a47b: 123000

tokens  

deepseek/deepseek-v4-flash: 1048576

tokens  

deepseek/deepseek-v4-pro: 1048576

tokens  

deepseek/deepseek-r1: 64000 tokens

 

google/gemma-4-26b-a4b-it: 262144

tokens    

google/gemma-4-31b-it: 262144 tokens

   

meta-llama/llama-4-maverick:1048576

tokens 

meta-llama/llama-4-scout: 327680 tokens

 

mistralai/codestral-2508:256000 tokens

mistralai/devstral-2512:262144 tokens 

mistralai/mistral-saba:32768 tokens 

moonshotai/kimi-k2.6: 262142 tokens

   

openai/gpt-5.3-codex: 400000 tokens

   

openai/gpt-oss-20b: 131072 tokens  

openai/gpt-oss-120b: 131072 tokens  

openai/o4-mini-high: 200000 tokens

   

qwen/qwen3-coder-flash:1000000 tokens

qwen/qwen3-coder-next:262144 tokens 

qwen/qwen3-coder-plus:1000000 tokens

qwen/qwen3.6-27b: 262144 tokens    

qwen/qwen3.6-flash: 1000000 tokens

   

qwen/qwen3.6-plus: 1000000 tokens

   

x-ai/grok-4.1-fast: 2000000 tokens

   

x-ai/grok-4.20: 2000000 tokens    

x-ai/grok-4.20-multi-agent: 2000000

tokens  

x-ai/grok-4.3: 1000000 tokens    

x-ai/grok-code-fast-1: 256000 tokens

 

xiaomi/mimo-v2.5: 1048576 tokens

   

xiaomi/mimo-v2.5-pro: 1048576 tokens

 

z-ai/glm-5-turbo: 202752 tokens  

z-ai/glm-5.1: 202752 tokens  

z-ai/glm-5v-turbo: 202752 tokens    

Bear in mind, local AI models are not listed

here due to the lack of standardization.

Depending on your hardware (and your level

of patience), you may be running larger

models than someone on a less powerful

machine. Also, you may have a penchant for

a specific AI model provider and want to use

their models.

MCP SERVER

As discussed in the Getting Started > AI

in Practice section, an MCP server is a

controller between DEVONthink and external

AI applications, giving them commands

and controlled access to your databases.

Here we'll cover some benefits and setup

information. As Anthropic is the one who

started this all and setting up MCP with their

Claude application requires very little effort,

we'll use it as our example.

For those curious about advantages of using

the MCP server, here are some things to

know:
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Requires No Coding: No programming skills

are needed — just the ability to compose a

clear query or command.

Easy to Install: The MCP server is a core

part of DEVONthink, requires no separate

modules, and updates automatically with

the application.

Targeted Editing: When editing text

documents, the AI works on specific

sections rather than rewriting the whole

document, reducing the risk of unintended

changes.

Local by Default, Remote Optional: The

server runs on your local machine by

default. Remote access is possible but

requires much more configuration.

Safe and Private: The AI has no access to

your database internals; all changes are

controlled by DEVONthink. Sensitive data

(credit cards, passwords, etc.) is stripped

before it reaches the LLM, items excluded

from AI & MCP access are fully ignored,

and your documents never leave your

Mac beyond what the LLM sees during a

conversation.

And if you're wondering what kinds of things

you can do with the MCP server, there are

many commands, capable in isolation and

powerful when run in combinations. Here are

some aspects of DEVONthink you can control

via the MCP :

Database & Navigation: Get information

about databases, selections, group

hierarchies, etc.

Record Management: Create, modify,

organize, and delete items. Get and set

metadata on items, e.g., tags, labels,

properties, etc. Import and export

documents.

Search & Discovery: Search for items,

classify documents, lookup similar records

or ones identified by attributes like name,

path, etc.

External AI Features: Process image data

with vision, transcribe audio, extract

content for AI use, or use AI searches, e.g.,

on PubMed or arXiv.

Content Processing: OCR scans, convert

between formats, merge documents, or

clip web content into your databases.

Academic/Research Tools: Extract DOI/

ISBN/ISSN numbers, find and download

documents based on those and other

attributes, get and apply bibliographic

metadata to documents.

So you can command your AI application

with directives like, Transcribe the

interview recordings from today and

save the transcript as a Markdown

note, grouped by the interviewee name

in a monthly group.

BASIC SETUP

DEVONthink's MCP server is built to be

run and accessed on the same Mac, letting

you leverage an external LLM and our

application's powerful automation functions.

Fortunately, the setup is usually very simple

as illustrated in the next paragraph.

First you need to set up DEVONthink's

MCP server in the AI > MCP settings. To

get up and running quickly, we'll just check

Redact sensitive content and Install for

Claude Desktop. Logically, if you're using

Claude Code, Codex, or the Hermes Agent,

you would install the appropriate option.

Enabling Launch at login is a good idea and
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lessens friction if you choose to explore

other applications in the future. Now open

Claude.app and ask something DEVONthink-

related, like, List the documents added

yesterday, but ignore RSS articles.

You are now using our MCP server to interact

with your documents and databases!

Other MCP Clients: You may not be running

one of the support AI applications but that

doesn't mean you're out of luck. Refer to the

client's documentation to see if it supports

standard input/output (stdio) or URL-based

communication and how to set up the MCP

connection. But be aware setting up access

from other applications may require editing a

configuration file manually.

HTTP Connections: Some AI applications

use a web-based method, e.g., http(s), for

the communication. DEVONthink supports

this as well, even as an alternate connection

method for those supporting both. For

connecting on your Mac, the server listens

at http://localhost:8420 by default,

requiring no authentication or encryption

required. It communicates using JSON-RPC

2.0 over POST requests with a Content-Type:

application/json header, a commonly used

method.

You also need to register the server URL

with your MCP application so it knows how

to connect. When used with the supported

clients, do this to use the URL access

method. Check the documentation for

configuring other clients.

Open /Applications/Utilities/Terminal,

paste the appropriate command for your

application, and press Return, e.g.,:

Terminal:

# Claude Code

$ claude mcp add --scope user --transport

http devonthink http://localhost:8420

# Codex

$ codex mcp add devonthink --url http://

localhost:8420

# Hermes Agent

$ hermes mcp add devonthink --url http://

localhost:8420

ADVANCED SETUP

While initially built for on-device access, it's

also possible to connect another device to

the MCP server. When connected to the

MCP server, you can make inquiries about the

host's databases and even run skills based on

the replies. While we can't offer application-

specific instructions for every instance, here

is a generic overview of the requirements.

If you want to access your DEVONthink

MCP server from another Mac or device on

your network, you'll need two important

authentication elements: a TLS certificate

and a bearer token. The server won't allow

network access without both pieces in place.

Bearer Token: This is a long alphanumeric

code specific to your MCP server. When a

device tries to connect to the MCP server, it

must present this token or it will be denied

access.

TLS Certificate: The server requires a proper

TLS identity stored in your macOS Keychain.

Self-signed certificates won't work so

you'll need one from a trusted Certificate

Authority. While we can't provide explicit
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instructions for getting a certificate, some

common places to acquire one are: from

your organization's IT department, via

Let's Encrypt in conjunction with tools like

Certbot, or by purchasing one from providers

like DigiCert, Sectigo.

Once you have your certificate, import it

into Apple's Keychain Access application.

Double-click the keychain entry, open the

Trust section, and set it to Always Trust. Save

the change when closing the window then

return to DEVONthink. If set up properly, you

should see it appear TLS Certificate popup

discussed below.

Setting up the Server Mac: Once you have

acquired and added a TLS certificate to

Keychain Access, setting up the server Mac is

straightforward. Open the AI > MCP settings

and do these things:

Enable Launch at login. This ensures the

server is up and running when DEVONthink

launches.

Set the Accept Connections popup to

From the local network. Note the URL field

as you will use it on the connecting device.

Click the Create button to generate a new

Bearer Token.

Select your certificate in the TLS

Certificate popup.

Optionally, set a specific Port if you need

to.

Note: Changing these settings modifies the

MCP configuration file so you don't have to

manually change it. However, if you know

what you're doing, the file can be found

at ~/Library/Application Support/

DEVONthink/MCP/config.json.

Connecting from Another Mac: Once the

host Mac is configured, add access to the

server on the connecting Mac using your

client. Armed with the URL and bearer token,

this may be done in the Terminal application,

e.g., for Claude Code:

Terminal:

$ claude mcp add --scope user --

transport http devonthink https://your-

host.local:8420 \

In the above command, replace your-

host.local:8420 with the URL and port

and <your-token> with the bearer token

from the server Mac's settings. Consult

the documentation for other MCP-capable

applications.

And for other applications, you may need to

edit a configuration file, either manually or

via the client's settings. Again, consult its

documentation.

CONTROLLING MCP'S BEHAVIOR

When you start using the MCP server, you

may be prompted to allow access to certain

locations. You may also be asked to allow

use of the MCP tools. This behavior will vary,

depending on the client application. We will

use Claude Desktop as an example.

The first time Claude uses a specific tool, you

will be asked to allow the behavior. Choose

Allow Once or Always Allow, whichever you're

comfortable with. However, you can not

only view but also control access or prohibit

certain functions from the MCP server.
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Step 1: In the Claude application, choose

Claude > Settings or press ⌘,.

Step 2: Click Connectors and you should

see, e.g., DEVONthink LOCAL DEV. Tap the

Configure button.

Step 3: Here you can view the list of

commands available. For a specific

command, click the encircled checkmark

icon to always allow, the hand icon

to require permission, and the circle-

backslash icon to block the command

entirely. Optionally, you can choose one

setting for all commands via the Custom

popup menu, e.g., always allowing all of

them.

HIDDEN PREFERENCES

There are a few settings in DEVONthink

not available through the application

Settings. Most of them are intended to

facilitate customer support but they might

be interesting for you as well.

Note: These hidden preferences could be

changed or removed with any update.

HOW TO USE THE HIDDEN PREFERENCES

You can toggle or set values for hidden

preferences using the defaults command in

the Terminal application. When setting these

preferences via the Terminal, DEVONthink

should not not be running or the changes may

not be preserved when quitting.

To set a preference using the Terminal,

noting the commands are case-sensitive,

they are written like this (excluding the

parentheses): defaults write com.devon-

technologies.think (the preference

name) (the preference type) (the

value). For example, the following command

enables the  preference by setting a -bool

(boolean type) to TRUE:

Terminal:

$ defaults write com.devon-

technologies.think

ShouldScaleAttachedImages -bool TRUE

Some hidden preferences require you to

specify a numeric value, e.g., CounterDigits.

These types of preferences also need to be

set via a Terminal command. Use the -int

(integer) type before specifying the number,

like so:

Terminal:

$ defaults write com.devon-

technologies.think CounterDigits -int 3

Other preferences use a -string type.

For example, there is a preference to

allow DEVONthink to detect other

plain text formats as plain text,

AdditionalPlainTextExtensions. As

this command replaces the existing list

of additional plain text extensions, we

recommend that you first read the current

list (empty by default) before adding your

own to them.

Terminal:

$ defaults read com.devon-

technologies.think

AdditionalPlainTextExtensions

2014-07-31 08:25:27.101

defaults[21950:3312262] The domain/

default pair of (/Users/eb/Library/

Preferences/com.devon-technologies.think

AdditionalPlainTextExtensions) does not

exist
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# This "error" shows there are no

additional formats specified.

$ defaults write com.devon-

technologies.think

AdditionalPlainTextExtensions -

string .otl.todotxt

$ defaults read com.devon-

technologies.think

AdditionalPlainTextExtensions

.otl.todotxt

AVAILABLE HIDDEN PREFERENCES KEYS

Here is a list of the available hidden

preferences. Each one includes a description,

its data type, and an example value:

AdditionalPlainTextExtensions: Adds

additional plain text extensions, separated

by dots. In Terminal: -string .dxf.nc .

AVSkippingInterval: Specify the numbers

of seconds to skip forward or backward

when using the right and left arrow keys

with Shift held in audio/video files. The

default is 15 seconds. In Terminal: -int 5.

AdditionalXMLExtensions: Adds additional

XML file name extensions, separated by

dots. In Terminal: -string .mathml .

BatesNumberDigits: Specifies the number

of digits used for the Bates Numbering via

the placeholder or scripting. In Terminal: -

int 4.

CounterDigits: Specifies the number of

digits used for the Counter placeholder. In

Terminal: -int 5.

DatePlaceholdersWithoutLeadingZeros:

Disables date and time placeholders from

using prefixing zeros. In Terminal: -bool

FALSE.

DisableActivityWindow: Disables

automatically showing/hiding of the

Activity window. In Terminal: -bool TRUE

DisableAutomaticUpdatingOfIndexedItems:

Disables automatic updating of indexed

items. In Terminal: -bool FALSE

DisableBadgeLabel: Disable the badge label

on DEVONthink's Dock icon. In Terminal: -

bool FALSE

DisableFileSystemEvents: DEVONthink

no longer listens to file system events. In

Terminal: -bool FALSE

DisableFileCoordination: DEVONthink no

longer uses file coordination, registering

its interest in certain files and waiting for

replies. This can cause very long delays if

the coordinating process isn't responding

quickly. In Terminal: -bool TRUE

DisableHighlightColorMapping: Uses the

same colors when highlighting documents

in dark and light mode. In Terminal: -bool

FALSE

DisablePDFDarkMode: Disables the dark

mode appearance for PDF documents. In

Terminal: -bool FALSE

DisablePDFValidation: Disables validating

PDFs created by merging, converting, or

clipping. In Terminal: -bool FALSE

DisablePreprocessedClipping: Disable

additional processing of a web page's

content before sending the clipped file to

DEVONthink. In Terminal: -bool TRUE

DisableRelativeDates: Disable displaying

relative dates, e.g., "Today" in the item

list. This will instead always show absolute

dates, e.g., "2023.02.14". In Terminal: -bool

TRUE

DisableTagAutocompletion: Disable

displaying the popup of tag suggestions
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when entering tags, e.g., in the Tags bar. In

Terminal: -bool FALSE

DontAutomaticallyEnableOperatorsOptions:

After a toolbar search, disables

automatically enabling the Operators &

Wildcards option in the Search inspector.

In Terminal: -bool FALSE

DontSetFindPboard: Disable using macOS'

shared pasteboard, avoiding search terms

from being automatically used in other

applications. In Terminal: -bool TRUE

EnableApplicationFiles: Applications can

be imported/indexed. In Terminal: -bool

TRUE

EnableFSEventLogging: Enables logging of

filesystem events when requested by our

support team. This setting should not be

needed for general use. In Terminal: -bool

TRUE

EnableEvernoteRTFDImport: Enable this to

import notes from Evernote notebooks as

rich text files. In Terminal: -bool FALSE

EnableSearchFieldAutocompletion: Enable

this to have DEVONthink attempt to

complete search strings as you type them

in the toolbar search field. Note this option

only works when the search options Live

while typing and Partial matches while

typing are disabled. (See also p. 127ff ) In

Terminal: -bool FALSE

ForceEditablePDFs: Some PDFs contain

objects that are problematic for Apple's

PDFKit. DEVONthink opens these files in

a read-only state. Enable this option to

disable this behavior and open all PDFs as

editable. Note: This does not eliminate the

potential for problems with certain PDFs.

In Terminal: -bool TRUE

IndexRawMarkdownSource: Index the

source code of Markdown files instead of

the rendered content only. In Terminal: -

bool TRUE

MaximumNumberOfRecentDestinations:

Specify the number of recent destinations

shown in the Recent Destinations section

of the context and popup menus, e.g., in

the Move To popover. The default value is

10. In Terminal: -int 15

MaximumNumberOfRecentSearches:

Specify the number of recent searches

available in the toolbar search field or the

Search inspector. The default value is 10. In

Terminal: -int 15.

MonospacedSidebarFont: Use a

monospaced system font in the sidebars of

main windows. In Terminal: -bool FALSE

MonospacedViewFont: Use a monospaced

system font in the item list of main

windows. In Terminal: -bool FALSE

PersistentSortingOfSearchResults: Retains

the last sort method used in database

search results. In Terminal: -bool TRUE

PlainTextIsMarkdown: Treat all plain text

files as markdown. In Terminal: -bool TRUE

RawMarkdownPasting: When pasting

rich content into a Markdown file, the

formatting is converted to Markdown.

Enable this to ignore formatting and paste

as raw plain text. In Terminal: -bool TRUE

RawOPMLImport: Imports .opml files as

native files instead of parsing and creating

groups, feeds, etc. from them. In Terminal:

-bool FALSE

RichNotesWithoutAttachments: Services

create RTF instead of RTFD. In Terminal: -

bool FALSE

ShowAdditionalInfoInPathBar: Shows

some details about the selected item in the

Information Bar. In Terminal: -bool TRUE
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SyncDebugLog: Enable additional sync

logging for debugging. In Terminal: -bool

TRUE

WindowToolbarStyleExpanded: Enable the

expanded toolbar style on macOS Big Sur.

This shows the title bar above the toolbar

instead of the new unified default style. In

Terminal: -bool TRUE

WindowToolbarTitleHidden: Disables

showing the window title in main

windows. Note this only works if the

WindowToolbarExpanded hidden

preference is not used. In Terminal: -bool

TRUE

ServerDebugLog: Enable additional logging

for debugging DEVONthink's webserver. In

Terminal: -bool TRUE
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This chapter contains the version history of

DEVONthink, our end user license agreement

(EULA), and credits.

VERSION HISTORY

 New   Improved   Fixed   Removed

VERSION 4.3.2

This maintenance release adds support for Anthropic's latest frontier model, Claude Fable 5, as

well as image diffusion models via Ollama. We optimized the search tool in the MCP server and

added a built-in connector for LM Studio to access it. Additionally, DEVONthink can redact many

national identification numbers before AI use. For research automation, four new AppleScript

commands let you locate and apply bibliographic metadata, and in the web interface, you can

now print PDF documents you're viewing. We also fixed compatibility with macOS 27 Golden

Gate Developer Beta.

Added four new research-based AppleScript commands: resolve DOI metadata, resolve

book metadata, download PDF from DOI, and search CrossRef. These complement the

functions of the MCP server in the higher editions of DEVONthink.

Added AppleScript synonyms: DOI for digital object identifier and ISBN for

international standard book number.

Pro — Added support for Claude Fable 5, via Anthropic and OpenRouter. Be aware that this is

a much more expensive model to use. Also note that at the time of the release of this version,

Anthropic has suspended access to Claude Fable 5 based on a US government directive. It may

or may not become available in the future.

Pro — Added LM Studio to the AI > MCP > Install Connectors settings.

Improved the overall reliability of the DEVONthink Markdown parser.

Pro — Updated the AI > Mixture of Agents - Images template.

Pro — DEVONthink redacts regional identification numbers, e.g., European identifiers, before

passing them to external AI via the Chat inspector, AI-related smart actions and scripts, the

Summarize and Transform popovers, and optionally the MCP server.
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Pro — The Chat assistant and smart actions no longer redact phone numbers, consistent with

the MCP server's behavior.

Pro — You can manually edit the MCP server's config.json file and retain your changes, unless

you toggle the Redact sensitive content option in AI > MCP settings.

Pro — In the Generate Image window or AI > Image Generation settings, you can now choose

image diffusion models provided by Ollama, e.g., z-image-turbo. These models are also

available via the model parameter of the download image for prompt AppleScript command

and the Mixture of Agents - Images template.

Pro — Added optional from_uuid parameter to the move_record MCP tool to move only

replicants from the specified source group. Ignored in case of cross-database moves.

Pro — Optimized and refined the search tool and the overall performance and reliability of the

MCP server.

Pro — The default context window for LM Studio is now 8,192 tokens.

Pro — Added support for Nvidia Nemotron 3 Super/Ultra and MiniMax M3 to OpenRouter.

Pro — More reliable get chat response for message … record … as "JSON" AppleScript

command.

Pro — The Download Bibliographic Metadata smart rule now uses the new AppleScript

commands.

Server — In the web interface, you can now print PDF documents for which you have download

rights.

DEVONthink crashed on launch on the macOS 27 Golden Gate Developer Beta. Fixed.

In Markdown documents, bold or italic formatting applied to selected text already containing

formatting didn't properly apply to the whole selection. Fixed.

Double-clicking a PDF document in the Reading List didn't always open the document on the

correct page. Fixed.

Viewing or annotating a PDF document on the macOS 27 Golden Gate Developer Beta caused

exceptions. Fixed.

The see-also score for images was usually too high, e.g., for scanned documents. Fixed.

Detached popovers weren't always restored properly in the latest versions of macOS. Fixed.

The DEVONthink widget extension and the MCP server (in the higher editions) contained a file

that could cause Time Machine to report an error. Fixed.

The AppleScript search command could return results not sorted by score. Fixed.

Window resizing was slow after clicking the Update Now button which is shown if the license

is only valid for updates for less than 30 days. Also, after extending the application license, the

Update Now notification could incorrectly continue to appear. Fixed.

Pro — Removed the prompt strength parameter from the download image for prompt

AppleScript command.
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Pro — Removed the outdated Stable Diffusion 3.5 models as well as the deprecated GPT-

Image-1-Mini model.

VERSION 4.3.1

This maintenance release further refines the new DEVONthink Markdown parser with options

like better image styling and captions, improved inline footnotes, and some fixes. This release

also improves the MCP server, including safer handling of custom metadata, setting item aliases,

opening documents externally, and using OpenLibrary as a fallback for Google Books. Additionally,

we updated some image-generation AI models and now support Claude Opus 4.8.

Support for headerless tables in DEVONthink Markdown.

Pro — A new optional parameter for the open_record MCP tool allows you to open documents

in an external application. This is disabled by default.

Pro — An exclude from chat AppleScript property that we added to the database class lets

you explicitly hide databases from AI access.

DEVONthink's Markdown parser better supports styling directly in image links, including CSS

units for scaling.

DEVONthink renders alt text in an image link as an image caption and supports standard

Markdown styling or linking, e.g., ![*Polar Bear*](/Animals/polarbear.png).

Inline footnotes in DEVONthink Markdown preserve embedded links.

Anchors in Markdown section headings are compatible with the MultiMarkdown

implementation.

Improved overall reliability of our Markdown parser and renderer.

Updated Finder icons for all DEVONthink document types, e.g., .dtBase2, .dtSmartRule, etc.,

on macOS Tahoe.

Pro — Updated AI > Mixture of Agents - Images template.

Pro — You can now change an item's alias via MCP.

Pro — Replicating items via MCP reports the destination of each item.

Pro — The Chat assistant, the Chat - Query and Chat - Continue if smart actions, the get

chat response for message and display chat dialog AppleScript commands, as well as

the summarization and transformation chat popovers now also redact IBANs. The MCP server

redacts IBANs if redaction is enabled.

Pro — The MCP tool to resolve Google Books metadata now uses OpenLibrary as a fallback, as

Google Books requires an API key to search.

Pro — Boolean custom metadata is set more reliably via MCP.

Pro — MCP tools in general are more reliable, including error responses and handling missing

UUIDs for groups. We have improved the communication with the MCP server too.
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Pro — On macOS Tahoe, the Apple Speech Analyzer more reliably transcribes audio and video

when an invalid language is specified via MCP or AppleScript.

Pro — For the download image for prompt AppleScript command, we updated the name

of some AI engines and also the description of some parameters. However, synonyms ensure

older scripts are still compatible.

Pro — We updated Claude Opus to version 4.8, via Anthropic and OpenRouter.

Pro — We replaced GPT-Image-1.5 with GPT-Image-2. Note that "HD" quality produces larger

images.

Pro — Nano Banana 2 uses the commonly available version gemini-3.1-flash-image model.

Pro — Editing images with Flux Pro or Max retains the original's image size, if possible.

Pro — We updated the Recraft image-generation model, but note that it no longer supports

styles.

Pro — DEVONthink sanitizes Gemma 4 responses via Ollama.

Server — Added localization to the See Also & Classify inspector in the web interface.

The Markdown parser incorrectly detected an indented horizontal line with spaced characters,

e.g., * * *, following a list in Markdown as a heading. Fixed.

Callouts and blockquotes beginning with lines similar to MultiMarkdown metadata didn't parse

and render correctly. Fixed.

In Markdown documents, emboldened text following punctuation, e.g., note:, wasn't parsed

properly by DEVONthink Markdown. Fixed.

Markdown blockquotes separated by one empty line no longer merge into one quote. Fixed.

The DEVONthink Markdown parser didn't allow CSS declarations containing spaces in YAML

frontmatter. Fixed.

Text in the toolbar search field of the Help viewer could overlap the clear button. Fixed.

Pro — The MCP server couldn't be accessed during DEVONthink's trial period. Fixed.

Pro — Looking up reminders via MCP could fail on items having no reminders. Fixed.

Pro — Items with rich text custom metadata could cause an exception for the MCP server.

Fixed.

Pro — If an invalid value was given while modifying custom metadata via MCP, it could remove

data from other fields. Fixed.

Pro — Downloading a PDF based on its DOI via MCP could fail even if the PDF was publicly

accessible. Fixed.

Pro — Tagging bookmarks with an invalid URL or while being offline could crash when done via

Apple's Foundation model on macOS Tahoe. Fixed.

Pro — On rare occasion, web searching with AI could cause a crash in the Chat assistant, smart

chat actions, or the get chat response for message AppleScript command. Fixed.
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Pro — Google's Nano Banana 2 and Pro could fail due to being asked for the wrong type of

output. Fixed.

Pro — Editing an image with Flux Pro or Max could crash if the original image's size was too

large. Fixed.

Server — Long Bonjour names specified in the Server > General settings could prohibit the web

server from starting. Fixed.

Server — PDF documents with emojis or an em-dash in their name downloaded in the web

interface had an incorrect filename and a .txt extension. Fixed.

Sync — Bonjour syncs could cause exceptions on rare occasion. Fixed.

Pro — To reduce time and token costs of the chat assistant, we removed Allow image

generation from the AI > Chat > Assistant settings. AI-generated images can still be made via

the Generate Image window.

Pro — We removed the Style setting from the AI > Image Generation settings and Generate

Image window. We also removed the style parameter from the download image for prompt

AppleScript command.

Pro — Google soon discontinues the Imagen models so we removed them from image

generation.

VERSION 4.3 HERSCHEL

DEVONthink 4.3 Herschel introduces our MCP server: A safe, private bridge that lets Claude,

Cowork, Codex, and other AI clients work directly with your databases. No scripting or third-

party tools required. On macOS Tahoe, we now support Apple Intelligence for light tasks and

Apple's faster SpeechAnalyzer for transcription. Other AI improvements include a leaner search

assistant, a dedicated tagging model, and web search via ollama.com.

A new Markdown parser and renderer replaces MultiMarkdown 6. It adds callouts, citations,

and better compatibility with AI output. Desktop widgets bring the reading list, favorites, and

workspaces to macOS Sequoia and later. For DEVONthink Server users, the web interface gains

classification, context menu commands for moving, duplicating, and replicating items, and a

dialog for opening item links. It also features a much better PDF viewer. As always, reliability and

performance continue to improve.

Note: We name this release after the periodic comet 35P/Herschel–Rigollet, discovered in 1788

by Caroline Lucretia Herschel (1750–1848). Caroline was the sister of the famous astronomer

William Herschel and made significant contributions to astronomy in her own right. She

discovered eight comets and numerous nebulae and star clusters, and compiled an influential
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catalogue of deep-sky objects. Caroline Herschel was the first known professional female

astronomer, became the first woman to receive a salary as a professional astronomer, and

received the Gold Medal of the Royal Astronomical Society.

Replacing MultiMarkdown, our new Markdown parser and renderer supports features like

callouts, citations, and tables with captions. It also brings improved CriticMarkup support and

is more compatible with AI-generated output. Choose the renderer in the Preview popup in

the Files > Markdown settings.

Supported in macOS Sequoia and later, new desktop widgets let you access your Reading List

or Favorites, load a Workspace, or view a tip from our blog.

View .highland Markdown files used by screenwriters.

The new URL command, x-devonthink://open-workspace?name=, lets you open an existing

workspace.

Pro — DEVONthink gets its own MCP server that provides a bridge between your databases

and supporting AI applications, e.g., Claude. Comprising a suite of almost 60 commands, it

is built with data privacy and security in mind, controlling local or remote access, redacting

private information from being transmitted, honoring all exclusions from AI set on items (or

databases), and limiting access to the internals of your database in the filesystem. In addition,

when the server is running, a menu bar icon appears with commands for controlling the server,

accessing the settings, or copying the URL you need. Requires macOS Sequoia or later.

Pro — Use the new Settings > AI > MCP settings to set up and install the DEVONthink MCP

server. The options include settings for privacy and making safe connections to other devices,

on and off your network.

Pro — The option Exclude from Chat & MCP in the Database Properties panel lets you easily

exclude entire databases from AI access. This is enabled by default for encrypted and revision-

proof databases.

Pro — DEVONthink supports Apple Intelligence's Foundation model in the AI > Chat settings

and AppleScript commands on macOS Tahoe and later. At this time, its use is limited to

simple tasks like renaming, tagging, etc. as the context window is very small and vision is not

supported.

Pro — Choose the AI model for automatic tagging functions with the new Chat Suggestions

popup in the Files > Tags settings. DEVONthink uses this, e.g., when importing files, using the

Data > Tags commands, or smart rules and batch processing actions.

Pro — Added support for LM Studio's reasoning effort (0.4.8 or later).

Pro — You can now use an ollama.com account for web searches in the AI > Search settings.

Server — Added an Open Item Link button to the Action  toolbar button and the context

menu of the item list in the web interface. This opens a dialog to enter an item link to be

revealed.
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Server — Added a Reveal command to the context menu of search results in the web

interface's item list, revealing the item and its location in the Navigate sidebar.

Server — Added Move, Duplicate, and Replicate commands to the context menu in the

web interface's item list, allowing you to navigate to and choose the destination for these

functions.

Server — Added a section for classifying items to the See Also inspector of the web interface,

including a context menu with related commands.

Converting Markdown documents to plain text, e.g., via the Data > Convert > To Plain Text 

command, strips all Markdown formatting and converts MathJax and DisplayMath into a more

readable form.

Sheets transcluded in Markdown use an underlying Markdown representation for a more

consistent appearance across documents.

The "What's New" window also appears while DEVONthink is in fullscreen mode.

Copying item links includes a Markdown-formatted link for use with third-party editors.

You can use an alternative syntax, :==, synonymously for the is search operator, e.g., in

created:==2026-04-14.

Commands like Open Externally use fewer resources, improving DEVONthink's responsiveness.

Both the digital object identifier AppleScript property and the Digital Object Identifier

smart rule and batch processing placeholder use also the URL to retrieve the DOI. The chat

assistant and MCP server of the Pro edition benefit from this too.

Pro — AI responses use our new Markdown parser, e.g., in the Chat assistant or the summary

and transform popovers. Additionally, the Chat assistant knows how and when it's appropriate

to use Markdown callouts (admonitions).

Pro — The Chat assistant, AI smart actions, summarize and transform functions, AI-related

AppleScript commands, and the new DEVONthink MCP server, redact or anonymize email

addresses, links, credit card numbers, phone numbers, authentication tokens, and labeled

secrets in the information sent to LLMs.

Pro — The Chat assistant displays images returned by Perplexity Sonar models.

Pro — The Help assistant uses fewer tokens and is faster and more reliable.

Pro — "Exclude from Chat" in the Generic inspector is now Exclude from Chat & MCP.

Pro — Local Apple SpeechAnalyzer replaces the "Local Apple Speech" option in the AI >

Transcription settings on macOS Tahoe and later. This utilizes Apple's new SpeechAnalysis

framework which processes audio locally and up to five times faster. Additionally, it will

automatically download and install resources available for the specific language being

transcribed.

Pro — Researching PubMed and arXiv via the Chat assistant is more reliable.

Pro — If AI requests the text contents of a document, DEVONthink provides a Markdown

representation for better access to things like links and styling. This applies to RTF(D), HTML
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pages, formatted notes, and web archives. (PDF and EPUB documents are already supported).

It also improves responses from many AI features, e.g., the Chat assistant and the get chat

response for message AppleScript command.

Pro — Batch tagging is more reliable with low-tier models, e.g., Magistral.

Pro — The default role for AI-related features, e.g., the AI smart actions, get chat response

for message AppleScript command, etc., includes the date, weekday, and current time.

Pro — If the digital object identifier (DOI) or international standard book number (ISBN) is

in the text, metadata, or content of a document, it is available to AI functions like the Chat

assistant, Chat - Query smart action, or get chat response for message AppleScript

command without processing the document further.

Pro — Tagging documents with AI retains the spelling when Files > Tags > Use only existing tags

of a database is enabled.

Pro — An improved definition of DEVONthink's search syntax makes database searches via

the Chat assistant, Chat - Query smart actions, and the get chat response for message

AppleScript command more precise and reliable.

Pro — Claude Opus is now at version 4.7, both via API and OpenRouter. With a knowledge

cutoff of January 2026, it supports up to one million input tokens and 128,000 output tokens

as well as high-resolution image processing, up to 3.75 megapixels. The Sonnet models also

support up to one million tokens now.

Pro — Updated OpenAI's GPT models to version 5.5, supporting a context window of one

million tokens and a knowledge cutoff date of December 1, 2025, but at a much higher cost.

Also, the internal names of these models no longer reference the version, ensuring future

updates don't adversely affect scripts, templates, or smart actions.

Pro — Updated Gemini 3.1 Flash (Preview) to Gemini 3.5 Flash, both via Google and

OpenRouter. Note that the new model is three times as expensive as the former one.

Pro — Gemini 3.1 Flash Lite is available via API and OpenRouter.

Pro — Updated the Mistral Small model to version 4 and Mistral Medium to 3.5, both with a

context window of 256,000 tokens and reasoning capabilities. However, these models are

much more expensive than the previous ones.

Pro — Qwen 3.5, Gemma 4, and versions 3 and 4 of Mistral Small are better supported locally

and via OpenRouter.

Pro — Improved token usage when using Perplexity for Web & Wikipedia searches.

Pro — Updated the Flux image generation models to Flux 2 Klein, Pro, and Max. They support

standard and HD quality and image editing, but not styles.

Pro — Nvidia's Nemotron 3 is better supported.

Pro — Xiaomi models are available in OpenRouter.

Pro — Updated many models in OpenRouter: Grok 4, replaced by Grok 4.2. Mistral Small 3.2,

replaced by Mistral Small 4. Gemma 3, replaced by Gemma 4. GLM 4.6 and 5, replaced by GLM

5.2. GLM 4.7 Flash, replaced by GLM 5(V) Turbo. Xiaomi MiMo-V2-Flash/Omni/Pro, replaced
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with MiMo-V2.5 and MiMo-V2.5 Pro. DeepSeek 3.2 and DeepSeek 3.2 (Speciale), replaced with

DeepSeek V4 or DeepSeek V4 Flash. Kimi K2 2.5, replaced by Kimi K2 2.6. All Qwen models,

replaced by various 3.6 models.

Pro — OpenAI's GPT-OSS models are better supported via LM Studio or Ollama local.

Server — A better PDF viewer in the web interface supports a table of contents, thumbnails,

and searching in all browsers. Additionally, toolbar search terms are automatically used when

selecting a PDF document in the search results.

Server — The context menu in the web interface's item list is better supported on mobile

devices.

Server — Double-clicking a group in the search results of the web interface's item list now

opens the group.

Server — DEVONthink's self-signed certificates generated in the Server > General settings use

even stronger 2048-bit encryption.

Sync — Synchronizing RSS feeds less frequently duplicates articles.

Converting Markdown documents to paginated PDF documents could sometimes fail. Fixed.

Opening braces with no matching closing braces could break Markdown transclusions. Fixed.

Converting images to PDF or merging PDF documents on macOS Tahoe could produce a

document with only white pages. Fixed.

Scrolling or selecting pages in a PDF document could mark the document as modified. Fixed.

On rare occasions, annotating PDF documents could cause an exception. Fixed.

Multi-page TIFF files couldn't be viewed or converted on macOS Tahoe. Regression. Fixed.

Web windows opened without a record, e.g., via AppleScript, always opened at the same size

with the Inspectors open. Fixed.

Scrollbars in Widescreen mode didn't behave properly on macOS Tahoe. Fixed.

Resizing document windows after switching to side-by-side mode didn't work correctly on

macOS Sequoia and later. Fixed.

Group tags didn't appear correctly in inactive tag fields. Fixed.

In tagging fields, the popup arrow on hovered tags didn't appear in the correct position. Fixed.

Depending on the date, time, and current locale, the contents of the Log window's Date/Time

column could appear clipped. Fixed.

Tooltip and click positioning in the Editing and Navigation bars were affected by a window's

width on macOS Tahoe. Fixed.

When using a Markdown document in the Annotation field of the Annotations & Reminders

inspector, the Format > Add Link and Format > Edit Link commands weren't supported. Fixed.

The Content > Table of Contents inspector didn't display correctly with Markdown documents

using more than three backticks to mark fenced code blocks. Fixed.
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Clearing the color of groups and tags from the Generic Info inspector or Info popover didn't

sync between devices. Fixed.

On startup, a failure to open a database showed an alert that could freeze the application on

rare occasions. Fixed.

The JavaScript command addReminder didn't use the correct scheduling. Fixed.

Pro — Transcribing PDF documents on demand, e.g., via Data > Recognition or automatically,

produced inconsistent results. Fixed.

Pro — Empty black or white PDF pages weren't ignored as input, leading to unnecessary AI

time and token usage on macOS Tahoe. Fixed.

Pro — Blockquotes in the Chat assistant weren't styled. Fixed.

Pro — Text pasted into the Title field of the Imprinter settings incorrectly added a % character.

Fixed.

Pro — Adding or deleting a Font placeholder in the Title field of the Imprinter settings didn't

update the Font selector popup. Fixed.

Pro — Inserting a placeholder before an existing placeholder in the Imprinter settings replaced

all the text following the new one. Fixed.

Pro — Custom metadata definitions added via AppleScript could cause sync issues. Fixed.

Pro — If DEVONthink was not running, the first scan from third-party software launched the

app but didn't run OCR on it. Fixed.

Server — In the web interface, PDF documents couldn't be viewed in Safari. Fixed.

Server — PDF documents viewed in the web interface on an iPad only displayed the first page.

Fixed.

Server — Markdown documents didn't display images using relative links in the web interface.

Fixed.

Server — The table of contents for EPUB files didn't work. Fixed.

Server — The arrow indicating the item list's sort direction was the opposite in the web

interface. Fixed.

Server — The user icons in the Server > Users settings didn't display correctly when launching

in dark mode and switching to light mode while the settings were open. Fixed.

Pro — Removed the Remote Apple Speech option from the AI > Transcription settings on

macOS Tahoe and later.

Pro — Removed OpenAI's GPT 4.1 models from API access and OpenRouter. We've also

removed GPT 5.1, GPT 5.2, and GPT 5 Nano and Mini from OpenRouter as they have been

superseded by newer models.

Pro — Removed Claude Opus 4.6 (Fast) from OpenRouter.
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VERSION 4.2.2

Today's maintenance release lets you create powerful AI-driven searches and add tags more

reliably via scripting. If you are using JavaScript for your automations, you can now use .js files.

In AI, Gemini and Nano Banana get updates, and Claude 3 Haiku retires. We also have a few fixes,

including better handling of .opml email attachments.

Pro — Perform AI-driven research with multiple sources, e.g., arXiv, PubMed, even your

databases, with the new perform chat research AppleScript command. Control where AI

searches with the sources parameter and the number of results with maximum results.

The appearance of placeholder text in the interface, e.g., in some empty table views, is more

consistent with the system settings.

We made some cosmetic improvements to the sidebar in the Help viewer.

You can now load external JavaScript for Automation (JXA) scripts with a .js extension in the

Scripts menu, as well as use them for smart rules and batch processing.

Tags separated by commas or semicolons are better parsed and applied when set via scripting.

Updated application icon for older macOS releases and Sparkle.

Pro — The automatically generated identifiers of custom metadata (see Data settings) now

ignore characters reserved for our search syntax, e.g., :.

Pro — Database searches via the Chat assistant, Chat - Query smart action, or the new

AppleScript perform chat research command now filter irrelevant results.

Pro — Revisions to the internal names of Anthropic's Claude models ensure future model

updates won’t break existing scripts, templates, or smart rules. Also, the AI > Research Report

and The Devonian Times templates now use Sonnet's revised name.

Pro — Gemini Pro and Flash Lite are now at version 3.1 (Preview) via the native API and

OpenRouter. Also, Gemini 3.1 Pro and 3.1 Flash handle reasoning better. Note that Gemini Flash

Lite 3.1 (Preview) is more expensive than the former version 2.5.

Pro — More reliable support in the chat assistant, the Chat - Query action of smart rules

and batch processing, and the get chat response for message AppleScript command for

evaluating mathematical expressions. In addition, the constant eps0 is now also supported.

Pro — Ollama has improved support for the lfm2 model and GPT-OSS now reasons better.

Pro — Ollama reasoning models (except GPT-OSS) enable thinking now only when using

Settings > AI > Chat: Usage: Best (option is also available in the chat assistant). Otherwise it's

disabled to speed up responses (e.g. up to twelve times faster in case of Qwen3.5).

Pro — Nano Banana 2 replaces version 1 and now supports the Quality (HD or Standard)

setting.

Pro — The script assistant supports GPT 5.3 Codex via OpenRouter.

Pro — We improved the AppleScript dictionary description of the transcribe record…

language command.

DEVONthink 4.3.2 Documentation, page 362



Server — When revisiting the web sharing interface, a warning dialog will appear if you're not

logged in.

Repairing a database with orphaned OPML documents incorrectly converted them to RSS

feeds or outlines. Fixed.

The View > Hide/Show toolbar command wasn't disabled in the Help viewer. Fixed.

Converting an empty rich text document to plain text or Markdown failed. Fixed.

Pro — Importing OPML email attachments always converted them to RSS feeds or outlines

and could create orphaned files. Fixed.

Pro — Removed the soon-to-be-retired Claude 3 Haiku. Bulk tasks, e.g., filtering search results,

are now done with 4.5 Haiku. Note that the 4.5 model is more expensive.

Pro — Removed all Qwen3 235b models from OpenRouter, except the ones for coding. Use the

latest Qwen 3.5 models instead.

VERSION 4.2.1

This maintenance release lets you mirror DEVONthink reminders to Apple Reminders via a new

script. It also includes a hidden preference to disable dark mode only for PDF documents on

macOS Tahoe or later, and lets you run batch processing on specified records via AppleScript. The

Pro and Server editions support Claude Sonnet and Opus 4.6 and improve the support for zAI

and Qwen models. The update brings several fixes, too, e.g., for lists in rich text documents not

displaying in macOS Tahoe.

The Scripts > Reminders > Export to Reminders menu item mirrors DEVONthink reminders to a

DEVONthink list in Apple Reminders.

A hidden preference, DisablePDFDarkMode, disables dark mode for PDF documents on macOS

Tahoe or later.

The perform batch configuration… record AppleScript command lets you run a batch

configuration on specified records.

Server — In the web interface, the toolbar search now supports the scope: prefix and its

abbreviation, s:, similar to the search AppleScript command (see below).

Search hits in PDF documents are better visible in dark mode on macOS Tahoe.

Sorting sheets is more reliable on columns with identical cell content, especially dates.

DEVONthink now better captures web content as clutter-free documents.

The width of the current main or document window again determines the maximum width of

the inspectors pane.

The Thumbnails inspector is more reliable and should alleviate some rare crashes, e.g., caused

after moving documents.
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Updated icon for the Global Inbox counterpart in the Finder.

The AppleScript search command now supports the scope: prefix (or its abbreviation, s:)

if you leave the in parameter unspecified or as a missing value. Supported scopes are: all,

inboxes, inbox, tags, trash, or the quoted name of a database.

Pro — Updated support for Claude Sonnet and Opus to version 4.6 via the native API and

OpenRouter. The script assistant also uses the latest version of Claude Sonnet. For both

models, DEVONthink uses adaptive thinking and effort instead of budget tokens (only natively

via Anthropic).

Pro — The AI > Research Report - PDF, AI > Research Report - HTML, and AI > The Devonian

Times templates now use Claude Sonnet 4.6.

Pro — Replaced zAI's GLM 4.7 with the latest version GLM 5 from OpenRouter.

Pro — Improved support for zAI's GLM 4.x models.

Pro — Optional support for API keys for LM Studio 0.4.0 or newer.

Pro — Updated or replaced various OpenRouter models for the script assistant with more

powerful models. Additionally, we have removed several OpenRouter models that no longer

exist.

Lists, e.g., bulleted lists, in rich text documents didn't display correctly on macOS Tahoe. Fixed.

Checkboxes in sheets, as well as boolean custom metadata in List views in the higher editions,

didn't display correctly on the latest macOS releases. Fixed.

In the Info > Annotations & Reminders inspector, text colors in Markdown annotation

documents were inconsistent. Fixed.

Dates in sheets or List view columns weren't parsed correctly if the date contained a four-digit

year and didn't match the format set in the system settings. Fixed.

PDF text and note annotations didn't always remember their last used font, so changes such

as moving or editing text reverted them to a default font. Fixed.

Clipping paginated PDF documents didn't build them correctly on macOS Tahoe. Fixed.

Emptying the trash could show a wrong, unnecessary alert in case of indexed, trashed items

which can't be deleted (e.g. located in the user's library folder). Fixed.

Finder tags of updated indexed items were used if the option to export Finder tags (see

Settings > Files > Tags) was enabled instead of the option to import Finder tags. Fixed.

Removing all tags, e.g., via Data > Tags > Remove All Tags, didn't trigger the On Tagging event

of smart rules. Fixed.

Minor visual glitches of File > Database Properties popover in the case of read-only databases.

Fixed.

The createRecordWith JXA command didn't support all properties of smart groups. Fixed.

The unlinked Wiki links AppleScript property was incorrectly included in the properties

property. Fixed.
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The direct, unnamed parameter of the search AppleScript command wasn't marked as

required and can't be a missing value. Fixed.

Pro — Settings > Imprinter didn't always save modified options. Fixed.

Pro — Changing the duplex setting of the scanner interface could freeze the application. Fixed.

Pro — Removed unsupported GPT Audio and GPT Audio Mini models from OpenRouter.

Pro — Removed obsolete MoonshotAI Kimi K2 0905 and MoonshotAI Kimi K2 Thinking models

from OpenRouter. Use the latest MoonshotAI Kimi K2.5 model instead.

Pro — Removed obsolete zAI's GLM 4.5 Air model from OpenRouter. Use the new GLM 4.7 Flash

model instead.

Pro — Removed Qwen3 Max and Qwen3 VL models from OpenRouter. Use the latest Qwen3.5

models instead.

VERSION 4.2 CASSINI

DEVONthink introduces a refreshed look with a new app icon and full support for Apple's Liquid

Glass design on macOS Tahoe. On macOS Sequoia and later, sidebars and inspectors now

animate smoothly in and out, and the Navigate sidebar is spring-loaded. Simply drag items to the

window edge to reveal it automatically. PDF documents on Tahoe also respect your dark mode

preference for more comfortable reading.

The Chat assistant gains powerful new capabilities: adjust many options directly within the chat

window, and access up to 50 saved conversations to pick up right where you left off. You can

now choose between DEVONthink, Perplexity, or Exa for web and Wikipedia searches, giving you

control over speed versus freshness. Updated AI models including Claude 4.5, GPT 5.2, Gemini 3,

and Google Nano Banana Pro, deliver improved performance across all AI use. When generating

images, you can choose the aspect ratio.

New workflow tools help you work faster: the detachable Graph popover lets you visualize

document connections, you can manually save named versions for finer revision control, and

annotation files are now easier to create, locate, and open directly from menus and inspectors.

Markdown documents also support smart quotes and dashes for polished typography.

Note: DEVONthink now requires macOS 13.5 Ventura or later.

Note: We name this release after the Cassini lunar crater and its namesake, Giovanni Domenico

Cassini (1625–1712). The Italian-French astronomer served as the first director of the Paris

Observatory. Cassini was a methodical observer and organizer of knowledge, systematically

cataloging celestial phenomena and discovering four of Saturn's moons and the division in

its rings. His dedication to precise observation and documentation lives on as one of the

foundational principles of science.
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DEVONthink supports Apple's Liquid Glass design language on macOS Tahoe and has a new,

fitting app icon. We have modified many parts of the user interface and will continue to do so

while Apple addresses issues. Many refinements we've made, e.g., to the popovers, apply to all

supported system versions.

The Data > New > Sheet panel lets you name the new sheet.

An Open button in the Annotations & Reminders > Annotations inspector lets you quickly open

the current annotation file.

The Versions inspector supports manually creating named versions.

The settings option Files > Markdown: Preview: Smart quotes and dashes tells DEVONthink to

render quotes and dashes using their typographically correct variants.

A warning shows when a database may be open in another user account.

After updating DEVONthink to the next feature release, a What's New panel shows the top

features of the release.

A hidden preference, WindowToolbarTitleHidden, lets you hide a main window's

title and gives you more space for toolbar items. Note that you cannot use it with the

WindowToolbarExpanded hidden preference.

The unlinked Wiki links AppleScript property for records helps detect WikiLinks without a

linked item.

The HTTP response class has two new AppleScript properties, error code and error

domain, to aid in troubleshooting.

Pro — New settings in the Chat assistant let you dynamically change options for the current

chat, including the Search scope, Usage, and Documents mode.

Pro — The Chat assistant now saves up to 50 chats, defined via the option Max. Recent Chats

in the AI > Chat settings. DEVONthink automatically names previous chats and lets you access

or remove them via the  button in both the Chat inspector and popover. Up to ten of today's

chats are listed at the top with previous chats in date-specific submenus. Selecting a previous

chat will attempt to reveal or open the associated document or selection with the previously

used document mode.

Pro — You can open the Chat popover via the keyboard shortcut ⌃⌘A that we added to Tools >

Chat.

Pro — The new menu command Tools > Graph opens the Graph inspector in a floating, resizable

popover. This popover will be restored on launch and with workspaces.

Pro — Separate AI > Search settings let you control where you want AI to search. This also

includes new Web & Wikipedia settings to search via DEVONthink (slower but more up to

date), Perplexity, or Exa (faster, but using indexed content).

Pro — The AI > Research Report template is now also available in a PDF variant.

Pro — Support for DeepSeek 3.2 and 3.2 (Speciale) via OpenRouter.

Pro — Support for the image generation model GPT-Image-1-Mini, accessible in the AI > Image

Generation settings and the Generate Image panel.
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Pro — Support for Google Nano Banana Pro, generating images in 2K and 4K. Note that it

generates images more slowly and is more expensive than Google Nano Banana. Also, the

Mixture-of-Agents- Images template uses Google Nano Banana Pro, if available.

Main and document windows now use modern APIs on macOS Sequoia and later, providing

animated toggling of the sidebars and inspectors. You can also collapse these panes by

dragging the separator to the window's edge.

On macOS Sequoia and later, the Navigate sidebar is now spring-loaded and will automatically

pop open if you drag an item to the left side of a main window.

The Format Bar is available in fullscreen window mode on macOS 15 and later. You show or

hide it with Format > Show/Hide Format Bar.

The selected row in the Move To and Insert Link popovers has better contrast when they don't

have focus.

DEVONthink more consistently positions popovers relative to the current window.

You can make the group selector larger than before.

The appearance of informational text is more consistent throughout the interface.

On macOS Tahoe, PDF documents now display in dark mode when General > Appearance > Use

dark background for documents is enabled.

When converting a rich text document to PDF, DEVONthink checks if the source document

only contains a single PDF attachment and no useful text, then uses the found PDF. This also

applies to email conversions in the Pro and Server editions.

New entries made via Data > Add To > Table of Contents can use the bounds of a selection

instead of just the page.

The Table of Contents inspector is more compatible with poorly constructed HTML content,

e.g., created by some AI models.

The "Remind Me" submenu in the Data and context menus is now Annotate & Remind. You can

still set a due date on a selected item but you can also create a new annotation document

via the template of your choice. The annotation will open in a new document window or be

displayed in the Annotations & Reminders > Annotations inspector, if it's open.

The Insert Quote command of the Info > Annotations & Reminders inspector supports also

Markdown documents.

In the AI > See Also inspector, the keyboard shortcut for the Move To command is only shown

when the ⌃ Control key is pressed.

The context menu of the item list of main windows now includes a Reveal command to reveal

replicants, duplicates, and an item's annotation document.

The command Apply Rule is now available in the context menu for smart rules added to the

Favorites.

The document date placeholders submenus are now under the Document options.

Using Data > Mark to lock or unlock a group applies the same to its children. This does not

apply when locking an item via scripting or smart rules.
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Drag-and-drop or copy-and-paste is now more compatible with third-party editors.

DEVONthink no longer shows a warning dialog after it crashed or was quit forcefully.

Automation prompts to allow DEVONthink to control the Finder no longer self-dismiss.

The compare AppleScript command now only returns a maximum of 40 results, consistent

with the See Also & Classify inspector.

You can now control how long the download URL and download markup/JSON from

AppleScript commands run by using a with timeout of x seconds… end timeout block.

Pro — Bookmarks are now supported in many AI-driven functions, like labeling, rating, and

tagging via the Data menu, summarization, as well as smart rules, batch processing, and AI

placeholders.

Pro — When using an AI model supporting tool calls, e.g., the ChatGPT models, the Chat

assistant can temporarily highlight words or sentences in the currently viewed document,

similar to the Search inspector.

Pro — The Chat assistant can now create comma or semicolon-delimited sheets (.csv),

instead of just tab-delimited (.tsv) ones.

Pro — The "Research Overview" template is now AI > Research Report - HTML.

Pro — The AI > Research Report and AI > The Devonian Times templates use updated models:

Gemini 3 Pro or Flash Preview, GPT 5.2, or GPT 5 Mini.

Pro — The Help assistant now first tries to determine the most relevant help pages. This can

drastically reduce the number of tokens used, up to 90%, and allows use of newer or more

expensive (and more capable) models.

Updated Google Nano Banana from preview to final release.

Pro — Aspect Ratio replaces the "Size" option in the AI > Image Generation settings and

Generate Image panel. Also, the aspect ratio AppleScript parameter replaces the "size"

parameter of the download image for prompt command. Supported sizes are 1:1, 16:9

(9:16), and 4:3 (3:4). This setting as well as which generative model is used and, optionally,

the quality setting, control the size of the resulting image.

Pro — The Chat assistant and AI actions like tagging or rating, better handle errors. The

assistant also more reliably clears chats. DEVONthink better filters AI-generated error

messages like those from placeholders in smart rules and batch processing, and also handles

OpenRouter errors better, e.g., when a provider is overloaded.

Pro — Updated GPT 5.1 to GPT 5.2, natively and via OpenRouter. Also, GPT 5 Pro, 5.1 Codex, and

5.1 Codex Mini are available in the Chat assistant via OpenRouter, the Codex and Codex Mini

models in the Script assistant.

Pro — Updated GPT-Image-1 to GPT-Image-1.5. The Data > New From Template > AI > Mixture-

of-Agents template support the new model.

Pro — Updated Anthropic Claude 4.1 Opus to 4.5 and Haiku to version 4.5, natively and via

OpenRouter. Claude 4.5 Opus is less expensive, a new parameter reduces response time and
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costs. Claude 4.5 Haiku supports reasoning, more output tokens, and has knowledge up to July

2025.

Pro — Updated Gemini 2.5 Pro to Gemini 3 Pro and Gemini 2 Flash to Gemini 3 Flash (Preview),

natively and via OpenRouter. Also, responses to vision requests are quicker, cheaper, and

support a vision limit of 200 items, useful for video, multi-page PDF documents, and multiple

selected images.

Pro — Updated support for Mistral Large 3, including via OpenRouter. Also Mistral's Devstral

Medium model is now Devstral 2, with a context window of 256,000 tokens and supported in

the Script assistant.

Pro — Mistral and local models have improved tool call support.

Pro — Ollama, LM Studio, and OpenAI (Compatible) models now require a minimum context

window of 4,096 tokens. We recommend 16k (16,384), when possible.

Pro — Depending on the usage setting, LM Studio can process images with a maximum

dimension up to 2,048 pixels.

Pro — DEVONthink examines and filters OpenAI (Compatible) models for capabilities, e.g.,

vision or tool call support, with servers not reporting this information on their own. Note that

the context window still needs to be specified. This provider is also more compatible with

endpoints hosting models like GPT 5.x or the O-models.

Pro — Updated further models usable via OpenRouter: Grok 4 Fast to Grok 4.1 Fast, Nova Lite

1.0 to Nova 2 Lite, and zAI's GLM to version 4.7.

Pro — Better support for the Qwen3 models.

Pro — OpenRouter models now prioritize price (Cheapest) or thoroughness (Best) for models

having multiple providers, depending on the AI > Chat > Usage setting.

Pro — The Chat - Query smart action works more reliably with low-tier models like GPT 5

Nano or Mini.

Pro — The get chat response for message AppleScript command has a better description.

Pro — The as parameter for the get chat response for message AppleScript command

accepts PDF to return a paginated PDF document of the response.

Pro — The appearance of the OCR settings is more consistent with other settings panes.

Sync — Bonjour passwords stored in Keychain Access now use the host's ID as the host name

of a device can sometimes change when switching networks.

Ordered lists in Markdown didn't render properly if there was no space after the dot. Fixed.

Inline MathJax equations didn't always render properly in Asian language documents. Fixed.

Web pages using the Consent framework crashed WebKit. Fixed.

Converting emails (Pro and Server editions) and rich text documents to PDF documents could

stall the app. Fixed.

Converting HTML documents didn't convert code blocks correctly. Fixed.

Capturing a web page within DEVONthink didn't honor the clutter-free setting. Fixed.
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Searching for tags in a toolbar search or via smart groups and rules didn't work correctly with

groups excluded from tagging and grouped RSS feeds. Fixed.

Switching between light and dark modes could cause visual artifacts in labels, ratings, and the

Activity pane. Fixed.

Destination popups, e.g., in the Sorter, didn't display correctly in dark mode if the destination

was the root of the Global Inbox or database. Fixed.

When detached, the Information popover didn't update when switching tabs in the frontmost

document window. Fixed.

The header of tables in various inspectors, e.g., Concordance > List showed artifacts on macOS

Tahoe. Fixed.

For favorited groups, the item count wasn't shown and their unread count didn't match what

was reported in the item list. Fixed.

The internal versions group was neither properly filtered when determining statistics in

Database Properties nor was it ignored in toolbar searches. Fixed.

Deleting a version from the Versions inspector would incorrectly close the current tab or

document window. Fixed.

The Tools > Show Info command closed the popover instead of activating it. Fixed.

The context menu could display an unnecessary and disabled Put Back command. Fixed.

The keystroke ⌃↩ on modern versions of macOS didn't work properly in Icon view and could

also change text selections. Fixed.

Pressing the ⎋ Escape key with the database authentication panel open caused an issue. Fixed.

The Sorter didn't always appear in the menubar on macOS Tahoe. Fixed.

The Apply Rule smart action didn't work properly if the applied rule ran asynchronous

actions, like chat suggestions. Fixed.

Pro — In rare cases, while in List view with a specific custom metadata field shown, disabling

that field on another device and synchronizing could crash the app. Fixed.

Pro — The Tools > Chat command didn't close an already open popover. Fixed.

Pro — The prompt field didn't have focus when the Chat popover opened. Fixed.

Pro — The Model popup in the Script assistant was too narrow for many OpenRouter models.

Fixed.

Pro — If the same model was accessible via a local and a remote Ollama installation, the local

model was chosen in the Model popup in the Chat assistant or AI-driven smart actions, e.g.,

Chat - Query. Fixed.

Pro — Embedded models in Ollama were not filtered from the model list. Fixed.

Pro — The Chat toolbar item wasn't disabled when a Chat popover was already open. Fixed.

Pro — Markdown blocks in chat messages were sometimes stripped out during chat or when

saving the conversation. Fixed.
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Pro — A document containing text provided to the smart actions Chat - Query and Chat -

Continue if wasn't handled correctly if the document mode was set to Without Document

or Document (Vision). Fixed.

Pro — The Data > New > Script window had no title. Fixed.

Pro — The Quality setting in the Data > New > Generate Image panel wasn't used. Fixed.

Pro — Using Data > Move to Trash could have caused glitches if the icon view of the scanner

interface was active. Fixed.

Pro — Tags were not applied to a document when scanning to a binder. Fixed.

Pro — The AI commands in the Rating, Label, and Tags submenus of the Data menu incorrectly

showed a star when running the Pro or Server editions. Fixed.

Pro — Changing the type of custom metadata fields, e.g., from Boolean or a number to a

string, then editing a smart rule using these fields, could crash the app. Fixed.

Pro — Removed tool calls for various AI functions from the Chat assistant: for compiling

scripts, support prompts, and for showing a toolbar search. All these functions were

superseded by the Search, Help, and Script assistants. These are less expensive, have shorter

response times, and are more reliable.

Pro — Removed Claude Sonnet 4 and 3.5 Haiku, both replaced by the 4.5 models.

Pro — Removed the deprecated Sonar Reasoning model.

Pro — Removed the outdated Dall-E 3 image generation model.

Pro — Removed Grok 4 Fast from OpenRouter, replaced by Grok 4.1 Fast.

Pro — Removed Devstral Small and Medium, including from OpenRouter, replaced by Devstral

2.

Pro — Removed DeepSeek 3.1 Terminus from OpenRouter.

Pro — Removed the Exacto models from OpenRouter as they weren't as reliable as expected,

as well as support for Voxtral, GPT-5-image-1, GPT-5-image-mini-1, o4-mini-deep-research, and

o3-deep-research.

Visual glitches on macOS Tahoe after switching between light and dark mode, a common

Liquid Glass issue.

VERSION 4.1.1

This release helps mitigate AI risks, especially when processing online content, to reduce the

potential for malicious prompt behavior. We also updated the supported AI providers, adding

support for Google's Nano Banana image engine and Anthropic's Claude 4.5 Sonnet.

DEVONthink now detects empty pages when clipping PDFs, ensuring more consistent and

useful results, and we made the Safari and share extensions more reliable on macOS Tahoe.

Mailboxes in the Import sidebar load faster and match Apple Mail's appearance and you can
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modify a document's searchable text via the chat or scripting. On the sync side, DEVONthink now

automatically adjusts resource usage based on your machine's temperature and workload, and

sync in general is more performant. Of course, we fixed bugs and glitches, too.

We added independent buttons for the Insert Back Link and Insert Quote commands to the

Annotations & Reminders > Annotations inspector.

Pro — We added two new options to the AI > Chat settings: Allow download of web pages

and Load remote images automatically to let DEVONthink download and examine web

content while generating a response. We disabled these options by default, as they could be

considered insecure.

Pro — We added separate Destination settings for image recognition and multimedia

transcription.

Pro — DEVONthink now suports Anthropic's Claude 4.5 Sonnet model with pricing and

possibilities identical to Claude 4 Sonnet. In addition, the Script Assistant uses now this

model instead of Claude 4 Sonnet.

Pro — We added support for Google's Nano Banana text-to-image engine in all image creation

functions, e.g., the Generate Image window. This model supports image editing, and, unusually,

defines the size and style directly from the prompt. You must have a Gemini API key to access

this model.

We improved the consistency of syntax colorizing for quotes in Markdown documents.

When converting EPUB documents, clipping web content, or using the download PDF

document from AppleScript command to create PDF documents, DEVONthink now detects

empty black and white pages and either filters them out or aborts the clipping.

When you select a local or global smart group or smart rule in the Navigate sidebar,

DEVONthink now uses the targeted group as the destination for new items and grouping

selected items.

We reduced resources used for versioning by 90%, especially during toolbar searches and while

updating smart groups and rules.

DEVONthink now explicitly registers its extensions to ensure they're available in Safari and

macOS' Share menu on macOS Tahoe or later.

You can now modify the plain text AppleScript property of transcribed files, e.g., images,

PDF documents, audio and video files. You can also use the transcription synonym.

The external smart script Zettel-ID handles errors caused by Markdown documents that

don't contain this ID.

We improved the handling of menu scripts execution.

Pro — Apple Mail mailboxes and their structures now load faster and more reliably in the

Import > Emails sidebar.
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Pro — Cross-linking items is now easier; just drag and drop an item onto the item link pop-up

menu in the Info > Data inspector or sheet form views.

Pro — The Help assistant provides the current help page to the chat, enabling summarization,

translation, and other AI-assisted tasks.

Pro — The Help and Chat assistants retain unsent prompts when reopening windows,

inspectors, or popovers.

Pro — A revised system prompt for chats eliminates unnecessary AI remarks about

anonymized links.

Pro — You can optionally save images created or edited via the Chat assistant to the database

via prompt. DEVONthink adds the prompt to the Finder Comments of the image.

Pro — The Chat assistant lets you modify the searchable text of transcribed documents (e.g.,

images, PDFs, audio, and video files), allowing updates to translated or spell-checked versions.

Pro — The context window of the current AI model now determines the number of tags

available for the Files > Tags > Import > Use only already existing tags of a database setting.

Pro — Database searches are faster across the board, from the Chat assistant to smart

actions and scripting, with notable gains for local AI models.

Pro — Web and Wikipedia searches via the Chat assistant, AI smart actions, and AppleScript

commands now also use the Ecosia and Yahoo search engines and better filter results from

Bing and Brave.

Pro — All AI responses, whether from summarization, transformation, script commands,

or the Chat assistant, now undergo sanitization to remove potentially insecure content.

Tool call names are stripped from the input, web page downloads are restricted to non-

document queries, and the Chat assistant disables downloads after accessing item contents,

annotations, or comments.

Pro — DEVONthink more reliably handles broken links and item links, e.g, returned by OpenAI's

gpt-oss model.

Pro — Google's Gemini models now automatically use the latest versions of their Flash Lite,

Flash, and Pro models

Pro — The The Devonian Times and Research Overview templates now default to Claude 4.5

Sonnet when Claude is the selected AI provider.

Pro — All Perplexity Sonar models now support vision capabilities.

Pro — The Magistral Small and Medium models use version 1.2 now, adding vision support and

expanding the context window to 128,000 tokens.

Pro — Tool calls with Mistral and local AI are simplified and improved.

Pro — Ollama (Remote) now supports API keys, e.g., for the new Ollama Cloud.

Pro — The OpenAI (Compatible) option now works with a broader range of providers and

models, including those managed by universities and other institutions.

Pro — Qwen Code Plus is now available via OpenRouter in the Script Assistant.
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Pro — The download image with prompt AppleScript command clearly reports an error if the

provided image data is not an image.

Pro — We improved the as property descriptions for the chat response for message and

add custom meta data commands.

Sync — The Reading List sidebar and custom metadata now sync more reliably via Bonjour.

Sync — DEVONthink now detects the battery and thermal state of the machine and

automatically throttles CPU and I/O load during synchronization when necessary.

Thumbnailing many small documents could sometimes cause a crash. Fixed.

Converting rich text documents or emails to paginated PDF documents could intermittently

freeze on macOS Tahoe. Fixed.

Invalid relative image and transclusion links in Markdown could break document previewing or

conversion, or crash the application. Fixed.

Links entered in lists in Markdown documents didn't work properly in WYSIWYG mode. Fixed.

Markdown headings containing code didn't display with correct colors. Fixed.

Links pasted into Markdown lists did not use the correct color. Fixed.

Searches with proximity operators didn't always highlight hits in PDF documents. Fixed.

In macOS dark mode, text entered in new HTML documents didn't invert to white. Fixed.

Tools > Summarize Annotations and the summarize annotations of records AppleScript

command sometimes returned annotations in the wrong order, such as those made by

PSPDFKit. Fixed.

Web clipping via the Sorter when opened with the keyboard shortcut incorrectly included

Safari's profile name. Fixed.

Images dropped or pasted into Markdown documents with the Files > Markdown > Import

images to group setting enabled didn't apply the Files > Import > Recognition or Files > Tags >

Import settings. Fixed.

Documents moved or duplicated between databases incorrectly added the extension to the

internal name and document could be renamed with an empty name if General > Appearance >

Show filename extensions was enabled. Fixed.

Duplicate notifications from the Extras sidebar occurred when multiple main windows were

open. Fixed.

The AppleScript dictionary incorrectly defined and described the root of main windows.

Fixed.

The internal name of files created via AppleScript incorrectly retained the extension. Fixed.

Pro — Loading the Model pop-up menu in the AI > Chat settings could sometimes cause a

crash with local AI providers. Fixed.

Pro — Claude AI wasn't working anymore in the Help assistant. Fixed.

Pro — Retrying a chat in the Help assistant failed after reopening the panel. Fixed.
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Pro — The Chat assistant and chat response popovers, such as Summarize, didn't render code

blocks or multiple tildes correctly. Fixed.

Pro — The Reveal command in the item link pop-up menus of the Data inspector or sheet form

view always opened a new window. Fixed.

Pro — AI responses in the Chat assistant, AI smart actions, or the get chat response for

message AppleScript command could stall if required items became unavailable, such as when

an item was deleted or its database closed. Fixed.

Pro — Image engines supporting image editing stopped working after creating two images.

Fixed.

Pro — The OpenAI (Compatible) option in the AI > Chat > Provider settings incorrectly required

/v1/ in the URL. Fixed.

Pro — In the German localization, the OCR > PDF Resolution setting couldn't be changed. Fixed.

Pro — In batch processing, the popovers in the Chat - Query and Chat - Continue if smart

actions failed to initialize correctly after switching configurations. Fixed.

Sync — Bonjour synchronization could sometimes cause memory issues. Fixed.

Pro — We replaced no longer functioning models and outdated models from the OpenRouter

options.

VERSION 4.1 EUROPA

Here it is, the first feature release for DEVONthink 4. Choose from a much wider range of server-

based AI models via OpenRouter or by connecting to just any OpenAI-compatible provider.

Integrate models from, e.g., Amazon, Meta, Microsoft, xAI, Baidu, Moonshot AI, Qwen, and more.

In addition, DEVONthink Europa adds native support for Claude 4.1 Opus, Gemini 2.5 Flash Lite,

OpenAI GPT-5, Google Imagen 4, and the latest models by Mistral. Connect to your institution's

Ollama installation with a new configuration option.

To further automate your work, describe your task to the the AI-powered script assistant. It

generates AppleScript and JavaScript for Automation (JXA) scripts and even corrects common

scripting issues. Edit images, both generated or dropped in from other sources, with prompts

using common AI image generation models. As generative AI is notoriously bad at maths, the

Chat and other AI-assisted functions now support mathematical functions, and if you're working

in academia, retrieval-augmented generation (RAG) gets direct access to the huge document

collection on arXiv. In addition, DEVONthink Europa comes with a new Quick Look extension

for previewing Spotlight results on macOS Sequoia and later, and more responsive editing of

especially larger Markdown documents. It also updates and sorts lists and empties the trash

significantly faster.
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Note: This version is named after Europa, Jupiter's fourth-largest moon. It is a captivating

world encased in an icy shell that hides a global subsurface ocean, one of the most promising

locations for extraterrestrial life in our solar system. Discovered in 1610 by Galileo Galilei, its

name, rooted in Greek mythology, reflects its enduring allure as a symbol of curiosity and the

unknown.

A new script editor, opened via Data > New > Script lets you draft different DEVONthink

scripts, e.g., for reminders or smart rules.

A new Quick Look plugin lets you preview documents in, e.g., Spotlight searches on macOS

Sequoia and later. This only supports standard file formats: rich and plain text, PDF, HTML,

XML, images, audio, and video.

A new search criterion Kind is PDF+Text serves as a shortened form of Kind is PDF/PS and

Word Count > 0. Additionally, the toolbar search syntax is kind:pdf+text, its negated form

kind:!pdf+text.

Added a placeholder to the alarm text field in the Info > Annotations & Reminders inspector.

The Zettel-ID external script for the Script with Input/Output smart rule action pull this

information from Markdown metadata.

The AppleScript record class supports the new read-only properties language and markdown

source.

Pro — Support for OpenRouter is available in the AI > Chat settings and the AppleScript suite.

This provides access to some AI models that aren't natively supported. Currently accessible

models are from: Amazon, Anthropic, Google, Meta, Microsoft, Mistral, OpenAI, Perplexity, xAI,

Baidu, Deepseek, Moonshot AI, Qwen, zAI, noting we aren't providing access to beta, preview,

experimental, outdated, or distilled models. The Help assistant, as well as the Research

Overview and Mixture of Agents - Text/Markdown templates, also support OpenRouter.

Pro — Added support for OpenAI's GPT-5 models. Currently much less expensive than the 4.1

models, it does have a much smaller context window of 400,000 tokens but supports more

output tokens and has been trained on more up to date information. Due to the lower costs,

web searches are filtered with GTP-5 Nano.

Pro — Added support for Anthropic's Claude 4.1 Opus.

Pro — Added support for Mistral's Voxtral transcription to the AI > Transcription settings.

Currently, this uses Voxtral Mini and is less expensive than OpenAI's speech-to-text models.

Pro — Added support for Google's Imagen 4 Ultra in the AI > Image Generation settings, the

Generate Image window, and accessible via the download image for prompt AppleScript

command. A Replicate.com account is required to use this model.

Pro — Added vision support to the Perplexity models Sonar, Sonar Pro, and Sonar Reasoning.

Pro — Added Ollama (Remote) the Chat > AI > Provider settings and renamed "Ollama" to

Ollama (Local). This allows you to access Ollama running on a network, e.g., at a company
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or university. The remote provider is also supported in AppleScript, e.g. by the get chat

response for message command.

Pro — Added a script assistant, available in the Script Editor window, smart actions Apply

Script and Script with Input/Output, or reminder scripts. Describe the action you need and a

code-compatible AI model will provide a draft script to get things started.

Pro — Save all images in a chat with the Save All Images context menu of the Chat assistant,

available if the current chat contains more than one image.

Pro — The Generate Image window can now modify a generated image or one dropped or

pasted into the window. Also, images generated via the Chat assistant can be modified. And

as the Chat popover is persistent between launches, you can modify an image in it at a later

time. Currently, this function is only available with certain models: Flux Schnell, Pro, Pro Ultra,

Stable Diffusion Large or Turbo, and GPT-Image-1.

Pro — The Generate Image window now displays a history of created images.

Pro — Given the poor calculations produced by LLMs, a new tool lets the Chat assistamt,

smart actions, and AppleScript commands evaluate mathematical expressions.

Pro — Added the new The Devonian Times template, summarizing today's news via AI.

Pro — Added the arXiv site as a search option the the AI > Chat settings.

Pro — Added a Language menu to the AI > Summarization settings.

Pro — Added a new built-in smart rule, Apply Chat Suggestions. This applies seven common

AI suggestions to matched documents, e.g., tagging, summarization, etc., utilizing placeholders

and one AI request. This rule can be duplicated and modified to suit your needs.

Pro — The Chat assistant, smart actions like Chat - Query, and the download chat

response for message AppleScript command can download links in various formats (HTML,

Markdown, text, snapshot). The format is automatically chosen, either by the AI or depending

on the user's prompt. Currently, this only works with commercial models.

Pro — The new AppleScript property current chat model returns the default model.

Pro — The new get chat capabilities for engine… model AppleScript command

retrieves the capabilities of a specific AI model.

Pro — The get chat response for message AppleScript command now has a usage

parameter to improve results or control the costs of using external AI.

"Audit-proof" databases have been renamed to Revision-proof.

Editing very long Markdown documents is more performant. DEVONthink detects links in

Markdown documents at least 25 times faster when syntax coloring and WYSIWYG is enabled.

Markdown WikiLinking now supports [[link|-]] to use the title of a linked item. This can be

useful when using short aliases for linking.

Prism.js renders Objective-C code marked with the alternate objc or language-objc as well

as the default language-objectivec.

DEVONthink indexes web-based documents and converts them to plain text better.
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The Go > To Document and Edit > Insert > Item Link popovers now search after a short delay to

avoid interfering with typing.

Updating or sorting by name or kind in item lists is up to ten times faster, including in popovers

such as Go > To Document.

Editing annotations in the Info > Annotations & Reminders inspector now supports versioning.

The Data > Move > Put Back command as well as its context menu counterpart display the

destination when only one item is selected.

For quicker sorting, the Ascending and Descending commands are now at the top of the View

> Sort menu and the sort popup menu in the Information bar of main windows.

The Add and Preview buttons in the Sorter now display their shortcut keys when you hold the

Command key.

In the Sorter's Voice Note and Video Note tabs, the camera and microphone menu is disabled

if DEVONthink is disabled in macOS' Privacy & Security > Camera settings.

Emptying the Trash is up to five times faster when versioning is not enabled.

DEVONthink's built-in folder action scripts now run smart rules using the perform smart

rule AppleScript command with the On Import and On OCR event triggers, as appropriate.

Querying tags via AppleScript is now supported, e.g., tags contains "support" or where

its tags contains {"2025","documentation"}.

Records now support the sheet-related AppleScript commands get cell at row/column,

set cell at row/column, add row cells, and delete row at position.

The AppleScript database property "audit proof" is now revision proof. However, audit

proof has been added as a synonym to ensure backwards-compatibility.

Pro — Summarizing documents to annotations, e.g., via Edit > Summarize via Chat or Tools >

Summarize Documents via Chat, first saves a version when versioning is enabled.

Pro — The Research Overview template now supports local AI engines and models having tool

call support and a context window of at least 32,000 tokens.

Pro — The notification of a chat-summarized RSS article is simpler when only one article is

involved.

Pro — The search assistant now accepts local AI models with a context window of at least

8,000 tokens.

Pro — In the Import > Image Capture sidebar, the Group menu now has a search field for

quickly locating groups. Also, the destination settings are saved after each scan and restored

when reconnecting to the scanner.

Pro — The From date in the Import > Emails sidebar now defaults to the last used To date.

Pro — The Chat assistant better handles detecting selected documents, especially when using

the Chat popover.

Pro — AI-directed features using web, Wikipedia, and PubMed searches are more efficient,

filtering out excess or links already processed by concurrent searches. This affects e.g., the
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Chat assistant, smart actions, and AppleScript commands, and could speed up responses and

minimize token usage.

Pro — The Chat assistant's progress indicator more clearly shows chat activity, e.g., searching

or downloading resources.

Pro — The Chat assistant doesn't scroll a received chat response out of sight anymore.

Pro — Prompt fields across the application, e.g., in the Chat assistant, the Generate Image

window, and the Help assistant, now support using ⇧↩ in addition to ⌥↩ for inserting a line

break.

Pro — The model menu in the Chat assistant features a search field if more than 25 items are

available.

Pro — Search request made to Google, Bing, and Brave via chat functions, e.g., the Chat -

Query action or prompts in the Chat assistant are more reliable. DEVONthink also handles

Mistral's rate limits better.

Pro — Bulk processing items via chat, e.g., tagging or summarizing, uses better error handling.

Pro — Chat tools calls for local AI models have a reduced temperature for more reliable results

and can now download web pages as needed. In addition, the Chat assistant handles errors

better.

Pro — Irrelevant PubMed and arXiv search results are now filtered in all AI functions, e.g., in

the Chat - Query smart action, maintaining the context of the current conversation. For

commercial providers, the least expensive model is used for filtering. Additionally, once enough

results have been received from these site and Wikipedia, other pending evaluations are

cancelled, saving both tokens and time.

Pro — Chat suggestions in smart actions, e.g., suggested tags, are more reliably retrieved.

Pro — The download image for prompt AppleScript command now reports an error if the

specified model doesn't support image editing. When using the Flux engine, the Flux Kontext

models are used as they are built for image editing, not just generation.

Pro — Updated Gemini 2.5 Flash to the final version.

Pro — Both filtering web search results and the Help assistant use now Gemini 2.5 Flash Lite.

Pro — Updated Google Image 4 to final version and is used in the Mixture-of-Agents - Images

template.

Pro — Both AI > Mixture-of-Agents templates no longer use Perplexity due to an increase in

irrelevant responses.

Pro — Updated Mistral Medium to version 3.1. Mistral Large 3 has better vision support. And

"Mistral AI" has been renamed to Mistral in the AI settings and Chat assistant.

Pro — The default context window set by DEVONthink for Ollama is now 16,000 tokens.

Pro — The "GPT4All" provider has been renamed to OpenAI (Compatible) and can be used

connect to any compatible remote services. It also now supports an API key, affecting the AI

settings, menus and related AppleScript commands.
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Pro — Improved compatibility of chat-based smart actions with LM Studio's MLX models, e.g.,

Gemman 3n.

Server — Improved HTTP handling, should also address a rare crash.

Markdown lists didn't render properly when indented with one space. Fixed.

Thumbnailing Markdown documents could cause a rare crash. Fixed.

Scrolling Markdown documents was affected after pasting copied text, changing margins, or

syntax highlighting. Fixed.

Remote images in Markdown documents didn't render in WYSIWYG mode if the files didn't

have a valid file extension. Fixed.

Markdown MathJax equations in Asian text didn't render properly. Fixed.

Indexed Google Drive documents couldn't be opened via the Data > Open With command.

Fixed.

Links using Apple Notes' URL scheme couldn't be clicked in documents. Fixed.

For RSS and Atom feeds with multiple authors, only the first was used. Fixed.

An open Quick Look panel didn't update when changing the selection of the view/edit pane

when General > Interface > Preview group content was enabled. Fixed.

In the item list in List view, the Tags column didn't display autocompletion results. Fixed.

The tooltip shown when hovering over items with truncated names didn't fully display the

name if the item also had property icons. Fixed.

Groups with a custom icon and applied color displayed differently in different parts of the

interface, e.g., the item list and context menu. Fixed.

In the Navigate sidebar, you could only drag and drop multiple favorites, smart groups, or

smart rules by the icon, not the name. Fixed.

The First, Previous, Next, and Last commands in the Go menu couldn't be used in toolbar

search results. Fixed.

The search field in the context menu and destination popups, e.g., in the Sorter, didn't sort the

results by relevance. Fixed.

In a multi-monitor setup with vertically positioned screens, the Sorter was only partially visible

as a docked tab. Fixed.

The item count in the Database Properties window incorrectly included saved versions. Fixed.

The internal versions group was incorrectly made visible in the Sorter. Fixed.

The Spotlight index for a database could incorrectly contain document versions. Fixed, though

rebuilding the Spotlight index via Database Properties may be needed.

.strings files weren't indexed correctly, potentially affecting versioning of AppleScript

modified files. Fixed.

The Scan Text smart rule action didn't ignore Markdown metadata if there was no other

content in the document. Fixed.
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If the DEVONthink helper background task crashed, other background tasks, e.g., running

scripts, could be blocked for a period of time. Fixed.

Pro — Processing multiple documents via the Chat assistant could sometimes crash the app.

Fixed.

Pro — Timestamps weren't properly restored when revisiting the Chat assistant. Fixed.

Pro — Replies in the Chat assistant could contain improperly escaped Markdown. Fixed.

Pro — The (AI) suffix on an AI-generated document names could be misplaced if the name

already had a file extension. Fixed.

Pro — Claude 3 Haiku responses in the Help assistant often included invalid links. Fixed.

Pro — Switching to Mistral in the Help assistant and resending the last chat message failed.

Fixed.

Pro — AI-generated web searches containing multiple site: operators didn't work correctly.

Fixed.

Pro — Item links or WikiLinks to groups weren't supported in the AI > Graph inspector. Fixed.

Pro — The AI > Graph inspector could incorrectly display a connection line to a hidden

(disabled) node. Fixed.

Pro — In the popup of URL fields in the Info > Data inspector and the form view of sheets, the

Paste and Remove commands neither saved changes nor updated the layout. Fixed.

Pro — In the Import > Emails sidebar, nested iCloud mailboxes were duplicated at the account's

top-level. Fixed.

Pro — Search queries using date-based custom metadata weren't always parsed correctly.

Fixed.

Pro — Some item properties, e.g., the URL or UUID, couldn't be retrieved by AI in the Chat

assistant, smart actions, or the get chat response for AppleScript command. Fixed.

Pro — The prompt for Scripts > Chat > Geolocate Image was incorrect. Fixed.

Pro — The get chat response for message… as HTML AppleScript command could return

incorrectly mapped links. Fixed.

Pro — Gemini 2.5 Pro didn't work with the get chat response for prompt AppleScript

command when thinking was disabled. Fixed.

Server — The icons in the Server > Users settings didn't look correctly in dark mode. Fixed.

Pro — Removed Data > New from Template > AI > Script Assistant as it has been replaced by

the Script Editor and Assistant.

Pro — Removed support for Google's Imagen 3 (Fast) AI model.

Pro — Removed support for Anthropic's Claude 3.7 Sonnet and Claude 4 Opus AI models.
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VERSION 4.0.2

This maintenance release introduces support for Google Imagen 4 (Preview), along with several

improvements and fixes. We enhanced handling of relative links in Markdown documents to allow

spaces, and we corrected an issue with list indentation. We also improved document language

detection, which can influence Chat-suggested properties like tags. The Favorites section, e.g.,

in the Move To context menu now correctly lists all favorited groups. Colored groups also show

their designated colors in more locations, such as the Path bar. For AI features, we expanded the

prompt field in the Chat and Help assistants to accommodate longer prompts. We extended the

timeout period for image generation, and queries will retry up to two times when necessary. As

always, we focused on increasing the application's stability and reliability.

Pro — Added support for Google Imagen 4 (Preview), accessible in the AI > Image Generation

settings, Data > New > Generate Image window, and the download image for prompt

AppleScript command.

Image links in Markdown documents now support relative URLs containing spaces without

requiring percent-escaping.

Custom colored groups now display in color in more places in the interface, e.g., the Path bar.

DEVONthink better detects the language of documents, whether you import, index, or create

them within the application. This can also improve results of chat-based features of the higher

editions, e.g., tag suggestions or summarization.

Pro — The prompt field in the Chat and Help assistants can now use up to one-third of the

pane's height.

Pro — The Chat assistant, chat-driven smart actions, and the get chat response for

message AppleScript command now perform two retries, as needed. Additionally, the Chat

assistant now shows a message when retrying queries.

Pro — Image generation requests run longer before they timeout.

Pro — Using engine GPT-Image-1 with the AppleScript command download image for

prompt now supports the image parameter.

Pro — Using Pico AI Server now supports vision for Gemma 3. We also reduced extraneous

logging.

Server — In the web interface, only groups with sub-groups display a disclosure triangle.

Line items in Markdown lists indented with 4 or more spaces didn't render correctly. Fixed.

Images and PDF documents dragged from the Finder into DEVONthink between two Macs

connected via Universal Control would be renamed on import. Fixed.

Copying section links in EPUB documents via the Table of Contents inspector didn't include

anchors. Fixed.
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After inserting or deleting pages in a PDF document, the title of main and document windows,

and the subtitle of document windows didn't reflect the changed page count. Fixed.

Toolbar searches using the size: search prefix would fail if they contained spaces, e.g., size>

5 MB. Fixed.

Switching away from the AI > Tags inspector to another part of the interface would

unnecessarily sound the system beep. Fixed.

The Favorites section in the Move To, Duplicate To, and Replicate To context menus and

Destination popups, e.g., in the Sorter, only displayed the first favorited group. Fixed.

.applescript files couldn't be used as external smart rule scripts due to an AppleScript error.

Fixed.

Sync — Databases with names containing, e.g., "GoogleDrive", "Google Drive", or "OneDrive"

couldn't be created or imported from sync locations. Fixed.

Pro — Nested IMAP mailboxes incorrectly appeared in the top-level mailbox in the Import >

Emails sidebar. Fixed.

Pro — The Label menus in the Info > Generic inspector, Info filter pane, and the context menu

of the Navigate sidebar incorrectly contained the Chat Suggestion command. Fixed.

Server — PDF documents didn't load in the web interface in Safari. Fixed.

Server — In the web interface, EPUB documents couldn't be navigated via the table of

contents. Fixed.

Server — Sorting the item list on the Size column sorted incorrectly and the Modified column

sorted in the reverse direction, ascending or descending. Fixed.

Server — The item list and view/edit pane didn't scroll at the same rate. Fixed.

VERSION 4.0 COPERNICUS

Our fourth major release — DEVONthink 4.0 Copernicus — brings a host of powerful new features

and improvements. DEVONthink now supports external AI providers, both commercial and

local AI, as a complement to its own internal engine and implemented with privacy and data

safety in mind. You can also write search queries in natural language, let the AI summarize or

transform text, and extract text from images or handwritten notes. Use speech-to-text to

transcribe and save the speech from media files. You can even create images using AI, directly

within DEVONthink.

Store important legal or financial documents in audit-proof databases and as PDF/A. Text in

PDFs without text layer and in images is searchable without OCR, and versioning lets you return

to previous versions of a document. Edit a document's table of contents, adjust spacings, and

fine-tune the WYSIWYG display for Markdown. Organize your favorites, smart groups, and smart
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rules into groups. We also added new inspectors, most notably a graph that visualizes document

relationships. The rewritten web interface of the Server edition is built on a modern foundation,

more powerful yet easier to use.

For automators of any skill level, there are new and improved smart actions, including some

utilizing AI, as well as many new AppleScript commands. Batch processing now lets you save and

reuse configurations.

Note: DEVONthink now requires macOS 13 Ventura or later.

Note: We're dedicating this version to the Copernicus lunar crater and its namesake, the

Polish astronomer Nicolaus Copernicus (1473–1543), who revolutionized our understanding of

the universe. Contrary to the prevailing view that the Earth was the center of everything, he

proposed that the Sun revolved around the Earth. This crater, with its rays extending across

the lunar surface, is as notable as the groundbreaking ideas of the man it honors.

Document versioning lets you preserve certain states of documents you're editing. Examine or

restore saved versions from the new Versions inspector.

Audit-proof databases, a new type of databases, prohibit modifying documents placed into

them, often necessary for legal or financial documents.

Create archival PDFs in PDF/A-2 format via: Data > Convert > to Flattened PDF (with

Annotations burnt in), Convert (& Continue) smart actions, and the convert record

AppleScript command.

Create new PDF bookmarks with the Add to Table of Contents command in the context menu

of the view/edit pane, Content > Thumbnails inspector, and the Data > Add To menu.

The new batch processing window allows you to create your own library of reusable

configurations.

Browse the built-in help in the new Help viewer with built-in navigation and search. With

the higher editions, you have access to an assistant for chatting with AI about all things

DEVONthink, even in languages other than English.

Toolbar searches have a new Related Words option, considering also words contextually similar

to your entered search terms.

A new Tags inspector shows current, related, and suggested tags for the selected document. It

also displays a graph of relationships for a selected tag.

The Destination and Location popup menus in the Sorter or View > Import section controls,

as well as the context submenus for Move To, Duplicate T, and Replicate To, now have a search

field at the top for more efficiently locating groups. Additionally, the location of potential

matches is shown in macOS 14.4 Sonoma and later.

Add reminders to selected items with the Remind Me command available in the Data and

contextual menus.
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Data > Move To > Put Back returns moved, classified, or trashed items back to their previous

location. This command is also available via the context menu.

Apply tags automatically with the new menu command Data > Tags > Assign Existing Tags. It

uses DEVONthink's internal AI to look for tags on similar documents or find tags within the

name and text and apply them automatically.

Typewriter-like scrolling keeps the currently edited line in the center of the document window.

Enable or disable this feature via the Format menu or in the Editing > Format settings.

Change the scope bar options of toolbar searches with key commands. Press ⌃⌥1 through 4

while a search is active.

Choose whether you want to show the documents contained in a selected group in the view/

edit pane with the General > Interface > Preview group content setting.

The General > Appearance settings allow assigning colors for duplicate and replicated items.

The Editing > Format settings let you control margin, line spacing, and maximum line widths.

We added Update name of WikiLinks in square brackets automatically to the WikiLinks

settings.

Disable automatically loading bookmarks with the Files > Preview > Automatically load

bookmarks setting. This might help avoiding issues with problematic bookmarks.

We added the option Files > Import > Use content creation & modification dates to use dates

from a document's content instead of filesystem dates.

Disable or enable sending anonymized usage data via the General > General > Usage: Send

anonymized analytics data setting. See our company's Privacy page for more information on

the data that may be sent.

The menu command Help > Hidden Preferences lets you more easily access rarely used

settings.

We added many new smart actions, e.g., Script with Input/Output for processing and

passing data, Set Script Input that holds data to be passed to the action, and a batch

processing action, User Input that allows you to enter information each time the automation

runs.

We also added new placeholders, e.g., User Input holding the text you entered with the batch

processing action of the same name, Script Output with the return value from the Script

with Input/Output smart action, and Original Name using the originally imported name of

a document.

And we added many external scripts for use with the Script with Input/Output smart

action, e.g., Text - Lowercase/Uppercase and Daily Quote, that execute and pass the

result to the next actions.

Add text to an existing document, by inserting, appending, or replacing the existing content,

with the powerful update text AppleScript command.

Install some popular script libraries from Late Night Software, e.g., Dialog Toolkit Plus, via the

DEVONthink > Install Add-Ons panel.
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Pro — DEVONthink can access external AI engines — both commercial and local models — in a

complementary but powerful role to its internal AI. Currently supported commercial services

are the latest models of: ChatGPT, Claude, Gemini, Mistral AI, and Perplexity. Supported

local AI applications are GPT4All, LM Studio, and Ollama. Depending on the capabilities of

each model, DEVONthink supports these AI functions: vision, tool calls, reasoning, and deep

research.

Pro — A new Chat assistant lets you interact with external AI engines in a variety of ways,

from document examination to impromptu inquiries. You access it in a new Chat inspector and

Chat popover. Copy or save your chats as a document for later reference, if needed.

Pro — We added a new suite of AI-driven templates in the Data > New from Template > AI

submenu. These cover a variety of use cases, like deep research, image creation, story writing,

and transcribing media and other documents into meeting notes.

Pro — Using Apple's Vision framework, DEVONthink will index certain PDFs on import, e.g.,

those with no text layer, an incomplete one, or with unintelligible content. This makes PDFs

searchable without doing OCR explicitly. You can disable this behavior with the Files > Import >

Transcribe PDF documents setting.

Pro — Via AI, DEVONthink can recognize text in images, including some handwriting, and

speech converted to text in media documents. The results can be stored as searchable text,

Finder comments, or in an annotation document.

Pro — The Data > New > Generate Image command lets you create images via your chosen text-

to-image AI engine without leaving the application.

Pro — A new Search Assistant popover lets you write search queries in natural language and

convert them to DEVONthink's search language via AI.

Pro — The annotation commands in the Annotations > Reminders popup menu give you the

option to insert AI-generated summaries. For images and media files that have recognized text

saved as Searchable Text, you can insert the transcription.

Pro — The menu command Edit > Summarize via Chat opens the Summarize popover for a

selected document.

Pro — Summarize selected documents via AI using Tools > Summarize Documents via Chat.

Output to a chosen format, e.g., rich text or a Finder comment.

Pro — The new Data > Recognize submenu gives you AI commands recognizing text and notes

or barcodes in an image or transcribing speech-to-text.

Pro — New commands in the Data menu's Rating, Label, and Tags submenus let you use AI to

change the metadata on selected files.

Pro — The new Graph inspector displays a variety of relationships for a selected document,

e.g, WikiLinks, item links, mentions, etc.

Pro — Produce auditing records listing the import, renaming, and deletion history of the

contents of an audit-proof database via new commands in the File > Export and Tools menus.
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Pro — We added functions for importing email attachments, including Tools > Import

Email Attachments, Files > Emails > Import attachments in the settings, and the import

attachments of record AppleScript command.

Pro — The new AI settings pane lets you control various AI functions: Chat for setting up your

default AI engine, Summarization to setup how summarization is done, Image Generation, and

Transcription.

Pro — We added a Chat Font Size option in the General > Appearance settings to change the

font size in AI-related actions, e.g., in the Chat assistant or the Summarize and Transform

popover.

Pro — We added a Recognition section to the Files > Import settings, containing options for

processing incoming documents with AI, e.g., to transcribe media files or PDFs.

Pro — The new setting Files > Tags > Import: Add Chat suggestion to documents lets you use

AI to examine a document and add tags to it. You can limit the suggestions to already existing

tags.

Pro — Import messages or mailboxes from Apple Mail or Microsoft Outlook with key

commands that you set up in the Files > Emails settings.

Pro — The new batch processing window offers several built-in configurations using AI in a

variety of ways, e.g., classifying documents or renaming a document based on its content.

Pro — Use AI-driven smart actions, e.g., Chat - Query for general AI queries, and the

conditional Chat - Continue if action that only continues running with a positive response.

Pro — Run OCR and use the created document for subsequent actions using the OCR &

Continue smart action.

Pro — We added new Chat Suggestions placeholders that DEVONthink resolves using AI, e.g.,

Price, Company, or Summary.

Pro — Several new AppleScript commands let you use external AI, e.g., get chat response

for message, download image for prompt, and transcribe record. These commands

also include many deep parameters, e.g., model, temperature, and thinking, to create very

detailed AI interactions.

Pro — The new Chat category of the Scripts menu provides you with some useful example

scripts.

Markdown documents now support live scrolling in Side-by-Side view and the rendering

updates as you edit. Also, WYSIWYG editing now displays image links as images and hides raw

URL data in the Markdown source.

Quickly create crosslinks between documents by typing >> and choosing from suggested

matches.

Square bracket WikiLinks now support alternate names and section anchors, e.g.,

[[Technical Note 15040|Email Issues#remedies]].

Toolbar search results now support using the View > Show/Hide Details command to let you

toggle displaying the matched item's location.
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Toolbar searches are now more forgiving with some syntax, internally correcting it as needed.

You now can group your custom items in the Navigate sidebar, e.g., your favorites, smart rules,

etc.

We relabeled some inspectors: "See Also & Classify" is now See Also, "Custom" is now Data.

The Info inspectors now include the Annotations & Reminders inspector.

Reminders now launch DEVONthink one minute before an alarm is set so you no longer need to

keep it running all the time. Also, the alarms now include Send Email with Item Link and a new

Send Email with Attachment, allowing you to email the document directly.

You can edit the outline in the Content > Table of Contents inspector. For text-based

documents, e.g., rich text, moving sections in the inspector moves the document contents as

well.

When you use the Data > New > With Clipboard command, it more intelligently creates a

format appropriate to the type of data on the clipboard, e.g., a Markdown document when it

detects Markdown content.

We reorganized the Settings panes to keep similar functions and concepts together. This

reorganization has produced some new panes, e.g., the Files > Tags settings, as well as many

updates to others, like setting label colors in the General > Labels view.

You can assign colors to groups via the Generic inspector or Info popover.

You can modify file dates and more types of custom metadata, e.g., currency, via smart rules

and batch processing, including using AI suggested values.

When the Verify & Repair Database command finds errors, they are now shown in a more

informative window. When relaunching after a crash or force quit, DEVONthink will attempt to

resolve errors it can.

We have modernized and improved the AppleScript support. It comes with better JXA

support, a new dictionary with code examples, new commands, properties, and parameters,

and optimizations greatly improving the performance of filtering clauses, e.g., whose and

where.

We've also made many subtle cosmetic changes to DEVONthink including updating many

icons, like property icons, special group icons like Contacts, and updated toolbar icons.

Pro — Email handling now uses AppleScript and shows more accurate mailbox structures

which also load more quickly in the Import > Emails sidebar. It also shows unread email counts

per-mailbox, similar to Apple Mail.

Pro — The rewritten File > Import > References from Bookends command uses Bookend's

improved AppleScript support and pulls in more information.

Server — We replaced the web interface with a rewritten, much more modern version, new

login page, support for displaying more file formats, handling more data, and more robust

interaction with DEVONthink.
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Server — In the Server > Users settings, logged in users have an indicator next to their

username. You can also set a Session Expiration to automatically log out idle users.

Sync — The approximate size of an encrypted database is now included in the sync data and

used as the default size when importing the database on another Mac.
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LICENSE AGREEMENT

PLEASE READ THIS LICENSE CAREFULLY

BEFORE USING OUR SOFTWARE. BY USING

THE SOFTWARE, YOU ARE AGREEING TO

BE BOUND BY THE TERMS OF THIS END

USER LICENSE AGREEMENT. IF YOU DO NOT

AGREE TO THE TERMS OF THIS LICENSE

YOU MUST DELETE THE SOFTWARE FROM

YOUR DEVICES.

1. LICENSE

The application and other components

(e.g. graphics, sounds) governed by

this License (the "Software") and the

related documentation are licensed to

you by DEVONtechnologies. You own

the devices on which the Software is

stored but DEVONtechnologies and/or

DEVONtechnologies' licensor(s) retain title to

the Software and related documentation.

1.1: This License allows you to use the

Software on the number of devices owned

or controlled by you, defined by the number

of Seats purchased for the License or, for

the App Store, by Apple. A Seat is a physical

device capable of running the Software. This

License does not limit the number of people

using the Software on the device.

1.2: Licenses purchased directly from

DEVONtechnologies can be resold in

compliance with European Union law.

Licenses purchased in the Apple App Store

are non-transferrable.

2. RESTRICTIONS

2.1: The Software contains copyrighted

material, trade secrets and other proprietary

material and in order to protect them

you may not decompile, reverse engineer,

disassemble or otherwise reduce the

Software to a human-perceivable form.

2.2: You may not sublicense, modify, rent,

lease, or create derivative works based upon

the Software in whole or in part. You may not

distribute the Software in any form.

3. MAINTENANCE AND SUPPORT

DEVONtechnologies provides support for

the Software with respect to this license

agreement or as required under applicable

law. Apple has no obligation whatsoever

to furnish any maintenance and support

services with respect to Software.

4. DISCLAIMER OF WARRANTY ON

SOFTWARE

4.1: You expressly acknowledge and agree

that use of the Software is at your sole risk.

The Software and related documentation

is provided "AS IS" and without warranty

of any kind. You acknowledge that

DEVONtechnologies, if technically and legally

possible, provides free trial versions of the

Software for evaluation.

4.2: DEVONtechnologies expressly disclaims

all warranties of any kind, whether express

or implied, including, but not limited to

the implied warranties of merchantability,

fitness for a particular purpose, and non-
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infringement. DEVONtechnologies is

responsible for warranties required by

applicable law.

If Software was purchased in the Apple

App Store and you notify Apple in case that

Software fails to conform to applicable

warranty, Apple will refund the purchase

price. To the maximum extent permitted

by applicable law, Apple will have no other

warranty obligation whatsoever with respect

to Software, and any other claims, losses,

liabilities, damages, costs or expenses

attributable to any failure to conform to any

warranty will be DEVONtechnologies' sole

responsibility.

4.3: Unless otherwise provided in Sect. 6,

DEVONtechnologies does not represent or

warrant to you that (a) the Software will

meet your requirements, (b) your use of

the Software will be uninterrupted, timely,

secure, or free from error, (c) any information

obtained by you as a result of your use of

the Software will be accurate or reliable,

and (d) that defects in the operation or

functionality of the Software provided to you

will be corrected.

4.4: No advice or information, whether

oral or written, obtained by you from

DEVONtechnologies shall create any warranty

not expressly stated in this License.

5. LIMITATION OF LIABILITY

5.1: UNDER NO CIRCUMSTANCES

INCLUDING NEGLIGENCE, SHALL

DEVONTECHNOLOGIES BE LIABLE FOR ANY

INCIDENTAL, SPECIAL OR CONSEQUENTIAL

DAMAGES THAT RESULT FROM THE USE

OR INABILITY TO USE THE SOFTWARE OR

RELATED DOCUMENTATION.

5.2: In no event shall DEVONtechnologies'

total liability to you for all damages, losses

and causes of action (whether in contract,

tort (including negligence) or otherwise)

exceed the amount paid by you for the

Software.

5.3: The aforementioned limitation of liability

also applies for the personal liability of

DEVONtechnologies' staff, contributors,

representatives, licensors, organs and their

members.

5.4: If you are domiciled in the Federal

Republic of Germany, the aforementioned

limitations of liability (Sect. 5.1 to 5.3) do

not apply for personal injury of life, body

and health, and for strict product liability

law. They do not apply in case the damage

is a consequence of the breach of a cardinal

obligation, an essential obligation, or a

warranty in the meaning of Section 444 of

the German Civil Code.

5.5: Liability for the breach of a cardinal

obligation or essential obligation is limited

to the amount paid by you for the Software.

Aforementioned limitation of liability with

respect to the amount you paid for the

Software does not apply in case of gross

negligence, wilful misconduct, personal injury

of life, body and health, the breach of a

warranty in the meaning of Section 444 of

the German Civil Code, other strict product

liability law. DEVONtechnologies remains

responsible for product liability according to

Sect. 44 a TKG (Telekommunikationsgesetz).
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5.6: The aforementioned limitations of

liability (Sect. 5.1 to 5.5) only apply as far as

permitted by law.

5.7: DEVONtechnologies is responsible for

addressing any claims of this License.

6. DEFECTS

6.1: DEVONtechnologies grants you a license

to the Software in its current version only.

DEVONtechnologies encourages you to use

the free trial version of the Software for

evaluation.

6.2: You cannot claim that a given state of

the Software will be achieved through an

update or a new version.

6.3: In the event that the Software does not

comply with express terms of this License

Agreement or there is a breach of these

warranties, if the usability of the Software

is affected severely and sustainably, or if

any bug or any severe anomaly could not

be detected during the use of the free trial

version, DEVONtechnologies may at its

option either replace the Software free of

charge to you or refund the purchase price.

7. INTELLECTUAL PROPERTY RIGHTS

DEVONtechnologies owns or licenses the

intellectual properties that Software is

based on. In case of third-party claims that

Software infringes third-party's intellectual

property rights, DEVONtechnologies is

responsible for the investigation, defense,

settlement and discharge of any such

intellectual property infringement claim.

8. GENERAL

8.1: Any changes, amendments, or the

abrogation of the agreement between

you and DEVONtechnologies, including

this License, require written form. The

requirement of written form can only be

waived in written.

8.2: This License constitutes the whole

legal agreement between you and

DEVONtechnologies with regard to the

Software, and completely replaces any

prior agreements between you and

DEVONtechnologies in relation to the

Software. Separate agreements may

apply for other software or services which

DEVONtechnologies may provide to you. If

the End User License Agreement available

on the DEVONtechnologies website differs

from this License, the online version has

precedence.

Apple, and Apple's subsidiaries, are third

party beneficiaries of the License, and, upon

your acceptance of the terms and conditions

of the License, Apple will have the right (and

will be deemed to have accepted the right)

to enforce the License against you as a third-

party beneficiary thereof.

8.3: You agree that you comply with

applicable third-party terms of agreement

when using Software.

8.4: You agree that if DEVONtechnologies

does not exercise or enforce any legal right or

remedy which is contained in this License, or

which DEVONtechnologies has the benefits

under any applicable law, this will not be
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taken as a waiver of DEVONtechnologies'

rights and those rights will still be available to

DEVONtechnologies.

8.5: If any court of law, having jurisdiction

to decide on this matter, finds that any

provision of this License is invalid, then this

provision will be removed from this License

without affecting the remaining parts of

this License. The remaining provisions of

this License will continue to be valid and

enforceable.

8.6: This License, and your relationship with

DEVONtechnologies with regard to the

Software, shall be governed by the laws of

Germany without regard to its conflicts

of laws provisions. The application of the

UN Convention on the International Sale of

Goods (CISG) shall be excluded.

8.7: The court of Besigheim, Germany,

shall have sole jurisdiction if you are a

businessman. In case you are a consumer,

the place of jurisdiction shall be Besigheim,

Germany, if you transfer your legal domicile

or regular residence to a place outside the

Federal republic of Germany, or your legal

domicile or regular residence are unknown

upon filing a legal action.

8.8: You agree and warrant that you are

not located in a country that is subject to

a U.S. Government embargo, or that has

been designated by the U.S. Government

as a "terrorist supporting" country; and you

are not listed on any U.S. Government list of

prohibited or restricted parties.

CREDITS

ABBYY FINEREADER ENGINE

ABBYY FineReader 11.x Engine Copyright

© ABBYY Software Ltd. OCR by ABBYY

Software House.

MULTIMARKDOWN

Copyright © 2016-2023 Fletcher T. Penney.

MultiMarkdown is released under both the

GPL and MIT licenses. You may pick the

license that best fits your needs.

Modifications to remove reliance on Glib2:

Copyright © 2011 Daniel Jalkut, licensed

explicitly MIT.

LyX export code © 2013-2014 Charles R.

Cowan, licensed under both GPL and MIT

licenses.

Portions based on: peg-markdown.

Copyright © 2008-2011 John MacFarlane.

ODF output code © 2011-2013 Fletcher T.

Penney. peg-markdown is released under

both the GPL and MIT licenses. You may

pick the license that best fits your needs.

Original Markdown specification by John

Gruber.

The GPL: This program is free software;

you can redistribute it and/or modify it

under the terms of the GNU General Public

License as published by the Free Software

Foundation; either version 2 of the License,

or (at your option) any later version. This

program is distributed in the hope that it will

be useful, but WITHOUT ANY WARRANTY;

without even the implied warranty of

MERCHANTABILITY or FITNESS FOR A

PARTICULAR PURPOSE. See the GNU General
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Public License for more details. You should

have received a copy of the GNU General

Public License along with this program; if

not, write to the Free Software Foundation,

Inc., 51 Franklin St, Fifth Floor, Boston, MA

02110-1301 USA

The MIT License: Permission is hereby

granted, free of charge, to any person

obtaining a copy of this software and

associated documentation files (the

"Software"), to deal in the Software without

restriction, including without limitation the

rights to use, copy, modify, merge, publish,

distribute, sublicense, and/or sell copies

of the Software, and to permit persons to

whom the Software is furnished to do so,

subject to the following conditions: The

above copyright notice and this permission

notice shall be included in all copies or

substantial portions of the Software. THE

SOFTWARE IS PROVIDED "AS IS", WITHOUT

WARRANTY OF ANY KIND, EXPRESS OR

IMPLIED, INCLUDING BUT NOT LIMITED TO

THE WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL

THE AUTHORS OR COPYRIGHT HOLDERS

BE LIABLE FOR ANY CLAIM, DAMAGES OR

OTHER LIABILITY, WHETHER IN AN ACTION

OF CONTRACT, TORT OR OTHERWISE,

ARISING FROM, OUT OF OR IN CONNECTION

WITH THE SOFTWARE OR THE USE OR

OTHER DEALINGS IN THE SOFTWARE.

PANTOMIME

Copyright © 2001-2009 Ludovic Marcotte.

SHORTCUTRECORDER

Copyright © 2006, contributors to

ShortcutRecorder. (See the contributors

listed in detail later in the file.)

All rights reserved. Redistribution and use

in source and binary forms, with or without

modification, are permitted provided that

the following conditions are met:

Redistributions of source code must retain

the above copyright notice, this list of

conditions and the following disclaimer.

Redistributions in binary form must

reproduce the above copyright notice,

this list of conditions and the following

disclaimer in the documentation and/

or other materials provided with the

distribution.

The name of the contributors may not

be used to endorse or promote products

derived from this software without specific

prior written permission.

THIS SOFTWARE IS PROVIDED BY THE

CONTRIBUTORS "AS IS" AND ANY EXPRESS

OR IMPLIED WARRANTIES, INCLUDING, BUT

NOT LIMITED TO, THE IMPLIED WARRANTIES

OF MERCHANTABILITY AND FITNESS FOR

A PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE CONTRIBUTORS

BE LIABLE FOR ANY DIRECT, INDIRECT,

INCIDENTAL, SPECIAL, EXEMPLARY, OR

CONSEQUENTIAL DAMAGES (INCLUDING,

BUT NOT LIMITED TO, PROCUREMENT OF

SUBSTITUTE GOODS OR SERVICES; LOSS

OF USE, DATA, OR PROFITS; OR BUSINESS

INTERRUPTION) HOWEVER CAUSED AND

ON ANY THEORY OF LIABILITY, WHETHER

IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE)
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ARISING IN ANY WAY OUT OF THE USE OF

THIS SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

Contributors to Shortcut Recorder, in no

order in particular:

Jesper, waffle software. Initial idea and

concept, first shot at implementation

using NSView.

David Dauer. Refinement, cleaner

reimplementation, documentation, IB

Palette.

Jamie Kirkpatrick, Kirk Consulting Ltd.

Further modularisation and re-factoring,

and general bug fixes.

Ilya Kulakov. ShortcutRecorder 2.0 and

further support.

Alexander Ljungberg. Graphics for

ShortcutRecorder 2.0

SPARKLE

Copyright © 2006-2014 The Sparkle Project

Permission is hereby granted, free of charge,

to any person obtaining a copy of this

software and associated documentation

files (the "Software"), to deal in the Software

without restriction, including without

limitation the rights to use, copy, modify,

merge, publish, distribute, sublicense, and/

or sell copies of the Software, and to permit

persons to whom the Software is furnished

to do so, subject to the following conditions:

The above copyright notice and this

permission notice shall be included in

all copies or substantial portions of the

Software.

THE SOFTWARE IS PROVIDED "AS IS",

WITHOUT WARRANTY OF ANY KIND,

EXPRESS OR IMPLIED, INCLUDING BUT

NOT LIMITED TO THE WARRANTIES

OF MERCHANTABILITY, FITNESS

FOR A PARTICULAR PURPOSE AND

NONINFRINGEMENT. IN NO EVENT SHALL

THE AUTHORS OR COPYRIGHT HOLDERS

BE LIABLE FOR ANY CLAIM, DAMAGES OR

OTHER LIABILITY, WHETHER IN AN ACTION

OF CONTRACT, TORT OR OTHERWISE,

ARISING FROM, OUT OF OR IN CONNECTION

WITH THE SOFTWARE OR THE USE OR

OTHER DEALINGS IN THE SOFTWARE.

SKIM

Copyright © 2008-2023, Christiaan Hofman

and contributors All rights reserved.

Redistribution and use in source and binary

forms, with or without modification, are

permitted provided that the following

conditions are met:

Redistributions of source code must retain

the above copyright notice, this list of

conditions and the following disclaimer.

Redistributions in binary form must

reproduce the above copyright notice, this

list of conditions and the following disclaimer

in the documentation and/or other materials

provided with the distribution. Neither the

name of Christiaan Hofman nor the names

of any other contributors may be used to

endorse or promote products derived from

this software without specific prior written

permission.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED
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WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE COPYRIGHT

OWNER OR CONTRIBUTORS BE LIABLE

FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

DAMAGES (INCLUDING, BUT NOT LIMITED

TO, PROCUREMENT OF SUBSTITUTE GOODS

OR SERVICES; LOSS OF USE, DATA, OR

PROFITS; OR BUSINESS INTERRUPTION)

HOWEVER CAUSED AND ON ANY THEORY

OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING

NEGLIGENCE OR OTHERWISE) ARISING

IN ANY WAY OUT OF THE USE OF THIS

SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.

LETSMOVE

Public domain. More information can be

found at LetsMove.

ZIPZAP

Copyright © 2012, Pixelglow Software. All

rights reserved.

Redistribution and use in source and binary

forms, with or without modification, are

permitted provided that the following

conditions are met:

Redistributions of source code must retain

the above copyright notice, this list of

conditions and the following disclaimer.

Redistributions in binary form must

reproduce the above copyright notice,

this list of conditions and the following

disclaimer in the documentation and/

or other materials provided with the

distribution.

THIS SOFTWARE IS PROVIDED BY THE

COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED

WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF

MERCHANTABILITY AND FITNESS FOR A

PARTICULAR PURPOSE ARE DISCLAIMED.

IN NO EVENT SHALL THE COPYRIGHT

HOLDER OR CONTRIBUTORS BE LIABLE

FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL

DAMAGES (INCLUDING, BUT NOT LIMITED

TO, PROCUREMENT OF SUBSTITUTE GOODS

OR SERVICES; LOSS OF USE, DATA, OR

PROFITS; OR BUSINESS INTERRUPTION)

HOWEVER CAUSED AND ON ANY THEORY

OF LIABILITY, WHETHER IN CONTRACT,

STRICT LIABILITY, OR TORT (INCLUDING

NEGLIGENCE OR OTHERWISE) ARISING

IN ANY WAY OUT OF THE USE OF THIS

SOFTWARE, EVEN IF ADVISED OF THE

POSSIBILITY OF SUCH DAMAGE.
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OTHER PRODUCTS

IN THIS CHAPTER

Overview 397

DEVONthink 397

DEVONthink To Go 397

DEVONagent 398

DEVONsphere 398

Needful Things 398

Besides DEVONthink, DEVONtechnologies

publishes a number of other commercial,

shareware, and freeware applications and

services that might be helpful for you.

OVERVIEW

DEVONtechnologies is focused on developing

innovative applications for finding, storing,

and organizing information. We make the

latest, complex technologies easy to use, and

fast.

DEVONthink

DEVONthink To Go

DEVONagent

DEVONsphere

We also publish some freeware apps and

services.

NEWSLETTER & COMMUNITY

Would you like us to keep you informed about

updates and new product releases? Visit our

blog and subscribe to our free newsletter.

If you have a moment feel free to visit our

lively user community. Here, users of all skill

levels meet to discuss our applications, talk

about our technology, and exchange tips and

tricks for DEVONthink & Co.

DEVONTHINK

Built on core concepts: capture, organize,

search and utilize, DEVONthink is your

document and information management

solution. Efficiently, capture and organize

your documents. Find your documents with

lightning-fast searches and share those

documents to other apps. And use it's built-in

AI or access external AI to make connections

and queries about your documents. For any

project or topic, large or small, DEVONthink

can be the center of it all.

Learn more about DEVONthink

Check your upgrade options if you want to

upgrade to a higher edition

DEVONTHINK TO GO

Carry a library of your documents in the

palm of your hand with DEVONthink To

Go. Make databases for any need, filling

and organizing them for quick access

and searches. Create, edit, and annotate

documents wherever you are. Use access

to external AI to ask questions and gain

insight into your documents. And keep your

databases in sync with other mobile devices

or DEVONthink on your Mac.
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Learn more about DEVONthink To Go.

DEVONAGENT

Your Internet search assistant, DEVONagent

Pro is a professional-grade, web-focused

search application. Choose where to search,

even multiple sites at once, and let it search

and filter the results, returning the most

relevant matches. Create search sets

that will run on a schedule, delivering its

findings via email, directly to DEVONthink,

or archive them for later. Its related utilities,

DEVONagent Express and Lite, run as

menubar application for quick and simpler

web searches.

Learn more about DEVONagent Pro.

DEVONSPHERE

Our answer to Spotlight, DEVONsphere

Express is your Mac-based search utility.

Using a simple but powerful search syntax,

locate documents in the locations you

choose, even ones in your DEVONthink

databases. Also, its unique See Also function

detects what's in your frontmost application

and tries to find related items for you.

Learn more about DEVONsphere Express.

NEEDFUL THINGS

Search files on your hard disk, watch web

cams, create thumbnails, or access all your

files and apps from the menu bar. Reformat

paragraphs in your favorite word processor or

do little calculations anywhere you can type

in text. Your network connection lets you

down or you want to know if a remote server

is still alive or already swimming belly-up? All

for free.

Learn more about our freeware apps and

services.
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